automatic version update by autodist [release 2.2.4-3mamba;Wed Dec 28 2022]
This commit is contained in:
parent
a920d40200
commit
9884db1f6d
51
miniupnpc-2.2.3-fix-make-install.patch
Normal file
51
miniupnpc-2.2.3-fix-make-install.patch
Normal file
@ -0,0 +1,51 @@
|
||||
From ed1dc4bb5cdc4a53963f3eb01089289e30acc5a3 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
|
||||
Date: Wed, 29 Sep 2021 08:28:27 +0200
|
||||
Subject: [PATCH] Makefile: fix install rules to account for $(BUILD)
|
||||
|
||||
Fix missing references to $(BUILD) in the install rules, as well
|
||||
as incorrect shared library symlink name. Otherwise, the 'install'
|
||||
phase fails either being unable to find files:
|
||||
|
||||
make: *** No rule to make target 'miniupnpc.pc', needed by 'install'. Stop.
|
||||
|
||||
or trying to create the symlink in the wrong subdirectory:
|
||||
|
||||
ln: failed to create symbolic link '/tmp/z/usr/lib/build/libminiupnpc.so': No such file or directory
|
||||
---
|
||||
miniupnpc/Makefile | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/miniupnpc/Makefile b/miniupnpc/Makefile
|
||||
index 4563b283..11a17f95 100644
|
||||
--- a/miniupnpc/Makefile
|
||||
+++ b/miniupnpc/Makefile
|
||||
@@ -162,7 +162,7 @@ PKGCONFIGDIR = $(INSTALLDIRLIB)/pkgconfig
|
||||
|
||||
FILESTOINSTALL = $(LIBRARY) $(EXECUTABLES)
|
||||
ifeq (, $(findstring amiga, $(OS)))
|
||||
-FILESTOINSTALL += $(SHAREDLIBRARY) miniupnpc.pc
|
||||
+FILESTOINSTALL += $(SHAREDLIBRARY) $(BUILD)/miniupnpc.pc
|
||||
endif
|
||||
|
||||
|
||||
@@ -251,15 +251,15 @@ install: updateversion $(FILESTOINSTALL)
|
||||
$(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)
|
||||
ifeq (, $(findstring amiga, $(OS)))
|
||||
$(INSTALL) -m 644 $(SHAREDLIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/$(SONAME)
|
||||
- ln -fs $(SONAME) $(DESTDIR)$(INSTALLDIRLIB)/$(SHAREDLIBRARY)
|
||||
+ ln -fs $(SONAME) $(DESTDIR)$(INSTALLDIRLIB)/$(notdir $(SHAREDLIBRARY))
|
||||
$(INSTALL) -d $(DESTDIR)$(PKGCONFIGDIR)
|
||||
- $(INSTALL) -m 644 miniupnpc.pc $(DESTDIR)$(PKGCONFIGDIR)
|
||||
+ $(INSTALL) -m 644 $(BUILD)/miniupnpc.pc $(DESTDIR)$(PKGCONFIGDIR)
|
||||
endif
|
||||
$(INSTALL) -d $(DESTDIR)$(INSTALLDIRBIN)
|
||||
ifneq (, $(findstring amiga, $(OS)))
|
||||
- $(INSTALL) -m 755 upnpc-static $(DESTDIR)$(INSTALLDIRBIN)/upnpc
|
||||
+ $(INSTALL) -m 755 $(BUILD)/upnpc-static $(DESTDIR)$(INSTALLDIRBIN)/upnpc
|
||||
else
|
||||
- $(INSTALL) -m 755 upnpc-shared $(DESTDIR)$(INSTALLDIRBIN)/upnpc
|
||||
+ $(INSTALL) -m 755 $(BUILD)/upnpc-shared $(DESTDIR)$(INSTALLDIRBIN)/upnpc
|
||||
endif
|
||||
$(INSTALL) -m 755 external-ip.sh $(DESTDIR)$(INSTALLDIRBIN)/external-ip
|
||||
ifeq (, $(findstring amiga, $(OS)))
|
@ -1,13 +1,14 @@
|
||||
Name: miniupnpc
|
||||
Version: 2.2.2
|
||||
Release: 2mamba
|
||||
Version: 2.2.4
|
||||
Release: 3mamba
|
||||
Summary: The MiniUPnP client library is useful whenever an application needs to listen for incoming connections
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||
URL: https://miniupnp.free.fr/
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://miniupnp.free.fr/
|
||||
Source: http://miniupnp.free.fr/files/miniupnpc-%{version}.tar.gz
|
||||
Patch0: miniupnpc-2.2.3-fix-make-install.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -20,7 +21,6 @@ The MiniUPnP client library is useful whenever an application needs to listen fo
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
Summary: The MiniUPnP client library is useful whenever an application needs to listen for incoming connections
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n lib%{name}
|
||||
The MiniUPnP client library is useful whenever an application needs to listen for incoming connections
|
||||
@ -31,7 +31,7 @@ Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: %{name}-devel
|
||||
Obsoletes: %{name}-devel
|
||||
Obsoletes: %{name}-devel < 2.2.3
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
This package contains static libraries and header files needed for development.
|
||||
@ -40,28 +40,29 @@ This package contains static libraries and header files needed for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p2 -b .fix-make-install
|
||||
# Workaround for CMakeInstall problem
|
||||
cp include/*.h .
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall \
|
||||
INSTALLPREFIX=%{_prefix} \
|
||||
INSTALLDIRLIB=%{_libdir}
|
||||
%makeinstall -C build
|
||||
|
||||
chmod +x %{buildroot}%{_libdir}/libminiupnpc.so.*
|
||||
#chmod +x %{buildroot}%{_libdir}/libminiupnpc.so.*
|
||||
install -D -m0755 external-ip.sh %{buildroot}%{_bindir}/external-ip
|
||||
install -D -m0755 build/upnpc-shared %{buildroot}%{_bindir}/upnpc
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name}
|
||||
/sbin/ldconfig
|
||||
:
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%postun -n lib%{name}
|
||||
/sbin/ldconfig
|
||||
:
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
@ -79,10 +80,24 @@ chmod +x %{buildroot}%{_libdir}/libminiupnpc.so.*
|
||||
%{_includedir}/miniupnpc/*.h
|
||||
%{_libdir}/libminiupnpc.a
|
||||
%{_libdir}/libminiupnpc.so
|
||||
%{_mandir}/man3/miniupnpc.3*
|
||||
#%{_mandir}/man3/miniupnpc.3*
|
||||
%{_libdir}/pkgconfig/miniupnpc.pc
|
||||
%dir %{_libdir}/cmake/miniupnpc
|
||||
%{_libdir}/cmake/miniupnpc/*miniupnpc*.cmake
|
||||
|
||||
%changelog
|
||||
* Wed Dec 28 2022 Automatic Build System <autodist@mambasoft.it> 2.2.4-3mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Dec 28 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.4-2mamba
|
||||
- rebuilt with tools
|
||||
|
||||
* Wed Dec 28 2022 Automatic Build System <autodist@mambasoft.it> 2.2.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Oct 04 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.3-1mamba
|
||||
- update to 2.2.3
|
||||
|
||||
* Tue Mar 23 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-2mamba
|
||||
- fixed library permissions; added debug package
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user