update to 2.7 [release 2.7-1mamba;Sun Jan 12 2014]
This commit is contained in:
parent
5fa1203e4c
commit
4c4c80036b
@ -1,2 +1,4 @@
|
||||
# minicom
|
||||
|
||||
Minicom is a menu driven communications program. It emulates ANSI and VT102 terminals. It has a dialing directory and auto zmodem download.
|
||||
|
||||
|
12
minicom-2.1-conf
Normal file
12
minicom-2.1-conf
Normal file
@ -0,0 +1,12 @@
|
||||
# Machine-generated file - use "minicom -s" to change parameters.
|
||||
pu pname7 YUNYNkermit
|
||||
pu pname8 NDNYNkermit
|
||||
pu pprog7 /usr/bin/gkermit -iXs
|
||||
pu pprog8 /usr/bin/gkermit -iXr
|
||||
pr port /dev/ttyS0
|
||||
pu baudrate 9600
|
||||
pu bits 8
|
||||
pu parity N
|
||||
pu stopbits 1
|
||||
pr kermit gkermit
|
||||
pu rtscts No
|
111
minicom-2.3-getline-rename.patch
Normal file
111
minicom-2.3-getline-rename.patch
Normal file
@ -0,0 +1,111 @@
|
||||
--- minicom-2.3.orig/src/minicom.c 2008-02-02 23:49:53.000000000 +0100
|
||||
+++ minicom-2.3/src/minicom.c 2009-05-19 22:09:13.121029740 +0200
|
||||
@@ -167,7 +167,7 @@
|
||||
#endif /*SIGTSTP*/
|
||||
|
||||
/* Get a line from either window or scroll back buffer. */
|
||||
-static ELM *getline(WIN *w, int no)
|
||||
+static ELM *_getline(WIN *w, int no)
|
||||
{
|
||||
int i;
|
||||
static ELM outofrange[MAXCOLS] = {{0,0,0}};
|
||||
@@ -205,7 +205,7 @@
|
||||
|
||||
w->direct = 0;
|
||||
for (f = 0; f < w->ys; f++)
|
||||
- mc_wdrawelm(w, f, getline(w, y++));
|
||||
+ mc_wdrawelm(w, f, _getline(w, y++));
|
||||
if (r)
|
||||
mc_wredraw(w, 1);
|
||||
w->direct = 1;
|
||||
@@ -227,7 +227,7 @@
|
||||
tmp_line[0]='\0';
|
||||
w->direct = 0;
|
||||
for (f = 0; f < w->ys; f++) {
|
||||
- tmp_e = getline(w, y++);
|
||||
+ tmp_e = _getline(w, y++);
|
||||
|
||||
/* First we "accumulate" the line into a variable */
|
||||
mc_wdrawelm_var(w, tmp_e, tmp_line);
|
||||
@@ -324,7 +324,7 @@
|
||||
|
||||
for (next_line = hit_line; next_line <= all_lines; next_line++) {
|
||||
/* we do 'something' here... :-) */
|
||||
- tmp_e = getline(w_hist, next_line);
|
||||
+ tmp_e = _getline(w_hist, next_line);
|
||||
|
||||
/*
|
||||
* First we "accumulate" the line into a variable.
|
||||
@@ -379,9 +379,9 @@
|
||||
static void drawcite(WIN *w, int y, int citey, int start, int end)
|
||||
{
|
||||
if (y+citey >= start && y+citey <= end)
|
||||
- mc_wdrawelm_inverse(w, y, getline(w, y+citey));
|
||||
+ mc_wdrawelm_inverse(w, y, _getline(w, y+citey));
|
||||
else
|
||||
- mc_wdrawelm(w, y, getline(w, y+citey));
|
||||
+ mc_wdrawelm(w, y, _getline(w, y+citey));
|
||||
}
|
||||
|
||||
static void drawcite_whole(WIN *w, int y, int start, int end)
|
||||
@@ -400,7 +400,7 @@
|
||||
for (y=start; y<=end; y++) {
|
||||
vt_send('>');
|
||||
vt_send(' ');
|
||||
- tmp_e = getline(w, y);
|
||||
+ tmp_e = _getline(w, y);
|
||||
mc_wdrawelm_var(w, tmp_e, tmp_line);
|
||||
tmp_line[w->xs] = 0;
|
||||
for (x = w->xs-1; x >= 0; x--) {
|
||||
@@ -600,7 +600,7 @@
|
||||
if (citemode) {
|
||||
inverse = (y+cite_y >= cite_ystart && y+cite_y <= cite_yend);
|
||||
} else {
|
||||
- tmp_e = getline(b_us, y);
|
||||
+ tmp_e = _getline(b_us, y);
|
||||
if (wcslen(look_for) > 1) {
|
||||
/* quick scan for pattern match */
|
||||
mc_wdrawelm_var(b_us, tmp_e, tmp_line);
|
||||
@@ -611,9 +611,9 @@
|
||||
}
|
||||
|
||||
if (inverse)
|
||||
- mc_wdrawelm_inverse(b_us, 0, getline(b_us, y));
|
||||
+ mc_wdrawelm_inverse(b_us, 0, _getline(b_us, y));
|
||||
else
|
||||
- mc_wdrawelm(b_us, 0, getline(b_us, y));
|
||||
+ mc_wdrawelm(b_us, 0, _getline(b_us, y));
|
||||
if (citemode)
|
||||
mc_wlocate(b_us, 0, cite_y);
|
||||
mc_wflush();
|
||||
@@ -648,7 +648,7 @@
|
||||
if (citemode) {
|
||||
inverse = (y+cite_y >= cite_ystart && y+cite_y <= cite_yend);
|
||||
} else {
|
||||
- tmp_e = getline(b_us, y + b_us->ys - 1);
|
||||
+ tmp_e = _getline(b_us, y + b_us->ys - 1);
|
||||
if (wcslen(look_for) > 1) {
|
||||
/* quick scan for pattern match */
|
||||
mc_wdrawelm_var(b_us, tmp_e, tmp_line);
|
||||
@@ -660,10 +660,10 @@
|
||||
|
||||
if (inverse)
|
||||
mc_wdrawelm_inverse(b_us, b_us->ys - 1,
|
||||
- getline(b_us, y + b_us->ys - 1));
|
||||
+ _getline(b_us, y + b_us->ys - 1));
|
||||
else
|
||||
mc_wdrawelm(b_us, b_us->ys - 1,
|
||||
- getline(b_us, y + b_us->ys - 1));
|
||||
+ _getline(b_us, y + b_us->ys - 1));
|
||||
if (citemode)
|
||||
mc_wlocate(b_us, 0, cite_y);
|
||||
mc_wflush();
|
||||
@@ -753,7 +753,7 @@
|
||||
mc_wlocate(b_st, 0, 0);
|
||||
mc_wprintf(b_st, hline);
|
||||
mc_wredraw(b_st, 1);
|
||||
- mc_wdrawelm_inverse(b_us, cite_y, getline(b_us, cite_ystart));
|
||||
+ mc_wdrawelm_inverse(b_us, cite_y, _getline(b_us, cite_ystart));
|
||||
mc_wlocate(b_us, 0, cite_y);
|
||||
break;
|
||||
case K_ESC:
|
102
minicom.spec
Normal file
102
minicom.spec
Normal file
@ -0,0 +1,102 @@
|
||||
%define minver %(echo %version | cut -d. -f3)
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: minicom
|
||||
Version: 2.7
|
||||
Release: 1mamba
|
||||
Summary: A menu driven communications program
|
||||
Group: Applications/Communication
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://alioth.debian.org/projects/minicom/
|
||||
Source: https://alioth.debian.org/frs/download.php/file/3977/minicom-%{version}.tar.gz
|
||||
#Source: http://alioth.debian.org/frs/download.php/%{minver}/minicom-%{majver}.tar.gz
|
||||
Source1: minicom-2.1-conf
|
||||
Patch0: minicom-2.3-getline-rename.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: gkermit
|
||||
%endif
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: liblockdev-devel
|
||||
BuildRequires: libncurses-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: liblockdev >= 1.0.1
|
||||
Requires: lrzsz
|
||||
%if "%{stage1}" != "1"
|
||||
Requires: gkermit >= 1.0
|
||||
%endif
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Minicom is a menu driven communications program. It emulates ANSI and VT102 terminals. It has a dialing directory and auto zmodem download.
|
||||
|
||||
%prep
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%setup -q -n %{name}-%{majver}
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-cfg-dir=%{_sysconfdir}/minicom
|
||||
%make
|
||||
|
||||
%install
|
||||
%makeinstall
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/minicom
|
||||
install -m 0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/minicom/minirc.dfl
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/minicom/minirc.dfl
|
||||
%{_bindir}/ascii-xfr
|
||||
%{_bindir}/minicom
|
||||
%{_bindir}/runscript
|
||||
%{_bindir}/xminicom
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Sun Jan 12 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7-1mamba
|
||||
- update to 2.7
|
||||
|
||||
* Wed Jan 25 2012 Automatic Build System <autodist@mambasoft.it> 2.6.3689-1mamba
|
||||
- update to 2.6.3689
|
||||
|
||||
* Mon Jan 31 2011 Automatic Build System <autodist@mambasoft.it> 2.5.3487-1mamba
|
||||
- update to 2.5.3487
|
||||
|
||||
* Mon Jan 31 2011 Automatic Build System <autodist@mambasoft.it> 2.5-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Nov 17 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3-3mamba
|
||||
- added requirement for lrzsz (for x/y/z modem support)
|
||||
|
||||
* Thu Apr 01 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3-2mamba
|
||||
- added patch to resolve a conflict with getline() function
|
||||
|
||||
* Sun Jan 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3-1mamba
|
||||
- update to 2.3
|
||||
|
||||
* Fri Jan 19 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2-1qilnx
|
||||
- update to version 2.2 by autospec
|
||||
|
||||
* Wed Aug 03 2005 Silvan Calarco <silvan.calarco@qinet.it> 2.1-4qilnx
|
||||
- added support for gkermit
|
||||
|
||||
* Fri Apr 09 2004 Silvan Calarco <silvan.calarco@qinet.it> 2.1-3qilnx
|
||||
- lockdev requirement added
|
||||
- default configuration files in /etc/minicom/
|
||||
|
||||
* Fri Apr 09 2004 Silvan Calarco <silvan.calarco@qinet.it> 2.1-2qilnx
|
||||
- fixed sysconfdir location
|
||||
|
||||
* Thu Jun 26 2003 Silvan Calarco <silvan.calarco@qinet.it> 2.1-1qilnx
|
||||
- Creation of minicom package
|
Loading…
Reference in New Issue
Block a user