automatic version update by autodist [release 8.1.0-1mamba;Fri May 10 2013]
This commit is contained in:
parent
16e811654c
commit
e8f9e3632d
12
mesa-demos-8.0.1-arm-tegra-eglut-VisualNoMask.patch
Normal file
12
mesa-demos-8.0.1-arm-tegra-eglut-VisualNoMask.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -ru mesa-demos-8.0.1/src/egl/eglut/eglut_x11.c mesa-demos-8.0.1.ok/src/egl/eglut/eglut_x11.c
|
||||||
|
--- mesa-demos-8.0.1/src/egl/eglut/eglut_x11.c 2010-07-07 19:57:15.000000000 +0200
|
||||||
|
+++ mesa-demos-8.0.1.ok/src/egl/eglut/eglut_x11.c 2012-11-11 19:47:10.370198001 +0100
|
||||||
|
@@ -38,7 +38,7 @@
|
||||||
|
/* The X window visual must match the EGL config */
|
||||||
|
visTemplate.visualid = vid;
|
||||||
|
visInfo = XGetVisualInfo(_eglut->native_dpy,
|
||||||
|
- VisualIDMask, &visTemplate, &num_visuals);
|
||||||
|
+ VisualNoMask, &visTemplate, &num_visuals);
|
||||||
|
if (!visInfo)
|
||||||
|
_eglutFatal("failed to get an visual of id 0x%x", vid);
|
||||||
|
|
12
mesa-demos-8.0.1-arm-tegra-es2gears-float.patch
Normal file
12
mesa-demos-8.0.1-arm-tegra-es2gears-float.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -ru mesa-demos-8.0.1/src/egl/opengles2/es2gears.c mesa-demos-8.0.1.ok/src/egl/opengles2/es2gears.c
|
||||||
|
--- mesa-demos-8.0.1/src/egl/opengles2/es2gears.c 2010-07-07 19:57:15.000000000 +0200
|
||||||
|
+++ mesa-demos-8.0.1.ok/src/egl/opengles2/es2gears.c 2012-11-11 19:35:30.450196959 +0100
|
||||||
|
@@ -341,7 +341,7 @@
|
||||||
|
"}\n";
|
||||||
|
|
||||||
|
static const char fragment_shader[] =
|
||||||
|
- //"precision mediump float;\n"
|
||||||
|
+ "precision mediump float\n;"
|
||||||
|
"uniform vec4 color;\n"
|
||||||
|
"uniform vec3 light;\n"
|
||||||
|
"varying vec3 rotated_normal;\n"
|
44
mesa-demos-8.0.1-missing_headers.patch
Normal file
44
mesa-demos-8.0.1-missing_headers.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
diff -Nru mesa-demos-8.0.1.orig//src/egl/openvg/lion-render.h mesa-demos-8.0.1/src/egl/openvg/lion-render.h
|
||||||
|
--- mesa-demos-8.0.1.orig//src/egl/openvg/lion-render.h 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ mesa-demos-8.0.1/src/egl/openvg/lion-render.h 2011-07-18 17:20:37.000000000 +0200
|
||||||
|
@@ -0,0 +1,16 @@
|
||||||
|
+#ifndef LION_RENDER_H
|
||||||
|
+#define LION_RENDER_H
|
||||||
|
+
|
||||||
|
+#include <VG/openvg.h>
|
||||||
|
+
|
||||||
|
+#define LION_SIZE 132
|
||||||
|
+struct lion {
|
||||||
|
+ VGPath paths[LION_SIZE];
|
||||||
|
+ VGPaint fills[LION_SIZE];
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+struct lion *lion_create(void);
|
||||||
|
+void lion_render(struct lion *l);
|
||||||
|
+void lion_destroy(struct lion *l);
|
||||||
|
+
|
||||||
|
+#endif
|
||||||
|
diff -Nru mesa-demos-8.0.1.orig//src/egl/openvg/trivial/eglcommon.h mesa-demos-8.0.1/src/egl/openvg/trivial/eglcommon.h
|
||||||
|
--- mesa-demos-8.0.1.orig//src/egl/openvg/trivial/eglcommon.h 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ mesa-demos-8.0.1/src/egl/openvg/trivial/eglcommon.h 2011-07-18 17:20:21.921788794 +0200
|
||||||
|
@@ -0,0 +1,20 @@
|
||||||
|
+#ifndef EGLCOMMON_H
|
||||||
|
+#define EGLCOMMON_H
|
||||||
|
+
|
||||||
|
+typedef void (*init_func)();
|
||||||
|
+typedef void (*reshape_func)(int, int);
|
||||||
|
+typedef void (*draw_func)();
|
||||||
|
+typedef int (*key_func)(unsigned key);
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+void set_window_size(int width, int height);
|
||||||
|
+int window_width(void);
|
||||||
|
+int window_height(void);
|
||||||
|
+
|
||||||
|
+int run(int argc, char **argv,
|
||||||
|
+ init_func init,
|
||||||
|
+ reshape_func resh,
|
||||||
|
+ draw_func draw,
|
||||||
|
+ key_func key);
|
||||||
|
+
|
||||||
|
+#endif
|
131
mesa-demos.spec
Normal file
131
mesa-demos.spec
Normal file
@ -0,0 +1,131 @@
|
|||||||
|
Name: mesa-demos
|
||||||
|
Version: 8.1.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Demos for the Mesa GL libraries
|
||||||
|
Group: Applications/Graphics
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://mesa3d.sourceforge.net
|
||||||
|
Source: ftp://ftp.freedesktop.org/pub/mesa/demos/%{version}/mesa-demos-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-8.0.1-missing_headers.patch
|
||||||
|
Patch1: mesa-demos-8.0.1-arm-tegra-es2gears-float.patch
|
||||||
|
Patch2: mesa-demos-8.0.1-arm-tegra-eglut-VisualNoMask.patch
|
||||||
|
License: MIT
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libfreeglut-devel
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libglew-devel
|
||||||
|
BuildRequires: libGLU-devel
|
||||||
|
BuildRequires: libOSMesa-devel
|
||||||
|
BuildRequires: libpthread-stubs-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXau-devel
|
||||||
|
BuildRequires: libxcb-devel
|
||||||
|
BuildRequires: libXdmcp-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libXi-devel
|
||||||
|
BuildRequires: libXrandr-devel
|
||||||
|
BuildRequires: libXrender-devel
|
||||||
|
BuildRequires: libXxf86vm-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
#BuildRequires: libGLw-devel
|
||||||
|
#BuildRequires: libOpenVG-devel
|
||||||
|
BuildRequires: libEGL-devel
|
||||||
|
BuildRequires: libGL-devel >= 8.0
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Demos for the Mesa GL libraries.
|
||||||
|
|
||||||
|
%package -n mesa-tests
|
||||||
|
Summary: Test and information tools for the Mesa libraries
|
||||||
|
Group: System/X11
|
||||||
|
Provides: Mesa-tools
|
||||||
|
Obsoletes: Mesa-tools
|
||||||
|
Provides: mesa-tools
|
||||||
|
Obsoletes: mesa-tools
|
||||||
|
|
||||||
|
%description -n mesa-tests
|
||||||
|
Test and information tools for the Mesa libraries.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
%ifarch arm
|
||||||
|
#%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make -j1
|
||||||
|
#LDADD="-lX11 -lpthread"
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
install -D -m0755 src/egl/opengl/eglgears_x11 %{buildroot}%{_bindir}/eglgears
|
||||||
|
install -D -m0755 src/egl/opengl/eglinfo %{buildroot}%{_bindir}/eglinfo
|
||||||
|
install -D -m0755 src/egl/opengles1/gears_x11 %{buildroot}%{_bindir}/es1gears
|
||||||
|
install -D -m0755 src/egl/opengles1/es1_info %{buildroot}%{_bindir}/es1_info
|
||||||
|
install -D -m0755 src/egl/opengles2/es2gears_x11 %{buildroot}%{_bindir}/es2gears
|
||||||
|
install -D -m0755 src/egl/opengles2/es2_info %{buildroot}%{_bindir}/es2_info
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_bindir}/bitmap
|
||||||
|
rm -f %{buildroot}%{_bindir}/clear
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -n mesa-tests
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/glxgears
|
||||||
|
%{_bindir}/glxinfo
|
||||||
|
%{_bindir}/eglgears
|
||||||
|
%{_bindir}/eglinfo
|
||||||
|
%{_bindir}/es1gears
|
||||||
|
%{_bindir}/es1_info
|
||||||
|
%{_bindir}/es2gears
|
||||||
|
%{_bindir}/es2_info
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/*
|
||||||
|
%exclude %{_bindir}/glxgears
|
||||||
|
%exclude %{_bindir}/glxinfo
|
||||||
|
%exclude %{_bindir}/glxgears
|
||||||
|
%exclude %{_bindir}/glxinfo
|
||||||
|
%exclude %{_bindir}/eglgears
|
||||||
|
%exclude %{_bindir}/eglinfo
|
||||||
|
%exclude %{_bindir}/es1gears
|
||||||
|
%exclude %{_bindir}/es1_info
|
||||||
|
%exclude %{_bindir}/es2gears
|
||||||
|
%exclude %{_bindir}/es2_info
|
||||||
|
%dir %{_datadir}/mesa-demos
|
||||||
|
%{_datadir}/mesa-demos/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri May 10 2013 Automatic Build System <autodist@mambasoft.it> 8.1.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Jun 30 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.1-6mamba
|
||||||
|
- also provide {egl,es1,es2}{info,gears} tools in mesa-tests package, which obsoletes mesa-tools
|
||||||
|
- 2012/11/11 edit (arm): patch eglut and es2gears to work on tegra platforms (https://wiki.ubuntu.com/ARM/TEGRA/AC100)
|
||||||
|
|
||||||
|
* Sun Feb 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.1-5mamba
|
||||||
|
- rebuilt with Mesa 8.0.1
|
||||||
|
|
||||||
|
* Tue Dec 13 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.1-4mamba
|
||||||
|
- workaround to fix build of egl demos
|
||||||
|
|
||||||
|
* Mon Jul 18 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.1-3mamba
|
||||||
|
- added buildrequirements for libEGL-devel and libGLw-devel
|
||||||
|
|
||||||
|
* Sun Feb 20 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.1-2mamba
|
||||||
|
- remove /usr/bin/clear to fix a conclict with ncurses
|
||||||
|
|
||||||
|
* Sat Feb 05 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user