174 lines
5.7 KiB
RPMSpec
174 lines
5.7 KiB
RPMSpec
### AUTOUPDATE-OFF: 8
|
|
Name: mediastreamer
|
|
Version: 5.2.111
|
|
Release: 1mamba
|
|
Summary: A GPL licensed library to make audio and video real-time streaming and processing
|
|
Group: Applications/Multimedia
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.linphone.org/technical-corner/mediastreamer2
|
|
Source: https://github.com/BelledonneCommunications/mediastreamer2.git/%{version}/mediastreamer2-%{version}.tar.bz2
|
|
Patch0: mediastreamer-2.16.1-x86-fix-conversion-error.patch
|
|
Patch1: mediastreamer-2.16.1-x86-fix-conversion-error-2.patch
|
|
Patch2: mediastreamer-5.2.111-ffmpeg-5.0.patch
|
|
Patch3: mediastreamer-5.2.111-fix-opengl-include.patch
|
|
Patch4: mediastreamer-5.2.111-cmake-config-location.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libXv-devel
|
|
BuildRequires: libalsa-devel
|
|
BuildRequires: libavcodec-ffmpeg-devel
|
|
BuildRequires: libavutil-ffmpeg-devel
|
|
BuildRequires: libbctoolbox-devel
|
|
BuildRequires: libbzrtp-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglew-devel
|
|
BuildRequires: libglvnd-devel
|
|
BuildRequires: libgsm-devel
|
|
BuildRequires: libjpeg-devel
|
|
BuildRequires: libopus-devel
|
|
BuildRequires: libortp-devel
|
|
BuildRequires: libpulseaudio-devel
|
|
BuildRequires: libspeex-devel
|
|
BuildRequires: libspeexdsp-devel
|
|
BuildRequires: libsrtp-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libswscale-ffmpeg-devel
|
|
BuildRequires: libtheora-devel
|
|
BuildRequires: libv4l-devel
|
|
BuildRequires: libvpx-devel
|
|
BuildRequires: libyuv-devel
|
|
BuildRequires: libzxing-cpp-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libortp-devel >= 5.2.111
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description
|
|
Mediastreamer2 is a GPL licensed library to make audio and video real-time streaming and processing. Written in pure C, it is based upon the oRTP library.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
Provides: libmediastreamer2
|
|
Obsoletes: libmediastreamer2 < 3
|
|
Obsoletes: mediastreamer-plugin-msilbc <= 2.1.2-4mamba
|
|
|
|
%description -n lib%{name}
|
|
Mediastreamer2 is a GPL licensed library to make audio and video real-time streaming and processing. Written in pure C, it is based upon the oRTP library.
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Provides: libmediastreamer2-devel
|
|
Obsoletes: libmediastreamer2-devel < 3
|
|
|
|
%description -n lib%{name}-devel
|
|
Mediastreamer2 is a GPL licensed library to make audio and video real-time streaming and processing. Written in pure C, it is based upon the oRTP library.
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n mediastreamer2-%{version}
|
|
#%patch0 -p1
|
|
%patch 1 -p1
|
|
%patch 2 -p1
|
|
%patch 3 -p1 -b .fix-opengl-include
|
|
%patch 4 -p1 -b .cmake-config-location
|
|
|
|
#./autogen.sh
|
|
|
|
# use system OpenGL headers
|
|
rm -fr include/OpenGL
|
|
|
|
%build
|
|
%cmake -d build \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DENABLE_STATIC=OFF \
|
|
-DENABLE_STRICT=OFF \
|
|
-DENABLE_UNIT_TESTS=OFF \
|
|
-DENABLE_MKV=ON
|
|
|
|
#% configure \
|
|
# CFLAGS="%{optflags} -DMS2_GIT_VERSION=\"\\\"unknown\\\"\""
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/mediastream
|
|
%{_bindir}/mkvstream
|
|
%{_datadir}/images/nowebcamCIF.jpg
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libmediastreamer.so.*
|
|
%doc LICENSE.txt
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/mediastreamer2
|
|
%{_includedir}/mediastreamer2/*.h
|
|
%{_libdir}/libmediastreamer.so
|
|
%dir %{_libdir}/cmake/Mediastreamer2
|
|
%{_libdir}/cmake/Mediastreamer2/Mediastreamer2*.cmake
|
|
%dir %{_docdir}/mediastreamer2-*
|
|
%dir %{_docdir}/mediastreamer2-*/html
|
|
%{_docdir}/mediastreamer2-*/html/*
|
|
%doc CHANGELOG.md
|
|
|
|
%changelog
|
|
* Thu Nov 23 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.111-1mamba
|
|
- update to 5.2.111
|
|
|
|
* Tue Jun 01 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.16-1mamba
|
|
- update to 4.5.16
|
|
|
|
* Mon Nov 13 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 2.16.1-1mamba
|
|
- update to 2.16.1
|
|
|
|
* Sat Jun 25 2016 Automatic Build System <autodist@mambasoft.it> 2.12.1-3mamba
|
|
- rebuilt by autoport with build requirements: libpulseaudio-devel>=9.0-1mamba
|
|
|
|
* Mon Apr 25 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.1-2mamba
|
|
- rebuilt by autoport with build requirements: libpulseaudio-devel>=8.0-1mamba
|
|
|
|
* Tue Jan 26 2016 Automatic Build System <autodist@mambasoft.it> 2.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jul 29 2015 Automatic Build System <autodist@mambasoft.it> 2.11.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 14 2015 Automatic Build System <autodist@mambasoft.it> 2.11.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 17 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.0-3mamba
|
|
- rebuilt with pulseaudio 6.0
|
|
|
|
* Thu May 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.0-2mamba
|
|
- ffmpeg 2.2 rebuild
|
|
|
|
* Wed Feb 26 2014 Automatic Build System <autodist@mambasoft.it> 2.10.0-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Jun 21 2013 Automatic Build System <autodist@mambasoft.it> 2.9.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 04 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.2-1mamba
|
|
- package created by autospec
|