automatic version update by autodist [release 4.3-1mamba;Sat Mar 02 2024]
This commit is contained in:
parent
baae0b6d36
commit
4c9c30d32d
@ -1,44 +0,0 @@
|
|||||||
From 1d13b599607e48446273913ce594931ba53df9fd Mon Sep 17 00:00:00 2001
|
|
||||||
From: Xiao Ni <xni@redhat.com>
|
|
||||||
Date: Sat, 6 Feb 2016 09:18:41 +0800
|
|
||||||
Subject: [PATCH] Fix some type comparison problems
|
|
||||||
|
|
||||||
As 26714713cd2bad9e0bf7f4669f6cc4659ceaab6c said, 32 bit signed
|
|
||||||
timestamps will overflow in the year 2038. It already changed the
|
|
||||||
utime and ctime in struct mdu_array_info_s from int to unsigned
|
|
||||||
int. So we need to change the values that compared with them to
|
|
||||||
unsigned int too.
|
|
||||||
|
|
||||||
Signed-off-by : Xiao Ni <xni@redhat.com>
|
|
||||||
Signed-off-by: Jes Sorensen <Jes.Sorensen@redhat.com>
|
|
||||||
---
|
|
||||||
Monitor.c | 2 +-
|
|
||||||
util.c | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Monitor.c b/Monitor.c
|
|
||||||
index f19c2e5..6df80f9 100644
|
|
||||||
--- a/Monitor.c
|
|
||||||
+++ b/Monitor.c
|
|
||||||
@@ -33,7 +33,7 @@
|
|
||||||
struct state {
|
|
||||||
char *devname;
|
|
||||||
char devnm[32]; /* to sync with mdstat info */
|
|
||||||
- long utime;
|
|
||||||
+ unsigned int utime;
|
|
||||||
int err;
|
|
||||||
char *spare_group;
|
|
||||||
int active, working, failed, spare, raid;
|
|
||||||
diff --git a/util.c b/util.c
|
|
||||||
index 970d484..6e7d3fb 100644
|
|
||||||
--- a/util.c
|
|
||||||
+++ b/util.c
|
|
||||||
@@ -1267,7 +1267,7 @@ struct supertype *guess_super_type(int fd, enum guess_types guess_type)
|
|
||||||
*/
|
|
||||||
struct superswitch *ss;
|
|
||||||
struct supertype *st;
|
|
||||||
- time_t besttime = 0;
|
|
||||||
+ unsigned int besttime = 0;
|
|
||||||
int bestsuper = -1;
|
|
||||||
int i;
|
|
||||||
|
|
11
mdadm.spec
11
mdadm.spec
@ -1,5 +1,5 @@
|
|||||||
Name: mdadm
|
Name: mdadm
|
||||||
Version: 4.2
|
Version: 4.3
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A tool to manage MD devices aka Linux Software RAID
|
Summary: A tool to manage MD devices aka Linux Software RAID
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
@ -9,7 +9,6 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: https://git.kernel.org/pub/scm/utils/mdadm/mdadm.git/
|
URL: https://git.kernel.org/pub/scm/utils/mdadm/mdadm.git/
|
||||||
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
|
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
|
||||||
Patch0: mdadm-3.3.1-gcc-4.9.patch
|
Patch0: mdadm-3.3.1-gcc-4.9.patch
|
||||||
Patch1: mdadm-3.4-i586-gcc-5.3.0.patch
|
|
||||||
Patch2: mdadm-4.1-no-Werror.patch
|
Patch2: mdadm-4.1-no-Werror.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
@ -30,9 +29,8 @@ The particular differences to raidtools is that mdadm is a single program, and i
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%define _default_patch_fuzz 2
|
%define _default_patch_fuzz 2
|
||||||
%patch0 -p1
|
%patch 0 -p1
|
||||||
#%patch1 -p1
|
#%patch 2 -p1
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%make \
|
%make \
|
||||||
@ -80,6 +78,9 @@ install -D -m 644 %{name}.conf-example \
|
|||||||
# ChangeLog README.initramfs TODO
|
# ChangeLog README.initramfs TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Mar 02 2024 Automatic Build System <autodist@openmamba.org> 4.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Jan 11 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2-1mamba
|
* Tue Jan 11 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2-1mamba
|
||||||
- update to 4.2
|
- update to 4.2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user