automatic version update by autodist [release 4.8.12-1mamba;Tue Apr 01 2014]

This commit is contained in:
Automatic Build System 2024-01-06 07:01:08 +01:00
parent 5f616e52e8
commit b5eecd72aa
7 changed files with 7935 additions and 0 deletions

View File

@ -1,2 +1,6 @@
# mc
Midnight Commander is a visual shell much like a file manager, only with way more features.
It is text mode, but also includes mouse support if you are running GPM.
Its coolest feature is the ability to ftp, view tar, zip files, and poke into RPMs for specific files.

7017
mc-4.6.2-utf8.patch Normal file

File diff suppressed because it is too large Load Diff

146
mc-4.7.0.1-extensions.patch Normal file
View File

@ -0,0 +1,146 @@
diff -up mc-4.7.0-pre4/configure.ac.extensions mc-4.7.0-pre4/configure.ac
--- mc-4.7.0-pre4/configure.ac.extensions 2009-10-30 19:44:38.000000000 +0100
+++ mc-4.7.0-pre4/configure.ac 2009-12-10 20:41:43.000000000 +0100
@@ -69,7 +69,7 @@ AC_PROG_LN_S
AC_CHECK_TOOL(AR, ar, ar)
dnl Only list browsers here that can be run in background (i.e. with `&')
-AC_CHECK_PROGS(X11_WWW, [gnome-moz-remote mozilla konqueror opera netscape])
+AC_CHECK_PROGS(X11_WWW, [firefox gnome-moz-remote mozilla konqueror opera netscape])
dnl
dnl Ovverriding mmap support. This has to be before AC_FUNC_MMAP is used.
diff -up mc-4.7.0-pre4/misc/mc.ext.in.extensions mc-4.7.0-pre4/misc/mc.ext.in
--- mc-4.7.0-pre4/misc/mc.ext.in.extensions 2009-10-29 20:02:37.000000000 +0100
+++ mc-4.7.0-pre4/misc/mc.ext.in 2009-12-10 20:46:47.000000000 +0100
@@ -226,8 +226,8 @@ regex/\.rpm$
# deb
regex/\.u?deb$
- Open=%cd %p#deb
- View=%view{ascii} dpkg-deb -I %f && echo && dpkg-deb -c %f
+ Open=%cd %p#uar
+ View=%view{ascii} file %f && nm %f
# dpkg
shell/.debd
@@ -387,7 +387,7 @@ shell/.ico
Include=image
include/image
- Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (gqview %f &); fi
+ Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (eog %f &); fi
View=%view{ascii} identify %f
#View=%view{ascii} asciiview %f
@@ -395,7 +395,8 @@ include/image
### Sound files ###
regex/\.([wW][aA][vV]|[sS][nN][dD]|[vV][oO][cC]|[aA][uU]|[sS][mM][pP]|[aA][iI][fF][fF]|[sS][nN][dD])$
- Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
+ Include=audio
+# Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
regex/\.([mM][oO][dD]|[sS]3[mM]|[xX][mM]|[iI][tT]|[mM][tT][mM]|669|[sS][tT][mM]|[uU][lL][tT]|[fF][aA][rR])$
Open=mikmod %f
@@ -405,15 +406,22 @@ regex/\.([wW][aA][wW]22)$
Open=vplay -s 22 %f
regex/\.([mM][pP]3)$
- Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
- View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+ Include=audio
+# Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
+# View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+
+regex/\.([mM][kK][aA])$
+ Include=audio
regex/\.([oO][gG][gG|aA|vV|xX])$
- Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
+ Include=audio
+# Open=ogg123 %f
+# Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
View=%view{ascii} ogginfo %s
regex/\.([sS][pP][xX]|[fF][lL][aA][cC])$
- Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
+ Include=audio
+# Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
regex/\.([mM][iI][dD][iI]?|[rR][mM][iI][dD]?)$
Open=timidity %f
@@ -422,11 +430,15 @@ regex/\.([wW][mM][aA])$
Open=mplayer -vo null %f
View=%view{ascii} mplayer -quiet -slave -frames 0 -vo null -ao null -identify %f 2>/dev/null | tail +13 || file %f
+include/audio
+ Open=mplayer %f
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
### Play lists ###
regex/\.([mM]3[uU]|[pP][lL][sS])$
- Open=if [ -z "$DISPLAY" ]; then mplayer -vo null -playlist %f; else (xmms -p %f >/dev/null 2>&1 &); fi
+ Open=mplayer -vo null -playlist %f
+# Open=if [ -z "$DISPLAY" ]; then mplayer -vo null -playlist %f; else (xmms -p %f >/dev/null 2>&1 &); fi
### Video ###
@@ -471,12 +486,12 @@ include/video
# Postscript
type/^PostScript
- Open=(gv %f &)
+ Open=(xdg-open %f &)
View=%view{ascii} ps2ascii %f
# PDF
type/^PDF
- Open=(xpdf %f &)
+ Open=(xdg-open %f &)
#Open=(acroread %f &)
#Open=(ghostview %f &)
View=%view{ascii} pdftotext %f -
@@ -486,7 +501,7 @@ type/^PDF
# html
regex/\.([hH][tT][mM][lL]?)$
- Open=(if test -n "@X11_WWW@" && test -n "$DISPLAY"; then (@X11_WWW@ file://%d/%p &) 1>&2; else links %f || lynx -force_html %f || ${PAGER:-more} %f; fi) 2>/dev/null
+ Open=xdg-open file://%d/%p 1>&2
View=%view{ascii} links -dump %f 2>/dev/null || w3m -dump %f 2>/dev/null || lynx -dump -force_html %f
# StarOffice 5.2
@@ -504,22 +519,27 @@ shell/.abw
# Microsoft Word Document
regex/\.([Dd][oO][cCtT]|[Ww][rR][iI])$
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
View=%view{ascii} antiword -t %f || catdoc -w %f || word2x -f text %f - || strings %f
type/^Microsoft\ Word
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
View=%view{ascii} antiword -t %f || catdoc -w %f || word2x -f text %f - || strings %f
# RTF document
regex/\.([rR][tT][fF])$
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
# Microsoft Excel Worksheet
regex/\.([xX][lL][sSwW])$
- Open=(gnumeric %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(gnumeric %f >/dev/null 2>&1 &)
View=%view{ascii} xls2csv %f || strings %f
type/^Microsoft\ Excel
- Open=(gnumeric %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(gnumeric %f >/dev/null 2>&1 &)
View=%view{ascii} xls2csv %f || strings %f
# Use OpenOffice.org to open any MS Office documents

View File

@ -0,0 +1,11 @@
--- mc-4.7.0-pre4.orig/src/tty/tty-slang.c 2009-11-07 16:29:08.000000000 0100
+++ mc-4.7.0-pre4/src/tty/tty-slang.c 2009-11-07 16:28:50.000000000 +0100
@@ -499,7 +499,7 @@ tty_set_alt_charset (gboolean alt_charse
void
tty_display_8bit (gboolean what)
{
- SLsmg_Display_Eight_Bit = what ? 128 : 160;
+ SLsmg_Display_Eight_Bit = what & xterm_flag ? 128 : 160;
}
void

View File

@ -0,0 +1,406 @@
diff -Nru mc-4.7.0.4.orig//configure mc-4.7.0.4/configure
--- mc-4.7.0.4.orig//configure 2010-04-02 09:37:38.000000000 +0200
+++ mc-4.7.0.4/configure 2010-04-12 00:43:23.076029038 +0200
@@ -44838,66 +44838,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
- mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
+mc_slang_is_valid_version=yes
if test x$mc_slang_is_valid_version = xno; then
@@ -45407,66 +45348,8 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then
@@ -45976,66 +45859,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then
@@ -47764,66 +47588,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then
@@ -48333,66 +48098,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then
@@ -48902,66 +48608,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then

View File

@ -0,0 +1,53 @@
Index: src/args.c
===================================================================
--- src/args.c (revision 23c95d36ac4465627fbc9183e083a8320df77fcf)
+++ src/args.c (revision e39c697df47fe1beb727e0cb890a4c27c22cef09)
@@ -546,5 +546,5 @@
else
{
- arg = mcedit_arg_vpath_new (tmp_vpath, 1);
+ arg = mcedit_arg_vpath_new (tmp_vpath, 0);
vfs_path_free (fname_vpath);
}
@@ -553,5 +553,5 @@
}
else
- arg = mcedit_arg_new (tmp, 1);
+ arg = mcedit_arg_new (tmp, 0);
flist = g_list_prepend (flist, arg);
@@ -559,12 +559,9 @@
if (flist == NULL)
- flist = g_list_prepend (flist, mcedit_arg_new (NULL, 1));
+ flist = g_list_prepend (flist, mcedit_arg_new (NULL, 0));
else if (first_line_number != -1)
{
/* overwrite line number for first file */
GList *l;
-
- if (first_line_number == 0)
- first_line_number = 1;
l = g_list_last (flist);
@@ -820,5 +817,5 @@
*
* @param file_name file name
- * @param line_number line number
+ * @param line_number line number. If value is 0, try to restore saved position.
* @return mcedit_arg_t object
*/
@@ -835,5 +832,5 @@
*
* @param file_vpath file path object
- * @param line_number line number
+ * @param line_number line number. If value is 0, try to restore saved position.
* @return mcedit_arg_t object
*/
@@ -846,6 +843,4 @@
arg = g_new (mcedit_arg_t, 1);
arg->file_vpath = file_vpath;
- if (line_number == 0)
- line_number = 1;
arg->line_number = line_number;

298
mc.spec Normal file
View File

@ -0,0 +1,298 @@
%define disable_X 0
%define enable_vfs 1
Name: mc
Version: 4.8.12
Release: 1mamba
Summary: A user-friendly file manager and visual shell
Group: Applications/Shells
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.midnight-commander.org
Source: http://www.midnight-commander.org/downloads/%{name}-%{version}.tar.xz
# see http://www.freedesktop.org/wiki/Software_2fBadSoftware
Patch1: %{name}-4.6.2-utf8.patch.gz
Patch5: %{name}-4.7.0.1-extensions.patch
Patch6: %{name}-4.7.0.1-tty-slang.patch
Patch7: %{name}-4.7.0.4-cross_compile_slang.patch
Patch8: mc-4.8.4-remember_file_position.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libglib-devel
%if "%{stage1}" != "1"
BuildRequires: libgpm-devel
%endif
BuildRequires: libslang-devel
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: bison
BuildRequires: gettext
BuildRequires: unzip
BuildRequires: bash
BuildRequires: gettext-devel
BuildRequires: pkgconfig
BuildRequires: pam-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Midnight Commander is a visual shell much like a file manager, only with way more features.
It is text mode, but also includes mouse support if you are running GPM.
Its coolest feature is the ability to ftp, view tar, zip files, and poke into RPMs for specific files.
%prep
%setup -q -n %{name}-%{version}
#%patch1 -p1
#%patch5 -p1
#%patch6 -p1
#%patch8 -p0
# FIXME: files in /lib should be converted to UTF-8
## convert man pages in /doc to UTF-8
#cd doc/man
#for i in mc.1.in xnc.hlp; do
# iconv -f koi8-r -t utf-8 < ru/${i} > ru/${i}.tmp
# mv -f ru/${i}.tmp ru/${i}
#done
#for i in mc.1.in mcserv.8.in xnc.hlp; do
# iconv -f iso-8859-5 -t utf-8 < sr/${i} > sr/${i}.tmp
# mv -f sr/${i}.tmp sr/${i}
#done
#for d in es it; do
# for i in mc.1.in xnc.hlp; do
# iconv -f iso-8859-3 -t utf-8 < ${d}/${i} > ${d}/${i}.tmp
# mv -f ${d}/${i}.tmp ${d}/${i}
# done
#done
#for d in hu pl; do
# for i in mc.1.in xnc.hlp; do
# iconv -f iso-8859-2 -t utf-8 < ${d}/${i} > ${d}/${i}.tmp
# mv -f ${d}/${i}.tmp ${d}/${i}
# done
#done
#%if "%{_host}" != "%{_build}"
#%patch7 -p1
#%endif
%build
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE %{optflags}"
#autoreconf
%configure \
--enable-charset \
--with-gpm-mouse \
--with-screen=slang \
%if "%{stage1}" != "1"
--with-samba \
%endif
--disable-rpath \
%if %enable_vfs
--enable-vfs-mcfs \
%endif
%if %disable_X
--without-x \
%endif
%if "%{_host}" != "%{_build}"
--with-slang-includes=/usr/%{_host}/include \
--with-slang-libs=/usr/%{_host}/lib \
CPPFLAGS="-lm -ldl"
%endif
%make CFLAGS="%optflags -I%{_includedir}/slang"
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%if "%{_build}" != "%{_host}"
(cd src; rm -f man2hlp; gcc man2hlp.c -o man2hlp `pkg-config glib-2.0 --cflags --libs` -I..)
%endif
%makeinstall
# install profile files
install -d %{buildroot}%{_sysconfdir}/profile.d
install -m 755 contrib/{mc.sh,mc.csh} %{buildroot}%{_sysconfdir}/profile.d
# install man pages in various languages
for lang in es hu it pl ru sr; do
mkdir -p %{buildroot}%{_mandir}/${lang}
mkdir -p %{buildroot}%{_mandir}/${lang}/man1
gzip -nf9 doc/man/${lang}/mc.1
install -m 644 doc/man/${lang}/mc.1.gz %{buildroot}%{_mandir}/${lang}/man1
done
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_sysconfdir}/mc/*
%{_bindir}/*
#%config %{_sysconfdir}/profile.d/*
%{_sysconfdir}/profile.d/*sh
%dir %{_datadir}/mc
%{_datadir}/mc/*
%dir %{_libexecdir}/mc
%{_libexecdir}/mc/cons.saver
%{_libexecdir}/mc/mc-wrapper.csh
%{_libexecdir}/mc/mc-wrapper.sh
%{_libexecdir}/mc/mc.csh
%{_libexecdir}/mc/mc.sh
%{_libexecdir}/mc/extfs.d
%{_libexecdir}/mc/fish
%dir %{_libexecdir}/mc/ext.d
%{_libexecdir}/mc/ext.d/*.sh
%{_mandir}/man1/*
%lang(es) %{_mandir}/es/man1/*
%lang(hu) %{_mandir}/hu/man1/*
%lang(it) %{_mandir}/it/man1/*
%lang(pl) %{_mandir}/pl/man1/*
%lang(ru) %{_mandir}/ru/man1/*
%lang(sr) %{_mandir}/sr/man1/*
%doc AUTHORS COPYING
#NEWS README*
%changelog
* Tue Apr 01 2014 Automatic Build System <autodist@mambasoft.it> 4.8.12-1mamba
- automatic version update by autodist
* Mon Dec 02 2013 Automatic Build System <autodist@mambasoft.it> 4.8.11-1mamba
- automatic version update by autodist
* Thu Aug 15 2013 Automatic Build System <autodist@mambasoft.it> 4.8.10-1mamba
- automatic update by autodist
* Thu Jul 11 2013 Automatic Build System <autodist@mambasoft.it> 4.8.9-1mamba
- automatic version update by autodist
* Fri Apr 05 2013 Automatic Build System <autodist@mambasoft.it> 4.8.8-1mamba
- automatic version update by autodist
* Wed Jan 02 2013 Automatic Build System <autodist@mambasoft.it> 4.8.7-1mamba
- automatic version update by autodist
* Thu Oct 18 2012 Automatic Build System <autodist@mambasoft.it> 4.8.6-1mamba
- automatic version update by autodist
* Mon Sep 17 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.4-2mamba
- added an upstream patch to fix a regression in remembering mcedit file position (https://www.midnight-commander.org/ticket/2853?cversion=0&cnum_hist=4)
- re-enabled X11 events support
* Fri Aug 17 2012 Automatic Build System <autodist@mambasoft.it> 4.8.4-1mamba
- automatic version update by autodist
* Thu Jul 19 2012 Automatic Build System <autodist@mambasoft.it> 4.8.1.4-1mamba
- automatic version update by autodist
* Thu Apr 26 2012 Automatic Build System <autodist@mambasoft.it> 4.8.1.3-1mamba
- automatic version update by autodist
* Sun Apr 22 2012 Automatic Build System <autodist@mambasoft.it> 4.8.1.2-1mamba
- automatic version update by autodist
* Tue Mar 20 2012 Automatic Build System <autodist@mambasoft.it> 4.8.1.1-1mamba
- automatic version update by autodist
* Wed Mar 14 2012 Automatic Build System <autodist@mambasoft.it> 4.8.1-1mamba
- automatic version update by autodist
* Mon Nov 14 2011 Automatic Build System <autodist@mambasoft.it> 4.8.0-1mamba
- automatic version update by autodist
* Sat Oct 01 2011 Automatic Build System <autodist@mambasoft.it> 4.7.5.5-1mamba
- update to 4.7.5.5
* Thu Sep 15 2011 Automatic Build System <autodist@mambasoft.it> 4.7.5.4-1mamba
- automatic version update by autodist
* Mon Aug 01 2011 Automatic Build System <autodist@mambasoft.it> 4.7.5.3-1mamba
- update to 4.7.5.3
* Mon Apr 11 2011 Automatic Build System <autodist@mambasoft.it> 4.7.5.2-1mamba
- automatic update by autodist
* Sun Feb 06 2011 Automatic Build System <autodist@mambasoft.it> 4.7.5.1-1mamba
- automatic update by autodist
* Tue Dec 28 2010 Automatic Build System <autodist@mambasoft.it> 4.7.5-1mamba
- automatic update by autodist
* Sun Nov 14 2010 Automatic Build System <autodist@mambasoft.it> 4.7.4-1mamba
- automatic update by autodist
* Mon Nov 08 2010 Automatic Build System <autodist@mambasoft.it> 4.7.0.10-1mamba
- automatic update to 4.7.0.10 by autodist
* Tue Sep 07 2010 Automatic Build System <autodist@mambasoft.it> 4.7.0.9-1mamba
- automatic update to 4.7.0.9 by autodist
* Sun Sep 05 2010 Automatic Build System <autodist@mambasoft.it> 4.7.0.8-1mamba
- automatic update to 4.7.0.8 by autodist
* Sun Jul 11 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.7.0.7-1mamba
- own %{_libexecdir}/mc
- update to 4.7.0.7
* Mon Apr 12 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.7.0.4-2mamba
- use standard make install
* Sun Apr 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.7.0.4-1mamba
- update to 4.7.0.4
* Fri Mar 05 2010 Automatic Build System <autodist@mambasoft.it> 4.7.0.3-1mamba
- automatic update to 4.7.0.3 by autodist
* Wed Feb 10 2010 Automatic Build System <autodist@mambasoft.it> 4.7.0.2-1mamba
- automatic update to 4.7.0.2 by autodist
* Mon Jan 18 2010 Automatic Build System <autodist@mambasoft.it> 4.7.0.1-1mamba
- automatic update to 4.7.0.1 by autodist
* Mon Dec 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.6.2-2mamba
- added utf-8 patch for this version; rebuilt with X events support enabled
* Mon Feb 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.6.2-1mamba
- update to 4.6.2
* Tue Dec 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 4.6.1-6mamba
- added bash32 and debian_fixes patches
* Mon Dec 31 2007 Aleph0 <aleph0@openmamba.org> 4.6.1-5mamba
- fix permissions for profile files
- do not create insecure temporary files in mc-wrapper.[c]sh
* Sat Aug 18 2007 Fabio Giani <fabio.giani@email.it> 4.6.1-4mamba
- specfile updates
* Tue Jan 31 2006 Davide Madrisan <davide.madrisan@qilinux.it> 4.6.1-3qilnx
- enabled support for samba
- do use slang instead of mcslang
- converted to UTF-8 charset and install all the available man pages
- added missing build requirements
* Wed Sep 14 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 4.6.1-2qilnx
- stable 4.6.1 version build
* Mon May 02 2005 Davide Madrisan <davide.madrisan@qilinux.it> 4.6.1-1qilnx
- update from CVS
- also fixes security issues QSA-2005-059
(CAN-2004-100[4,5,9], CAN-2004-109[0,1,2,3], CAN-2004-117[4,5,6])
* Tue May 18 2004 Davide Madrisan <davide.madrisan@qilinux.it> 4.6.0-5qilnx
- specfile updates
* Mon May 03 2004 Davide Madrisan <davide.madrisan@qilinux.it> 4.6.0-4qilnx
- fixed CVE-CAN-2004-{0226,0231,0232} vulnerabilities
* Wed Jan 28 2004 Davide Madrisan <davide.madrisan@qilinux.it> 4.6.0-3qilnx
- conditional disable_X flag
- /usr/lib/mc directory ownership
* Wed Jan 21 2004 Davide Madrisan <davide.madrisan@qilinux.it> 4.6.0-2qilnx
- fixed CVE-CAN-2003-1023 vulnerability
- specfile updated
* Mon Apr 14 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it>
- creation of mc package