automatic version update by autodist [release 4.8.31-1mamba;Sat Jan 27 2024]

This commit is contained in:
Automatic Build System 2024-01-28 09:16:33 +01:00
parent c73b760172
commit 6d2bc1f6d1
6 changed files with 14 additions and 7692 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,146 +0,0 @@
diff -up mc-4.7.0-pre4/configure.ac.extensions mc-4.7.0-pre4/configure.ac
--- mc-4.7.0-pre4/configure.ac.extensions 2009-10-30 19:44:38.000000000 +0100
+++ mc-4.7.0-pre4/configure.ac 2009-12-10 20:41:43.000000000 +0100
@@ -69,7 +69,7 @@ AC_PROG_LN_S
AC_CHECK_TOOL(AR, ar, ar)
dnl Only list browsers here that can be run in background (i.e. with `&')
-AC_CHECK_PROGS(X11_WWW, [gnome-moz-remote mozilla konqueror opera netscape])
+AC_CHECK_PROGS(X11_WWW, [firefox gnome-moz-remote mozilla konqueror opera netscape])
dnl
dnl Ovverriding mmap support. This has to be before AC_FUNC_MMAP is used.
diff -up mc-4.7.0-pre4/misc/mc.ext.in.extensions mc-4.7.0-pre4/misc/mc.ext.in
--- mc-4.7.0-pre4/misc/mc.ext.in.extensions 2009-10-29 20:02:37.000000000 +0100
+++ mc-4.7.0-pre4/misc/mc.ext.in 2009-12-10 20:46:47.000000000 +0100
@@ -226,8 +226,8 @@ regex/\.rpm$
# deb
regex/\.u?deb$
- Open=%cd %p#deb
- View=%view{ascii} dpkg-deb -I %f && echo && dpkg-deb -c %f
+ Open=%cd %p#uar
+ View=%view{ascii} file %f && nm %f
# dpkg
shell/.debd
@@ -387,7 +387,7 @@ shell/.ico
Include=image
include/image
- Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (gqview %f &); fi
+ Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (eog %f &); fi
View=%view{ascii} identify %f
#View=%view{ascii} asciiview %f
@@ -395,7 +395,8 @@ include/image
### Sound files ###
regex/\.([wW][aA][vV]|[sS][nN][dD]|[vV][oO][cC]|[aA][uU]|[sS][mM][pP]|[aA][iI][fF][fF]|[sS][nN][dD])$
- Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
+ Include=audio
+# Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
regex/\.([mM][oO][dD]|[sS]3[mM]|[xX][mM]|[iI][tT]|[mM][tT][mM]|669|[sS][tT][mM]|[uU][lL][tT]|[fF][aA][rR])$
Open=mikmod %f
@@ -405,15 +406,22 @@ regex/\.([wW][aA][wW]22)$
Open=vplay -s 22 %f
regex/\.([mM][pP]3)$
- Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
- View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+ Include=audio
+# Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
+# View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+
+regex/\.([mM][kK][aA])$
+ Include=audio
regex/\.([oO][gG][gG|aA|vV|xX])$
- Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
+ Include=audio
+# Open=ogg123 %f
+# Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
View=%view{ascii} ogginfo %s
regex/\.([sS][pP][xX]|[fF][lL][aA][cC])$
- Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
+ Include=audio
+# Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
regex/\.([mM][iI][dD][iI]?|[rR][mM][iI][dD]?)$
Open=timidity %f
@@ -422,11 +430,15 @@ regex/\.([wW][mM][aA])$
Open=mplayer -vo null %f
View=%view{ascii} mplayer -quiet -slave -frames 0 -vo null -ao null -identify %f 2>/dev/null | tail +13 || file %f
+include/audio
+ Open=mplayer %f
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
### Play lists ###
regex/\.([mM]3[uU]|[pP][lL][sS])$
- Open=if [ -z "$DISPLAY" ]; then mplayer -vo null -playlist %f; else (xmms -p %f >/dev/null 2>&1 &); fi
+ Open=mplayer -vo null -playlist %f
+# Open=if [ -z "$DISPLAY" ]; then mplayer -vo null -playlist %f; else (xmms -p %f >/dev/null 2>&1 &); fi
### Video ###
@@ -471,12 +486,12 @@ include/video
# Postscript
type/^PostScript
- Open=(gv %f &)
+ Open=(xdg-open %f &)
View=%view{ascii} ps2ascii %f
# PDF
type/^PDF
- Open=(xpdf %f &)
+ Open=(xdg-open %f &)
#Open=(acroread %f &)
#Open=(ghostview %f &)
View=%view{ascii} pdftotext %f -
@@ -486,7 +501,7 @@ type/^PDF
# html
regex/\.([hH][tT][mM][lL]?)$
- Open=(if test -n "@X11_WWW@" && test -n "$DISPLAY"; then (@X11_WWW@ file://%d/%p &) 1>&2; else links %f || lynx -force_html %f || ${PAGER:-more} %f; fi) 2>/dev/null
+ Open=xdg-open file://%d/%p 1>&2
View=%view{ascii} links -dump %f 2>/dev/null || w3m -dump %f 2>/dev/null || lynx -dump -force_html %f
# StarOffice 5.2
@@ -504,22 +519,27 @@ shell/.abw
# Microsoft Word Document
regex/\.([Dd][oO][cCtT]|[Ww][rR][iI])$
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
View=%view{ascii} antiword -t %f || catdoc -w %f || word2x -f text %f - || strings %f
type/^Microsoft\ Word
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
View=%view{ascii} antiword -t %f || catdoc -w %f || word2x -f text %f - || strings %f
# RTF document
regex/\.([rR][tT][fF])$
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
# Microsoft Excel Worksheet
regex/\.([xX][lL][sSwW])$
- Open=(gnumeric %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(gnumeric %f >/dev/null 2>&1 &)
View=%view{ascii} xls2csv %f || strings %f
type/^Microsoft\ Excel
- Open=(gnumeric %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(gnumeric %f >/dev/null 2>&1 &)
View=%view{ascii} xls2csv %f || strings %f
# Use OpenOffice.org to open any MS Office documents

View File

@ -1,11 +0,0 @@
--- mc-4.7.0-pre4.orig/src/tty/tty-slang.c 2009-11-07 16:29:08.000000000 0100
+++ mc-4.7.0-pre4/src/tty/tty-slang.c 2009-11-07 16:28:50.000000000 +0100
@@ -499,7 +499,7 @@ tty_set_alt_charset (gboolean alt_charse
void
tty_display_8bit (gboolean what)
{
- SLsmg_Display_Eight_Bit = what ? 128 : 160;
+ SLsmg_Display_Eight_Bit = what & xterm_flag ? 128 : 160;
}
void

View File

@ -1,406 +0,0 @@
diff -Nru mc-4.7.0.4.orig//configure mc-4.7.0.4/configure
--- mc-4.7.0.4.orig//configure 2010-04-02 09:37:38.000000000 +0200
+++ mc-4.7.0.4/configure 2010-04-12 00:43:23.076029038 +0200
@@ -44838,66 +44838,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
- mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
+mc_slang_is_valid_version=yes
if test x$mc_slang_is_valid_version = xno; then
@@ -45407,66 +45348,8 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then
@@ -45976,66 +45859,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then
@@ -47764,66 +47588,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then
@@ -48333,66 +48098,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then
@@ -48902,66 +48608,7 @@
if test x"$found_slang" = x"yes"; then
{ $as_echo "$as_me:$LINENO: checking for S-Lang version 2.0 or newer" >&5
$as_echo_n "checking for S-Lang version 2.0 or newer... " >&6; }
- if test "$cross_compiling" = yes; then
- mc_slang_is_valid_version=no
-
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#ifdef HAVE_SLANG_SLANG_H
-#include <slang/slang.h>
-#else
-#include <slang.h>
-#endif
-int main (void)
-{
-#if SLANG_VERSION >= 20000
- return 0;
-#else
- return 1;
-#endif
-}
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_link") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
mc_slang_is_valid_version=yes
-else
- $as_echo "$as_me: program exited with status $ac_status" >&5
-$as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-mc_slang_is_valid_version=no
-fi
-rm -rf conftest.dSYM
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
if test x$mc_slang_is_valid_version = xno; then

View File

@ -1,53 +0,0 @@
Index: src/args.c
===================================================================
--- src/args.c (revision 23c95d36ac4465627fbc9183e083a8320df77fcf)
+++ src/args.c (revision e39c697df47fe1beb727e0cb890a4c27c22cef09)
@@ -546,5 +546,5 @@
else
{
- arg = mcedit_arg_vpath_new (tmp_vpath, 1);
+ arg = mcedit_arg_vpath_new (tmp_vpath, 0);
vfs_path_free (fname_vpath);
}
@@ -553,5 +553,5 @@
}
else
- arg = mcedit_arg_new (tmp, 1);
+ arg = mcedit_arg_new (tmp, 0);
flist = g_list_prepend (flist, arg);
@@ -559,12 +559,9 @@
if (flist == NULL)
- flist = g_list_prepend (flist, mcedit_arg_new (NULL, 1));
+ flist = g_list_prepend (flist, mcedit_arg_new (NULL, 0));
else if (first_line_number != -1)
{
/* overwrite line number for first file */
GList *l;
-
- if (first_line_number == 0)
- first_line_number = 1;
l = g_list_last (flist);
@@ -820,5 +817,5 @@
*
* @param file_name file name
- * @param line_number line number
+ * @param line_number line number. If value is 0, try to restore saved position.
* @return mcedit_arg_t object
*/
@@ -835,5 +832,5 @@
*
* @param file_vpath file path object
- * @param line_number line number
+ * @param line_number line number. If value is 0, try to restore saved position.
* @return mcedit_arg_t object
*/
@@ -846,6 +843,4 @@
arg = g_new (mcedit_arg_t, 1);
arg->file_vpath = file_vpath;
- if (line_number == 0)
- line_number = 1;
arg->line_number = line_number;

73
mc.spec
View File

@ -2,7 +2,7 @@
%define enable_vfs 1 %define enable_vfs 1
Name: mc Name: mc
Version: 4.8.30 Version: 4.8.31
Release: 1mamba Release: 1mamba
Summary: A user-friendly file manager and visual shell Summary: A user-friendly file manager and visual shell
Group: Applications/Shells Group: Applications/Shells
@ -11,20 +11,15 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://midnight-commander.org/ URL: http://midnight-commander.org/
Source: http://www.midnight-commander.org/downloads/%{name}-%{version}.tar.xz Source: http://www.midnight-commander.org/downloads/%{name}-%{version}.tar.xz
# see http://www.freedesktop.org/wiki/Software_2fBadSoftware
Patch1: %{name}-4.6.2-utf8.patch.gz
Patch5: %{name}-4.7.0.1-extensions.patch
Patch6: %{name}-4.7.0.1-tty-slang.patch
Patch7: %{name}-4.7.0.4-cross_compile_slang.patch
Patch8: mc-4.8.4-remember_file_position.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libe2fs-devel
BuildRequires: libglib-devel BuildRequires: libglib-devel
%if "%{stage1}" != "1"
BuildRequires: libgpm-devel BuildRequires: libgpm-devel
%endif BuildRequires: libperl
BuildRequires: libslang-devel BuildRequires: libslang-devel
BuildRequires: libssh2-devel
BuildRequires: perl-devel BuildRequires: perl-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: bison BuildRequires: bison
@ -40,51 +35,18 @@ Midnight Commander is a visual shell much like a file manager, only with way mor
It is text mode, but also includes mouse support if you are running GPM. It is text mode, but also includes mouse support if you are running GPM.
Its coolest feature is the ability to ftp, view tar, zip files, and poke into RPMs for specific files. Its coolest feature is the ability to ftp, view tar, zip files, and poke into RPMs for specific files.
%debug_package
%prep %prep
%setup -q -n %{name}-%{version} %setup -q
#%patch1 -p1
#%patch5 -p1
#%patch6 -p1
#%patch8 -p0
# FIXME: files in /lib should be converted to UTF-8
## convert man pages in /doc to UTF-8
#cd doc/man
#for i in mc.1.in xnc.hlp; do
# iconv -f koi8-r -t utf-8 < ru/${i} > ru/${i}.tmp
# mv -f ru/${i}.tmp ru/${i}
#done
#for i in mc.1.in mcserv.8.in xnc.hlp; do
# iconv -f iso-8859-5 -t utf-8 < sr/${i} > sr/${i}.tmp
# mv -f sr/${i}.tmp sr/${i}
#done
#for d in es it; do
# for i in mc.1.in xnc.hlp; do
# iconv -f iso-8859-3 -t utf-8 < ${d}/${i} > ${d}/${i}.tmp
# mv -f ${d}/${i}.tmp ${d}/${i}
# done
#done
#for d in hu pl; do
# for i in mc.1.in xnc.hlp; do
# iconv -f iso-8859-2 -t utf-8 < ${d}/${i} > ${d}/${i}.tmp
# mv -f ${d}/${i}.tmp ${d}/${i}
# done
#done
#%if "%{_host}" != "%{_build}"
#%patch7 -p1
#%endif
%build %build
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE %{optflags}" export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE %{optflags}"
#autoreconf
%configure \ %configure \
--enable-charset \ --enable-charset \
--with-gpm-mouse \ --with-gpm-mouse \
--with-screen=slang \ --with-screen=slang \
%if "%{stage1}" != "1"
--with-samba \ --with-samba \
%endif
--disable-rpath \ --disable-rpath \
%if %enable_vfs %if %enable_vfs
--enable-vfs-mcfs \ --enable-vfs-mcfs \
@ -92,11 +54,6 @@ export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE %{optflags}"
%if %disable_X %if %disable_X
--without-x \ --without-x \
%endif %endif
%if "%{_host}" != "%{_build}"
--with-slang-includes=/usr/%{_host}/include \
--with-slang-libs=/usr/%{_host}/lib \
CPPFLAGS="-lm -ldl"
%endif
%make CFLAGS="%optflags -I%{_includedir}/slang" %make CFLAGS="%optflags -I%{_includedir}/slang"
@ -120,7 +77,7 @@ gzip -nf9 doc/man/${lang}/mc.1
install -m 644 doc/man/${lang}/mc.1.gz %{buildroot}%{_mandir}/${lang}/man1 install -m 644 doc/man/${lang}/mc.1.gz %{buildroot}%{_mandir}/${lang}/man1
done done
%find_lang %{name} %find_lang %{name} --with-man
%clean %clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -129,7 +86,6 @@ done
%defattr(-,root,root) %defattr(-,root,root)
%{_sysconfdir}/mc/* %{_sysconfdir}/mc/*
%{_bindir}/* %{_bindir}/*
#%config %{_sysconfdir}/profile.d/*
%{_sysconfdir}/profile.d/*sh %{_sysconfdir}/profile.d/*sh
%dir %{_datadir}/mc %dir %{_datadir}/mc
%{_datadir}/mc/* %{_datadir}/mc/*
@ -140,20 +96,19 @@ done
%{_libexecdir}/mc/mc.csh %{_libexecdir}/mc/mc.csh
%{_libexecdir}/mc/mc.sh %{_libexecdir}/mc/mc.sh
%{_libexecdir}/mc/extfs.d %{_libexecdir}/mc/extfs.d
%{_libexecdir}/mc/fish #%{_libexecdir}/mc/fish
%dir %{_libexecdir}/mc/ext.d %dir %{_libexecdir}/mc/ext.d
%{_libexecdir}/mc/ext.d/*.sh %{_libexecdir}/mc/ext.d/*.sh
%dir %{_libexecdir}/mc/shell
%{_libexecdir}/mc/shell/*
%{_mandir}/man1/* %{_mandir}/man1/*
%lang(es) %{_mandir}/es/man1/*
%lang(hu) %{_mandir}/hu/man1/*
%lang(it) %{_mandir}/it/man1/*
%lang(pl) %{_mandir}/pl/man1/*
%lang(ru) %{_mandir}/ru/man1/*
%lang(sr) %{_mandir}/sr/man1/*
%doc AUTHORS COPYING %doc AUTHORS COPYING
#NEWS README* #NEWS README*
%changelog %changelog
* Sat Jan 27 2024 Automatic Build System <autodist@openmamba.org> 4.8.31-1mamba
- automatic version update by autodist
* Mon Aug 14 2023 Automatic Build System <autodist@mambasoft.it> 4.8.30-1mamba * Mon Aug 14 2023 Automatic Build System <autodist@mambasoft.it> 4.8.30-1mamba
- automatic version update by autodist - automatic version update by autodist