automatic version update by autodist [release 5.33.0-1mamba;Sun Apr 13 2014]

This commit is contained in:
Automatic Build System 2024-01-06 06:59:15 +01:00
parent f9a8bc7cf1
commit b1435160b4
4 changed files with 369 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# maxima # maxima
A sophisticated computer algebra system.

View File

@ -0,0 +1,235 @@
commit 79bae2da8dc19bbd3355112bb9abb64c4c48ecb2
Author: Julien Puydt <julien.puydt@laposte.net>
Date: Fri May 17 19:39:48 2013 +0200
Patch fixing the compilation with texinfo 5
diff --git a/Bugs.texi b/Bugs.texi
index 0d1bf5e..3032459 100644
--- a/Bugs.texi
+++ b/Bugs.texi
@@ -17,7 +17,7 @@ answer, but are marked as known bugs.
@code{run_testsuite} takes the following optional keyword arguments
-@table @var
+@table @code
@item display_all
Display all tests. Normally, the tests are not displayed, unless the test
fails. (Defaults to @code{false}).
diff --git a/Integration.texi b/Integration.texi
index a5443b5..09b39a7 100644
--- a/Integration.texi
+++ b/Integration.texi
@@ -1000,7 +1000,7 @@ achieved.
The keyword arguments are optional and may be specified in any order.
They all take the form @code{key=val}. The keyword arguments are:
-@table @var
+@table @code
@item epsrel
Desired relative error of approximation. Default is 1d-8.
@item epsabs
@@ -1092,7 +1092,7 @@ operator, a Maxima lambda expression, or a general Maxima expression.
The keyword arguments are optional and may be specified in any order.
They all take the form @code{key=val}. The keyword arguments are:
-@table @var
+@table @code
@item epsrel
Desired relative error of approximation. Default is 1d-8.
@item epsabs
@@ -1200,7 +1200,7 @@ One of the limits of integration must be infinity. If not, then
The keyword arguments are optional and may be specified in any order.
They all take the form @code{key=val}. The keyword arguments are:
-@table @var
+@table @code
@item epsrel
Desired relative error of approximation. Default is 1d-8.
@item epsabs
@@ -1297,7 +1297,7 @@ operator, a Maxima lambda expression, or a general Maxima expression.
The keyword arguments are optional and may be specified in any order.
They all take the form @code{key=val}. The keyword arguments are:
-@table @var
+@table @code
@item epsrel
Desired relative error of approximation. Default is 1d-8.
@item epsabs
@@ -1414,7 +1414,7 @@ operator, a Maxima lambda expression, or a general Maxima expression.
The keyword arguments are optional and may be specified in any order.
They all take the form @code{key=val}. The keyword arguments are:
-@table @var
+@table @code
@item epsabs
Desired absolute error of approximation. Default is 1d-10.
@item limit
@@ -1551,7 +1551,7 @@ operator, a Maxima lambda expression, or a general Maxima expression.
The keyword arguments are optional and may be specified in any order.
They all take the form @code{key=val}. The keyword arguments are:
-@table @var
+@table @code
@item epsrel
Desired relative error of approximation. Default is 1d-8.
@item epsabs
@@ -1684,7 +1684,7 @@ operator, a Maxima lambda expression, or a general Maxima expression.
The keyword arguments are optional and may be specified in any order.
They all take the form @code{key=val}. The keyword arguments are:
-@table @var
+@table @code
@item epsrel
Desired relative error of approximation. Default is 1d-8.
@item epsabs
@@ -1788,7 +1788,7 @@ the integrand is singular or discontinous.
The keyword arguments are optional and may be specified in any order.
They all take the form @code{key=val}. The keyword arguments are:
-@table @var
+@table @code
@item epsrel
Desired relative error of approximation. Default is 1d-8.
@item epsabs
diff --git a/Numerical.texi b/Numerical.texi
index 6ce826a..a788ac6 100644
--- a/Numerical.texi
+++ b/Numerical.texi
@@ -422,7 +422,7 @@ The accuracy of @code{find_root} is governed by @code{abserr} and
@code{find_root}. These keyword arguments take the form
@code{key=val}. The keyword arguments are
-@table @var
+@table @code
@item abserr
Desired absolute error of function value at root. Default is
@code{find_root_abs}.
diff --git a/category-macros.texi b/category-macros.texi
index f8984ae..c7cf8ab 100644
--- a/category-macros.texi
+++ b/category-macros.texi
@@ -25,32 +25,38 @@
@c Macros for cross references
-@macro mref {nodename}
@ifhtml
+@macro mref {nodename}
@code{@ref{\nodename\}}
+@end macro
@end ifhtml
@ifnothtml
+@macro mref {nodename}
@code{\nodename\}
-@end ifnothtml
@end macro
+@end ifnothtml
-@macro mxref {nodename, text}
@ifhtml
+@macro mxref {nodename, text}
@code{@ref{\nodename\, \text\}}
+@end macro
@end ifhtml
@ifnothtml
+@macro mxref {nodename, text}
@code{\text\}
-@end ifnothtml
@end macro
+@end ifnothtml
-@macro mrefdot {nodename}
@ifhtml
+@macro mrefdot {nodename}
@code{@ref{\nodename\}}.
+@end macro
@end ifhtml
@ifnothtml
+@macro mrefdot {nodename}
@code{\nodename\}.
-@end ifnothtml
@end macro
+@end ifnothtml
@macro mxrefdot {nodename, text}
@ifhtml
@@ -61,30 +67,36 @@
@end ifnothtml
@end macro
-@macro mrefcomma {nodename}
@ifhtml
+@macro mrefcomma {nodename}
@code{@ref{\nodename\}},
+@end macro
@end ifhtml
@ifnothtml
+@macro mrefcomma {nodename}
@code{\nodename\},
-@end ifnothtml
@end macro
+@end ifnothtml
-@macro mxrefcomma {nodename, text}
@ifhtml
+@macro mxrefcomma {nodename, text}
@code{@ref{\nodename\, \text\}},
+@end macro
@end ifhtml
@ifnothtml
+@macro mxrefcomma {nodename, text}
@code{\text\},
-@end ifnothtml
@end macro
+@end ifnothtml
-@macro mrefparen {nodename}
@ifhtml
+@macro mrefparen {nodename}
@code{@ref{\nodename\}})
+@end macro
@end ifhtml
@ifnothtml
+@macro mrefparen {nodename}
@code{\nodename\})
-@end ifnothtml
@end macro
+@end ifnothtml
diff --git a/lapack.texi b/lapack.texi
index 01ddeeb..8702ade 100644
--- a/lapack.texi
+++ b/lapack.texi
@@ -417,7 +417,7 @@ specifed by optional keyword arguments: The keyword arguments are
optional and may be specified in any order. They all take the form
@code{key=val}. The keyword arguments are:
-@table @var
+@table @code
@item C
The matrix @var{C} that should be added. The default is @code{false},
which means no matrix is added.
diff --git a/zeilberger.texi b/zeilberger.texi
index 7caf72b..ad36fb6 100644
--- a/zeilberger.texi
+++ b/zeilberger.texi
@@ -21,7 +21,7 @@ summation.
@category{Sums and products} @category{Share packages} @category{Package zeilberger}
@closecatbox
-@subsubsection The indefinite summation problem
+@subsection The indefinite summation problem
@code{zeilberger} implements Gosper's algorithm for indefinite hypergeometric summation.
Given a hypergeometric term @math{F_k} in @math{k} we want to find its hypergeometric
@@ -34,7 +34,7 @@ $$F_k = f_{k+1} - f_k.$$
@math{F_k = f_(k+1) - f_k}.
@end ifnottex
-@subsubsection The definite summation problem
+@subsection The definite summation problem
@code{zeilberger} implements Zeilberger's algorithm for definite hypergeometric summation.
Given a proper hypergeometric term (in @math{n} and @math{k})

BIN
maxima.png Normal file

Binary file not shown.

After

Width:  |  Height:  |  Size: 869 B

132
maxima.spec Normal file
View File

@ -0,0 +1,132 @@
Name: maxima
Version: 5.33.0
Release: 1mamba
Summary: A sophisticated computer algebra system
Group: Graphical Desktop/Applications/Educational
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://maxima.sourceforge.net/
Source: http://downloads.sourceforge.net/sourceforge/maxima/%{name}-%{version}.tar.gz
Source1: maxima.png
Patch0: maxima-5.30.0-texinfo-5.patch
License: GPL
Requires(post):%{__install_info}
BuildRequires: clisp-devel >= 2.34
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libncurses-devel
BuildRequires: libreadline-devel
BuildRequires: libtk-devel
## AUTOBUILDREQ-END
Requires: libtk
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
A sophisticated computer algebra system.
%prep
%setup -q
#cd doc/info
#%patch0 -p1
#cd ../../
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
mkdir -p %{buildroot}%{_datadir}/pixmaps
install -D -m 644 %{SOURCE1} %{buildroot}%{_datadir}/pixmaps/maxima.png
# Create the system menu entry
mkdir -p %{buildroot}%{_datadir}/applications
cat > %{buildroot}%{_datadir}/applications/maxima.desktop << EOF
[Desktop Entry]
GenericName=A sophisticated computer algebra system
GenericName[de]=Computeralgebra System
GenericName[it]=algebra a livello avanzato
Comment=A sophisticated computer algebra system
Exec=/usr/bin/xmaxima
Icon=/usr/share/pixmaps/maxima.png
Terminal=1
Type=Application
Categories=Qt;KDE;Math;Education
EOF
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post
%install_info maxima.info
%preun
%uninstall_info maxima.info
exit 0
%files
%defattr(-,root,root)
%{_bindir}/maxima
%{_bindir}/rmaxima
%{_bindir}/xmaxima
%{_libexecdir}/maxima/%{version}/mgnuplot
#%{_libexecdir}/maxima/%{version}/omplotdata
%{_libdir}/maxima/%{version}/binary-clisp/lisp.run
%{_libdir}/maxima/%{version}/binary-clisp/maxima.mem
%dir %{_datadir}/maxima
%{_datadir}/maxima/*
%{_datadir}/pixmaps/maxima.png
%{_datadir}/applications/maxima.desktop
%{_infodir}/*
%{_mandir}/man1/maxima.1.gz
%doc AUTHORS COPYING ChangeLog INSTALL NEWS README README.external README.lisps
%doc README.rpms
%changelog
* Sun Apr 13 2014 Automatic Build System <autodist@mambasoft.it> 5.33.0-1mamba
- automatic version update by autodist
* Fri Jan 31 2014 Automatic Build System <autodist@mambasoft.it> 5.32.1-1mamba
- automatic version update by autodist
* Sun Oct 06 2013 Automatic Build System <autodist@mambasoft.it> 5.31.2-1mamba
- automatic update by autodist
* Mon Jun 03 2013 Automatic Build System <autodist@mambasoft.it> 5.30.0-1mamba
- automatic version update by autodist
* Mon Jan 07 2013 Automatic Build System <autodist@mambasoft.it> 5.29.1-1mamba
- automatic version update by autodist
* Wed Aug 19 2009 Automatic Build System <autodist@mambasoft.it> 5.19.1-2mamba
- automatic rebuild by autodist
* Wed Aug 19 2009 Automatic Build System <autodist@mambasoft.it> 5.19.1-1mamba
- automatic update by autodist
* Sun Aug 09 2009 Automatic Build System <autodist@mambasoft.it> 5.19.0-1mamba
- automatic update by autodist
* Wed Jul 01 2009 Automatic Build System <autodist@mambasoft.it> 5.18.1-1mamba
- automatic update by autodist
* Mon Mar 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 5.17.0-1mamba
- update to 5.17.0
* Mon Jul 28 2008 gil <puntogil@libero.it> 5.15.0-1mamba
- update to 5.15.0
* Wed Nov 10 2005 Massimo Pintore <massimo.pintore@qilinux.it> 5.9.2-2qilnx
- added libtk as requires and buildrequires
* Mon Nov 07 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 5.9.2-1qilnx
- update to version 5.9.2 by autospec
* Mon Sep 26 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 5.9.1-2qilnx
- added desktop file
* Wed Aug 24 2005 Massimo Pintore <massimo.pintore@qilinux.it> 5.9.1-1qilnx
- package created by autospec