renamed from marble5 to marble [release 16.04.2-2mamba;Sun Jul 10 2016]
This commit is contained in:
parent
8753a3274a
commit
e07ec755a5
10
marble-15.12.2-gcc-5.3.0-std_isnan.patch
Normal file
10
marble-15.12.2-gcc-5.3.0-std_isnan.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- marble-15.12.2/src/plugins/positionprovider/gpsd/GpsdPositionProviderPlugin.cpp.orig 2016-03-09 16:33:24.863963392 +0100
|
||||
+++ marble-15.12.2/src/plugins/positionprovider/gpsd/GpsdPositionProviderPlugin.cpp 2016-03-09 16:30:15.644197929 +0100
|
||||
@@ -15,6 +15,7 @@
|
||||
#include <math.h>
|
||||
|
||||
using namespace Marble;
|
||||
+using namespace std;
|
||||
/* TRANSLATOR Marble::GpsdPositionProviderPlugin */
|
||||
|
||||
QString GpsdPositionProviderPlugin::name() const
|
194
marble.spec
194
marble.spec
@ -1,29 +1,53 @@
|
||||
Name: marble
|
||||
Version: 4.14.3
|
||||
Release: 3mamba
|
||||
Version: 16.04.2
|
||||
Release: 2mamba
|
||||
Summary: A free open source geographical map program
|
||||
Group: Graphical Desktop/Applications/Educational
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://edu.kde.org/marble/
|
||||
Source: http://download.kde.org/stable/%{version}/src/marble-%{version}.tar.xz
|
||||
Source: http://download.kde.org/stable/applications/%{version}/src/marble-%{version}.tar.xz
|
||||
Patch0: marble-4.13.0-arm_qreal_double.patch
|
||||
Patch1: marble-15.12.2-gcc-5.3.0-std_isnan.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: kdelibs-devel
|
||||
BuildRequires: libQt5ExtSerialPort-devel
|
||||
BuildRequires: libQt5WebKit-devel
|
||||
BuildRequires: libattica5-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgps-devel
|
||||
BuildRequires: libphonon-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libsoprano-devel
|
||||
BuildRequires: libkauth-devel
|
||||
BuildRequires: libkcodecs-devel
|
||||
BuildRequires: libkcompletion-devel
|
||||
BuildRequires: libkconfig-devel
|
||||
BuildRequires: libkconfigwidgets-devel
|
||||
BuildRequires: libkcoreaddons-devel
|
||||
BuildRequires: libkcrash-devel
|
||||
BuildRequires: libki18n-devel
|
||||
BuildRequires: libkio-devel
|
||||
BuildRequires: libkjobwidgets-devel
|
||||
BuildRequires: libknewstuff-devel
|
||||
BuildRequires: libkpackage-devel
|
||||
BuildRequires: libkparts-devel
|
||||
BuildRequires: libkrunner-devel
|
||||
BuildRequires: libkservice-devel
|
||||
BuildRequires: libktextwidgets-devel
|
||||
BuildRequires: libkwidgetsaddons-devel
|
||||
BuildRequires: libkxmlgui-devel
|
||||
BuildRequires: libphonon-qt5-devel
|
||||
BuildRequires: libplasma-framework-devel
|
||||
BuildRequires: libqt5-devel
|
||||
BuildRequires: libsonnet-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libwlocate-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libqt-mobility-devel
|
||||
BuildRequires: libgps-devel >= 3.7
|
||||
Conflicts: kdeedu4-devel < 4.7.1
|
||||
Provides: marble5
|
||||
Obsoletes: marble5
|
||||
Requires: libmarble = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
@ -48,7 +72,9 @@ Choose between a Flat Map ("Plate carré"), Mercator or the Globe.
|
||||
|
||||
%package -n libmarble
|
||||
Group: Graphical Desktop/Libraries/KDE
|
||||
Summary: Runtime files for %{name}
|
||||
Summary: KDE5 library files for %{name}
|
||||
Provides: libmarble5
|
||||
Obsoletes: libmarble5
|
||||
|
||||
%description -n libmarble
|
||||
%{summary}.
|
||||
@ -57,22 +83,19 @@ Summary: Runtime files for %{name}
|
||||
Group: Development/Libraries
|
||||
Summary: Marble development files
|
||||
Requires: libmarble = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: libmarble5-devel
|
||||
Obsoletes: libmarble5-devel
|
||||
|
||||
%description -n libmarble-devel
|
||||
%{summary}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%ifarch arm
|
||||
#%patch0 -p1
|
||||
#%endif
|
||||
%setup -q -n marble-%{version}
|
||||
%patch1 -p1
|
||||
#-D -T
|
||||
|
||||
%build
|
||||
%cmake_kde4 -d build \
|
||||
-DQTMOBILITY_INCLUDE_DIR:PATH=%{_qt4_headerdir}/QtMobility \
|
||||
-DQTLOCATION_INCLUDE_DIR:PATH=%{_qt4_headerdir}/QtLocation
|
||||
%cmake_kde5 -d build
|
||||
|
||||
%make
|
||||
|
||||
@ -80,23 +103,21 @@ Requires: libmarble = %{?epoch:%epoch:}%{version}-%{release}
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
rm -f %{buildroot}%{_kde4_libdir}/libastro.so*
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
touch --no-create %{_kde4_icondir}/hicolor &>/dev/null
|
||||
touch --no-create %{_kde5_icondir}/hicolor &>/dev/null
|
||||
exit 0
|
||||
|
||||
%posttrans
|
||||
gtk-update-icon-cache %{_kde4_icondir}/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_kde5_icondir}/hicolor &>/dev/null
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
if [ $1 -eq 0 ]; then
|
||||
touch --no-create %{_kde4_icondir}/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_kde4_icondir}/hicolor &>/dev/null
|
||||
touch --no-create %{_kde5_icondir}/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_kde5_icondir}/hicolor &>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
@ -105,58 +126,97 @@ exit 0
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_kde4_bindir}/marble
|
||||
%{_kde4_bindir}/marble-mobile
|
||||
%{_kde4_bindir}/marble-qt
|
||||
%{_kde4_bindir}/marble-touch
|
||||
#%{_kde4_bindir}/routing-instructions
|
||||
#%{_kde4_bindir}/tilecreator
|
||||
%dir %{_kde4_datadir}/marble
|
||||
%{_kde4_datadir}/marble/*
|
||||
%doc %lang(en) %{_kde4_htmldir}/en/marble
|
||||
%{_kde4_icondir}/hicolor/*/apps/marble.png
|
||||
%{_kde4_kcfgdir}/marble.kcfg
|
||||
%{_kde4_libdir}/kde4/marblethumbnail.so
|
||||
%{_kde4_libdir}/kde4/plasma_applet_worldclock.so
|
||||
%{_kde4_libdir}/kde4/plasma_runner_marble.so
|
||||
#%{_kde4_servicesdir}/marble_part.desktop
|
||||
%{_kde4_servicesdir}/plasma-applet-kworldclock.desktop
|
||||
%{_kde4_servicesdir}/plasma-runner-marble.desktop
|
||||
%{_kde4_servicesdir}/marble_*.desktop
|
||||
%{_kde4_sharedir}/appdata/marble.appdata.xml
|
||||
%{_kde4_xdgappsdir}/marble*.desktop
|
||||
%{_kde4_xdgmimedir}/geo.xml
|
||||
%doc COPYING.DOC CREDITS
|
||||
%{_kde5_bindir}/marble
|
||||
#%{_kde5_bindir}/marble-mobile
|
||||
%{_kde5_bindir}/marble-qt
|
||||
#%{_kde5_bindir}/marble-touch
|
||||
%dir %{_kde5_datadir}/marble
|
||||
%{_kde5_datadir}/marble/*
|
||||
%{_datadir}/mime/packages/geo.xml
|
||||
%doc %lang(en) %{_kde5_htmldir}/en/marble
|
||||
%dir %{_datadir}/kxmlgui5/marble
|
||||
%{_datadir}/kxmlgui5/marble/*
|
||||
%{_kde5_icondir}/hicolor/*/apps/marble.png
|
||||
%{_kde5_kcfgdir}/marble.kcfg
|
||||
%{_kde5_servicesdir}/plasma-runner-marble.desktop
|
||||
%{_kde5_servicesdir}/marble_*.desktop
|
||||
%{_kde5_sharedir}/appdata/marble.appdata.xml
|
||||
%{_kde5_xdgappsdir}/marble*.desktop
|
||||
|
||||
%files -n libmarble
|
||||
%defattr(-,root,root)
|
||||
#%{_kde4_libdir}/libastro.so.*
|
||||
%{_kde4_libdir}/libmarblewidget.so.*
|
||||
%{_kde4_libdir}/kde4/libmarble_part.so
|
||||
%dir %{_kde4_pluginsdir}/marble
|
||||
%{_kde4_pluginsdir}/marble/*
|
||||
%{_libdir}/qt5/plugins/libmarble_part.so
|
||||
%{_libdir}/qt5/plugins/libmarblethumbnail.so
|
||||
%{_libdir}/qt5/plugins/plasma_runner_marble.so
|
||||
%{_libdir}/libastro.so.*
|
||||
%{_libdir}/libmarblewidget-qt5.so.*
|
||||
%dir %{_libdir}/marble
|
||||
%dir %{_libdir}/marble/plugins
|
||||
#%ifarch x86_64
|
||||
#%{_libdir}/marble/plugins/org/kde/edu/marble/*
|
||||
#%else
|
||||
#%{_libdir}/qt5/qml/org/kde/edu/marble/*
|
||||
#%endif
|
||||
%dir %{_libdir}/marble/plugins
|
||||
%{_libdir}/marble/plugins/lib*.so
|
||||
%{_libdir}/plugins/designer/lib*.so
|
||||
%doc COPYING.DOC CREDITS
|
||||
|
||||
%files -n libmarble-devel
|
||||
%defattr(-,root,root)
|
||||
%{_kde4_datadir}/cmake/modules/FindMarble.cmake
|
||||
%dir %{_kde4_includedir}/astro
|
||||
%{_kde4_includedir}/astro/*.h
|
||||
%dir %{_kde4_includedir}/marble
|
||||
%{_kde4_includedir}/marble/*
|
||||
#%{_kde4_libdir}/libastro.so
|
||||
%{_kde4_libdir}/libmarblewidget.so
|
||||
%{_kde4_pluginsdir}/designer/LatLonEditPlugin.so
|
||||
%{_kde4_pluginsdir}/designer/MarbleNavigatorPlugin.so
|
||||
%{_kde4_pluginsdir}/designer/MarbleWidgetPlugin.so
|
||||
%doc BUGS ChangeLog TODO
|
||||
%dir %{_includedir}/astro
|
||||
%{_includedir}/astro/*.h
|
||||
%dir %{_includedir}/marble
|
||||
%{_includedir}/marble/*.h
|
||||
%{_libdir}/libastro.so
|
||||
%{_libdir}/libmarblewidget-qt5.so
|
||||
%{_libdir}/libmarbledeclarative.so
|
||||
%doc BUGS ChangeLog
|
||||
%doc docs/*
|
||||
|
||||
%changelog
|
||||
* Mon Jul 04 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.3-3mamba
|
||||
- rebuilt with debug package
|
||||
* Sun Jul 10 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 16.04.2-2mamba
|
||||
- renamed from marble5 to marble
|
||||
|
||||
* Sat Jun 18 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.3-2mamba
|
||||
- remove libastro provided by marble5
|
||||
* Wed Jun 15 2016 Automatic Build System <autodist@mambasoft.it> 16.04.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon May 16 2016 Automatic Build System <autodist@mambasoft.it> 16.04.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Apr 23 2016 Automatic Build System <autodist@mambasoft.it> 16.04.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Mar 16 2016 Automatic Build System <autodist@mambasoft.it> 15.12.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Mar 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 15.12.2-2mamba
|
||||
- rebuilt with libwlocate
|
||||
|
||||
* Wed Feb 17 2016 Automatic Build System <autodist@mambasoft.it> 15.12.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jan 16 2016 Automatic Build System <autodist@mambasoft.it> 15.12.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jan 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 15.12.0-1mamba
|
||||
- update to 15.12.0
|
||||
- rename from marble to marble5
|
||||
|
||||
* Sun Dec 27 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 15.08.3-3mamba
|
||||
- fix path of cmake file
|
||||
|
||||
* Sat Nov 21 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 15.08.3-2mamba
|
||||
- build also kde4 version
|
||||
|
||||
* Wed Nov 11 2015 Automatic Build System <autodist@mambasoft.it> 15.08.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 14 2015 Automatic Build System <autodist@mambasoft.it> 15.08.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Oct 10 2015 Automatic Build System <autodist@mambasoft.it> 15.08.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Nov 20 2014 Automatic Build System <autodist@mambasoft.it> 4.14.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
Loading…
Reference in New Issue
Block a user