automatic version update by autodist [release 4.13.0-1mamba;Wed Apr 23 2014]

This commit is contained in:
Automatic Build System 2024-01-06 06:56:41 +01:00
parent 91e86e40ec
commit 279d864353
3 changed files with 268 additions and 0 deletions

View File

@ -1,2 +1,16 @@
# marble
Marble is a Virtual Globe and World Atlas that you can use to learn more about Earth: You can pan and zoom around and you can look up places and roads.
A mouse click on a place label will provide the respective Wikipedia article.
Of course it's also possible to measure distances between locations or watch the current cloud cover.
Marble offers different thematic maps:
- A classroom-style topographic map,
- a satellite view,
- street map,
- earth at night and
- temperature and precipitation maps.
All maps include a custom map key, so it can also be used as an educational tool for use in class-rooms.
For educational purposes you can also change date and time and watch how the starry sky and the twilight zone on the map change.
In opposite to other virtual globes Marble also features multiple projections:
Choose between a Flat Map ("Plate carré"), Mercator or the Globe.

View File

@ -0,0 +1,11 @@
--- marble-4.13.0/tests/GeoUriParserTest.cpp.orig 2014-05-01 20:58:07.322703258 +0200
+++ marble-4.13.0/tests/GeoUriParserTest.cpp 2014-05-01 20:51:01.363102128 +0200
@@ -72,7 +72,7 @@
GeoDataCoordinates coords = parser.coordinates();
double cLat = 0.0, cLon = 0.0, cAlt = 0.0;
- coords.geoCoordinates(cLon, cLat, cAlt, GeoDataCoordinates::Degree);
+ coords.geoCoordinates((qreal&)cLon, (qreal&)cLat, (qreal&)cAlt, GeoDataCoordinates::Degree);
QCOMPARE(ret, valid);
if ( ret == valid ) {

243
marble.spec Normal file
View File

@ -0,0 +1,243 @@
Name: marble
Version: 4.13.0
Release: 1mamba
Summary: A free open source geographical map program
Group: Graphical Desktop/Applications/Educational
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: http://edu.kde.org/marble/
Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/marble-%{version}.tar.xz
Patch0: marble-4.13.0-arm_qreal_double.patch
License: LGPL
BuildRequires: cmake
BuildRequires: qt-mobility-devel
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: kdelibs-devel
BuildRequires: libgcc
BuildRequires: libgps-devel
BuildRequires: libphonon-devel
BuildRequires: libqt4-devel
BuildRequires: libsoprano-devel
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: libgps-devel >= 3.7
Conflicts: kdeedu4-devel < 4.7.1
Requires: libmarble = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
# FIXME:
#-- checking for module 'liblocation>=0.102'
#-- package 'liblocation>=0.102' not found
%description
Marble is a Virtual Globe and World Atlas that you can use to learn more about Earth: You can pan and zoom around and you can look up places and roads.
A mouse click on a place label will provide the respective Wikipedia article.
Of course it's also possible to measure distances between locations or watch the current cloud cover.
Marble offers different thematic maps:
- A classroom-style topographic map,
- a satellite view,
- street map,
- earth at night and
- temperature and precipitation maps.
All maps include a custom map key, so it can also be used as an educational tool for use in class-rooms.
For educational purposes you can also change date and time and watch how the starry sky and the twilight zone on the map change.
In opposite to other virtual globes Marble also features multiple projections:
Choose between a Flat Map ("Plate carré"), Mercator or the Globe.
%package -n libmarble
Group: Graphical Desktop/Libraries/KDE
Summary: Runtime files for %{name}
%description -n libmarble
%{summary}.
%package -n libmarble-devel
Group: Development/Libraries
Summary: Marble development files
Requires: libmarble = %{?epoch:%epoch:}%{version}-%{release}
%description -n libmarble-devel
%{summary}.
%prep
%setup -q
%ifarch arm
%patch0 -p1
%endif
%build
%cmake_kde4 -d build \
-DQTMOBILITY_INCLUDE_DIR:PATH=%{_qt4_headerdir}/QtMobility \
-DQTLOCATION_INCLUDE_DIR:PATH=%{_qt4_headerdir}/QtLocation
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post
touch --no-create %{_kde4_icondir}/hicolor &>/dev/null
exit 0
%posttrans
gtk-update-icon-cache %{_kde4_icondir}/hicolor &>/dev/null
exit 0
%postun
if [ $1 -eq 0 ]; then
touch --no-create %{_kde4_icondir}/hicolor &>/dev/null
gtk-update-icon-cache %{_kde4_icondir}/hicolor &>/dev/null
fi
exit 0
%post -n libmarble -p /sbin/ldconfig
%postun -n libmarble -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_kde4_bindir}/marble
%{_kde4_bindir}/marble-mobile
%{_kde4_bindir}/marble-qt
%{_kde4_bindir}/marble-touch
#%{_kde4_bindir}/routing-instructions
#%{_kde4_bindir}/tilecreator
%dir %{_kde4_datadir}/marble
%{_kde4_datadir}/marble/*
%doc %lang(en) %{_kde4_htmldir}/en/marble
%{_kde4_icondir}/hicolor/*/apps/marble.png
%{_kde4_kcfgdir}/marble.kcfg
%{_kde4_libdir}/kde4/plasma_applet_worldclock.so
%{_kde4_libdir}/kde4/plasma_runner_marble.so
#%{_kde4_servicesdir}/marble_part.desktop
%{_kde4_servicesdir}/plasma-applet-kworldclock.desktop
%{_kde4_servicesdir}/plasma-runner-marble.desktop
%{_kde4_servicesdir}/marble_*.desktop
%{_kde4_xdgappsdir}/marble*.desktop
%{_kde4_xdgmimedir}/geo.xml
%doc COPYING.DOC CREDITS
%files -n libmarble
%defattr(-,root,root)
%{_kde4_libdir}/libastro.so.*
%{_kde4_libdir}/libmarblewidget.so.*
%{_kde4_libdir}/kde4/libmarble_part.so
%dir %{_kde4_pluginsdir}/marble
%{_kde4_pluginsdir}/marble/*
%files -n libmarble-devel
%defattr(-,root,root)
%{_kde4_datadir}/cmake/modules/FindMarble.cmake
%dir %{_kde4_includedir}/astro
%{_kde4_includedir}/astro/*.h
%dir %{_kde4_includedir}/marble
%{_kde4_includedir}/marble/*
%{_kde4_libdir}/libastro.so
%{_kde4_libdir}/libmarblewidget.so
%{_kde4_pluginsdir}/designer/LatLonEditPlugin.so
%{_kde4_pluginsdir}/designer/MarbleNavigatorPlugin.so
%{_kde4_pluginsdir}/designer/MarbleWidgetPlugin.so
%doc BUGS ChangeLog TODO
%doc docs/*
%changelog
* Wed Apr 23 2014 Automatic Build System <autodist@mambasoft.it> 4.13.0-1mamba
- automatic version update by autodist
* Thu Apr 03 2014 Automatic Build System <autodist@mambasoft.it> 4.12.4-1mamba
- automatic version update by autodist
* Wed Mar 05 2014 Automatic Build System <autodist@mambasoft.it> 4.12.3-1mamba
- automatic version update by autodist
* Wed Feb 05 2014 Automatic Build System <autodist@mambasoft.it> 4.12.2-1mamba
- automatic version update by autodist
* Tue Jan 14 2014 Automatic Build System <autodist@mambasoft.it> 4.12.1-1mamba
- automatic version update by autodist
* Sat Dec 21 2013 Automatic Build System <autodist@mambasoft.it> 4.12.0-1mamba
- automatic version update by autodist
* Thu Dec 05 2013 Automatic Build System <autodist@mambasoft.it> 4.11.4-1mamba
- automatic version update by autodist
* Wed Nov 06 2013 Automatic Build System <autodist@mambasoft.it> 4.11.3-1mamba
- automatic version update by autodist
* Wed Oct 02 2013 Automatic Build System <autodist@mambasoft.it> 4.11.2-1mamba
- automatic version update by autodist
* Wed Sep 04 2013 Automatic Build System <autodist@mambasoft.it> 4.11.1-1mamba
- automatic version update by autodist
* Thu Aug 15 2013 Automatic Build System <autodist@mambasoft.it> 4.11.0-1mamba
- automatic version update by autodist
* Tue Jul 02 2013 Automatic Build System <autodist@mambasoft.it> 4.10.5-1mamba
- automatic version update by autodist
* Wed Jun 05 2013 Automatic Build System <autodist@mambasoft.it> 4.10.4-1mamba
- automatic version update by autodist
* Sun Jun 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.10.3-2mamba
- gpsd 3.9 mass rebuild
* Tue May 07 2013 Automatic Build System <autodist@mambasoft.it> 4.10.3-1mamba
- automatic version update by autodist
* Wed Apr 03 2013 Automatic Build System <autodist@mambasoft.it> 4.10.2-1mamba
- automatic version update by autodist
* Tue Mar 05 2013 Automatic Build System <autodist@mambasoft.it> 4.10.1-1mamba
- automatic version update by autodist
* Thu Feb 14 2013 Automatic Build System <autodist@mambasoft.it> 4.10.0-1mamba
- automatic version update by autodist
* Thu Jan 03 2013 Automatic Build System <autodist@mambasoft.it> 4.9.5-1mamba
- automatic version update by autodist
* Wed Dec 05 2012 Automatic Build System <autodist@mambasoft.it> 4.9.4-1mamba
- automatic version update by autodist
* Thu Nov 08 2012 Automatic Build System <autodist@mambasoft.it> 4.9.3-1mamba
- automatic version update by autodist
* Thu Oct 04 2012 Automatic Build System <autodist@mambasoft.it> 4.9.2-1mamba
- automatic version update by autodist
* Thu Sep 06 2012 Automatic Build System <autodist@mambasoft.it> 4.9.1-1mamba
- automatic version update by autodist
* Mon Aug 13 2012 Automatic Build System <autodist@mambasoft.it> 4.9.0-1mamba
- automatic version update by autodist
* Sat Jun 09 2012 Automatic Build System <autodist@mambasoft.it> 4.8.4-1mamba
- automatic version update by autodist
* Fri May 04 2012 Automatic Build System <autodist@mambasoft.it> 4.8.3-1mamba
- automatic version update by autodist
* Sat Apr 07 2012 Automatic Build System <autodist@mambasoft.it> 4.8.2-1mamba
- automatic version update by autodist
* Sat Mar 24 2012 Automatic Build System <autodist@mambasoft.it> 4.8.1-1mamba
- automatic version update by autodist
* Sun Dec 11 2011 Automatic Build System <autodist@mambasoft.it> 4.7.4-1mamba
- automatic version update by autodist
* Thu Nov 03 2011 Automatic Build System <autodist@mambasoft.it> 4.7.3-1mamba
- automatic version update by autodist
* Fri Oct 14 2011 Automatic Build System <autodist@mambasoft.it> 4.7.2-1mamba
- automatic version update by autodist
* Sun Sep 18 2011 Davide Madrisan <davide.madrisan@gmail.com> 4.7.1-1mamba
- package created by autospec