automatic version update by autodist [release 2.1.17-1mamba;Mon Nov 25 2013]
This commit is contained in:
parent
cf131de50f
commit
fc63904421
@ -1,2 +1,6 @@
|
||||
# mailman
|
||||
|
||||
Mailman is free software for managing electronic mail discussion and e-newsletter lists.
|
||||
Mailman is integrated with the web, making it easy for users to manage their accounts and for list owners to administer their lists.
|
||||
Mailman supports built-in archiving, automatic bounce processing, content filtering, digest delivery, spam filters, and more.
|
||||
|
||||
|
13
mailman-2.1.10-cmd_subscribe_fixsyntax.patch
Normal file
13
mailman-2.1.10-cmd_subscribe_fixsyntax.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- Mailman/Commands/cmd_subscribe.py 2008-03-20 03:07:51 +0000
|
||||
+++ Mailman/Commands/cmd_subscribe.py 2008-04-23 14:32:48 +0000
|
||||
@@ -71,7 +71,8 @@
|
||||
return STOP
|
||||
argnum += 1
|
||||
# Fix the password/digest issue
|
||||
- if digest is None and password.lower() in ('digest', 'nodigest'):
|
||||
+ if (digest is None
|
||||
+ and password and password.lower() in ('digest', 'nodigest')):
|
||||
if password.lower() == 'digest':
|
||||
digest = 1
|
||||
else:
|
||||
|
15
mailman-2.1.10-template_it_antispam_fix.patch
Normal file
15
mailman-2.1.10-template_it_antispam_fix.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -Nru mailman-2.1.10.orig/templates/it/verify.txt mailman-2.1.10/templates/it/verify.txt
|
||||
--- mailman-2.1.10.orig/templates/it/verify.txt 2008-04-21 20:28:22.000000000 +0200
|
||||
+++ mailman-2.1.10/templates/it/verify.txt 2008-06-10 18:26:05.000000000 +0200
|
||||
@@ -4,10 +4,7 @@
|
||||
indirizzo email, "%(email)s", alla mailing list %(listaddr)s.
|
||||
Per confermare che vuoi essere iscritto a questa lista, rispondi
|
||||
semplicemente a questo messaggio lasciando intatta la riga
|
||||
-dell'oggetto. Oppure visita questa pagina:
|
||||
-
|
||||
- %(confirmurl)s
|
||||
-
|
||||
+dell'oggetto.
|
||||
Oppure includi questa riga -- e solo quella -- in un messaggio
|
||||
indirizzato a %(requestaddr)s:
|
||||
|
45
mailman-2.1.11-use_python2.4.patch
Normal file
45
mailman-2.1.11-use_python2.4.patch
Normal file
@ -0,0 +1,45 @@
|
||||
diff -Nru mailman-2.1.11.orig/bin/msgfmt.py mailman-2.1.11/bin/msgfmt.py
|
||||
--- mailman-2.1.11.orig/bin/msgfmt.py 2008-06-30 18:29:46.000000000 +0200
|
||||
+++ mailman-2.1.11/bin/msgfmt.py 2008-12-05 15:01:05.000000000 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#! /usr/bin/env python
|
||||
+#! /usr/bin/env python2.4
|
||||
# -*- coding: iso-8859-1 -*-
|
||||
# Written by Martin v. Löwis <loewis@informatik.hu-berlin.de>
|
||||
|
||||
diff -Nru mailman-2.1.11.orig/Mailman/Archiver/pipermail.py mailman-2.1.11/Mailman/Archiver/pipermail.py
|
||||
--- mailman-2.1.11.orig/Mailman/Archiver/pipermail.py 2008-06-30 18:29:46.000000000 +0200
|
||||
+++ mailman-2.1.11/Mailman/Archiver/pipermail.py 2008-12-05 15:01:27.000000000 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#! /usr/bin/env python
|
||||
+#! /usr/bin/env python2.4
|
||||
|
||||
from __future__ import nested_scopes
|
||||
|
||||
diff -Nru mailman-2.1.11.orig/Mailman/Post.py mailman-2.1.11/Mailman/Post.py
|
||||
--- mailman-2.1.11.orig/Mailman/Post.py 2008-06-30 18:29:46.000000000 +0200
|
||||
+++ mailman-2.1.11/Mailman/Post.py 2008-12-05 15:01:16.000000000 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#! /usr/bin/env python
|
||||
+#! /usr/bin/env python2.4
|
||||
#
|
||||
# Copyright (C) 2001,2002 by the Free Software Foundation, Inc.
|
||||
#
|
||||
diff -Nru mailman-2.1.11.orig/tests/fblast.py mailman-2.1.11/tests/fblast.py
|
||||
--- mailman-2.1.11.orig/tests/fblast.py 2008-06-30 18:29:46.000000000 +0200
|
||||
+++ mailman-2.1.11/tests/fblast.py 2008-12-05 15:01:56.000000000 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#! /usr/bin/env python
|
||||
+#! /usr/bin/env python2.4
|
||||
"""Throw email at Mailman as fast as you can.
|
||||
|
||||
This is not a unit test, it's a functional test, so you can't run it within
|
||||
diff -Nru mailman-2.1.11.orig/tests/onebounce.py mailman-2.1.11/tests/onebounce.py
|
||||
--- mailman-2.1.11.orig/tests/onebounce.py 2008-06-30 18:29:46.000000000 +0200
|
||||
+++ mailman-2.1.11/tests/onebounce.py 2008-12-05 15:01:42.000000000 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#! /usr/bin/env python
|
||||
+#! /usr/bin/env python2.4
|
||||
|
||||
# Copyright (C) 2002 by the Free Software Foundation, Inc.
|
||||
#
|
12
mailman-2.1.9-fix_buildroot.patch
Normal file
12
mailman-2.1.9-fix_buildroot.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru mailman-2.1.9.orig/Makefile.in mailman-2.1.9/Makefile.in
|
||||
--- mailman-2.1.9.orig/Makefile.in 2005-08-27 03:40:17.000000000 +0200
|
||||
+++ mailman-2.1.9/Makefile.in 2007-05-24 12:02:56.000000000 +0200
|
||||
@@ -124,7 +124,7 @@
|
||||
do \
|
||||
(cd $$d; $(MAKE) DESTDIR=$(DESTDIR) install); \
|
||||
done
|
||||
- $(PYTHON) -c 'from compileall import *; compile_dir("$(DESTDIR)$(prefix)/Mailman")'
|
||||
+ $(PYTHON) -c 'from compileall import *; compile_dir("$(DESTDIR)$(prefix)/Mailman",99,"$(prefix)/Mailman")'
|
||||
|
||||
# Only run bin/update if we aren't installing in DESTDIR, as this
|
||||
# means there are probably no lists to deal with, and it wouldn't
|
27
mailman-apache.conf
Normal file
27
mailman-apache.conf
Normal file
@ -0,0 +1,27 @@
|
||||
#
|
||||
#mailman web configuration for Apache
|
||||
#
|
||||
ScriptAlias /mailman/ "/usr/share/mailman/cgi-bin/"
|
||||
<Directory "/usr/share/mailman/cgi-bin/">
|
||||
Options ExecCGI
|
||||
AllowOverride Options
|
||||
Order allow,deny
|
||||
Allow from all
|
||||
</Directory>
|
||||
|
||||
Alias /pipermail/ "/var/mailman/archives/public/"
|
||||
<Directory "/var/mailman/archives/public/">
|
||||
AllowOverride Options
|
||||
Order allow,deny
|
||||
Allow from all
|
||||
</Directory>
|
||||
|
||||
Alias /icons/ /var/www/icons/
|
||||
<Directory "/var/www/icons/">
|
||||
AllowOverride Options
|
||||
Order allow,deny
|
||||
Allow from all
|
||||
</Directory>
|
||||
|
||||
|
||||
|
7
mailman-cron
Normal file
7
mailman-cron
Normal file
@ -0,0 +1,7 @@
|
||||
#!/bin/bash
|
||||
/usr/share/mailman/bin/update_aliases.sh
|
||||
if [ -e "/usr/sbin/vmailmgrd" ]; then
|
||||
/usr/share/mailman/bin/update_aliases_vmailmgr.sh
|
||||
else
|
||||
exit 0
|
||||
fi
|
66
mailman-initscript
Normal file
66
mailman-initscript
Normal file
@ -0,0 +1,66 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# mailman This shell script starts and stops GNU Mailman.
|
||||
#
|
||||
# Copyright (C) 2001-2003 by the Free Software Foundation, Inc.
|
||||
#
|
||||
# This program is free software; you can redistribute it and/or
|
||||
# modify it under the terms of the GNU General Public License
|
||||
# as published by the Free Software Foundation; either version 2
|
||||
# of the License, or (at your option) any later version.
|
||||
#
|
||||
# This program is distributed in the hope that it will be useful,
|
||||
# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
# GNU General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
# along with this program; if not, write to the Free Software
|
||||
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
|
||||
#
|
||||
# Copy this file to /etc/init.d/ (or /etc/rc.d/init.d/ depending on
|
||||
# your system) and activate it as such:
|
||||
#
|
||||
# On Debian, type "update-rc.d mailman defaults"
|
||||
# On RedHat, and derivatives, install with "chkconfig --add mailman"
|
||||
#
|
||||
# chkconfig: 2345 98 12
|
||||
# description: Mailman is the GNU Mailing List Manager, a program that \
|
||||
# manages electronic mail discussion groups. For more \
|
||||
# on GNU Mailman see http://www.list.org
|
||||
# processname: mailmanctl
|
||||
# config: /usr/share/mailman/Mailman/mm_cfg.py
|
||||
# pidfile: /var/mailman/data/master-qrunner.pid
|
||||
|
||||
PYTHON=/usr/bin/python
|
||||
MAILMANHOME=/usr/share/mailman
|
||||
MAILMANCTL=$MAILMANHOME/bin/mailmanctl
|
||||
|
||||
. /etc/sysconfig/rc
|
||||
. $rc_functions
|
||||
|
||||
case "$1" in
|
||||
'start')
|
||||
#rm -f $MAILMANHOME/locks/*
|
||||
echo -n "Starting mailman: "
|
||||
$PYTHON $MAILMANCTL -s -q start &>/dev/null
|
||||
evaluate_retval
|
||||
echo
|
||||
;;
|
||||
|
||||
'stop')
|
||||
echo -n "Stopping mailman: "
|
||||
$PYTHON $MAILMANCTL -q stop
|
||||
evaluate_retval
|
||||
echo
|
||||
;;
|
||||
|
||||
'restart')
|
||||
echo -n "Restarting mailman: "
|
||||
$PYTHON $MAILMANCTL -q restart
|
||||
evaluate_retval
|
||||
echo
|
||||
;;
|
||||
|
||||
esac
|
||||
exit 0
|
26
mailman-update_aliases.sh
Normal file
26
mailman-update_aliases.sh
Normal file
@ -0,0 +1,26 @@
|
||||
#!/bin/bash
|
||||
#
|
||||
# Written by Silvan Calarco for the QiLinux and the openmamba distributions
|
||||
# Copyright (c) 2003-2007 by Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
# Released under the GNU GPL version 2 license
|
||||
|
||||
[ -e /usr/sbin/postfix ] && {
|
||||
/usr/share/mailman/bin/genaliases -q > /etc/aliases-mailman
|
||||
newaliases
|
||||
exit 0
|
||||
}
|
||||
[ -e /var/qmail/bin/newaliases ] && {
|
||||
# generate a new aliases file for qmail
|
||||
cat > /etc/aliases << EOF
|
||||
#
|
||||
# This aliases file was automatically generated by update_aliases
|
||||
# for mailman
|
||||
# Please, don't add manual aliases here because they will be lost
|
||||
# when this file is regenerated
|
||||
#
|
||||
EOF
|
||||
/usr/share/mailman/bin/genaliases -q >> /etc/aliases
|
||||
/var/qmail/bin/newaliases
|
||||
exit 0
|
||||
}
|
||||
exit 0
|
34
mailman-update_aliases_vmailmgr.sh
Normal file
34
mailman-update_aliases_vmailmgr.sh
Normal file
@ -0,0 +1,34 @@
|
||||
#!/bin/bash
|
||||
#
|
||||
# Generate vmailmgr aliases for mailman mailing lists
|
||||
#
|
||||
# 5/13/2004: created by Silvan Calarco for the QiLinux distribution
|
||||
#
|
||||
# Copyright (c) by Silvan Calarco <silvan.calarco@mamabsoft.it>
|
||||
# Released under the GNU GPL version 2 license
|
||||
|
||||
test $UID = 0 ||
|
||||
{ echo "error: $0: must be superuser" >&2
|
||||
{ (exit 1); exit 1; }; }
|
||||
|
||||
[ -e /var/qmail/bin ] && {
|
||||
for listdomain in `grep -v "^#" /etc/qmail/virtualdomains | sed -n "s|^\(.*\):.*|\1|p"`; do
|
||||
listuser=`grep -v "^#" /etc/qmail/virtualdomains | sed -n "s|^$listdomain:\(.*\)|\1|p"`
|
||||
|
||||
getent passwd $listuser >/dev/null ||
|
||||
{ echo "error: $0: user $listuser does not exist"
|
||||
{ (exit 1); exit 1; }; }
|
||||
|
||||
# add mailman-* stuff to current domain
|
||||
for i in `sed -n "s|^\(mailman.*\):.*|\1|p" /etc/aliases`; do
|
||||
su $listuser -c "vaddalias $i mailman@localhost 2>&1 >/dev/null" >/dev/null
|
||||
done
|
||||
|
||||
for currlist in `/usr/share/mailman/bin/list_lists -V $listdomain | sed -n "s|^[ ]*\(.*\) - .*|\1|p"`; do
|
||||
for i in `sed -n "s|^\($currlist.*\):.*|\1|pi" /etc/aliases`; do
|
||||
su $listuser -c "vaddalias $i $i@localhost 2>&1 >/dev/null" >/dev/null
|
||||
done
|
||||
done
|
||||
done
|
||||
}
|
||||
exit 0
|
311
mailman.spec
Normal file
311
mailman.spec
Normal file
@ -0,0 +1,311 @@
|
||||
%define mailman_uid 64910
|
||||
%define mailman_gid 64910
|
||||
%define nobody_gid 65013
|
||||
|
||||
Name: mailman
|
||||
Version: 2.1.17
|
||||
Release: 1mamba
|
||||
Summary: Free software for managing electronic mail discussion and e-newsletter lists
|
||||
Group: System/Servers
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://mailman.sourceforge.net
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/mailman/mailman-%{version}.tgz
|
||||
Source1: %{name}-update_aliases.sh
|
||||
Source2: %{name}-cron
|
||||
Source3: %{name}-update_aliases_vmailmgr.sh
|
||||
Source4: %{name}-apache.conf
|
||||
Source5: %{name}-initscript
|
||||
Patch0: %{name}-2.1.9-fix_buildroot.patch
|
||||
Patch1: %{name}-2.1.10-template_it_antispam_fix.patch
|
||||
Patch2: %{name}-2.1.10-cmd_subscribe_fixsyntax.patch
|
||||
Patch3: %{name}-2.1.11-use_python2.4.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: expect
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: python
|
||||
Requires(pre): expect >= 8.4.5
|
||||
Requires: python >= 2.2.3
|
||||
Requires: apache >= 2.0.45
|
||||
Requires: vixie-cron >= 3.0.1
|
||||
Requires: mta
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
# FIXME: postfix integration is missing
|
||||
|
||||
%description
|
||||
Mailman is free software for managing electronic mail discussion and e-newsletter lists.
|
||||
Mailman is integrated with the web, making it easy for users to manage their accounts and for list owners to administer their lists.
|
||||
Mailman supports built-in archiving, automatic bounce processing, content filtering, digest delivery, spam filters, and more.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
# FIXME: the following patch disables the confirmation url link in email
|
||||
# so that some smtp server filters like smpt.fastwebnet.it don't
|
||||
# block the message (error "554 Message Refused")
|
||||
%patch1 -p1
|
||||
#%patch2 -p0
|
||||
#%patch3 -p1
|
||||
|
||||
%build
|
||||
# activate sendmail patching the handler (otherwise it won't work for
|
||||
# safety reasons)
|
||||
sed -i "s|assert 0|#assert 0|" Mailman/Handlers/Sendmail.py
|
||||
sed -i "s|/usr/bin/env|/bin/env|" bin/msgfmt.py tests/onebounce.py
|
||||
|
||||
%configure \
|
||||
--prefix=%{_datadir}/mailman \
|
||||
--exec_prefix=%{_datadir}/mailman \
|
||||
--bindir=%{_bindir} \
|
||||
--with-permcheck=no \
|
||||
--with-var-prefix=/var/mailman \
|
||||
--with-cgi-gid=nobody \
|
||||
--with-mailhost=localhost \
|
||||
--with-urlhost=localhost \
|
||||
--with-mail-gid=mailman \
|
||||
--with-mail-uid=mailman \
|
||||
--with-python=%{_bindir}/python \
|
||||
PYTHON=%{__python}
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
install -d %{buildroot}/var/www/cgi-bin
|
||||
%makeinstall
|
||||
|
||||
sed -i "s|MAILMAN_USER = ''|MAILMAN_USER = 'mailman'|
|
||||
s|MAILMAN_GROUP = ''|MAILMAN_GROUP = 'mailman'|" \
|
||||
%{buildroot}%{_datadir}/mailman/Mailman/Defaults.py
|
||||
|
||||
install -D %{buildroot}%{_datadir}/mailman/cron/crontab.in \
|
||||
%{buildroot}%{_sysconfdir}/cron.d/mailman
|
||||
install -D -m 0755 %{S:5} \
|
||||
%{buildroot}%{_initrddir}/mailman
|
||||
install -m 0755 %{S:1} \
|
||||
%{buildroot}%{_datadir}/mailman/bin/update_aliases.sh
|
||||
install -m 0755 %{S:3} \
|
||||
%{buildroot}%{_datadir}/mailman/bin/update_aliases_vmailmgr.sh
|
||||
install -D %{S:2} \
|
||||
%{buildroot}%{_sysconfdir}/cron.daily/mailman
|
||||
install -D %{S:4} \
|
||||
%{buildroot}%{_sysconfdir}/httpd/httpd.d/mailman.conf
|
||||
|
||||
mv %{buildroot}%{_datadir}/mailman/icons %{buildroot}/var/www
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%pre
|
||||
# new install
|
||||
if [ $1 -ge 1 ]; then
|
||||
groupadd -g %{nobody_gid} nobody 2>/dev/null
|
||||
groupadd -g %{mailman_gid} mailman 2>/dev/null
|
||||
useradd -u %{mailman_uid} -g mailman -d /dev/null mailman \
|
||||
-s /bin/false 2>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%post
|
||||
# new install
|
||||
if [ $1 -eq 1 ]; then
|
||||
sed -i "s|\(DEFAULT_EMAIL_HOST = \).*|\1'`hostname -f`'|
|
||||
s|\(DEFAULT_URL_HOST = \).*|\1'`hostname -f`'|
|
||||
s|#\(DELIVERY_MODULE = 'Sendmail'\)|\1|
|
||||
s|\(DELIVERY_MODULE = 'SMTPDirect'\)|#\1|" \
|
||||
%{_datadir}/mailman/Mailman/Defaults.py
|
||||
|
||||
[ -e /usr/sbin/postfix ] && {
|
||||
# postfix configuation
|
||||
postconf -e alias_database=hash:/etc/aliases,hash:/etc/aliases-mailman
|
||||
%{_datadir}/mailman/bin/newlist -q \
|
||||
mailman postmaster@`postconf -hv mydomain` \
|
||||
`/usr/bin/mkpasswd -l 10 -s 0` &>/dev/null
|
||||
echo "\
|
||||
Mailman list created.
|
||||
Use %{_datadir}/mailman/bin/mmsitepass to set mailman administrator password."
|
||||
|
||||
} || {
|
||||
[ -f /etc/qmail/me ] && {
|
||||
# qmail configuration
|
||||
%{_datadir}/mailman/bin/newlist -q \
|
||||
mailman postmaster@`cat /etc/qmail/me` \
|
||||
`/usr/bin/mkpasswd -l 10 -s 0` &>/dev/null
|
||||
%{_datadir}/mailman/bin/update_aliases.sh
|
||||
echo "\
|
||||
Mailman list created.
|
||||
Use %{_datadir}/mailman/bin/mmsitepass to set mailman administrator password."
|
||||
}
|
||||
}
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
# update
|
||||
if [ $1 -eq 1 ]; then
|
||||
/sbin/chkconfig mailman
|
||||
[ $? -eq 0 ] && %{_initrddir}/mailman restart 2>/dev/null
|
||||
fi
|
||||
if [ $1 -eq 0 ]; then
|
||||
[ -e /usr/sbin/postconf ] && postconf -e alias_database=hash:/etc/aliases
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%preun
|
||||
# erase
|
||||
if [ $1 -eq 0 ]; then
|
||||
/sbin/chkconfig --del mailman
|
||||
%{_initrddir}/mailman stop 2>/dev/null
|
||||
userdel mailman 2>/dev/null
|
||||
groupdel mailman 2>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/httpd/httpd.d/mailman.conf
|
||||
%dir %attr(2775,root,root) %{_datadir}/mailman/
|
||||
%attr(2775,root,mailman) %{_datadir}/mailman/bin/*
|
||||
%attr(2775,root,mailman) %{_datadir}/mailman/cgi-bin/*
|
||||
%attr(2775,root,mailman) %{_datadir}/mailman/cron/*
|
||||
%attr(2775,root,mailman) %{_datadir}/mailman/mail/*
|
||||
%attr(2775,root,mailman) %{_datadir}/mailman/Mailman/*
|
||||
%attr(2775,root,mailman) %{_datadir}/mailman/messages/*
|
||||
#%attr(2775,root,mailman) %{_datadir}/mailman/pythonlib/*
|
||||
%attr(2775,root,mailman) %{_datadir}/mailman/scripts/*
|
||||
%attr(2775,root,mailman) %{_datadir}/mailman/templates/*
|
||||
%attr(2775,root,mailman) %{_datadir}/mailman/tests/*
|
||||
%config(noreplace) %{_datadir}/mailman/Mailman/Defaults.py
|
||||
%config(noreplace) %{_datadir}/mailman/Mailman/mm_cfg.py
|
||||
%attr(0755,root,root) %{_initrddir}/mailman
|
||||
%{_sysconfdir}/cron.d/mailman
|
||||
%{_sysconfdir}/cron.daily/mailman
|
||||
%dir %attr(2775,root,mailman) /var/mailman
|
||||
%dir %attr(2770,root,mailman) /var/mailman/archives/private
|
||||
%dir %attr(2775,root,mailman) /var/mailman/archives/public
|
||||
%dir %attr(2775,root,mailman) /var/mailman/data
|
||||
%attr(2775,root,mailman) /var/mailman/data/sitelist.cfg
|
||||
%dir %attr(2775,root,mailman) /var/mailman/lists
|
||||
%dir %attr(2775,root,mailman) /var/mailman/logs
|
||||
%dir %attr(2775,root,mailman) /var/mailman/qfiles
|
||||
%dir %attr(2775,root,mailman) /var/mailman/spam
|
||||
/var/www/icons/*
|
||||
%doc gnu-COPYING-GPL
|
||||
#%doc README ACKNOWLEDGMENTS FAQ BUGS README.* TODO UPGRADING NEWS
|
||||
|
||||
%changelog
|
||||
* Mon Nov 25 2013 Automatic Build System <autodist@mambasoft.it> 2.1.17-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 30 2013 Automatic Build System <autodist@mambasoft.it> 2.1.16-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu May 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.15-3mamba
|
||||
- python 2.7 rebuild
|
||||
|
||||
* Sat Apr 13 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.15-2mamba
|
||||
- fix pidfile location in initscript for systemd to correctly detect status
|
||||
|
||||
* Thu Jan 03 2013 Automatic Build System <autodist@mambasoft.it> 2.1.15-1mamba
|
||||
- update to 2.1.15
|
||||
|
||||
* Tue Sep 21 2010 Automatic Build System <autodist@mambasoft.it> 2.1.14-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Feb 04 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.13-1mamba
|
||||
- update to 2.1.13
|
||||
|
||||
* Mon Mar 30 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.12-2mamba
|
||||
- remove use_python2.4 patch
|
||||
|
||||
* Mon Mar 30 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.12-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Jan 08 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.11-2mamba
|
||||
- update cron and update_aliases script for exiting with 0
|
||||
|
||||
* Fri Dec 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.11-1mamba
|
||||
- update to 2.1.11
|
||||
- added patch to force use of python 2.4 (python 2.6 not supported yet); initscript patched too
|
||||
|
||||
* Thu Jun 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.10-2mamba
|
||||
- added a patch to fix a syntax error in cmd_subscribe.py
|
||||
|
||||
* Tue Jun 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.10-1mamba
|
||||
- update to 2.1.10
|
||||
- added anti-spam patch to workaround a problem with fastweb-it smtp server
|
||||
|
||||
* Fri Jan 18 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.9-7mamba
|
||||
- initscript: send output to /dev/null so startup script won't hung when
|
||||
used with |tee
|
||||
|
||||
* Sat Jun 02 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.9-6mamba
|
||||
- fix various permissions
|
||||
|
||||
* Thu May 24 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.9-5mamba
|
||||
- fix permissions on %{_datadir}/mailman directory
|
||||
|
||||
* Thu May 24 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.9-4mamba
|
||||
- use nobody as cgi and mail gid
|
||||
- patch: remove buildroot patchs in python compiled files
|
||||
- set nofiles as the mail-gid
|
||||
|
||||
* Sun Mar 18 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.9-3qilnx
|
||||
- change gid to nobody as used by postfix
|
||||
- fixed general permissions
|
||||
- added httpd.d configuration file
|
||||
|
||||
* Wed Mar 14 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.9-2qilnx
|
||||
- fixed scripts for integration with postfix as well as qmail
|
||||
|
||||
* Mon Sep 18 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.1.9-1qilnx
|
||||
- update to version 2.1.9 by autospec
|
||||
- also fixes several security issues including CVE-2006-[2941,3636] (qibug#88)
|
||||
|
||||
* Wed Jun 28 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.1.8b1-2qilnx
|
||||
- fixed creation of used mailman when qmail is not installed
|
||||
- execute qmail dependent commands in the specfile scriptlets only if qmail
|
||||
is installed
|
||||
|
||||
* Thu Apr 06 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.8b1-1qilnx
|
||||
- update to version 2.1.8b1 by autospec
|
||||
- removed dependency on qmail
|
||||
|
||||
* Thu Sep 22 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.1.6-1qilnx
|
||||
- update to version 2.1.6 by autospec
|
||||
- also fixes the security vulnerability CVE- 2005-3573
|
||||
- removed security patches (merged upstream)
|
||||
- %%post script fixed
|
||||
|
||||
* Fri Feb 11 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.1.5-3qilnx
|
||||
- security fix QSA-2005-014 (CAN-2004-1177, CAN-2005-0202)
|
||||
|
||||
* Wed Jun 30 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.5-2qilnx
|
||||
- fixed a /usr/bin/env dependency problem
|
||||
|
||||
* Thu May 28 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.1.5-1qilnx
|
||||
- new version rebuild
|
||||
|
||||
* Wed May 26 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.1.4-5qilnx
|
||||
- added security patch for remote password retrieval (CAN-2004-0412)
|
||||
backported from mailman 2.1.5 by Mark J Cox <mjc@redhat.com>
|
||||
|
||||
* Tue May 13 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.4-4qilnx
|
||||
- added update_aliases_vmailmgr.sh script for virtual domain aliases creation
|
||||
|
||||
* Mon May 10 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.4-3qilnx
|
||||
- some fixes on post script
|
||||
|
||||
* Mon May 03 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.4-2qilnx
|
||||
- added automatic mailman list configuration
|
||||
|
||||
* Tue Feb 17 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.1.4-1qilnx
|
||||
- new version rebuilt (security bugfixes)
|
||||
|
||||
* Tue Sep 16 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.2-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user