automatic rebuild by autodist [release 1.1.9-2mamba;Thu Aug 01 2013]
This commit is contained in:
parent
14d978a7e9
commit
34a979d0dd
@ -1,2 +1,4 @@
|
|||||||
# mISDNuser
|
# mISDNuser
|
||||||
|
|
||||||
|
User space tools for the mISDN 2.0 driver.
|
||||||
|
|
||||||
|
110
mISDNuser-1.1.9-soname.patch
Normal file
110
mISDNuser-1.1.9-soname.patch
Normal file
@ -0,0 +1,110 @@
|
|||||||
|
diff -Nru mISDNuser-1_1_9.orig/i4lnet/Makefile mISDNuser-1_1_9/i4lnet/Makefile
|
||||||
|
--- mISDNuser-1_1_9.orig/i4lnet/Makefile 2008-11-18 12:35:09.000000000 +0100
|
||||||
|
+++ mISDNuser-1_1_9/i4lnet/Makefile 2009-08-28 14:30:18.835179949 +0200
|
||||||
|
@@ -2,12 +2,18 @@
|
||||||
|
AR = ar
|
||||||
|
RANLIB = ranlib
|
||||||
|
|
||||||
|
-all: libisdnnet.a libisdnnet_pic.a libisdnnet.so
|
||||||
|
+SOMAJOR=0
|
||||||
|
+SOMINOR=0.0
|
||||||
|
+SOVERSION=$(SOMAJOR).$(SOMINOR)
|
||||||
|
+
|
||||||
|
+all: libisdnnet.a libisdnnet_pic.a libisdnnet.so.$(SOVERSION)
|
||||||
|
|
||||||
|
install:
|
||||||
|
install -m 644 libisdnnet.a $(INSTALL_PREFIX)/usr/lib
|
||||||
|
install -m 644 libisdnnet_pic.a $(INSTALL_PREFIX)/usr/lib
|
||||||
|
- install -m 644 libisdnnet.so $(INSTALL_PREFIX)/usr/lib
|
||||||
|
+ install -m 755 libisdnnet.so.$(SOVERSION) $(INSTALL_PREFIX)/usr/lib/
|
||||||
|
+ ln -sf libisdnnet.so.$(SOVERSION) $(INSTALL_PREFIX)/usr/lib/libisdnnet.so.$(SOMAJOR)
|
||||||
|
+ ln -sf libisdnnet.so.$(SOVERSION) $(INSTALL_PREFIX)/usr/lib/libisdnnet.so
|
||||||
|
cp *.h $(INSTALL_PREFIX)/usr/include/mISDNuser/
|
||||||
|
|
||||||
|
ISDNNET_OBJ = net_if.o isdn_debug.o isdn_msg.o fsm.o net_l2.o tei.o net_l3.o \
|
||||||
|
@@ -27,8 +33,8 @@
|
||||||
|
$(AR) cru $@ $^
|
||||||
|
$(RANLIB) $@
|
||||||
|
|
||||||
|
-libisdnnet.so: $(ISDNNET_OBJ)
|
||||||
|
- $(CC) $(CFLAGS) -shared -Xlinker -x -o $@ $^
|
||||||
|
+libisdnnet.so.$(SOVERSION): $(ISDNNET_OBJ)
|
||||||
|
+ $(CC) $(CFLAGS) -shared -Xlinker -x -Wl,-soname,libisdnnet.so.$(SOVERSION) -o $@ $^
|
||||||
|
|
||||||
|
.c.o:
|
||||||
|
$(CC) $(CFLAGS) -o $@ -c $<
|
||||||
|
diff -Nru mISDNuser-1_1_9.orig/lib/Makefile mISDNuser-1_1_9/lib/Makefile
|
||||||
|
--- mISDNuser-1_1_9.orig/lib/Makefile 2008-11-18 12:35:09.000000000 +0100
|
||||||
|
+++ mISDNuser-1_1_9/lib/Makefile 2009-08-28 14:29:56.945929917 +0200
|
||||||
|
@@ -2,10 +2,16 @@
|
||||||
|
AR = ar
|
||||||
|
RANLIB = ranlib
|
||||||
|
|
||||||
|
-all: libmISDN.a libmISDN_pic.a libmISDN.so
|
||||||
|
+SOMAJOR=0
|
||||||
|
+SOMINOR=0.0
|
||||||
|
+SOVERSION=$(SOMAJOR).$(SOMINOR)
|
||||||
|
+
|
||||||
|
+all: libmISDN.a libmISDN_pic.a libmISDN.so.$(SOVERSION)
|
||||||
|
|
||||||
|
install:
|
||||||
|
- install -m 644 libmISDN.so $(INSTALL_PREFIX)/usr/lib
|
||||||
|
+ install -m 755 libmISDN.so.$(SOVERSION) $(INSTALL_PREFIX)/usr/lib
|
||||||
|
+ ln -s libmISDN.so.$(SOVERSION) $(INSTALL_PREFIX)/usr/lib/libmISDN.so.$(SOMAJOR)
|
||||||
|
+ ln -s libmISDN.so.$(SOVERSION) $(INSTALL_PREFIX)/usr/lib/libmISDN.so
|
||||||
|
install -m 644 libmISDN_pic.a $(INSTALL_PREFIX)/usr/lib
|
||||||
|
install -m 644 libmISDN.a $(INSTALL_PREFIX)/usr/lib
|
||||||
|
|
||||||
|
@@ -24,8 +30,8 @@
|
||||||
|
$(AR) cru $@ $^
|
||||||
|
$(RANLIB) $@
|
||||||
|
|
||||||
|
-libmISDN.so: $(LIBMISDN_OBJS)
|
||||||
|
- $(CC) $(CFLAGS) -shared -Xlinker -x -o $@ $^
|
||||||
|
+libmISDN.so.$(SOVERSION): $(LIBMISDN_OBJS)
|
||||||
|
+ $(CC) $(CFLAGS) -shared -Xlinker -x -Wl,-soname,libmISDN.so.$(SOMAJOR) -o $@ $^
|
||||||
|
|
||||||
|
.c.o:
|
||||||
|
$(CC) $(CFLAGS) -o $@ -c $<
|
||||||
|
diff -Nru mISDNuser-1_1_9.orig/suppserv/Makefile mISDNuser-1_1_9/suppserv/Makefile
|
||||||
|
--- mISDNuser-1_1_9.orig/suppserv/Makefile 2008-11-18 12:35:09.000000000 +0100
|
||||||
|
+++ mISDNuser-1_1_9/suppserv/Makefile 2009-08-28 14:31:52.616180077 +0200
|
||||||
|
@@ -2,19 +2,25 @@
|
||||||
|
AR = ar
|
||||||
|
RANLIB = ranlib
|
||||||
|
|
||||||
|
+SOMAJOR=0
|
||||||
|
+SOMINOR=0.0
|
||||||
|
+SOVERSION=$(SOMAJOR).$(SOMINOR)
|
||||||
|
+
|
||||||
|
#CFLAGS += -DASN1_DEBUG
|
||||||
|
|
||||||
|
SUPPSERV_OBJ = asn1.o asn1_enc.o asn1_generic.o asn1_aoc.o asn1_basic_service.o asn1_comp.o asn1_diversion.o asn1_address.o fac.o
|
||||||
|
SUPPSERV_PICOBJ = $(SUPPSERV_OBJ:%.o=%.lo)
|
||||||
|
|
||||||
|
-all: libsuppserv.a libsuppserv_pic.a libsuppserv.so
|
||||||
|
+all: libsuppserv.a libsuppserv_pic.a libsuppserv.so.$(SOVERSION)
|
||||||
|
|
||||||
|
main: $(SUPPSERVOBJ)
|
||||||
|
|
||||||
|
install:
|
||||||
|
install -m 644 libsuppserv.a $(INSTALL_PREFIX)/usr/lib
|
||||||
|
install -m 644 libsuppserv_pic.a $(INSTALL_PREFIX)/usr/lib
|
||||||
|
- install -m 644 libsuppserv.so $(INSTALL_PREFIX)/usr/lib
|
||||||
|
+ install -m 755 libsuppserv.so.$(SOVERSION) $(INSTALL_PREFIX)/usr/lib
|
||||||
|
+ ln -s libsuppserv.so.$(SOVERSION) $(INSTALL_PREFIX)/usr/lib/libsuppserv.so.$(SOMAJOR)
|
||||||
|
+ ln -s libsuppserv.so.$(SOVERSION) $(INSTALL_PREFIX)/usr/lib/libsuppserv.so
|
||||||
|
cp *.h $(INSTALL_PREFIX)/usr/include/mISDNuser/
|
||||||
|
|
||||||
|
libsuppserv_pic.a: $(SUPPSERV_PICOBJ)
|
||||||
|
@@ -25,8 +31,8 @@
|
||||||
|
$(AR) cru $@ $<
|
||||||
|
$(RANLIB) $@
|
||||||
|
|
||||||
|
-libsuppserv.so: $(SUPPSERV_OBJ)
|
||||||
|
- $(CC) -shared -Xlinker -x -o $@ $^
|
||||||
|
+libsuppserv.so.$(SOVERSION): $(SUPPSERV_OBJ)
|
||||||
|
+ $(CC) -shared -Xlinker -x -Wl,-soname,libsuppserv.so.$(SONAME) -o $@ $^
|
||||||
|
|
||||||
|
|
||||||
|
.c.o:
|
110
mISDNuser.spec
Normal file
110
mISDNuser.spec
Normal file
@ -0,0 +1,110 @@
|
|||||||
|
%define pkgver %(echo %version | tr . _)
|
||||||
|
Name: mISDNuser
|
||||||
|
Version: 1.1.9
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: User space tools for the mISDN driver
|
||||||
|
Group: System/Kernel and Hardware
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.misdn.org
|
||||||
|
#Source: http://www.linux-call-router.de/download/lcr-1.5/mISDNuser_%{version}.tar.gz
|
||||||
|
Source: http://www.misdn.org/downloads/releases/mISDNuser-%{pkgver}.tar.gz
|
||||||
|
Source1: http://www.misdn.org/downloads/releases/mISDN-%{pkgver}.tar.gz
|
||||||
|
Patch0: %{name}-1.1.9-soname.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libncurses-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
Requires: libmISDN = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
User space tools for the mISDN 2.0 driver.
|
||||||
|
|
||||||
|
%package -n libmISDN
|
||||||
|
Summary: Library for supporting the mISDN kernel driver
|
||||||
|
Group: System/Libraries
|
||||||
|
|
||||||
|
%description -n libmISDN
|
||||||
|
Library for supporting the mISDN kernel driver.
|
||||||
|
|
||||||
|
%package -n libmISDN-devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: libmISDN = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n libmISDN-devel
|
||||||
|
Library for supporting the mISDN kernel driver.
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{pkgver} -a1
|
||||||
|
%patch0 -p1
|
||||||
|
cp -a mISDN-%{pkgver}/include/linux include
|
||||||
|
|
||||||
|
%build
|
||||||
|
%make -j1 MISDNDIR=`pwd`
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall MISDNDIR=`pwd` INSTALL_PREFIX=%{buildroot}
|
||||||
|
install -d -m0755 %{buildroot}%{_includedir}
|
||||||
|
cp -a mISDN-%{pkgver}/include/linux %{buildroot}%{_includedir}
|
||||||
|
|
||||||
|
%ifarch x86_64
|
||||||
|
mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -n libmISDN -p /sbin/ldconfig
|
||||||
|
%postun -n libmISDN -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/loadfirm
|
||||||
|
%{_bindir}/mISDNdebugtool
|
||||||
|
%{_bindir}/misdnportinfo
|
||||||
|
%{_bindir}/sendhwctrl
|
||||||
|
%{_bindir}/testcon
|
||||||
|
%{_bindir}/testcon_l2
|
||||||
|
%{_bindir}/testlayer1
|
||||||
|
%{_bindir}/testlayer3
|
||||||
|
%{_bindir}/testlib
|
||||||
|
%{_bindir}/tstlib
|
||||||
|
%{_bindir}/voipisdn
|
||||||
|
|
||||||
|
%files -n libmISDN
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libisdnnet.so.*
|
||||||
|
%{_libdir}/libmISDN.so.*
|
||||||
|
%{_libdir}/libsuppserv.so.*
|
||||||
|
%doc CHANGES COPYING.LIB LICENSE
|
||||||
|
|
||||||
|
%files -n libmISDN-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/mISDNuser
|
||||||
|
%{_includedir}/mISDNuser/*.h
|
||||||
|
%{_includedir}/linux/isdn_compat.h
|
||||||
|
%{_includedir}/linux/mISDNdebugtool.h
|
||||||
|
%{_includedir}/linux/mISDNif.h
|
||||||
|
%{_libdir}/libisdnnet.so
|
||||||
|
%{_libdir}/libisdnnet.a
|
||||||
|
%{_libdir}/libisdnnet_pic.a
|
||||||
|
%{_libdir}/libmISDN.so
|
||||||
|
%{_libdir}/libmISDN.a
|
||||||
|
%{_libdir}/libmISDN_pic.a
|
||||||
|
%{_libdir}/libsuppserv.so
|
||||||
|
%{_libdir}/libsuppserv.a
|
||||||
|
%{_libdir}/libsuppserv_pic.a
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Aug 01 2013 Automatic Build System <autodist@mambasoft.it> 1.1.9-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Fri Aug 28 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.9-1mamba
|
||||||
|
- update to 1.1.9
|
||||||
|
|
Loading…
Reference in New Issue
Block a user