added upstream patch to fix plugin loader (https://github.com/lxqt/lxqt-panel/pull/2053) [release 2.0.0-2mamba;Sun Apr 28 2024]

This commit is contained in:
Automatic Build System 2024-04-28 23:23:40 +02:00
parent 150fde9672
commit 9f11861dc8
3 changed files with 41 additions and 10 deletions

View File

@ -2,4 +2,3 @@
lxqt-panel represents the taskbar of LXQt. lxqt-panel represents the taskbar of LXQt.

View File

@ -0,0 +1,24 @@
From 9536426d4e12b107a706611ead246a9e0ea1d628 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bernhard=20Rosenkr=C3=A4nzer?= <bero@lindev.ch>
Date: Sat, 20 Apr 2024 22:25:18 +0200
Subject: [PATCH] Fix plugin loader (#2052)
The lxqt-plugin binary needs to export symbols that should be visible to
plugins being loaded with QPluginLoader or dlopen.
---
panel/CMakeLists.txt | 2 ++
1 file changed, 2 insertions(+)
diff --git a/panel/CMakeLists.txt b/panel/CMakeLists.txt
index 556d2212f..d9fe784bf 100644
--- a/panel/CMakeLists.txt
+++ b/panel/CMakeLists.txt
@@ -91,6 +91,8 @@ lxqt_translate_ts(QM_FILES SOURCES
lxqt_app_translation_loader(SOURCES ${PROJECT_NAME})
+set(CMAKE_EXECUTABLE_ENABLE_EXPORTS TRUE)
+
add_executable(${PROJECT}
${PUB_HEADERS}
${PRIV_HEADERS}

View File

@ -1,6 +1,6 @@
Name: lxqt-panel Name: lxqt-panel
Version: 1.4.0 Version: 2.0.0
Release: 1mamba Release: 2mamba
Summary: The taskbar of the LXQt desktop environment Summary: The taskbar of the LXQt desktop environment
Group: Graphical Desktop/Applications/Environment Group: Graphical Desktop/Applications/Environment
Vendor: openmamba Vendor: openmamba
@ -8,24 +8,25 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/lxqt/lxqt-panel URL: https://github.com/lxqt/lxqt-panel
Source: https://github.com/lxqt/lxqt-panel.git/%{version}/lxqt-panel-%{version}.tar.bz2 Source: https://github.com/lxqt/lxqt-panel.git/%{version}/lxqt-panel-%{version}.tar.bz2
Patch0: lxqt-panel-2.0.0-upstream-fix-plugin-loader.patch
License: LGPL License: LGPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libQt5Svg-devel
BuildRequires: libQt5X11Extras-devel
BuildRequires: libX11-devel BuildRequires: libX11-devel
BuildRequires: libXtst-devel BuildRequires: libXtst-devel
BuildRequires: libalsa-devel BuildRequires: libalsa-devel
BuildRequires: libdbusmenu-qt5-devel BuildRequires: libdbusmenu-lxqt-devel
BuildRequires: libgcc BuildRequires: libgcc
BuildRequires: libglib-devel BuildRequires: libglib-devel
BuildRequires: libkwindowsystem-devel BuildRequires: libglvnd-devel
BuildRequires: libkf6-kwindowsystem-devel
BuildRequires: libkf6-solid-devel
BuildRequires: liblayer-shell-qt-devel
BuildRequires: liblxqt-devel BuildRequires: liblxqt-devel
BuildRequires: liblxqt-globalkeys-devel BuildRequires: liblxqt-globalkeys-devel
BuildRequires: libpulseaudio-devel BuildRequires: libpulseaudio-devel
BuildRequires: libqtxdg-devel BuildRequires: libqtxdg-devel
BuildRequires: libsensors-devel BuildRequires: libsensors-devel
BuildRequires: libsolid-devel
BuildRequires: libstatgrab-devel BuildRequires: libstatgrab-devel
BuildRequires: libstdc++6-devel BuildRequires: libstdc++6-devel
BuildRequires: libsysstat-devel BuildRequires: libsysstat-devel
@ -33,7 +34,8 @@ BuildRequires: libxcb-devel
BuildRequires: libxcb-image-devel BuildRequires: libxcb-image-devel
BuildRequires: libxcb-util-devel BuildRequires: libxcb-util-devel
BuildRequires: libxkbcommon-devel BuildRequires: libxkbcommon-devel
BuildRequires: qt5-qtbase-devel BuildRequires: qt6-qtbase-devel
BuildRequires: qt6-qtsvg-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: cmake BuildRequires: cmake
BuildRequires: lxqt-menu-data BuildRequires: lxqt-menu-data
@ -45,7 +47,6 @@ Requires: pavucontrol-qt
%description %description
lxqt-panel represents the taskbar of LXQt. lxqt-panel represents the taskbar of LXQt.
%package -n lib%{name} %package -n lib%{name}
Group: System/Libraries Group: System/Libraries
Summary: Shared libraries for %{name} Summary: Shared libraries for %{name}
@ -66,6 +67,7 @@ This package contains libraries and header files for developing applications tha
%prep %prep
%setup -q %setup -q
%patch 0 -p1 -b .upstream-fix-plugin-loader
%build %build
%cmake -d build %cmake -d build
@ -112,6 +114,12 @@ done
%changelog %changelog
* Sun Apr 28 2024 Automatic Build System <autodist@openmamba.org> 2.0.0-2mamba
- added upstream patch to fix plugin loader (https://github.com/lxqt/lxqt-panel/pull/2053)
* Fri Apr 26 2024 Automatic Build System <autodist@openmamba.org> 2.0.0-1mamba
- automatic version update by autodist
* Wed Nov 08 2023 Automatic Build System <autodist@mambasoft.it> 1.4.0-1mamba * Wed Nov 08 2023 Automatic Build System <autodist@mambasoft.it> 1.4.0-1mamba
- automatic version update by autodist - automatic version update by autodist