rebuilt with specfile fixes [release 0.4.7-2mamba;Sat Jan 25 2025]
This commit is contained in:
parent
a4234dd28c
commit
6ab32b7325
@ -1,14 +0,0 @@
|
|||||||
diff -Nru lxmusic-0.4.5.orig/src/lxmusic-notify.c lxmusic-0.4.5/src/lxmusic-notify.c
|
|
||||||
--- lxmusic-0.4.5.orig/src/lxmusic-notify.c 2012-05-20 00:09:58.000000000 +0200
|
|
||||||
+++ lxmusic-0.4.5/src/lxmusic-notify.c 2012-07-30 00:06:53.499831208 +0200
|
|
||||||
@@ -84,9 +84,8 @@
|
|
||||||
else
|
|
||||||
g_string_append( message, title );
|
|
||||||
struct _LXMusicNotification *lxn = g_new ( struct _LXMusicNotification, 1);
|
|
||||||
- lxn->notify = notify_notification_new (summary, message->str, NULL, NULL);
|
|
||||||
+ lxn->notify = notify_notification_new (summary, message->str, NULL);
|
|
||||||
notify_notification_set_urgency (lxn->notify, NOTIFY_URGENCY_NORMAL);
|
|
||||||
- notify_notification_attach_to_status_icon( lxn->notify, status_icon );
|
|
||||||
notify_notification_set_timeout (lxn->notify, NOTIFY_EXPIRES_DEFAULT);
|
|
||||||
g_string_free( message, TRUE );
|
|
||||||
return lxn;
|
|
23
lxmusic.spec
23
lxmusic.spec
@ -1,27 +1,26 @@
|
|||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: lxmusic
|
Name: lxmusic
|
||||||
Version: 0.4.7
|
Version: 0.4.7
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: LXMusic - The minimalist music player for LXDE.
|
Summary: LXMusic - The minimalist music player for LXDE
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Fabio Giani <fabio.giani@gmail.com>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.lxde.org/
|
URL: http://www.lxde.org/
|
||||||
Source: http://downloads.sourceforge.net/project/lxde/LXMusic%20%28music%20player%29/LXMusic%20%{majver}.x/lxmusic-%{version}.tar.xz
|
Source: http://downloads.sourceforge.net/project/lxde/LXMusic%20%28music%20player%29/LXMusic%20%{majver}.x/lxmusic-%{version}.tar.xz
|
||||||
Patch0: %{name}-0.4.2-no-tools-menu.patch
|
Patch0: lxmusic-0.4.2-no-tools-menu.patch
|
||||||
Patch1: %{name}-0.4.5-libnotify-0.7.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libatk-devel
|
BuildRequires: libat-spi2-core-devel
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libfontconfig-devel
|
BuildRequires: libfontconfig-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libgtk2-devel
|
BuildRequires: libgtk2-devel
|
||||||
|
BuildRequires: libharfbuzz-devel
|
||||||
BuildRequires: libnotify-devel
|
BuildRequires: libnotify-devel
|
||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libxmms2-devel
|
BuildRequires: libxmms2-devel
|
||||||
@ -34,10 +33,8 @@ It has very few functionality, and can do nothing more than play the music. The
|
|||||||
This is currently aimed to be used as the default music player of LXDE (Lightweight X11 Desktop Environment) project.
|
This is currently aimed to be used as the default music player of LXDE (Lightweight X11 Desktop Environment) project.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch 0 -p1
|
%patch 0 -p1
|
||||||
#%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -56,13 +53,17 @@ This is currently aimed to be used as the default music player of LXDE (Lightwei
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/%{name}
|
%{_bindir}/%{name}
|
||||||
%{_datadir}/applications/lxmusic.desktop
|
%{_datadir}/applications/lxmusic.desktop
|
||||||
%{_datadir}/lxmusic
|
%dir %{_datadir}/lxmusic
|
||||||
|
%{_datadir}/lxmusic/*
|
||||||
%{_datadir}/pixmaps/lxmusic.png
|
%{_datadir}/pixmaps/lxmusic.png
|
||||||
%{_mandir}/man1/lxmusic.1.gz
|
%{_mandir}/man1/lxmusic.1*
|
||||||
%doc AUTHORS COPYING
|
%doc AUTHORS COPYING
|
||||||
# README
|
# README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 25 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.7-2mamba
|
||||||
|
- rebuilt with specfile fixes
|
||||||
|
|
||||||
* Sun Feb 21 2016 Automatic Build System <autodist@mambasoft.it> 0.4.7-1mamba
|
* Sun Feb 21 2016 Automatic Build System <autodist@mambasoft.it> 0.4.7-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user