diff --git a/README.md b/README.md
index 92c3428..8f6f12c 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,6 @@
# lxmusic
+LXMusic is a very simple gtk+ XMMS2 client written in pure C.
+It has very few functionality, and can do nothing more than play the music. The UI is very clean and simple.
+This is currently aimed to be used as the default music player of LXDE (Lightweight X11 Desktop Environment) project.
+
diff --git a/lxmusic-0.4.2-no-tools-menu.patch b/lxmusic-0.4.2-no-tools-menu.patch
new file mode 100644
index 0000000..5ae175c
--- /dev/null
+++ b/lxmusic-0.4.2-no-tools-menu.patch
@@ -0,0 +1,25 @@
+diff -up lxmusic-0.4.2/data/lxmusic.ui.glade.BAD lxmusic-0.4.2/data/lxmusic.ui.glade
+--- lxmusic-0.4.2/data/lxmusic.ui.glade.BAD 2009-08-11 16:20:39.915240510 -0400
++++ lxmusic-0.4.2/data/lxmusic.ui.glade 2009-08-11 16:21:02.868240450 -0400
+@@ -180,12 +180,6 @@
+
+
+
+-
+- tools_mi
+- _Tools
+-
+-
+-
+
+ help_mi
+ _Help
+
+@@ -230,7 +224,6 @@
+
+
+
+-
+
+
+
\ No newline at end of file
diff --git a/lxmusic-0.4.5-libnotify-0.7.patch b/lxmusic-0.4.5-libnotify-0.7.patch
new file mode 100644
index 0000000..bd73541
--- /dev/null
+++ b/lxmusic-0.4.5-libnotify-0.7.patch
@@ -0,0 +1,14 @@
+diff -Nru lxmusic-0.4.5.orig/src/lxmusic-notify.c lxmusic-0.4.5/src/lxmusic-notify.c
+--- lxmusic-0.4.5.orig/src/lxmusic-notify.c 2012-05-20 00:09:58.000000000 +0200
++++ lxmusic-0.4.5/src/lxmusic-notify.c 2012-07-30 00:06:53.499831208 +0200
+@@ -84,9 +84,8 @@
+ else
+ g_string_append( message, title );
+ struct _LXMusicNotification *lxn = g_new ( struct _LXMusicNotification, 1);
+- lxn->notify = notify_notification_new (summary, message->str, NULL, NULL);
++ lxn->notify = notify_notification_new (summary, message->str, NULL);
+ notify_notification_set_urgency (lxn->notify, NOTIFY_URGENCY_NORMAL);
+- notify_notification_attach_to_status_icon( lxn->notify, status_icon );
+ notify_notification_set_timeout (lxn->notify, NOTIFY_EXPIRES_DEFAULT);
+ g_string_free( message, TRUE );
+ return lxn;
diff --git a/lxmusic.spec b/lxmusic.spec
new file mode 100644
index 0000000..38fe26e
--- /dev/null
+++ b/lxmusic.spec
@@ -0,0 +1,74 @@
+Name: lxmusic
+Version: 0.4.5
+Release: 1mamba
+Summary: LXMusic - The minimalist music player for LXDE.
+Group: Graphical Desktop/Applications/Multimedia
+Vendor: openmamba
+Distribution: openmamba
+Packager: Fabio Giani
+URL: http://www.lxde.org/
+Source: http://downloads.sourceforge.net/project/lxde/LXMusic%20%28music%20player%29/LXMusic%20%{version}/lxmusic-%{version}.tar.gz
+Patch0: %{name}-0.4.2-no-tools-menu.patch
+Patch1: %{name}-0.4.5-libnotify-0.7.patch
+License: GPL
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
+## AUTOBUILDREQ-BEGIN
+BuildRequires: glibc-devel
+BuildRequires: libatk-devel
+BuildRequires: libcairo-devel
+BuildRequires: libfontconfig-devel
+BuildRequires: libfreetype-devel
+BuildRequires: libgdk-pixbuf-devel
+BuildRequires: libglib-devel
+BuildRequires: libgtk2-devel
+BuildRequires: libnotify-devel
+BuildRequires: libpango-devel
+BuildRequires: libxmms2-devel
+## AUTOBUILDREQ-END
+Requires: xmms2
+
+%description
+LXMusic is a very simple gtk+ XMMS2 client written in pure C.
+It has very few functionality, and can do nothing more than play the music. The UI is very clean and simple.
+This is currently aimed to be used as the default music player of LXDE (Lightweight X11 Desktop Environment) project.
+
+%prep
+
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+%configure
+%make
+
+%install
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+%makeinstall
+
+%find_lang %{name}
+
+%clean
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+
+%files -f %{name}.lang
+%defattr(-,root,root)
+%{_bindir}/%{name}
+%{_datadir}/applications/lxmusic.desktop
+%{_datadir}/lxmusic
+%{_datadir}/pixmaps/lxmusic.png
+%doc AUTHORS COPYING
+# README
+
+%changelog
+* Mon Jul 30 2012 Silvan Calarco 0.4.5-1mamba
+- update to 0.4.5
+
+* Sun May 30 2010 Silvan Calarco 0.4.4-1mamba
+- update to 0.4.4
+
+* Sat Jan 23 2010 Fabio Giani 0.4.2-2mamba
+- group changed, patch added
+
+* Fri Jan 15 2010 Fabio Giani 0.4.2-1mamba
+- package created by autospec