rebuilt without ConsoleKit (added patch) [release 0.4.1-10mamba;Mon Jun 30 2014]
This commit is contained in:
parent
03a4b54c30
commit
85caaed7ab
11
lxdm-0.4.1-automake-1.14.patch
Normal file
11
lxdm-0.4.1-automake-1.14.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- lxdm-0.4.1.orig/configure.ac 2014-06-30 13:12:09.483024636 +0200
|
||||||
|
+++ lxdm-0.4.1/configure.ac 2014-06-30 14:21:51.021675785 +0200
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
|
||||||
|
AC_PREREQ([2.63])
|
||||||
|
AC_INIT([lxdm], [0.4.1], [http://lxde.org/])
|
||||||
|
-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
|
||||||
|
+AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
|
||||||
|
|
||||||
|
AC_CONFIG_SRCDIR([src/lxdm.c])
|
||||||
|
AC_CONFIG_HEADERS([config.h])
|
35
lxdm-0.4.1-disable-consolekit.patch
Normal file
35
lxdm-0.4.1-disable-consolekit.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
--- lxdm-0.4.1.orig/configure.ac 2014-06-30 14:28:36.720796000 +0200
|
||||||
|
+++ lxdm-0.4.1/configure.ac 2014-06-30 14:29:47.328029842 +0200
|
||||||
|
@@ -19,8 +19,6 @@
|
||||||
|
AC_ARG_WITH(pam,AC_HELP_STRING([--without-pam],[build without pam]),
|
||||||
|
[],[AC_CHECK_LIB([pam], [pam_open_session])])
|
||||||
|
|
||||||
|
-AC_CHECK_LIB([ck-connector],[ck_connector_open_session])
|
||||||
|
-
|
||||||
|
# Checks for header files.
|
||||||
|
AC_PATH_X
|
||||||
|
AC_CHECK_HEADERS([shadow.h stdlib.h string.h unistd.h utmpx.h])
|
||||||
|
@@ -80,11 +78,22 @@
|
||||||
|
AC_SUBST(GTK_CFLAGS)
|
||||||
|
AC_SUBST(GTK_LIBS)
|
||||||
|
|
||||||
|
-PKG_CHECK_MODULES(CONSOLEKIT, "ck-connector",[
|
||||||
|
+
|
||||||
|
+AC_ARG_ENABLE(consolekit,
|
||||||
|
+ AC_HELP_STRING([--disable-consolekit],[disable ConsoleKit support]),
|
||||||
|
+ [enable_consolekit=$enableval],
|
||||||
|
+ [enable_consolekit=yes]
|
||||||
|
+)
|
||||||
|
+
|
||||||
|
+if test "x$enable_consolekit" = "xyes" ; then
|
||||||
|
+ AC_CHECK_LIB([ck-connector],[ck_connector_open_session])
|
||||||
|
+ PKG_CHECK_MODULES(CONSOLEKIT, "ck-connector",[
|
||||||
|
AC_SUBST(CONSOLEKIT_CFLAGS)
|
||||||
|
AC_SUBST(CONSOLEKIT_LIBS)],[
|
||||||
|
echo "ConsoleKit devel package not found"
|
||||||
|
])
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
|
||||||
|
AC_ARG_ENABLE(password,
|
||||||
|
AC_HELP_STRING([--enable-password],[enable to load autologin password store at config file]),
|
15
lxdm.spec
15
lxdm.spec
@ -1,6 +1,6 @@
|
|||||||
Name: lxdm
|
Name: lxdm
|
||||||
Version: 0.4.1
|
Version: 0.4.1
|
||||||
Release: 9mamba
|
Release: 10mamba
|
||||||
Summary: Login manager for the Lightweight X11 Desktop Environment
|
Summary: Login manager for the Lightweight X11 Desktop Environment
|
||||||
Group: Graphical Desktop/Applications/Environment
|
Group: Graphical Desktop/Applications/Environment
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -13,6 +13,8 @@ Patch1: %{name}-0.4.1-glib-2.32.patch
|
|||||||
Patch2: lxdm-0.4.1-pam_console_remove.patch
|
Patch2: lxdm-0.4.1-pam_console_remove.patch
|
||||||
Patch3: lxdm-0.4.1-active_vt_1.patch
|
Patch3: lxdm-0.4.1-active_vt_1.patch
|
||||||
Patch4: lxdm-0.4.1-Xorg-no-background.patch
|
Patch4: lxdm-0.4.1-Xorg-no-background.patch
|
||||||
|
Patch5: lxdm-0.4.1-disable-consolekit.patch
|
||||||
|
Patch6: lxdm-0.4.1-automake-1.14.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
@ -44,13 +46,17 @@ Login manager for the Lightweight X11 Desktop Environment.
|
|||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
%patch6 -p1
|
||||||
# Remove pregenerated lxdm.conf to recreate with passed directories
|
# Remove pregenerated lxdm.conf to recreate with passed directories
|
||||||
# Fixes configuring for using /usr/local/libexec
|
# Fixes configuring for using /usr/local/libexec
|
||||||
rm -f data/lxdm.conf
|
rm -f data/lxdm.conf
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
autoreconf -f -i
|
||||||
|
%configure \
|
||||||
|
--disable-consolekit
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -128,6 +134,9 @@ fi
|
|||||||
#README TODO
|
#README TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 30 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.1-10mamba
|
||||||
|
- rebuilt without ConsoleKit (added patch)
|
||||||
|
|
||||||
* Mon Jul 15 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.1-9mamba
|
* Mon Jul 15 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.1-9mamba
|
||||||
- fix lxdm.service after fixing plymouth 0.8.8 for smooth transition
|
- fix lxdm.service after fixing plymouth 0.8.8 for smooth transition
|
||||||
- lxdm.conf: run X as "Xorg -background none -nolisten tcp"
|
- lxdm.conf: run X as "Xorg -background none -nolisten tcp"
|
||||||
|
Loading…
Reference in New Issue
Block a user