added a patch to fix path of udevadm [release 2.02.114-4mamba;Sat Jan 17 2015]
This commit is contained in:
parent
e82105b85a
commit
ecca63316a
11
lvm2-2.02.114-udevadm_fix_path.patch
Normal file
11
lvm2-2.02.114-udevadm_fix_path.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- LVM2.2.02.114/scripts/lvm2_activation_generator_systemd_red_hat.c.orig 2015-01-17 18:51:54.492204036 +0100
|
||||||
|
+++ LVM2.2.02.114/scripts/lvm2_activation_generator_systemd_red_hat.c 2015-01-17 18:52:07.022203336 +0100
|
||||||
|
@@ -137,7 +137,7 @@
|
||||||
|
fprintf(f, "After=%s iscsi.service fcoe.service\n"
|
||||||
|
"Before=remote-fs.target shutdown.target\n\n"
|
||||||
|
"[Service]\n"
|
||||||
|
- "ExecStartPre=/usr/bin/udevadm settle\n", unit_names[UNIT_MAIN]);
|
||||||
|
+ "ExecStartPre=/bin/udevadm settle\n", unit_names[UNIT_MAIN]);
|
||||||
|
} else {
|
||||||
|
if (unit == UNIT_EARLY) {
|
||||||
|
fputs("After=systemd-udev-settle.service\n"
|
46
lvm2.spec
46
lvm2.spec
@ -1,6 +1,6 @@
|
|||||||
Name: lvm2
|
Name: lvm2
|
||||||
Version: 2.02.114
|
Version: 2.02.114
|
||||||
Release: 2mamba
|
Release: 4mamba
|
||||||
Summary: A userspace toolset that provides logical volume management facilities on Linux
|
Summary: A userspace toolset that provides logical volume management facilities on Linux
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -9,21 +9,23 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: http://sources.redhat.com/lvm2/
|
URL: http://sources.redhat.com/lvm2/
|
||||||
Source: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
Source: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
||||||
Patch0: lvm2-2.02.98-link-as-needed.patch
|
Patch0: lvm2-2.02.98-link-as-needed.patch
|
||||||
|
Patch1: lvm2-2.02.114-udevadm_fix_path.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libblkid-devel
|
BuildRequires: libblkid-devel
|
||||||
BuildRequires: libncurses-devel
|
|
||||||
BuildRequires: libpcre-devel
|
BuildRequires: libpcre-devel
|
||||||
BuildRequires: libreadline-devel
|
BuildRequires: libreadline-devel
|
||||||
BuildRequires: libselinux-devel
|
BuildRequires: libselinux-devel
|
||||||
BuildRequires: libsepol-devel
|
BuildRequires: libsepol-devel
|
||||||
|
BuildRequires: libtermcap-devel
|
||||||
BuildRequires: libudev-devel
|
BuildRequires: libudev-devel
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
Provides: device-mapper
|
Provides: device-mapper
|
||||||
Obsoletes: device-mapper
|
Obsoletes: device-mapper
|
||||||
Requires: libdevmapper = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: libdevmapper = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
%systemd_requires
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -75,6 +77,7 @@ This package contains files needed to develop applications that use the %{name}
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n LVM2.%{version}
|
%setup -q -n LVM2.%{version}
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -88,6 +91,8 @@ This package contains files needed to develop applications that use the %{name}
|
|||||||
--enable-dmeventd \
|
--enable-dmeventd \
|
||||||
--enable-lvmetad \
|
--enable-lvmetad \
|
||||||
--with-systemdsystemunitdir=%{_unitdir} \
|
--with-systemdsystemunitdir=%{_unitdir} \
|
||||||
|
--with-default-dm-run-dir=/run \
|
||||||
|
--with-default-run-dir=/run/lvm \
|
||||||
%if "%{_host}" != "%{_build}"
|
%if "%{_host}" != "%{_build}"
|
||||||
ac_cv_func_malloc_0_nonnull=yes
|
ac_cv_func_malloc_0_nonnull=yes
|
||||||
%endif
|
%endif
|
||||||
@ -100,7 +105,10 @@ This package contains files needed to develop applications that use the %{name}
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall
|
%makeinstall \
|
||||||
|
install_systemd_generators \
|
||||||
|
install_systemd_units \
|
||||||
|
install_tmpfiles_configuration
|
||||||
|
|
||||||
#cd libdm
|
#cd libdm
|
||||||
#% makeinstall INSTALL_TYPE="install_pkgconfig install_static"
|
#% makeinstall INSTALL_TYPE="install_pkgconfig install_static"
|
||||||
@ -108,6 +116,21 @@ This package contains files needed to develop applications that use the %{name}
|
|||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post
|
||||||
|
%systemd_post lvm2-monitor
|
||||||
|
:
|
||||||
|
|
||||||
|
%preun
|
||||||
|
%systemd_preun_cups lvm2-monitor
|
||||||
|
:
|
||||||
|
|
||||||
|
%postun
|
||||||
|
%systemd_postun_with_restart lvm2-monitor
|
||||||
|
:
|
||||||
|
|
||||||
|
%post -n lib%{name} -p /sbin/ldconfig
|
||||||
|
%postun -n lib%{name} -p /sbin/ldconfig
|
||||||
|
|
||||||
%post -n libdevmapper -p /sbin/ldconfig
|
%post -n libdevmapper -p /sbin/ldconfig
|
||||||
%postun -n libdevmapper -p /sbin/ldconfig
|
%postun -n libdevmapper -p /sbin/ldconfig
|
||||||
|
|
||||||
@ -178,6 +201,15 @@ This package contains files needed to develop applications that use the %{name}
|
|||||||
/lib/udev/rules.d/13-dm-disk.rules
|
/lib/udev/rules.d/13-dm-disk.rules
|
||||||
/lib/udev/rules.d/69-dm-lvm-metad.rules
|
/lib/udev/rules.d/69-dm-lvm-metad.rules
|
||||||
/lib/udev/rules.d/95-dm-notify.rules
|
/lib/udev/rules.d/95-dm-notify.rules
|
||||||
|
%{_tmpfilesdir}/lvm2.conf
|
||||||
|
%{_unitdir}/blk-availability.service
|
||||||
|
%{_unitdir}/dm-event.service
|
||||||
|
%{_unitdir}/dm-event.socket
|
||||||
|
%{_unitdir}/lvm2-lvmetad.service
|
||||||
|
%{_unitdir}/lvm2-lvmetad.socket
|
||||||
|
%{_unitdir}/lvm2-monitor.service
|
||||||
|
%{_unitdir}/lvm2-pvscan@.service
|
||||||
|
/lib/systemd/system-generators/lvm2-activation-generator
|
||||||
%{_mandir}/man5/lvm.conf.5.*
|
%{_mandir}/man5/lvm.conf.5.*
|
||||||
%{_mandir}/man7/lvmcache.7*
|
%{_mandir}/man7/lvmcache.7*
|
||||||
%{_mandir}/man7/lvmthin.7*
|
%{_mandir}/man7/lvmthin.7*
|
||||||
@ -203,6 +235,7 @@ This package contains files needed to develop applications that use the %{name}
|
|||||||
%{_mandir}/man8/lvremove.8.*
|
%{_mandir}/man8/lvremove.8.*
|
||||||
%{_mandir}/man8/lvrename.8.*
|
%{_mandir}/man8/lvrename.8.*
|
||||||
%{_mandir}/man8/lvresize.8.*
|
%{_mandir}/man8/lvresize.8.*
|
||||||
|
%{_mandir}/man8/lvm2-activation-generator.8*
|
||||||
%{_mandir}/man8/lvs.8.*
|
%{_mandir}/man8/lvs.8.*
|
||||||
%{_mandir}/man8/lvscan.8.*
|
%{_mandir}/man8/lvscan.8.*
|
||||||
%{_mandir}/man8/pvchange.8.*
|
%{_mandir}/man8/pvchange.8.*
|
||||||
@ -277,6 +310,13 @@ This package contains files needed to develop applications that use the %{name}
|
|||||||
#%doc README WHATS_NEW
|
#%doc README WHATS_NEW
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 17 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.02.114-4mamba
|
||||||
|
- added a patch to fix path of udevadm
|
||||||
|
|
||||||
|
* Sat Jan 17 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.02.114-3mamba
|
||||||
|
- explicity install systemd files
|
||||||
|
- move /var/run/* to /run
|
||||||
|
|
||||||
* Tue Dec 16 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.02.114-2mamba
|
* Tue Dec 16 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.02.114-2mamba
|
||||||
- force linking readline with termcap
|
- force linking readline with termcap
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user