automatic version update by autodist [release 2.6.1.1-1mamba;Thu Mar 07 2024]
This commit is contained in:
parent
b9ca4c3149
commit
810a23e1b6
@ -1,6 +1,4 @@
|
||||
# luminance-hdr
|
||||
|
||||
Luminance is a graphical program for assembling bracketed photos into High
|
||||
Dynamic Range (HDR) images. It also provides a number of tone-mapping
|
||||
operators for creating low dynamic range versions of HDR images.
|
||||
Luminance is a graphical program for assembling bracketed photos into High Dynamic Range (HDR) images. It also provides a number of tone-mapping operators for creating low dynamic range versions of HDR images.
|
||||
|
||||
|
13
luminance-hdr-2.6.1.1-fix-headers.patch
Normal file
13
luminance-hdr-2.6.1.1-fix-headers.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/src/Common/init_fftw.h b/src/Common/init_fftw.h
|
||||
index af2fc02c..a4aad47f 100644
|
||||
--- a/src/Common/init_fftw.h
|
||||
+++ b/src/Common/init_fftw.h
|
||||
@@ -22,7 +22,7 @@
|
||||
#ifndef INIT_FFTW_H
|
||||
#define INIT_FFTW_H
|
||||
|
||||
-#include <boost/thread/mutex.hpp>
|
||||
+#include <mutex>
|
||||
|
||||
class FFTW_MUTEX {
|
||||
public:
|
26
luminance-hdr-2.6.1.1-openexr-3.1.5.patch
Normal file
26
luminance-hdr-2.6.1.1-openexr-3.1.5.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 8ff498d0..23f5c387 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -191,7 +191,7 @@ INCLUDE_DIRECTORIES(${TIFF_INCLUDE_DIR})
|
||||
FIND_PACKAGE(PNG REQUIRED)
|
||||
INCLUDE_DIRECTORIES(${PNG_INCLUDE_DIR})
|
||||
|
||||
-FIND_PACKAGE(OpenEXR REQUIRED)
|
||||
+FIND_PACKAGE(OpenEXR CONFIG REQUIRED)
|
||||
INCLUDE_DIRECTORIES(${OPENEXR_INCLUDE_DIR} "${OPENEXR_INCLUDE_DIR}/OpenEXR")
|
||||
|
||||
FIND_PACKAGE(GSL REQUIRED)
|
||||
diff --git a/src/Libpfs/CMakeLists.txt b/src/Libpfs/CMakeLists.txt
|
||||
index 80617998..ce3c746e 100644
|
||||
--- a/src/Libpfs/CMakeLists.txt
|
||||
+++ b/src/Libpfs/CMakeLists.txt
|
||||
@@ -12,7 +12,7 @@ ADD_SUBDIRECTORY(colorspace)
|
||||
ADD_SUBDIRECTORY(io)
|
||||
|
||||
ADD_LIBRARY(pfs STATIC ${LIBPFS_H} ${LIBPFS_HXX} ${LIBPFS_CPP})
|
||||
-TARGET_LINK_LIBRARIES(pfs Qt5::Core Qt5::Gui Qt5::Widgets)
|
||||
+TARGET_LINK_LIBRARIES(pfs Qt5::Core Qt5::Gui Qt5::Widgets OpenEXR::OpenEXR)
|
||||
|
||||
SET(LUMINANCE_MODULES_GUI ${LUMINANCE_MODULES_GUI} pfs PARENT_SCOPE)
|
||||
SET(LUMINANCE_MODULES_CLI ${LUMINANCE_MODULES_CLI} pfs PARENT_SCOPE)
|
@ -1,55 +1,66 @@
|
||||
Name: luminance-hdr
|
||||
Version: 2.3.1
|
||||
Release: 3mamba
|
||||
Version: 2.6.1.1
|
||||
Release: 1mamba
|
||||
Summary: A graphical tool for creating and tone-mapping HDR images
|
||||
Group: Graphical Desktop/Applications/Graphics
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||
URL: http://qtpfsgui.sourceforge.net/
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://sourceforge.net/projects/qtpfsgui/
|
||||
Source: http://downloads.sourceforge.net/project/qtpfsgui/luminance/%{version}/luminance-hdr-%{version}.tar.bz2
|
||||
Patch0: luminance-hdr-2.6.1.1-openexr-3.1.5.patch
|
||||
Patch1: luminance-hdr-2.6.1.1-fix-headers.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libQt5Positioning-devel
|
||||
BuildRequires: libQt5WebChannel-devel
|
||||
BuildRequires: libQt5WebEngine-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libcfitsio-devel
|
||||
BuildRequires: libexiv2-devel
|
||||
BuildRequires: libfftw-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgomp-devel
|
||||
BuildRequires: libgsl-devel
|
||||
BuildRequires: libilmbase-devel
|
||||
BuildRequires: libimath-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblcms2-devel
|
||||
BuildRequires: libopenexr-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libraw-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: qt5-qtdeclarative-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Luminance is a graphical program for assembling bracketed photos into High
|
||||
Dynamic Range (HDR) images. It also provides a number of tone-mapping
|
||||
operators for creating low dynamic range versions of HDR images.
|
||||
Luminance is a graphical program for assembling bracketed photos into High Dynamic Range (HDR) images. It also provides a number of tone-mapping operators for creating low dynamic range versions of HDR images.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -c -q
|
||||
%setup -q
|
||||
%patch 0 -p1 -b .openexr-3.1.5
|
||||
%patch 1 -p1 -b .fix-headers
|
||||
|
||||
%build
|
||||
|
||||
cmake -Wno-dev -DBUILD_SHARED_LIBS:BOOL=OFF -DCMAKE_INSTALL_PREFIX=/usr
|
||||
|
||||
%make
|
||||
%cmake -d build \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
make install/fast DESTDIR=%{buildroot} PREFIX=/usr
|
||||
install -d %{buildroot}%{_datadir}/%{name}/i18n
|
||||
cp -pf *.qm %{buildroot}%{_datadir}/%{name}/i18n
|
||||
install -d %{buildroot}/%{_datadir}/mime/packages
|
||||
cp -pf luminance-hdr.xml %{buildroot}/%{_datadir}/mime/packages
|
||||
cp -pf luminance-hdr.desktop %{buildroot}/%{_datadir}/applications
|
||||
%makeinstall -C build
|
||||
|
||||
#make install/fast DESTDIR=%{buildroot} PREFIX=/usr
|
||||
#install -d %{buildroot}%{_datadir}/%{name}/i18n
|
||||
#cp -pf *.qm %{buildroot}%{_datadir}/%{name}/i18n
|
||||
#install -d %{buildroot}/%{_datadir}/mime/packages
|
||||
#cp -pf luminance-hdr.xml %{buildroot}/%{_datadir}/mime/packages
|
||||
#cp -pf luminance-hdr.desktop %{buildroot}/%{_datadir}/applications
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -58,24 +69,25 @@ cp -pf luminance-hdr.desktop %{buildroot}/%{_datadir}/applications
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/luminance-hdr
|
||||
%{_bindir}/luminance-hdr-cli
|
||||
%{_datadir}/applications/luminance-hdr.desktop
|
||||
%{_datadir}/mime/packages/luminance-hdr.xml
|
||||
%{_datadir}/icons/hicolor/48x48/apps/luminance-hdr.png
|
||||
%{_datadir}/luminance-hdr/AUTHORS
|
||||
%{_datadir}/luminance-hdr/Changelog
|
||||
%{_datadir}/luminance-hdr/LICENSE
|
||||
%{_datadir}/luminance-hdr/README
|
||||
%{_datadir}/luminance-hdr/help/en/README
|
||||
%{_datadir}/luminance-hdr/help/en/*.html
|
||||
%{_datadir}/luminance-hdr/help/en/external.png
|
||||
%{_datadir}/luminance-hdr/help/en/images/*.png
|
||||
%{_datadir}/luminance-hdr/help/en/menu.xml
|
||||
%{_datadir}/luminance-hdr/help/en/style.css
|
||||
#%{_datadir}/luminance-hdr/help/js/*.js
|
||||
%{_datadir}/appdata/net.sourceforge.qtpfsgui.LuminanceHDR.appdata.xml
|
||||
%{_datadir}/applications/net.sourceforge.qtpfsgui.LuminanceHDR.desktop
|
||||
%dir %{_datadir}/luminance-hdr
|
||||
%dir %{_datadir}/luminance-hdr/doc
|
||||
%{_datadir}/luminance-hdr/doc/*
|
||||
%dir %{_datadir}/luminance-hdr/hdrhtml
|
||||
%{_datadir}/luminance-hdr/hdrhtml/*
|
||||
%dir %{_datadir}/luminance-hdr/help
|
||||
%dir %{_datadir}/luminance-hdr/help/en
|
||||
%{_datadir}/luminance-hdr/help/en/*
|
||||
%dir %{_datadir}/luminance-hdr/i18n
|
||||
%{_datadir}/luminance-hdr/i18n/*.qm
|
||||
%{_datadir}/icons/hicolor/48x48/apps/luminance-hdr.png
|
||||
%doc AUTHORS LICENSE
|
||||
|
||||
%changelog
|
||||
* Thu Mar 07 2024 Automatic Build System <autodist@openmamba.org> 2.6.1.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1-3mamba
|
||||
- rebuilt with openexr 2.1.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user