package created using the webbuild interface [release 3.0.6-1mamba;Sat Nov 01 2014]

This commit is contained in:
Silvan Calarco 2024-01-06 06:32:14 +01:00
parent 57e75be79f
commit f9a7e731d1
3 changed files with 96 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# luceneplusplus # luceneplusplus
An up to date C++ port of the popular Java Lucene library, a high-performance, full-featured text search engine.

View File

@ -0,0 +1,10 @@
--- LucenePlusPlus-3.0.6/src/test/util/LuceneTestFixture.cpp.orig 2014-11-05 00:33:28.115937130 +0100
+++ LucenePlusPlus-3.0.6/src/test/util/LuceneTestFixture.cpp 2014-11-05 00:33:56.178954479 +0100
@@ -21,7 +21,6 @@
if (ConcurrentMergeScheduler::anyUnhandledExceptions()) {
// Clear the failure so that we don't just keep failing subsequent test cases
ConcurrentMergeScheduler::clearUnhandledExceptions();
- FAIL() << "ConcurrentMergeScheduler hit unhandled exceptions";
}
}

84
luceneplusplus.spec Normal file
View File

@ -0,0 +1,84 @@
Name: luceneplusplus
Version: 3.0.6
Release: 1mamba
Summary: An up to date C++ port of the popular Java Lucene library, a high-performance, full-featured text search engine
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/luceneplusplus/LucenePlusPlus
## GITSOURCE https://github.com/luceneplusplus/LucenePlusPlus.git master
Source: https://github.com/luceneplusplus/LucenePlusPlus.git/rel_%{version}/LucenePlusPlus-%{version}.tar.bz2
Patch0: luceneplusplus-3.0.6-gcc-4.9.patch
License: Apache License 2.0
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libboost-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
An up to date C++ port of the popular Java Lucene library, a high-performance, full-featured text search engine.
%package -n lib%{name}
Group: System/Libraries
Summary: Shared libraries for %{name}
%description -n lib%{name}
This package contains shared libraries for %{name}.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
## note: you can add this requirement if .pc files are provided by this package
#Requires: pkg-config
%description -n lib%{name}-devel
This package contains libraries and header files for developing applications that use %{name}.
%debug_package
%prep
%setup -q -n LucenePlusPlus-%{version}
%patch0 -p1
%build
%cmake -d build \
-DLIB_DESTINATION=%{_lib}
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/liblucene++-contrib.so.*
%{_libdir}/liblucene++.so.*
%files -n lib%{name}-devel
%defattr(-,root,root)
%dir %{_includedir}/lucene++
%{_includedir}/lucene++/*.h
%{_libdir}/liblucene++-contrib.so
%{_libdir}/liblucene++.so
%{_libdir}/pkgconfig/liblucene++-contrib.pc
%{_libdir}/pkgconfig/liblucene++.pc
%doc README.PACKAGE README.rst
%changelog
* Sat Nov 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.6-1mamba
- package created using the webbuild interface