update to 5.3.6 [release 5.3.6-1mamba;Wed Dec 22 2021]
This commit is contained in:
parent
702096e48c
commit
7f1cf0bddf
@ -1,2 +1,11 @@
|
||||
# lua53
|
||||
|
||||
Lua is a powerful light-weight programming language designed for extending applications.
|
||||
Lua is also frequently used as a general-purpose, stand-alone language.
|
||||
Lua combines simple procedural syntax with powerful data description constructs based on associative arrays and extensible semantics.
|
||||
Lua is dynamically typed, interpreted from bytecodes, and has automatic memory management with garbage collection, making it ideal for configuration, scripting, and rapid prototyping.
|
||||
A fundamental concept in the design of Lua is to provide meta-mechanisms for implementing features, instead of providing a host of features directly in the language.
|
||||
For example, although Lua is not a pure object-oriented language, it does provide meta-mechanisms for implementing classes and inheritance.
|
||||
Lua's meta-mechanisms bring an economy of concepts and keep the language small, while allowing the semantics to be extended in unconventional ways.
|
||||
Extensible semantics is a distinguishing feature of Lua.
|
||||
|
||||
|
61
lua-5.3.1-shared_library.patch
Normal file
61
lua-5.3.1-shared_library.patch
Normal file
@ -0,0 +1,61 @@
|
||||
Submitted By: Igor Živković <contact@igor-zivkovic.from.hr>
|
||||
Date: 2013-06-19
|
||||
Initial Package Version: 5.2.2
|
||||
Upstream Status: Rejected
|
||||
Origin: Arch Linux packages repository
|
||||
Description: Adds the compilation of a shared library.
|
||||
|
||||
diff -Naur lua-5.3.0.orig/Makefile lua-5.3.0/Makefile
|
||||
--- lua-5.3.0.orig/Makefile 2014-10-30 00:14:41.000000000 +0100
|
||||
+++ lua-5.3.0/Makefile 2015-01-19 22:14:09.822290828 +0100
|
||||
@@ -52,7 +52,7 @@
|
||||
all: $(PLAT)
|
||||
|
||||
$(PLATS) clean:
|
||||
- cd src && $(MAKE) $@
|
||||
+ cd src && $(MAKE) $@ V=$(V) R=$(R)
|
||||
|
||||
test: dummy
|
||||
src/lua -v
|
||||
diff -Naur lua-5.3.0.orig/src/Makefile lua-5.3.0/src/Makefile
|
||||
--- lua-5.3.0.orig/src/Makefile 2015-01-05 17:04:52.000000000 +0100
|
||||
+++ lua-5.3.0/src/Makefile 2015-01-19 22:14:52.559378543 +0100
|
||||
@@ -7,7 +7,7 @@
|
||||
PLAT= none
|
||||
|
||||
CC= gcc -std=gnu99
|
||||
-CFLAGS= -O2 -Wall -Wextra -DLUA_COMPAT_5_2 $(SYSCFLAGS) $(MYCFLAGS)
|
||||
+CFLAGS= -fPIC -O2 -Wall -Wextra -DLUA_COMPAT_5_2 $(SYSCFLAGS) $(MYCFLAGS)
|
||||
LDFLAGS= $(SYSLDFLAGS) $(MYLDFLAGS)
|
||||
LIBS= -lm $(SYSLIBS) $(MYLIBS)
|
||||
|
||||
@@ -29,6 +29,7 @@
|
||||
PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
|
||||
|
||||
LUA_A= liblua.a
|
||||
+LUA_SO= liblua.so
|
||||
CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
|
||||
lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
|
||||
ltm.o lundump.o lvm.o lzio.o
|
||||
@@ -43,7 +44,7 @@
|
||||
LUAC_O= luac.o
|
||||
|
||||
ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
|
||||
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
|
||||
+ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
|
||||
ALL_A= $(LUA_A)
|
||||
|
||||
# Targets start here.
|
||||
@@ -59,6 +60,12 @@
|
||||
$(AR) $@ $(BASE_O)
|
||||
$(RANLIB) $@
|
||||
|
||||
+$(LUA_SO): $(CORE_O) $(LIB_O)
|
||||
+ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
|
||||
+ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
|
||||
+ ln -sf $(LUA_SO).$(R) $(LUA_SO)
|
||||
+
|
||||
+
|
||||
$(LUA_T): $(LUA_O) $(LUA_A)
|
||||
$(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
|
||||
|
213
lua53.spec
Normal file
213
lua53.spec
Normal file
@ -0,0 +1,213 @@
|
||||
%define libname liblua53
|
||||
%define libmajver %(echo %version | cut -d. -f 1-2)
|
||||
|
||||
Name: lua53
|
||||
Version: 5.3.6
|
||||
Release: 1mamba
|
||||
Summary: A powerful light-weight and embeddable programming language
|
||||
Group: Applications/Development
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.lua.org
|
||||
Source: http://www.lua.org/ftp/lua-%{version}.tar.gz
|
||||
Patch3: lua-5.3.1-shared_library.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libtermcap-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
%description
|
||||
Lua is a powerful light-weight programming language designed for extending applications.
|
||||
Lua is also frequently used as a general-purpose, stand-alone language.
|
||||
Lua combines simple procedural syntax with powerful data description constructs based on associative arrays and extensible semantics.
|
||||
Lua is dynamically typed, interpreted from bytecodes, and has automatic memory management with garbage collection, making it ideal for configuration, scripting, and rapid prototyping.
|
||||
A fundamental concept in the design of Lua is to provide meta-mechanisms for implementing features, instead of providing a host of features directly in the language.
|
||||
For example, although Lua is not a pure object-oriented language, it does provide meta-mechanisms for implementing classes and inheritance.
|
||||
Lua's meta-mechanisms bring an economy of concepts and keep the language small, while allowing the semantics to be extended in unconventional ways.
|
||||
Extensible semantics is a distinguishing feature of Lua.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Lua is a powerful light-weight programming language designed for extending applications.
|
||||
Lua is also frequently used as a general-purpose, stand-alone language.
|
||||
|
||||
This package contains files needed for embedding lua into your application.
|
||||
|
||||
%package -n %{libname}
|
||||
Summary: Lua is a powerful, light-weight programming language
|
||||
Group: System/Libraries
|
||||
#Provides: liblua.so
|
||||
#Provides: liblualib.so
|
||||
|
||||
%description -n %{libname}
|
||||
Lua is a powerful light-weight programming language designed for extending applications.
|
||||
This package contains the dynamic libraries provided by lua scripting language.
|
||||
|
||||
%package -n %{libname}-devel
|
||||
Summary: Static libraries and headers for lua
|
||||
Group: Development/Libraries
|
||||
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n %{libname}-devel
|
||||
Lua is a powerful light-weight programming language designed for extending applications.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n lua-%{version}
|
||||
#%patch0 -p1 -b .dynlib
|
||||
#%patch1 -p1 -b .luapc
|
||||
#%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
%make MYCFLAGS="$CFLAGS -fPIC -DLUA_COMPAT_5_2 -DLUA_COMPAT_5_1" MYLDFLAGS="$LDFLAGS -ltermcap" linux
|
||||
#%make -j1 -C src \
|
||||
# CC=%{_host}-gcc \
|
||||
# MYCFLAGS="$RPM_OPT_FLAGS -fPIC -DLUA_COMPAT_5_2 -DLUA_COMPAT_5_1" -DLUA_USE_LINUX" \
|
||||
# make MYCFLAGS="$CFLAGS -fPIC MYLDFLAGS="$LDFLAGS" linux
|
||||
# MYLIBS="-Wl,-E -ldl -lreadline -lhistory -lncurses" V=%{libmajver} all
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall \
|
||||
INSTALL_TOP=%{buildroot}%{_prefix} \
|
||||
INSTALL_INC=%{buildroot}%{_includedir}/lua%{libmajver} \
|
||||
INSTALL_LIB=%{buildroot}%{_libdir} \
|
||||
INSTALL_MAN=%{buildroot}%{_mandir}/man1
|
||||
|
||||
install -d %{buildroot}%{_datadir}/lua
|
||||
#install -m 644 test/*.lua %{buildroot}%{_datadir}/lua
|
||||
|
||||
install -d %{buildroot}%{_libdir}
|
||||
install -m 755 src/liblua.so.%{libmajver} %{buildroot}%{_libdir}
|
||||
ln -s liblua.so.%{libmajver} %{buildroot}%{_libdir}/liblua.so
|
||||
|
||||
#install -D -m644 etc/lua.pc %{buildroot}%{_libdir}/pkgconfig/lua.pc
|
||||
install -d %{buildroot}%{_libdir}/pkgconfig/
|
||||
echo "\
|
||||
prefix=%{_prefix}
|
||||
exec_prefix=%{_exec_prefix}
|
||||
libdir=%{_libdir}
|
||||
includedir=%{_includedir}/lua%{libmajver}
|
||||
|
||||
Name: lua
|
||||
Description: An Extensible Extension Language
|
||||
Version: %{version}
|
||||
Requires:
|
||||
Libs: -L%{_libdir} -llua -lm -lreadline
|
||||
Cflags: -I%{_includedir}/lua%{libmajver}" > \
|
||||
%{buildroot}%{_libdir}/pkgconfig/lua%{libmajver}.pc
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post -n %{libname} -p /sbin/ldconfig
|
||||
%postun -n %{libname} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/lua
|
||||
%{_bindir}/luac
|
||||
%dir %{_datadir}/lua
|
||||
#%{_datadir}/lua/*.lua
|
||||
%{_mandir}/man1/lua.*
|
||||
%{_mandir}/man1/luac.*
|
||||
|
||||
%files -n %{libname}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/liblua.so.*
|
||||
|
||||
%files -n %{libname}-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/lua%{libmajver}
|
||||
%{_includedir}/lua%{libmajver}/*.h
|
||||
%{_includedir}/lua%{libmajver}/*.hpp
|
||||
%{_libdir}/liblua.a
|
||||
%{_libdir}/liblua.so
|
||||
%{_libdir}/pkgconfig/lua%{libmajver}.pc
|
||||
%doc README doc/*.html doc/*.css doc/*.gif doc/*.png
|
||||
|
||||
%changelog
|
||||
* Wed Dec 22 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.3.6-1mamba
|
||||
- update to 5.3.6
|
||||
|
||||
* Sat Aug 25 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 5.3.5-2mamba
|
||||
- rebuild with LUA_COMPAT_5_1 and LUA_COMPAT_5_2 support
|
||||
|
||||
* Tue Jul 10 2018 Automatic Build System <autodist@mambasoft.it> 5.3.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Feb 06 2017 Automatic Build System <autodist@mambasoft.it> 5.3.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jun 09 2016 Automatic Build System <autodist@mambasoft.it> 5.3.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jan 25 2016 Automatic Build System <autodist@mambasoft.it> 5.3.2-2mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jan 25 2016 Automatic Build System <autodist@mambasoft.it> 5.3.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Sep 16 2015 Automatic Build System <autodist@mambasoft.it> 5.3.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Mar 21 2015 Automatic Build System <autodist@mambasoft.it> 5.2.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Dec 07 2013 Automatic Build System <autodist@mambasoft.it> 5.2.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jul 18 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.2-3mamba
|
||||
- lua.pc: fix cflags
|
||||
|
||||
* Tue Jun 04 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.2-2mamba
|
||||
- install headers unser %{_includedir}/lua5.2 to avoid conflicts with packages wanting lua51
|
||||
|
||||
* Thu Mar 28 2013 Automatic Build System <autodist@mambasoft.it> 5.2.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Aug 14 2012 Automatic Build System <autodist@mambasoft.it> 5.2.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Dec 31 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 5.1.4-2mamba
|
||||
- rebuilt with debug package
|
||||
|
||||
* Thu Dec 04 2008 gil <puntogil@libero.it> 5.1.4-1mamba
|
||||
- update to 5.1.4
|
||||
|
||||
* Mon Jul 07 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 5.1.3-1mamba
|
||||
- update to 5.1.3
|
||||
- fix liblua.so: make it a symlink to liblua.so.*
|
||||
|
||||
* Fri Oct 26 2007 Aleph0 <aleph0@openmamba.org> 5.1.2-3mamba
|
||||
- do not provide liblualib.so
|
||||
|
||||
* Thu Oct 25 2007 Aleph0 <aleph0@openmamba.org> 5.1.2-2mamba
|
||||
- add lua.pc
|
||||
|
||||
* Wed Oct 24 2007 Aleph0 <aleph0@openmamba.org> 5.1.2-1mamba
|
||||
- update to 5.1.2
|
||||
- patched to build dynamic libraries
|
||||
- package coding examples contained in the source code
|
||||
- use standard CFLAGS options when building
|
||||
|
||||
* Thu Dec 14 2006 Aleph0 <aleph0@openmamba.org> 5.0.3-2qilnx
|
||||
- created devel package
|
||||
- build shared libraries
|
||||
- added more documentation files
|
||||
|
||||
* Wed Oct 18 2006 Davide Madrisan <davide.madrisan@qilinux.it> 5.0.3-1qilnx
|
||||
- update to version 5.0.3 by autospec
|
||||
|
||||
* Tue Apr 04 2006 Davide Madrisan <davide.madrisan@qilinux.it> 5.0.2-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user