automatic version update by autodist [release 5.4.3-1mamba;Sat Nov 27 2021]

This commit is contained in:
Automatic Build System 2024-01-06 06:31:24 +01:00
parent ca56f49e60
commit 5689d5a6a6
3 changed files with 71 additions and 70 deletions

View File

@ -1,61 +0,0 @@
Submitted By: Igor Živković <contact@igor-zivkovic.from.hr>
Date: 2013-06-19
Initial Package Version: 5.2.2
Upstream Status: Rejected
Origin: Arch Linux packages repository
Description: Adds the compilation of a shared library.
diff -Naur lua-5.3.0.orig/Makefile lua-5.3.0/Makefile
--- lua-5.3.0.orig/Makefile 2014-10-30 00:14:41.000000000 +0100
+++ lua-5.3.0/Makefile 2015-01-19 22:14:09.822290828 +0100
@@ -52,7 +52,7 @@
all: $(PLAT)
$(PLATS) clean:
- cd src && $(MAKE) $@
+ cd src && $(MAKE) $@ V=$(V) R=$(R)
test: dummy
src/lua -v
diff -Naur lua-5.3.0.orig/src/Makefile lua-5.3.0/src/Makefile
--- lua-5.3.0.orig/src/Makefile 2015-01-05 17:04:52.000000000 +0100
+++ lua-5.3.0/src/Makefile 2015-01-19 22:14:52.559378543 +0100
@@ -7,7 +7,7 @@
PLAT= none
CC= gcc -std=gnu99
-CFLAGS= -O2 -Wall -Wextra -DLUA_COMPAT_5_2 $(SYSCFLAGS) $(MYCFLAGS)
+CFLAGS= -fPIC -O2 -Wall -Wextra -DLUA_COMPAT_5_2 $(SYSCFLAGS) $(MYCFLAGS)
LDFLAGS= $(SYSLDFLAGS) $(MYLDFLAGS)
LIBS= -lm $(SYSLIBS) $(MYLIBS)
@@ -29,6 +29,7 @@
PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
LUA_A= liblua.a
+LUA_SO= liblua.so
CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
ltm.o lundump.o lvm.o lzio.o
@@ -43,7 +44,7 @@
LUAC_O= luac.o
ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
+ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
ALL_A= $(LUA_A)
# Targets start here.
@@ -59,6 +60,12 @@
$(AR) $@ $(BASE_O)
$(RANLIB) $@
+$(LUA_SO): $(CORE_O) $(LIB_O)
+ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
+ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
+ ln -sf $(LUA_SO).$(R) $(LUA_SO)
+
+
$(LUA_T): $(LUA_O) $(LUA_A)
$(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)

View File

@ -0,0 +1,60 @@
diff --git a/Makefile b/Makefile
index 416f444..eeaff03 100644
--- a/Makefile
+++ b/Makefile
@@ -52,7 +52,7 @@ R= $V.0
all: $(PLAT)
$(PLATS) help test clean:
- @cd src && $(MAKE) $@
+ @cd src && $(MAKE) $@ V=$(V) R=$(R)
install: dummy
cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
diff --git a/src/Makefile b/src/Makefile
index 514593d..372a6dc 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -33,6 +33,7 @@ CMCFLAGS= -Os
PLATS= guess aix bsd c89 freebsd generic linux linux-readline macosx mingw posix solaris
LUA_A= liblua.a
+LUA_SO= liblua.so
CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o lundump.o lvm.o lzio.o
LIB_O= lauxlib.o lbaselib.o lcorolib.o ldblib.o liolib.o lmathlib.o loadlib.o loslib.o lstrlib.o ltablib.o lutf8lib.o linit.o
BASE_O= $(CORE_O) $(LIB_O) $(MYOBJS)
@@ -44,7 +45,7 @@ LUAC_T= luac
LUAC_O= luac.o
ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
+ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
ALL_A= $(LUA_A)
# Targets start here.
@@ -60,6 +61,12 @@ $(LUA_A): $(BASE_O)
$(AR) $@ $(BASE_O)
$(RANLIB) $@
+$(LUA_SO): $(CORE_O) $(LIB_O)
+ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
+ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
+ ln -sf $(LUA_SO).$(R) $(LUA_SO)
+
+
$(LUA_T): $(LUA_O) $(LUA_A)
$(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
diff --git a/src/luaconf.h b/src/luaconf.h
index bdf927e..7e15198 100644
--- a/src/luaconf.h
+++ b/src/luaconf.h
@@ -227,7 +227,7 @@
#else /* }{ */
-#define LUA_ROOT "/usr/local/"
+#define LUA_ROOT "/usr/"
#define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR "/"
#define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR "/"

View File

@ -2,8 +2,8 @@
%define libmajver %(echo %version | cut -d. -f 1-2)
Name: lua
Version: 5.3.5
Release: 2mamba
Version: 5.4.3
Release: 1mamba
Summary: A powerful light-weight and embeddable programming language
Group: Applications/Development
Vendor: openmamba
@ -14,14 +14,13 @@ Source: http://www.lua.org/ftp/lua-%{version}.tar.gz
Patch0: %{name}-5.2.0-dynlib.patch
Patch1: %{name}-5.1.2-luapc.patch
Patch2: %{name}-5.1.4-cross_compile.patch
Patch3: lua-5.3.1-shared_library.patch
Patch3: lua-5.4.3-shared_library.patch
License: MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libncurses-devel
BuildRequires: libreadline-devel
BuildRequires: libtermcap-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Lua is a powerful light-weight programming language designed for extending applications.
@ -58,8 +57,8 @@ This package contains the dynamic libraries provided by lua scripting language.
Summary: Static libraries and headers for lua
Group: Development/Libraries
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
Obsoletes: lua-devel
Provides: lua-devel = %{?epoch:%epoch:}%{version}-%{release}
Obsoletes: lua-devel < 5.4.3
%description -n %{libname}-devel
Lua is a powerful light-weight programming language designed for extending applications.
@ -72,10 +71,10 @@ This package contains static libraries and header files need for development.
#%patch0 -p1 -b .dynlib
#%patch1 -p1 -b .luapc
#%patch2 -p1
%patch3 -p1
%patch3 -p1 -b .shared_library
%build
%make MYCFLAGS="$CFLAGS -fPIC -DLUA_COMPAT_5_2 -DLUA_COMPAT_5_1" MYLDFLAGS="$LDFLAGS -ltermcap" linux
%make MYCFLAGS="$CFLAGS -fPIC -DLUA_COMPAT_5_2 -DLUA_COMPAT_5_1" MYLDFLAGS="$LDFLAGS -ltermcap" linux-readline
#%make -j1 -C src \
# CC=%{_host}-gcc \
# MYCFLAGS="$RPM_OPT_FLAGS -fPIC -DLUA_COMPAT_5_2 -DLUA_COMPAT_5_1" -DLUA_USE_LINUX" \
@ -107,7 +106,7 @@ includedir=%{_includedir}/lua%{libmajver}
Name: Lua
Description: An Extensible Extension Language
Version: 5.3.5
Version: 5.4.3
Requires:
Libs: -L%{_libdir} -llua -lm -lreadline
Cflags: -I%{_includedir}/lua%{libmajver}" > \
@ -143,6 +142,9 @@ Cflags: -I%{_includedir}/lua%{libmajver}" > \
%doc README doc/*.html doc/*.css doc/*.gif doc/*.png
%changelog
* Sat Nov 27 2021 Automatic Build System <autodist@mambasoft.it> 5.4.3-1mamba
- automatic version update by autodist
* Sat Aug 25 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 5.3.5-2mamba
- rebuild with LUA_COMPAT_5_1 and LUA_COMPAT_5_2 support