automatic version update by autodist [release 5.3.2-2mamba;Mon Jan 25 2016]
This commit is contained in:
parent
71ee43b0cb
commit
30c7b5071a
61
lua-5.3.1-shared_library.patch
Normal file
61
lua-5.3.1-shared_library.patch
Normal file
@ -0,0 +1,61 @@
|
||||
Submitted By: Igor Živković <contact@igor-zivkovic.from.hr>
|
||||
Date: 2013-06-19
|
||||
Initial Package Version: 5.2.2
|
||||
Upstream Status: Rejected
|
||||
Origin: Arch Linux packages repository
|
||||
Description: Adds the compilation of a shared library.
|
||||
|
||||
diff -Naur lua-5.3.0.orig/Makefile lua-5.3.0/Makefile
|
||||
--- lua-5.3.0.orig/Makefile 2014-10-30 00:14:41.000000000 +0100
|
||||
+++ lua-5.3.0/Makefile 2015-01-19 22:14:09.822290828 +0100
|
||||
@@ -52,7 +52,7 @@
|
||||
all: $(PLAT)
|
||||
|
||||
$(PLATS) clean:
|
||||
- cd src && $(MAKE) $@
|
||||
+ cd src && $(MAKE) $@ V=$(V) R=$(R)
|
||||
|
||||
test: dummy
|
||||
src/lua -v
|
||||
diff -Naur lua-5.3.0.orig/src/Makefile lua-5.3.0/src/Makefile
|
||||
--- lua-5.3.0.orig/src/Makefile 2015-01-05 17:04:52.000000000 +0100
|
||||
+++ lua-5.3.0/src/Makefile 2015-01-19 22:14:52.559378543 +0100
|
||||
@@ -7,7 +7,7 @@
|
||||
PLAT= none
|
||||
|
||||
CC= gcc -std=gnu99
|
||||
-CFLAGS= -O2 -Wall -Wextra -DLUA_COMPAT_5_2 $(SYSCFLAGS) $(MYCFLAGS)
|
||||
+CFLAGS= -fPIC -O2 -Wall -Wextra -DLUA_COMPAT_5_2 $(SYSCFLAGS) $(MYCFLAGS)
|
||||
LDFLAGS= $(SYSLDFLAGS) $(MYLDFLAGS)
|
||||
LIBS= -lm $(SYSLIBS) $(MYLIBS)
|
||||
|
||||
@@ -29,6 +29,7 @@
|
||||
PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
|
||||
|
||||
LUA_A= liblua.a
|
||||
+LUA_SO= liblua.so
|
||||
CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
|
||||
lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
|
||||
ltm.o lundump.o lvm.o lzio.o
|
||||
@@ -43,7 +44,7 @@
|
||||
LUAC_O= luac.o
|
||||
|
||||
ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
|
||||
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
|
||||
+ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
|
||||
ALL_A= $(LUA_A)
|
||||
|
||||
# Targets start here.
|
||||
@@ -59,6 +60,12 @@
|
||||
$(AR) $@ $(BASE_O)
|
||||
$(RANLIB) $@
|
||||
|
||||
+$(LUA_SO): $(CORE_O) $(LIB_O)
|
||||
+ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
|
||||
+ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
|
||||
+ ln -sf $(LUA_SO).$(R) $(LUA_SO)
|
||||
+
|
||||
+
|
||||
$(LUA_T): $(LUA_O) $(LUA_A)
|
||||
$(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
|
||||
|
25
lua.spec
25
lua.spec
@ -2,7 +2,7 @@
|
||||
%define libmajver %(echo %version | cut -d. -f 1-2)
|
||||
|
||||
Name: lua
|
||||
Version: 5.2.4
|
||||
Version: 5.3.2
|
||||
Release: 2mamba
|
||||
Summary: A powerful light-weight and embeddable programming language
|
||||
Group: Applications/Development
|
||||
@ -14,6 +14,7 @@ Source: http://www.lua.org/ftp/lua-%{version}.tar.gz
|
||||
Patch0: %{name}-5.2.0-dynlib.patch
|
||||
Patch1: %{name}-5.1.2-luapc.patch
|
||||
Patch2: %{name}-5.1.4-cross_compile.patch
|
||||
Patch3: lua-5.3.1-shared_library.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -68,9 +69,10 @@ This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .dynlib
|
||||
#%patch0 -p1 -b .dynlib
|
||||
#%patch1 -p1 -b .luapc
|
||||
%patch2 -p1
|
||||
#%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
##% make linux
|
||||
@ -104,13 +106,11 @@ includedir=%{_includedir}/lua%{libmajver}
|
||||
|
||||
Name: Lua
|
||||
Description: An Extensible Extension Language
|
||||
Version: 5.2.4
|
||||
Version: 5.3.2
|
||||
Requires:
|
||||
Libs: -L%{_libdir} -llua -lm -lreadline
|
||||
Cflags: -I%{_includedir}/lua%{libmajver}" > \
|
||||
%{buildroot}%{_libdir}/pkgconfig/lua%{libmajver}.pc
|
||||
|
||||
ln -s lua%{libmajver}.pc %{buildroot}%{_libdir}/pkgconfig/lua.pc
|
||||
%{buildroot}%{_libdir}/pkgconfig/lua.pc
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
@ -139,12 +139,17 @@ ln -s lua%{libmajver}.pc %{buildroot}%{_libdir}/pkgconfig/lua.pc
|
||||
%{_libdir}/liblua.a
|
||||
%{_libdir}/liblua.so
|
||||
%{_libdir}/pkgconfig/lua.pc
|
||||
%{_libdir}/pkgconfig/lua%{libmajver}.pc
|
||||
%doc README doc/*.html doc/*.css doc/*.gif doc/*.png
|
||||
|
||||
%changelog
|
||||
* Wed Nov 11 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.4-2mamba
|
||||
- pkgconfig: provide lua5.2.pc as well as lua.pc
|
||||
* Mon Jan 25 2016 Automatic Build System <autodist@mambasoft.it> 5.3.2-2mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jan 25 2016 Automatic Build System <autodist@mambasoft.it> 5.3.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Sep 16 2015 Automatic Build System <autodist@mambasoft.it> 5.3.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Mar 21 2015 Automatic Build System <autodist@mambasoft.it> 5.2.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
Loading…
Reference in New Issue
Block a user