automatic version update by autodist [release 0.7.3-1mamba;Thu Sep 19 2013]
This commit is contained in:
parent
aef577f5d7
commit
b106e12d55
@ -1,2 +1,8 @@
|
|||||||
# ltrace
|
# ltrace
|
||||||
|
|
||||||
|
ltrace is a debugging program which runs a specified command until it exits.
|
||||||
|
While the command is executing, ltrace intercepts and records the dynamic library calls which are called by the executed process and the signals received by that process.
|
||||||
|
It can also intercept and print the system calls executed by the program.
|
||||||
|
The program to be traced need not be recompiled for this, so you can use it on binaries for which you don't have the source handy.
|
||||||
|
You should install ltrace if you need a sysadmin tool for tracking the execution of processes.
|
||||||
|
|
||||||
|
18
ltrace-0.4-makefile.patch
Normal file
18
ltrace-0.4-makefile.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -ru ltrace-0.4/Makefile.in ltrace-0.4-fix/Makefile.in
|
||||||
|
--- ltrace-0.4/Makefile.in 2006-03-05 23:21:07.000000000 +0100
|
||||||
|
+++ ltrace-0.4-fix/Makefile.in 2006-06-29 09:17:18.000000000 +0200
|
||||||
|
@@ -20,10 +20,10 @@
|
||||||
|
LIBS = @LIBS@
|
||||||
|
|
||||||
|
INSTALL = @INSTALL@
|
||||||
|
-INSTALL_FILE = $(INSTALL) -p -o root -g root -m 644
|
||||||
|
-INSTALL_PROGRAM = $(INSTALL) -p -o root -g root -m 755
|
||||||
|
-INSTALL_SCRIPT = $(INSTALL) -p -o root -g root -m 755
|
||||||
|
-INSTALL_DIR = $(INSTALL) -p -d -o root -g root -m 755
|
||||||
|
+INSTALL_FILE = $(INSTALL) -p -m 644
|
||||||
|
+INSTALL_PROGRAM = $(INSTALL) -p -m 755
|
||||||
|
+INSTALL_SCRIPT = $(INSTALL) -p -m 755
|
||||||
|
+INSTALL_DIR = $(INSTALL) -p -d -m 755
|
||||||
|
|
||||||
|
OBJ = ltrace.o options.o elf.o output.o read_config_file.o \
|
||||||
|
execute_program.o wait_for_something.o process_event.o \
|
72
ltrace.spec
Normal file
72
ltrace.spec
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
Name: ltrace
|
||||||
|
Version: 0.7.3
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Tracks runtime library calls in dynamically linked programs
|
||||||
|
Group: Development/Tools
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Aleph0 <aleph0@openmamba.org>
|
||||||
|
URL: http://packages.debian.org/unstable/utils/ltrace
|
||||||
|
Source: git://git.debian.org/git/collab-maint/ltrace.git/%{version}/ltrace-%{version}.tar.bz2
|
||||||
|
Patch: %{name}-0.4-makefile.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: elfutils-libelf-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
ltrace is a debugging program which runs a specified command until it exits.
|
||||||
|
While the command is executing, ltrace intercepts and records the dynamic library calls which are called by the executed process and the signals received by that process.
|
||||||
|
It can also intercept and print the system calls executed by the program.
|
||||||
|
The program to be traced need not be recompiled for this, so you can use it on binaries for which you don't have the source handy.
|
||||||
|
You should install ltrace if you need a sysadmin tool for tracking the execution of processes.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
|
||||||
|
%build
|
||||||
|
./autogen.sh
|
||||||
|
%configure
|
||||||
|
%make CFLAGS="-Wno-unused-local-typedefs"
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
rm -fr %{buildroot}%{_datadir}/doc/ltrace
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/ltrace
|
||||||
|
%{_sysconfdir}/ltrace.conf
|
||||||
|
%{_mandir}/man1/ltrace.1*
|
||||||
|
%{_mandir}/man5/ltrace.conf.5*
|
||||||
|
%doc COPYING
|
||||||
|
#%doc BUGS ChangeLog README TODO
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Sep 19 2013 Automatic Build System <autodist@mambasoft.it> 0.7.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Apr 27 2013 Automatic Build System <autodist@mambasoft.it> 0.7.2-1mamba
|
||||||
|
- update to 0.7.2
|
||||||
|
|
||||||
|
* Sun Jul 26 2009 Automatic Build System <autodist@mambasoft.it> 0.5.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu May 28 2009 Automatic Build System <autodist@mambasoft.it> 0.5.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Feb 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Dec 12 2007 Aleph0 <aleph0@openmamba.org> 0.5-1mamba
|
||||||
|
- update to 0.5
|
||||||
|
|
||||||
|
* Thu Jun 29 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.4-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user