226 lines
7.5 KiB
RPMSpec
226 lines
7.5 KiB
RPMSpec
%define gitver %(echo %version | tr _ -)
|
|
Name: lmms
|
|
Version: 1.2.2
|
|
Release: 1mamba
|
|
Summary: LMMS - Linux MultiMedia Studio
|
|
Group: Graphical Desktop/Applications/Multimedia
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
|
URL: http://lmms.sourceforge.net/
|
|
Source: https://github.com/LMMS/lmms.git/v%{gitver}/lmms-%{version}.tar.bz2
|
|
#http://downloads.sourceforge.net/project/lmms/lmms/%{version}/lmms-%{version}-src.tar.bz2
|
|
Patch0: %{name}-0.4.2-plugin_dir.patch
|
|
Patch1: libfltk-1.1.9-gcc44.patch
|
|
Patch2: lmms-0.4.13-gcc-4.7.patch
|
|
Patch3: lmms-1.0.3-gcc-4.9.0.patch
|
|
Patch4: lmms-1.1.3-gcc-5.3.patch
|
|
Patch5: lmms-1.1.3-gcc-5.3-ladspa.patch
|
|
Patch6: lmms-1.2.0_rc6-x86_64-wine-lib-fix.patch
|
|
License: GPL
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: fluidsynth-devel
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libSDL-devel
|
|
BuildRequires: libXcursor-devel
|
|
BuildRequires: libXext-devel
|
|
BuildRequires: libXfixes-devel
|
|
BuildRequires: libXft-devel
|
|
BuildRequires: libXinerama-devel
|
|
BuildRequires: libalsa-devel
|
|
BuildRequires: libfftw-devel
|
|
BuildRequires: libfltk-devel
|
|
BuildRequires: libfontconfig-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: liblame-devel
|
|
BuildRequires: libogg-devel
|
|
BuildRequires: libportaudio-devel
|
|
BuildRequires: libpulseaudio-devel
|
|
BuildRequires: libqt4-devel
|
|
BuildRequires: libsamplerate-devel
|
|
BuildRequires: libsndfile-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libvorbis-devel
|
|
BuildRequires: libz-devel
|
|
%ifarch %{ix86} x86_64
|
|
BuildRequires: wine-devel
|
|
%endif
|
|
## AUTOBUILDREQ-END
|
|
Requires: libSDL
|
|
Requires: libSDL_sound
|
|
Requires: libalsa
|
|
Requires: libogg
|
|
Requires: libsamplerate
|
|
Requires: libvorbis
|
|
Requires: libsndfile
|
|
Requires: swh-plugins
|
|
|
|
%description
|
|
LMMS aims to be a free alternative to popular (but commercial and closed-source) programs like FruityLoops, Cubase and Logic giving you the ability of producing music with your computer by creating/synthesizing sounds,arranging samples, playing live with keyboard and much more...
|
|
LMMS combines the features of a tracker-/sequencer-program (pattern-/channel-/sample-/song-/effect-management) and those of powerful synthesizers and samplers in a modern, user-friendly and easy to use graphical user-interface.
|
|
|
|
%package devel
|
|
Summary: Devel package for %{name}
|
|
Group: Development/Libraries
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
LMMS aims to be a free alternative to popular (but commercial and closed-source) programs like FruityLoops, Cubase and Logic giving you the ability of producing music with your computer by creating/synthesizing sounds,arranging samples, playing live with keyboard and much more...
|
|
LMMS combines the features of a tracker-/sequencer-program (pattern-/channel-/sample-/song-/effect-management) and those of powerful synthesizers and samplers in a modern, user-friendly and easy to use graphical user-interface.
|
|
This package contains header files needed for development.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n %{name}-%{version}
|
|
#%patch0 -p1
|
|
#cd plugins/zynaddsubfx/fltk
|
|
#%patch1 -p1
|
|
%patch2 -p1
|
|
#%patch3 -p1
|
|
#%patch4 -p1
|
|
%patch5 -p1
|
|
%patch6 -p1
|
|
|
|
%build
|
|
# FIXME:
|
|
# * Stk Mallets: not found, please install libstk0-dev (or similiar) ;if you require the Vibed Instrument
|
|
%cmake -d build \
|
|
-DCMAKE_INSTALL_LIBDIR=%{_lib}
|
|
|
|
#% ifarch x86_64
|
|
# -DWANT_VST_NOWINE:BOOL=ON
|
|
#% endif
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
#mkdir -p %{buildroot}%{_datadir}/applications
|
|
#cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
|
#[Desktop Entry]
|
|
#Encoding=UTF-8
|
|
#Name=LMMS
|
|
#GenericName=Linux MultiMedia Studio
|
|
#Comment=Linux MultiMedia Studio
|
|
#Exec=lmms
|
|
#Icon=/usr/share/lmms/themes/default/icon.png
|
|
#StartupNotify=true
|
|
#Terminal=false
|
|
#Type=Application
|
|
#Categories=Applications;AudioVideo;
|
|
#MimeType=application/x-lmms-project
|
|
#EOF
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/lmms
|
|
%dir %{_libdir}/lmms
|
|
%{_libdir}/lmms/*.so
|
|
%dir %{_libdir}/lmms/ladspa
|
|
%{_libdir}/lmms/ladspa/*.so
|
|
%dir %{_libdir}/lmms/optional
|
|
%{_libdir}/lmms/optional/libcarla_native-plugin.so
|
|
#%{_libdir}/lmms/RemoteVstPlugin
|
|
%{_libdir}/lmms/RemoteZynAddSubFx
|
|
%dir %{_datadir}/lmms
|
|
%{_datadir}/lmms/*
|
|
%{_datadir}/mime/packages/lmms.xml
|
|
%{_datadir}/applications/lmms.desktop
|
|
%{_datadir}/bash-completion/completions/lmms
|
|
%{_datadir}/icons/hicolor/scalable/apps/lmms.svg
|
|
%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-lmms-project.svg
|
|
%{_datadir}/icons/hicolor/*/apps/lmms.png
|
|
%{_datadir}/icons/hicolor/*/mimetypes/application-x-lmms-project.png
|
|
%{_mandir}/man1/lmms.1*
|
|
%doc doc/AUTHORS LICENSE.txt
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/lmms
|
|
%{_includedir}/lmms/*.h
|
|
%{_includedir}/lmms/embed.cpp
|
|
#%doc README TODO
|
|
|
|
%changelog
|
|
* Sat Jan 30 2021 Automatic Build System <autodist@mambasoft.it> 1.2.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 28 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0_rc6-1mamba
|
|
- update to 1.2.0_rc6
|
|
|
|
* Sat Apr 11 2015 Automatic Build System <autodist@mambasoft.it> 1.1.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 18 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-1mamba
|
|
- update to 1.1.0
|
|
|
|
* Tue Sep 23 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.3-1mamba
|
|
- update to 1.0.3
|
|
|
|
* Sun Apr 27 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.0-1mamba
|
|
- update to 1.0.0
|
|
|
|
* Thu Jun 13 2013 Automatic Build System <autodist@mambasoft.it> 0.4.15-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 02 2013 Automatic Build System <autodist@mambasoft.it> 0.4.14-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.13-3mamba
|
|
- added gcc 4.7 build patch
|
|
|
|
* Wed Jun 20 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.13-2mamba
|
|
- rebuilt with wine 1.5.2-3mamba to re-enable VST support
|
|
|
|
* Tue Jun 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.13-1mamba
|
|
- update to 0.4.13
|
|
- added devel and debug packages
|
|
- fixed group
|
|
|
|
* Mon Jul 25 2011 Automatic Build System <autodist@mambasoft.it> 0.4.12-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Mar 23 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.10-2mamba
|
|
- fix LIB_DIR to remove startup error on libtripleoscillator.so path
|
|
|
|
* Thu Mar 10 2011 Automatic Build System <autodist@mambasoft.it> 0.4.10-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Jan 28 2011 Automatic Build System <autodist@mambasoft.it> 0.4.9-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Oct 01 2010 Automatic Build System <autodist@mambasoft.it> 0.4.8-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Aug 09 2010 Automatic Build System <autodist@mambasoft.it> 0.4.7-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Jan 28 2010 Automatic Build System <autodist@mambasoft.it> 0.4.6-1mamba
|
|
- automatic update to 0.4.6 by autodist
|
|
|
|
* Wed Aug 19 2009 Automatic Build System <autodist@mambasoft.it> 0.4.5-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Jul 01 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.4-1mamba
|
|
- update to 0.4.4
|
|
|
|
* Tue Mar 31 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.3-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Feb 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.2-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Jun 06 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.3.2-1mamba
|
|
- package created by autospec
|