rebuilt with current libfluidsynth; specfile fixes [release 1.2.2-2mamba;Sat Jan 18 2025]
This commit is contained in:
parent
9ce860b19b
commit
f358d808f3
@ -1,32 +0,0 @@
|
|||||||
diff -Nru fltk-1.1.9.orig/src/filename_list.cxx fltk-1.1.9/src/filename_list.cxx
|
|
||||||
--- fltk-1.1.9.orig/src/filename_list.cxx 2006-06-09 18:16:34.000000000 +0200
|
|
||||||
+++ fltk-1.1.9/src/filename_list.cxx 2009-07-01 14:25:03.841445929 +0200
|
|
||||||
@@ -67,7 +67,7 @@
|
|
||||||
// The vast majority of UNIX systems want the sort function to have this
|
|
||||||
// prototype, most likely so that it can be passed to qsort without any
|
|
||||||
// changes:
|
|
||||||
- int n = scandir(d, list, 0, (int(*)(const void*,const void*))sort);
|
|
||||||
+ int n = scandir(d, list, 0, (int(*)(const dirent **,const dirent **))sort);
|
|
||||||
#else
|
|
||||||
// This version is when we define our own scandir (WIN32 and perhaps
|
|
||||||
// some Unix systems) and apparently on IRIX:
|
|
||||||
diff -ru fltk-1.1.9.orig/src/fl_set_fonts_xft.cxx fltk-1.1.9/src/fl_set_fonts_xft.cxx
|
|
||||||
--- fltk-1.1.9.orig/src/fl_set_fonts_xft.cxx 2006-10-03 04:35:12.000000000 +0200
|
|
||||||
+++ fltk-1.1.9/src/fl_set_fonts_xft.cxx 2009-07-01 14:28:28.268210527 +0200
|
|
||||||
@@ -253,13 +253,13 @@
|
|
||||||
// So the bit we want is up to the first comma - BUT some strings have
|
|
||||||
// more than one name, separated by, guess what?, a comma...
|
|
||||||
stop = start = first = 0;
|
|
||||||
- stop = strchr((const char *)font, ',');
|
|
||||||
- start = strchr((const char *)font, ':');
|
|
||||||
+ stop = strchr((char *)font, ',');
|
|
||||||
+ start = strchr((char *)font, ':');
|
|
||||||
if ((stop) && (start) && (stop < start))
|
|
||||||
{
|
|
||||||
first = stop + 1; // discard first version of name
|
|
||||||
// find first comma *after* the end of the name
|
|
||||||
- stop = strchr((const char *)start, ',');
|
|
||||||
+ stop = strchr((char *)start, ',');
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nru lmms-0.4.2.orig/CMakeLists.txt lmms-0.4.2/CMakeLists.txt
|
|
||||||
--- lmms-0.4.2.orig/CMakeLists.txt 2008-12-19 17:44:15.000000000 +0100
|
|
||||||
+++ lmms-0.4.2/CMakeLists.txt 2009-02-04 17:11:07.000000000 +0100
|
|
||||||
@@ -415,7 +415,7 @@
|
|
||||||
#
|
|
||||||
# build LMMS-binary
|
|
||||||
#
|
|
||||||
-ADD_DEFINITIONS(-D'LIB_DIR="${CMAKE_INSTALL_PREFIX}/${LIB_DIR}/"' -D'PLUGIN_DIR="${CMAKE_INSTALL_PREFIX}/${LIB_DIR}/lmms/"' ${PULSEAUDIO_DEFINITIONS} ${PORTAUDIO_DEFINITIONS})
|
|
||||||
+ADD_DEFINITIONS(-D'LIB_DIR="${CMAKE_INSTALL_PREFIX}/${LIB_DIR}/"' -D'PLUGIN_DIR="${CMAKE_INSTALL_LIBDIR}/lmms/"' ${PULSEAUDIO_DEFINITIONS} ${PORTAUDIO_DEFINITIONS})
|
|
||||||
|
|
||||||
INCLUDE_DIRECTORIES(${CMAKE_BINARY_DIR} ${CMAKE_BINARY_DIR}/include ${CMAKE_SOURCE_DIR} ${CMAKE_SOURCE_DIR}/include ${SDL_INCLUDE_DIR} ${PORTAUDIO_INCLUDE_DIR} ${PULSEAUDIO_INCLUDE_DIR} ${JACK_INCLUDE_DIRS} ${OGGVORBIS_INCLUDE_DIR} ${SAMPLERATE_INCLUDE_DIRS} ${SNDFILE_INCLUDE_DIRS})
|
|
||||||
LINK_DIRECTORIES(${CMAKE_INSTALL_PREFIX}/lib ${ASOUND_LIBRARY_DIR} ${JACK_LIBRARY_DIRS} ${SAMPLERATE_LIBRARY_DIRS} ${SNDFILE_LIBRARY_DIRS})
|
|
@ -1,47 +0,0 @@
|
|||||||
From ab55b26e4b1521e5401f60a2f618f31579e9cc5c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tobias Doerffel <tobias.doerffel@gmail.com>
|
|
||||||
Date: Sat, 5 Jul 2014 17:46:10 +0200
|
|
||||||
Subject: [PATCH] SWH/BodeShifterCV: fix out-of-bounds array access
|
|
||||||
|
|
||||||
The xcoeffs array only has 100 elements and thus accessing xcoeffs[100]
|
|
||||||
leads to undefined behaviour.
|
|
||||||
---
|
|
||||||
plugins/LadspaEffect/swh/bode_shifter_cv_1432.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
|
||||||
index 41fb4f0..967edf6 100644
|
|
||||||
--- a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
|
||||||
+++ b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
|
||||||
@@ -247,7 +247,7 @@ static void runBodeShifterCV(LADSPA_Handle instance, unsigned long sample_count)
|
|
||||||
/* Perform the Hilbert FIR convolution
|
|
||||||
* (probably FFT would be faster) */
|
|
||||||
hilb = 0.0f;
|
|
||||||
- for (i = 0; i <= NZEROS/2; i++) {
|
|
||||||
+ for (i = 0; i < NZEROS/2; i++) {
|
|
||||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
||||||
--- lmms-1.0.3/plugins/LadspaEffect/swh/surround_encoder_1401.c.orig 2014-09-18 22:46:21.446975318 +0200
|
|
||||||
+++ lmms-1.0.3/plugins/LadspaEffect/swh/surround_encoder_1401.c 2014-09-18 22:50:07.186985543 +0200
|
|
||||||
@@ -228,7 +228,7 @@
|
|
||||||
for (pos = 0; pos < sample_count; pos++) {
|
|
||||||
delay[dptr] = s[pos];
|
|
||||||
hilb = 0.0f;
|
|
||||||
- for (i = 0; i <= NZEROS/2; i++) {
|
|
||||||
+ for (i = 0; i < NZEROS/2; i++) {
|
|
||||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
|
||||||
}
|
|
||||||
dptr = (dptr + 1) & (D_SIZE - 1);
|
|
||||||
@@ -296,7 +296,7 @@
|
|
||||||
for (pos = 0; pos < sample_count; pos++) {
|
|
||||||
delay[dptr] = s[pos];
|
|
||||||
hilb = 0.0f;
|
|
||||||
- for (i = 0; i <= NZEROS/2; i++) {
|
|
||||||
+ for (i = 0; i < NZEROS/2; i++) {
|
|
||||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
|
||||||
}
|
|
||||||
dptr = (dptr + 1) & (D_SIZE - 1);
|
|
@ -1,27 +0,0 @@
|
|||||||
From 317b2f02a829f694a66c760fc6de7df1db99b006 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tobias Doerffel <tobias.doerffel@gmail.com>
|
|
||||||
Date: Mon, 16 Feb 2015 18:22:49 +0100
|
|
||||||
Subject: [PATCH] AutomatableModel: fix wrong comparison logic
|
|
||||||
|
|
||||||
We must not negate the float but instead test for inequality in order to
|
|
||||||
determine whether the linked model has to be updated.
|
|
||||||
|
|
||||||
Closes #1761.
|
|
||||||
---
|
|
||||||
src/core/AutomatableModel.cpp | 3 +--
|
|
||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/core/AutomatableModel.cpp b/src/core/AutomatableModel.cpp
|
|
||||||
index 6c7501c..bf56285 100644
|
|
||||||
--- a/src/core/AutomatableModel.cpp
|
|
||||||
+++ b/src/core/AutomatableModel.cpp
|
|
||||||
@@ -318,8 +318,7 @@ void AutomatableModel::setAutomatedValue( const float value )
|
|
||||||
it != m_linkedModels.end(); ++it )
|
|
||||||
{
|
|
||||||
if( (*it)->m_setValueDepth < 1 &&
|
|
||||||
- !(*it)->fittedValue( m_value ) !=
|
|
||||||
- (*it)->m_value )
|
|
||||||
+ (*it)->fittedValue( m_value ) != (*it)->m_value )
|
|
||||||
{
|
|
||||||
(*it)->setAutomatedValue( value );
|
|
||||||
}
|
|
59
lmms.spec
59
lmms.spec
@ -1,60 +1,48 @@
|
|||||||
%define gitver %(echo %version | tr _ -)
|
%define gitver %(echo %version | tr _ -)
|
||||||
Name: lmms
|
Name: lmms
|
||||||
Version: 1.2.2
|
Version: 1.2.2
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: LMMS - Linux MultiMedia Studio
|
Summary: LMMS - Linux MultiMedia Studio
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://lmms.sourceforge.net/
|
URL: https://sourceforge.net/projects/lmms/
|
||||||
Source: https://github.com/LMMS/lmms.git/v%{gitver}/lmms-%{version}.tar.bz2
|
Source: https://github.com/LMMS/lmms.git/v%{gitver}/lmms-%{version}.tar.bz2
|
||||||
#http://downloads.sourceforge.net/project/lmms/lmms/%{version}/lmms-%{version}-src.tar.bz2
|
Patch0: lmms-0.4.13-gcc-4.7.patch
|
||||||
Patch0: %{name}-0.4.2-plugin_dir.patch
|
Patch1: lmms-1.1.3-gcc-5.3-ladspa.patch
|
||||||
Patch1: libfltk-1.1.9-gcc44.patch
|
Patch2: lmms-1.2.0_rc6-x86_64-wine-lib-fix.patch
|
||||||
Patch2: lmms-0.4.13-gcc-4.7.patch
|
|
||||||
Patch3: lmms-1.0.3-gcc-4.9.0.patch
|
|
||||||
Patch4: lmms-1.1.3-gcc-5.3.patch
|
|
||||||
Patch5: lmms-1.1.3-gcc-5.3-ladspa.patch
|
|
||||||
Patch6: lmms-1.2.0_rc6-x86_64-wine-lib-fix.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: fluidsynth-devel
|
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libSDL-devel
|
BuildRequires: libQtCore
|
||||||
|
BuildRequires: libQtGui
|
||||||
|
BuildRequires: libQtXml
|
||||||
BuildRequires: libXcursor-devel
|
BuildRequires: libXcursor-devel
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
BuildRequires: libXfixes-devel
|
BuildRequires: libXfixes-devel
|
||||||
BuildRequires: libXft-devel
|
BuildRequires: libXft-devel
|
||||||
BuildRequires: libXinerama-devel
|
BuildRequires: libXinerama-devel
|
||||||
|
BuildRequires: libXrender-devel
|
||||||
BuildRequires: libalsa-devel
|
BuildRequires: libalsa-devel
|
||||||
BuildRequires: libfftw-devel
|
BuildRequires: libfftw-devel
|
||||||
BuildRequires: libfltk-devel
|
BuildRequires: libfltk-devel
|
||||||
|
BuildRequires: libfluidsynth-devel
|
||||||
BuildRequires: libfontconfig-devel
|
BuildRequires: libfontconfig-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: liblame-devel
|
BuildRequires: liblame-devel
|
||||||
BuildRequires: libogg-devel
|
BuildRequires: libogg-devel
|
||||||
BuildRequires: libportaudio-devel
|
BuildRequires: libportaudio-devel
|
||||||
BuildRequires: libpulseaudio-devel
|
BuildRequires: libpulseaudio-devel
|
||||||
BuildRequires: libqt4-devel
|
|
||||||
BuildRequires: libsamplerate-devel
|
BuildRequires: libsamplerate-devel
|
||||||
|
BuildRequires: libsdl12-compat-devel
|
||||||
BuildRequires: libsndfile-devel
|
BuildRequires: libsndfile-devel
|
||||||
|
BuildRequires: libsndio-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libvorbis-devel
|
BuildRequires: libvorbis-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
%ifarch %{ix86} x86_64
|
|
||||||
BuildRequires: wine-devel
|
|
||||||
%endif
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
Requires: libSDL
|
Recommends: swh-plugins
|
||||||
Requires: libSDL_sound
|
|
||||||
Requires: libalsa
|
|
||||||
Requires: libogg
|
|
||||||
Requires: libsamplerate
|
|
||||||
Requires: libvorbis
|
|
||||||
Requires: libsndfile
|
|
||||||
Requires: swh-plugins
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
LMMS aims to be a free alternative to popular (but commercial and closed-source) programs like FruityLoops, Cubase and Logic giving you the ability of producing music with your computer by creating/synthesizing sounds,arranging samples, playing live with keyboard and much more...
|
LMMS aims to be a free alternative to popular (but commercial and closed-source) programs like FruityLoops, Cubase and Logic giving you the ability of producing music with your computer by creating/synthesizing sounds,arranging samples, playing live with keyboard and much more...
|
||||||
@ -70,18 +58,11 @@ LMMS aims to be a free alternative to popular (but commercial and closed-source)
|
|||||||
LMMS combines the features of a tracker-/sequencer-program (pattern-/channel-/sample-/song-/effect-management) and those of powerful synthesizers and samplers in a modern, user-friendly and easy to use graphical user-interface.
|
LMMS combines the features of a tracker-/sequencer-program (pattern-/channel-/sample-/song-/effect-management) and those of powerful synthesizers and samplers in a modern, user-friendly and easy to use graphical user-interface.
|
||||||
This package contains header files needed for development.
|
This package contains header files needed for development.
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q
|
||||||
#%patch0 -p1
|
%patch 0 -p1
|
||||||
#cd plugins/zynaddsubfx/fltk
|
%patch 1 -p1
|
||||||
#%patch1 -p1
|
%patch 2 -p1
|
||||||
%patch2 -p1
|
|
||||||
#%patch3 -p1
|
|
||||||
#%patch4 -p1
|
|
||||||
%patch5 -p1
|
|
||||||
%patch6 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# FIXME:
|
# FIXME:
|
||||||
@ -131,7 +112,6 @@ This package contains header files needed for development.
|
|||||||
%{_libdir}/lmms/ladspa/*.so
|
%{_libdir}/lmms/ladspa/*.so
|
||||||
%dir %{_libdir}/lmms/optional
|
%dir %{_libdir}/lmms/optional
|
||||||
%{_libdir}/lmms/optional/libcarla_native-plugin.so
|
%{_libdir}/lmms/optional/libcarla_native-plugin.so
|
||||||
#%{_libdir}/lmms/RemoteVstPlugin
|
|
||||||
%{_libdir}/lmms/RemoteZynAddSubFx
|
%{_libdir}/lmms/RemoteZynAddSubFx
|
||||||
%dir %{_datadir}/lmms
|
%dir %{_datadir}/lmms
|
||||||
%{_datadir}/lmms/*
|
%{_datadir}/lmms/*
|
||||||
@ -153,6 +133,9 @@ This package contains header files needed for development.
|
|||||||
#%doc README TODO
|
#%doc README TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 18 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.2-2mamba
|
||||||
|
- rebuilt with current libfluidsynth; specfile fixes
|
||||||
|
|
||||||
* Sat Jan 30 2021 Automatic Build System <autodist@mambasoft.it> 1.2.2-1mamba
|
* Sat Jan 30 2021 Automatic Build System <autodist@mambasoft.it> 1.2.2-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user