update to 1.2.0_rc6 [release 1.2.0_rc6-1mamba;Tue Aug 28 2018]
This commit is contained in:
parent
5195e06b89
commit
e5b46d8a3e
94
lmms-1.1.3-gcc-5.3-ladspa.patch
Normal file
94
lmms-1.1.3-gcc-5.3-ladspa.patch
Normal file
@ -0,0 +1,94 @@
|
|||||||
|
--- lmms-1.1.3/plugins/LadspaEffect/swh/ladspa-util.h.orig 2016-04-22 20:26:05.662541545 +0200
|
||||||
|
+++ lmms-1.1.3/plugins/LadspaEffect/swh/ladspa-util.h 2016-04-22 20:26:52.048512562 +0200
|
||||||
|
@@ -59,7 +59,7 @@
|
||||||
|
// Denormalise floats, only actually needed for PIII and recent PowerPC
|
||||||
|
//#define FLUSH_TO_ZERO(fv) (((*(unsigned int*)&(fv))&0x7f800000)==0)?0.0f:(fv)
|
||||||
|
|
||||||
|
-static inline float flush_to_zero(float f)
|
||||||
|
+inline float flush_to_zero(float f)
|
||||||
|
{
|
||||||
|
ls_pcast32 v;
|
||||||
|
|
||||||
|
@@ -70,7 +70,7 @@
|
||||||
|
return (v.i & 0x7f800000) < 0x08000000 ? 0.0f : f;
|
||||||
|
}
|
||||||
|
|
||||||
|
-static inline void round_to_zero(volatile float *f)
|
||||||
|
+inline void round_to_zero(volatile float *f)
|
||||||
|
{
|
||||||
|
*f += 1e-18;
|
||||||
|
*f -= 1e-18;
|
||||||
|
@@ -78,7 +78,7 @@
|
||||||
|
|
||||||
|
/* A set of branchless clipping operations from Laurent de Soras */
|
||||||
|
|
||||||
|
-static inline float f_max(float x, float a)
|
||||||
|
+inline float f_max(float x, float a)
|
||||||
|
{
|
||||||
|
x -= a;
|
||||||
|
x += fabs(x);
|
||||||
|
@@ -88,7 +88,7 @@
|
||||||
|
return x;
|
||||||
|
}
|
||||||
|
|
||||||
|
-static inline float f_min(float x, float b)
|
||||||
|
+inline float f_min(float x, float b)
|
||||||
|
{
|
||||||
|
x = b - x;
|
||||||
|
x += fabs(x);
|
||||||
|
@@ -98,7 +98,7 @@
|
||||||
|
return x;
|
||||||
|
}
|
||||||
|
|
||||||
|
-static inline float f_clamp(float x, float a, float b)
|
||||||
|
+inline float f_clamp(float x, float a, float b)
|
||||||
|
{
|
||||||
|
const float x1 = fabs(x - a);
|
||||||
|
const float x2 = fabs(x - b);
|
||||||
|
@@ -129,7 +129,7 @@
|
||||||
|
#define LIN_INTERP(f,a,b) ((a) + (f) * ((b) - (a)))
|
||||||
|
|
||||||
|
// Cubic interpolation function
|
||||||
|
-static inline float cube_interp(const float fr, const float inm1, const float
|
||||||
|
+inline float cube_interp(const float fr, const float inm1, const float
|
||||||
|
in, const float inp1, const float inp2)
|
||||||
|
{
|
||||||
|
return in + 0.5f * fr * (inp1 - inm1 +
|
||||||
|
@@ -139,7 +139,7 @@
|
||||||
|
|
||||||
|
/* fast sin^2 aproxiamtion, adapted from jan AT rpgfan's posting to the
|
||||||
|
* music-dsp list */
|
||||||
|
-static inline float f_sin_sq(float angle)
|
||||||
|
+inline float f_sin_sq(float angle)
|
||||||
|
{
|
||||||
|
const float asqr = angle * angle;
|
||||||
|
float result = -2.39e-08f;
|
||||||
|
@@ -166,7 +166,7 @@
|
||||||
|
#else
|
||||||
|
|
||||||
|
// Round float to int using IEEE int* hack
|
||||||
|
-static inline int f_round(float f)
|
||||||
|
+inline int f_round(float f)
|
||||||
|
{
|
||||||
|
ls_pcast32 p;
|
||||||
|
|
||||||
|
@@ -179,7 +179,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
// Truncate float to int
|
||||||
|
-static inline int f_trunc(float f)
|
||||||
|
+inline int f_trunc(float f)
|
||||||
|
{
|
||||||
|
return f_round(floorf(f));
|
||||||
|
}
|
||||||
|
--- lmms-1.1.3/plugins/LadspaEffect/swh/imp_1199.c.orig 2016-04-22 20:36:17.446165618 +0200
|
||||||
|
+++ lmms-1.1.3/plugins/LadspaEffect/swh/imp_1199.c 2016-04-22 20:37:09.784133888 +0200
|
||||||
|
@@ -70,7 +70,7 @@
|
||||||
|
fft_plan plan_rc[IMPULSES],
|
||||||
|
plan_cr[IMPULSES];
|
||||||
|
|
||||||
|
-static fftw_real *real_in, *real_out, *comp_in, *comp_out;
|
||||||
|
+fftw_real *real_in, *real_out, *comp_in, *comp_out;
|
||||||
|
|
||||||
|
unsigned int fft_length[IMPULSES];
|
||||||
|
|
27
lmms-1.1.3-gcc-5.3.patch
Normal file
27
lmms-1.1.3-gcc-5.3.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 317b2f02a829f694a66c760fc6de7df1db99b006 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tobias Doerffel <tobias.doerffel@gmail.com>
|
||||||
|
Date: Mon, 16 Feb 2015 18:22:49 +0100
|
||||||
|
Subject: [PATCH] AutomatableModel: fix wrong comparison logic
|
||||||
|
|
||||||
|
We must not negate the float but instead test for inequality in order to
|
||||||
|
determine whether the linked model has to be updated.
|
||||||
|
|
||||||
|
Closes #1761.
|
||||||
|
---
|
||||||
|
src/core/AutomatableModel.cpp | 3 +--
|
||||||
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/core/AutomatableModel.cpp b/src/core/AutomatableModel.cpp
|
||||||
|
index 6c7501c..bf56285 100644
|
||||||
|
--- a/src/core/AutomatableModel.cpp
|
||||||
|
+++ b/src/core/AutomatableModel.cpp
|
||||||
|
@@ -318,8 +318,7 @@ void AutomatableModel::setAutomatedValue( const float value )
|
||||||
|
it != m_linkedModels.end(); ++it )
|
||||||
|
{
|
||||||
|
if( (*it)->m_setValueDepth < 1 &&
|
||||||
|
- !(*it)->fittedValue( m_value ) !=
|
||||||
|
- (*it)->m_value )
|
||||||
|
+ (*it)->fittedValue( m_value ) != (*it)->m_value )
|
||||||
|
{
|
||||||
|
(*it)->setAutomatedValue( value );
|
||||||
|
}
|
10
lmms-1.2.0_rc6-x86_64-wine-lib-fix.patch
Normal file
10
lmms-1.2.0_rc6-x86_64-wine-lib-fix.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- lmms-1.2.0_rc6/cmake/modules/FindWine.cmake.orig 2018-08-28 20:07:41.598331970 +0200
|
||||||
|
+++ lmms-1.2.0_rc6/cmake/modules/FindWine.cmake 2018-08-28 20:07:47.639362591 +0200
|
||||||
|
@@ -29,7 +29,6 @@
|
||||||
|
# Gentoo systems
|
||||||
|
STRING(REPLACE "/lib/wine-" "/lib32/wine-" FLAG "${FLAG}")
|
||||||
|
# WineHQ (/opt/wine-stable, /opt/wine-devel, /opt/wine-staging)
|
||||||
|
- STRING(REPLACE "/lib64/wine/" "/lib/wine/" FLAG "${FLAG}")
|
||||||
|
|
||||||
|
STRING(REGEX REPLACE "/wine/libwinecrt0.a.*" "" WINE_LIBRARY_FIX "${FLAG}")
|
||||||
|
SET(WINE_LIBRARY_FIX "${WINE_LIBRARY_FIX}/")
|
69
lmms.spec
69
lmms.spec
@ -1,5 +1,6 @@
|
|||||||
|
%define gitver %(echo %version | tr _ -)
|
||||||
Name: lmms
|
Name: lmms
|
||||||
Version: 1.0.3
|
Version: 1.2.0_rc6
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: LMMS - Linux MultiMedia Studio
|
Summary: LMMS - Linux MultiMedia Studio
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
@ -7,45 +8,45 @@ Vendor: openmamba
|
|||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
||||||
URL: http://lmms.sourceforge.net/
|
URL: http://lmms.sourceforge.net/
|
||||||
Source: http://downloads.sourceforge.net/project/lmms/lmms/%{version}/lmms-%{version}-src.tar.bz2
|
Source: https://github.com/LMMS/lmms.git/v%{gitver}/lmms-%{version}.tar.bz2
|
||||||
|
#http://downloads.sourceforge.net/project/lmms/lmms/%{version}/lmms-%{version}-src.tar.bz2
|
||||||
Patch0: %{name}-0.4.2-plugin_dir.patch
|
Patch0: %{name}-0.4.2-plugin_dir.patch
|
||||||
Patch1: libfltk-1.1.9-gcc44.patch
|
Patch1: libfltk-1.1.9-gcc44.patch
|
||||||
Patch2: lmms-0.4.13-gcc-4.7.patch
|
Patch2: lmms-0.4.13-gcc-4.7.patch
|
||||||
Patch3: lmms-1.0.3-gcc-4.9.0.patch
|
Patch3: lmms-1.0.3-gcc-4.9.0.patch
|
||||||
|
Patch4: lmms-1.1.3-gcc-5.3.patch
|
||||||
|
Patch5: lmms-1.1.3-gcc-5.3-ladspa.patch
|
||||||
|
Patch6: lmms-1.2.0_rc6-x86_64-wine-lib-fix.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: fluidsynth-devel
|
BuildRequires: fluidsynth-devel
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libSDL-devel
|
||||||
|
BuildRequires: libXcursor-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libXfixes-devel
|
||||||
|
BuildRequires: libXft-devel
|
||||||
|
BuildRequires: libXinerama-devel
|
||||||
BuildRequires: libalsa-devel
|
BuildRequires: libalsa-devel
|
||||||
BuildRequires: libfftw-devel
|
BuildRequires: libfftw-devel
|
||||||
|
BuildRequires: libfltk-devel
|
||||||
BuildRequires: libfontconfig-devel
|
BuildRequires: libfontconfig-devel
|
||||||
BuildRequires: libfreetype-devel
|
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libICE-devel
|
BuildRequires: liblame-devel
|
||||||
BuildRequires: libjack-devel
|
|
||||||
BuildRequires: libogg-devel
|
BuildRequires: libogg-devel
|
||||||
BuildRequires: libportaudio-devel
|
BuildRequires: libportaudio-devel
|
||||||
BuildRequires: libpulseaudio-devel
|
BuildRequires: libpulseaudio-devel
|
||||||
BuildRequires: libqt4-devel
|
BuildRequires: libqt4-devel
|
||||||
BuildRequires: libsamplerate-devel
|
BuildRequires: libsamplerate-devel
|
||||||
BuildRequires: libSDL-devel
|
|
||||||
BuildRequires: libSDL_sound-devel
|
|
||||||
BuildRequires: libSM-devel
|
|
||||||
BuildRequires: libsndfile-devel
|
BuildRequires: libsndfile-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libvorbis-devel
|
BuildRequires: libvorbis-devel
|
||||||
BuildRequires: libX11-devel
|
|
||||||
BuildRequires: libXext-devel
|
|
||||||
BuildRequires: libXft-devel
|
|
||||||
BuildRequires: libXinerama-devel
|
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: swh-plugins
|
|
||||||
%ifarch %{ix86} x86_64
|
%ifarch %{ix86} x86_64
|
||||||
BuildRequires: wine-devel
|
BuildRequires: wine-devel
|
||||||
%endif
|
%endif
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libfltk-devel
|
|
||||||
Requires: libSDL
|
Requires: libSDL
|
||||||
Requires: libSDL_sound
|
Requires: libSDL_sound
|
||||||
Requires: libalsa
|
Requires: libalsa
|
||||||
@ -73,27 +74,31 @@ This package contains header files needed for development.
|
|||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n %{name}-%{version}
|
||||||
#%patch0 -p1
|
#%patch0 -p1
|
||||||
#cd plugins/zynaddsubfx/fltk
|
#cd plugins/zynaddsubfx/fltk
|
||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
#%patch3 -p1
|
||||||
|
#%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
%patch6 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# FIXME:
|
# FIXME:
|
||||||
# * Stk Mallets: not found, please install libstk0-dev (or similiar) ;if you require the Vibed Instrument
|
# * Stk Mallets: not found, please install libstk0-dev (or similiar) ;if you require the Vibed Instrument
|
||||||
%cmake \
|
%cmake -d build \
|
||||||
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
|
-DCMAKE_INSTALL_LIBDIR=%{_lib}
|
||||||
%ifarch 86_64
|
|
||||||
-DWANT_VST_NOWINE:BOOL=ON
|
#% ifarch x86_64
|
||||||
%endif
|
# -DWANT_VST_NOWINE:BOOL=ON
|
||||||
|
#% endif
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall
|
%makeinstall -C build
|
||||||
|
|
||||||
#mkdir -p %{buildroot}%{_datadir}/applications
|
#mkdir -p %{buildroot}%{_datadir}/applications
|
||||||
#cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
#cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
||||||
@ -123,26 +128,34 @@ This package contains header files needed for development.
|
|||||||
%{_bindir}/lmms
|
%{_bindir}/lmms
|
||||||
%{_libdir}/lmms/*.so
|
%{_libdir}/lmms/*.so
|
||||||
%{_libdir}/lmms/ladspa/*.so
|
%{_libdir}/lmms/ladspa/*.so
|
||||||
%ifarch %{ix86}
|
|
||||||
%{_libdir}/lmms/RemoteVstPlugin
|
%{_libdir}/lmms/RemoteVstPlugin
|
||||||
%endif
|
|
||||||
%{_libdir}/lmms/RemoteZynAddSubFx
|
%{_libdir}/lmms/RemoteZynAddSubFx
|
||||||
%{_datadir}/lmms/*
|
%{_datadir}/lmms/*
|
||||||
%{_datadir}/menu/lmms
|
%{_datadir}/icons/hicolor/scalable/apps/lmms.svg
|
||||||
|
%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-lmms-project.svg
|
||||||
%{_datadir}/mime/packages/lmms.xml
|
%{_datadir}/mime/packages/lmms.xml
|
||||||
%{_datadir}/applications/lmms.desktop
|
%{_datadir}/applications/lmms.desktop
|
||||||
%{_datadir}/pixmaps/lmms.png
|
#%{_datadir}/pixmaps/lmms.png
|
||||||
%{_mandir}/man1/lmms.1*
|
%{_mandir}/man1/lmms.1*
|
||||||
%doc AUTHORS COPYING
|
%doc doc/AUTHORS LICENSE.txt
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_includedir}/lmms
|
%dir %{_includedir}/lmms
|
||||||
%{_includedir}/lmms/*.h
|
%{_includedir}/lmms/*.h
|
||||||
%{_includedir}/lmms/embed.cpp
|
%{_includedir}/lmms/embed.cpp
|
||||||
%doc README TODO
|
#%doc README TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 28 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0_rc6-1mamba
|
||||||
|
- update to 1.2.0_rc6
|
||||||
|
|
||||||
|
* Sat Apr 11 2015 Automatic Build System <autodist@mambasoft.it> 1.1.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Jan 18 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-1mamba
|
||||||
|
- update to 1.1.0
|
||||||
|
|
||||||
* Tue Sep 23 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.3-1mamba
|
* Tue Sep 23 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.3-1mamba
|
||||||
- update to 1.0.3
|
- update to 1.0.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user