update to 1.0.3 [release 1.0.3-1mamba;Tue Sep 23 2014]
This commit is contained in:
parent
2add3437d6
commit
5195e06b89
47
lmms-1.0.3-gcc-4.9.0.patch
Normal file
47
lmms-1.0.3-gcc-4.9.0.patch
Normal file
@ -0,0 +1,47 @@
|
||||
From ab55b26e4b1521e5401f60a2f618f31579e9cc5c Mon Sep 17 00:00:00 2001
|
||||
From: Tobias Doerffel <tobias.doerffel@gmail.com>
|
||||
Date: Sat, 5 Jul 2014 17:46:10 +0200
|
||||
Subject: [PATCH] SWH/BodeShifterCV: fix out-of-bounds array access
|
||||
|
||||
The xcoeffs array only has 100 elements and thus accessing xcoeffs[100]
|
||||
leads to undefined behaviour.
|
||||
---
|
||||
plugins/LadspaEffect/swh/bode_shifter_cv_1432.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
||||
index 41fb4f0..967edf6 100644
|
||||
--- a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
||||
+++ b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
||||
@@ -247,7 +247,7 @@ static void runBodeShifterCV(LADSPA_Handle instance, unsigned long sample_count)
|
||||
/* Perform the Hilbert FIR convolution
|
||||
* (probably FFT would be faster) */
|
||||
hilb = 0.0f;
|
||||
- for (i = 0; i <= NZEROS/2; i++) {
|
||||
+ for (i = 0; i < NZEROS/2; i++) {
|
||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
||||
}
|
||||
|
||||
--
|
||||
1.9.3
|
||||
|
||||
--- lmms-1.0.3/plugins/LadspaEffect/swh/surround_encoder_1401.c.orig 2014-09-18 22:46:21.446975318 +0200
|
||||
+++ lmms-1.0.3/plugins/LadspaEffect/swh/surround_encoder_1401.c 2014-09-18 22:50:07.186985543 +0200
|
||||
@@ -228,7 +228,7 @@
|
||||
for (pos = 0; pos < sample_count; pos++) {
|
||||
delay[dptr] = s[pos];
|
||||
hilb = 0.0f;
|
||||
- for (i = 0; i <= NZEROS/2; i++) {
|
||||
+ for (i = 0; i < NZEROS/2; i++) {
|
||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
||||
}
|
||||
dptr = (dptr + 1) & (D_SIZE - 1);
|
||||
@@ -296,7 +296,7 @@
|
||||
for (pos = 0; pos < sample_count; pos++) {
|
||||
delay[dptr] = s[pos];
|
||||
hilb = 0.0f;
|
||||
- for (i = 0; i <= NZEROS/2; i++) {
|
||||
+ for (i = 0; i < NZEROS/2; i++) {
|
||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
||||
}
|
||||
dptr = (dptr + 1) & (D_SIZE - 1);
|
23
lmms.spec
23
lmms.spec
@ -1,5 +1,5 @@
|
||||
Name: lmms
|
||||
Version: 0.4.15
|
||||
Version: 1.0.3
|
||||
Release: 1mamba
|
||||
Summary: LMMS - Linux MultiMedia Studio
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
@ -7,10 +7,11 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
||||
URL: http://lmms.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/lmms/lmms-%{version}.tar.bz2
|
||||
Source: http://downloads.sourceforge.net/project/lmms/lmms/%{version}/lmms-%{version}-src.tar.bz2
|
||||
Patch0: %{name}-0.4.2-plugin_dir.patch
|
||||
Patch1: libfltk-1.1.9-gcc44.patch
|
||||
Patch2: lmms-0.4.13-gcc-4.7.patch
|
||||
Patch3: lmms-1.0.3-gcc-4.9.0.patch
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
@ -44,9 +45,7 @@ BuildRequires: swh-plugins
|
||||
BuildRequires: wine-devel
|
||||
%endif
|
||||
## AUTOBUILDREQ-END
|
||||
%ifarch %{ix86} x86_64
|
||||
BuildRequires: wine-devel >= 1.5.2-3mamba
|
||||
%endif
|
||||
BuildRequires: libfltk-devel
|
||||
Requires: libSDL
|
||||
Requires: libSDL_sound
|
||||
Requires: libalsa
|
||||
@ -79,12 +78,16 @@ This package contains header files needed for development.
|
||||
#cd plugins/zynaddsubfx/fltk
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
# FIXME:
|
||||
# * Stk Mallets: not found, please install libstk0-dev (or similiar) ;if you require the Vibed Instrument
|
||||
%cmake \
|
||||
-DCMAKE_INSTALL_LIBDIR=%{_lib}
|
||||
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
|
||||
%ifarch 86_64
|
||||
-DWANT_VST_NOWINE:BOOL=ON
|
||||
%endif
|
||||
|
||||
%make
|
||||
|
||||
@ -129,7 +132,7 @@ This package contains header files needed for development.
|
||||
%{_datadir}/mime/packages/lmms.xml
|
||||
%{_datadir}/applications/lmms.desktop
|
||||
%{_datadir}/pixmaps/lmms.png
|
||||
%{_mandir}/man1/lmms.1.gz
|
||||
%{_mandir}/man1/lmms.1*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
@ -140,6 +143,12 @@ This package contains header files needed for development.
|
||||
%doc README TODO
|
||||
|
||||
%changelog
|
||||
* Tue Sep 23 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.3-1mamba
|
||||
- update to 1.0.3
|
||||
|
||||
* Sun Apr 27 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.0-1mamba
|
||||
- update to 1.0.0
|
||||
|
||||
* Thu Jun 13 2013 Automatic Build System <autodist@mambasoft.it> 0.4.15-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user