automatic version update by autodist [release 3.3.5-1mamba;Sun Feb 02 2014]
This commit is contained in:
parent
2ebd7206d2
commit
0e56c6bfa6
@ -1,2 +1,4 @@
|
||||
# lm_sensors
|
||||
|
||||
lm_sensors provides tools for monitoring the hardware health of Linux systems containing hardware health monitoring hardware such as the LM78 and LM75.
|
||||
|
||||
|
13
lm_sensors-3.3.1-kernel-3.0.patch
Normal file
13
lm_sensors-3.3.1-kernel-3.0.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -Nru lm_sensors-3.3.1.orig/prog/detect/sensors-detect lm_sensors-3.3.1/prog/detect/sensors-detect
|
||||
--- lm_sensors-3.3.1.orig/prog/detect/sensors-detect 2011-07-10 21:22:53.000000000 +0200
|
||||
+++ lm_sensors-3.3.1/prog/detect/sensors-detect 2012-01-06 16:41:53.139801191 +0100
|
||||
@@ -2472,7 +2472,8 @@
|
||||
|
||||
sub initialize_kernel_version
|
||||
{
|
||||
- `uname -r` =~ /(\d+)\.(\d+)\.(\d+)(.*)/;
|
||||
+ #Third decimal only for point releases starting with 3.0
|
||||
+ `uname -r` =~ /(\d+)\.(\d+)(\.(\d+))?(.*)/;
|
||||
@kernel_version = ($1, $2, $3, $4);
|
||||
chomp($kernel_arch = `uname -m`);
|
||||
|
177
lm_sensors.spec
Normal file
177
lm_sensors.spec
Normal file
@ -0,0 +1,177 @@
|
||||
Name: lm_sensors
|
||||
Version: 3.3.5
|
||||
Release: 1mamba
|
||||
Summary: Tools for monitoring the hardware health of Linux systems
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.lm-sensors.org/
|
||||
Source: http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-%{version}.tar.bz2
|
||||
Patch: %{name}-3.3.1-kernel-3.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: perl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libsysfs-devel >= 2.0.0
|
||||
BuildRequires: flex
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||
|
||||
%description
|
||||
lm_sensors provides tools for monitoring the hardware health of Linux systems containing hardware health monitoring hardware such as the LM78 and LM75.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{version}
|
||||
Conflicts: lm_sensors2-devel
|
||||
|
||||
%description devel
|
||||
lm_sensors provides tools for monitoring the hardware health of Linux systems containing hardware health monitoring hardware such as the LM78 and LM75.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%make user PREFIX=%{_prefix} MANDIR=%{_mandir} LIBDIR=%{_libdir}
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
make user_install MANDIR=%{_mandir} PREFIX=%{_prefix} DESTDIR=%{buildroot} LIBDIR=%{_libdir}
|
||||
|
||||
install -D -m 0755 prog/init/fancontrol.init %{buildroot}%{_initrddir}/fancontrol
|
||||
install -D -m 0755 prog/init/lm_sensors.init %{buildroot}%{_initrddir}/lm_sensors
|
||||
#install -D -m 0755 prog/init/sensord.init %{buildroot}%{_initrddir}/sensord
|
||||
|
||||
install -d %{buildroot}%{_sysconfdir}/sysconfig
|
||||
> %{buildroot}%{_sysconfdir}/sysconfig/lm_sensors
|
||||
|
||||
sed -i "s|/usr/local|/usr|" \
|
||||
%{buildroot}%{_initrddir}/fancontrol \
|
||||
%{buildroot}%{_initrddir}/lm_sensors
|
||||
|
||||
# remove installed kernel headers that will cause a conflict
|
||||
rm -f %{buildroot}%{_includedir}/linux/*.h
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
%ifnarch arm
|
||||
# FIXME: produces a system crash on ARM build platform, disable until better tests are done
|
||||
if [ $1 -ge 1 ]; then
|
||||
# new install or upgrade
|
||||
[ -e /proc/mounts ] && /usr/sbin/sensors-detect >/dev/null << _EOF
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
_EOF
|
||||
fi
|
||||
%endif
|
||||
exit 0
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*
|
||||
%{_sbindir}/*
|
||||
%config(noreplace) %{_sysconfdir}/sensors3.conf
|
||||
%ghost %{_sysconfdir}/sysconfig/lm_sensors
|
||||
%{_initrddir}/*
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man5/*
|
||||
%{_mandir}/man8/*
|
||||
%{_libdir}/*.so.*
|
||||
%doc CHANGES CONTRIBUTORS COPYING README
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/*.a
|
||||
%dir %{_includedir}/sensors
|
||||
%{_includedir}/sensors/*.h
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Sun Feb 02 2014 Automatic Build System <autodist@mambasoft.it> 3.3.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed May 29 2013 Automatic Build System <autodist@mambasoft.it> 3.3.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Nov 12 2012 Automatic Build System <autodist@mambasoft.it> 3.3.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jul 25 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3.2-1mamba
|
||||
- update to 3.3.2
|
||||
|
||||
* Fri Jan 06 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3.1-2mamba
|
||||
- added patch for kernel >=3.0
|
||||
|
||||
* Mon Jul 25 2011 Automatic Build System <autodist@mambasoft.it> 3.3.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Mar 29 2011 Automatic Build System <autodist@mambasoft.it> 3.3.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Oct 16 2010 Automatic Build System <autodist@mambasoft.it> 3.2.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Feb 09 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.2-2mamba
|
||||
- post script: specify full path of sensors-detect to fix installation with makedist
|
||||
|
||||
* Fri Feb 05 2010 Automatic Build System <autodist@mambasoft.it> 3.1.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jun 29 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.1-1mamba
|
||||
- update to 3.1.1
|
||||
|
||||
* Sun Mar 08 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jan 05 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.3-1mamba
|
||||
- update to 3.0.3
|
||||
|
||||
* Tue May 29 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.3-1mamba
|
||||
- update to 2.10.3
|
||||
|
||||
* Wed Jun 28 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.0-1qilnx
|
||||
- update to version 2.10.0 by autospec
|
||||
|
||||
* Tue Dec 20 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.9.2-2qilnx
|
||||
- sensors-detect requires /proc/mounts
|
||||
- added %%ghost file %{_sysconfdir}/sysconfig/lm_sensors
|
||||
|
||||
* Tue Sep 27 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.2-1qilnx
|
||||
- update to version 2.9.2 by autospec
|
||||
- CAN-2005-2672 vulnerability fixed upstream, patch removed
|
||||
|
||||
* Tue Aug 30 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.9.1-1qilnx
|
||||
- update to version 2.9.1 by autospec
|
||||
|
||||
* Fri Aug 26 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.9.0-3qilnx
|
||||
- pwmconfig: do not create temporary files in an insecure manner
|
||||
(QSA-2005-094: CAN-2005-2672)
|
||||
|
||||
* Thu Feb 17 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.0-2qilnx
|
||||
- removed conflict headers in devel package
|
||||
- run sensors-detect on install/upgrade
|
||||
|
||||
* Thu Feb 17 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.0-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user