rebuilt with binutils plugin LLVMgold.so [release 7.0.1-2mamba;Mon Jan 21 2019]
This commit is contained in:
parent
58c4424420
commit
e8347d638d
@ -1,16 +1,15 @@
|
|||||||
--- llvm-5.0.0.src/tools/clang/lib/Driver/ToolChains/Gnu.cpp.orig 2017-11-28 09:10:30.171661497 +0100
|
--- llvm-7.0.0.src/tools/clang/lib/Driver/ToolChains/Gnu.cpp.orig 2018-07-31 16:21:46.000000000 +0200
|
||||||
+++ llvm-5.0.0.src/tools/clang/lib/Driver/ToolChains/Gnu.cpp 2017-11-28 09:11:30.022800395 +0100
|
+++ llvm-7.0.0.src/tools/clang/lib/Driver/ToolChains/Gnu.cpp 2018-10-07 21:50:01.056333257 +0200
|
||||||
@@ -1808,7 +1808,8 @@
|
@@ -1818,7 +1818,7 @@
|
||||||
"aarch64_be-linux-gnu"};
|
"aarch64_be-linux-gnu"};
|
||||||
|
|
||||||
static const char *const ARMLibDirs[] = {"/lib"};
|
static const char *const ARMLibDirs[] = {"/lib"};
|
||||||
- static const char *const ARMTriples[] = {"arm-linux-gnueabi",
|
- static const char *const ARMTriples[] = {"arm-linux-gnueabi"};
|
||||||
+ static const char *const ARMTriples[] = {"arm-openmamba-linux-gnueabi",
|
+ static const char *const ARMTriples[] = {"arm-openmamba-linux-gnueabi", "arm-linux-gnueabi"};
|
||||||
+ "arm-linux-gnueabi",
|
|
||||||
"arm-linux-androideabi"};
|
|
||||||
static const char *const ARMHFTriples[] = {"arm-linux-gnueabihf",
|
static const char *const ARMHFTriples[] = {"arm-linux-gnueabihf",
|
||||||
"armv7hl-redhat-linux-gnueabi",
|
"armv7hl-redhat-linux-gnueabi",
|
||||||
@@ -1822,6 +1823,7 @@
|
"armv6hl-suse-linux-gnueabi",
|
||||||
|
@@ -1830,6 +1830,7 @@
|
||||||
|
|
||||||
static const char *const X86_64LibDirs[] = {"/lib64", "/lib"};
|
static const char *const X86_64LibDirs[] = {"/lib64", "/lib"};
|
||||||
static const char *const X86_64Triples[] = {
|
static const char *const X86_64Triples[] = {
|
||||||
@ -18,7 +17,7 @@
|
|||||||
"x86_64-linux-gnu", "x86_64-unknown-linux-gnu",
|
"x86_64-linux-gnu", "x86_64-unknown-linux-gnu",
|
||||||
"x86_64-pc-linux-gnu", "x86_64-redhat-linux6E",
|
"x86_64-pc-linux-gnu", "x86_64-redhat-linux6E",
|
||||||
"x86_64-redhat-linux", "x86_64-suse-linux",
|
"x86_64-redhat-linux", "x86_64-suse-linux",
|
||||||
@@ -1831,6 +1833,7 @@
|
@@ -1839,6 +1840,7 @@
|
||||||
static const char *const X32LibDirs[] = {"/libx32"};
|
static const char *const X32LibDirs[] = {"/libx32"};
|
||||||
static const char *const X86LibDirs[] = {"/lib32", "/lib"};
|
static const char *const X86LibDirs[] = {"/lib32", "/lib"};
|
||||||
static const char *const X86Triples[] = {
|
static const char *const X86Triples[] = {
|
28
llvm.spec
28
llvm.spec
@ -1,8 +1,8 @@
|
|||||||
%define gccver %(gcc -dumpversion)
|
%define gccver %(gcc -dumpversion)
|
||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: llvm
|
Name: llvm
|
||||||
Version: 6.0.1
|
Version: 7.0.1
|
||||||
Release: 4mamba
|
Release: 2mamba
|
||||||
Summary: The Low Level Virtual Machine
|
Summary: The Low Level Virtual Machine
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -18,7 +18,7 @@ Source5: https://releases.llvm.org/%{version}/lldb-%{version}.src.tar.xz
|
|||||||
Source6: llvm-6.0.0-llvm-config.patch
|
Source6: llvm-6.0.0-llvm-config.patch
|
||||||
Patch0: %{name}-3.1-llvm-config.patch
|
Patch0: %{name}-3.1-llvm-config.patch
|
||||||
Patch1: llvm-3.4-default-to-i586.patch
|
Patch1: llvm-3.4-default-to-i586.patch
|
||||||
Patch2: llvm-5.0.0-openmamba-triplet.patch
|
Patch2: llvm-7.0.0-openmamba-triplet.patch
|
||||||
Patch3: llvm-3.5.0-buildfix-CommandLine_h-getOption.patch
|
Patch3: llvm-3.5.0-buildfix-CommandLine_h-getOption.patch
|
||||||
Patch4: llvm-3.5.0-x86_64-llvm-config.patch
|
Patch4: llvm-3.5.0-x86_64-llvm-config.patch
|
||||||
Patch5: llvm-3.5.0-llvm-config.patch
|
Patch5: llvm-3.5.0-llvm-config.patch
|
||||||
@ -182,7 +182,7 @@ mv lldb-%{version}.src tools/lldb
|
|||||||
#%patch7 -p1
|
#%patch7 -p1
|
||||||
#%patch8 -p1
|
#%patch8 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
%patch10 -p0
|
#%patch10 -p0
|
||||||
#%patch11 -p1
|
#%patch11 -p1
|
||||||
#%patch12 -p1
|
#%patch12 -p1
|
||||||
#%patch13 -p1
|
#%patch13 -p1
|
||||||
@ -212,6 +212,7 @@ cmake \
|
|||||||
-DCMAKE_BUILD_TYPE=Release \
|
-DCMAKE_BUILD_TYPE=Release \
|
||||||
-DLLVM_BUILD_LLVM_DYLIB=ON \
|
-DLLVM_BUILD_LLVM_DYLIB=ON \
|
||||||
-DLLVM_LINK_LLVM_DYLIB=ON \
|
-DLLVM_LINK_LLVM_DYLIB=ON \
|
||||||
|
-DLLVM_BINUTILS_INCDIR=%{_includedir} \
|
||||||
-DPYTHON_EXECUTABLE=%{_bindir}/python \
|
-DPYTHON_EXECUTABLE=%{_bindir}/python \
|
||||||
-DLLDB_DISABLE_PYTHON=ON \
|
-DLLDB_DISABLE_PYTHON=ON \
|
||||||
-DLLVM_INSTALL_UTILS=ON \
|
-DLLVM_INSTALL_UTILS=ON \
|
||||||
@ -314,9 +315,11 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
|||||||
%{_mandir}/man1/llvm-diff.1*
|
%{_mandir}/man1/llvm-diff.1*
|
||||||
%{_mandir}/man1/llvm-dis.1*
|
%{_mandir}/man1/llvm-dis.1*
|
||||||
%{_mandir}/man1/llvm-dwarfdump.1*
|
%{_mandir}/man1/llvm-dwarfdump.1*
|
||||||
|
%{_mandir}/man1/llvm-exegesis.1*
|
||||||
%{_mandir}/man1/llvm-extract.1*
|
%{_mandir}/man1/llvm-extract.1*
|
||||||
%{_mandir}/man1/llvm-lib.1*
|
%{_mandir}/man1/llvm-lib.1*
|
||||||
%{_mandir}/man1/llvm-link.1*
|
%{_mandir}/man1/llvm-link.1*
|
||||||
|
%{_mandir}/man1/llvm-mca.1*
|
||||||
%{_mandir}/man1/llvm-nm.1*
|
%{_mandir}/man1/llvm-nm.1*
|
||||||
%{_mandir}/man1/llvm-pdbutil.1*
|
%{_mandir}/man1/llvm-pdbutil.1*
|
||||||
%{_mandir}/man1/llvm-profdata.1*
|
%{_mandir}/man1/llvm-profdata.1*
|
||||||
@ -334,6 +337,9 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
|||||||
%{_bindir}/FileCheck
|
%{_bindir}/FileCheck
|
||||||
%{_bindir}/clangd
|
%{_bindir}/clangd
|
||||||
%{_bindir}/count
|
%{_bindir}/count
|
||||||
|
%{_bindir}/diagtool
|
||||||
|
%{_bindir}/dsymutil
|
||||||
|
%{_bindir}/hmaptool
|
||||||
%{_bindir}/find-all-symbols
|
%{_bindir}/find-all-symbols
|
||||||
%{_bindir}/ld64.lld
|
%{_bindir}/ld64.lld
|
||||||
%{_bindir}/ld.lld
|
%{_bindir}/ld.lld
|
||||||
@ -353,10 +359,11 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
|||||||
%dir %{_docdir}/lld
|
%dir %{_docdir}/lld
|
||||||
%{_docdir}/lld/*
|
%{_docdir}/lld/*
|
||||||
%{_mandir}/man1/extraclangtools.1*
|
%{_mandir}/man1/extraclangtools.1*
|
||||||
|
%{_mandir}/man1/diagtool.1*
|
||||||
|
|
||||||
%files -n libllvm
|
%files -n libllvm
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libLLVM-%{majver}.so
|
#%{_libdir}/libLLVM-%{majver}.so
|
||||||
%{_libdir}/libLTO.so.*
|
%{_libdir}/libLTO.so.*
|
||||||
%{_libdir}/liblldb.so.*
|
%{_libdir}/liblldb.so.*
|
||||||
%{_libdir}/liblldbIntelFeatures.so.*
|
%{_libdir}/liblldbIntelFeatures.so.*
|
||||||
@ -371,7 +378,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
|||||||
%{_includedir}/lldb/*
|
%{_includedir}/lldb/*
|
||||||
%{_libdir}/*.a
|
%{_libdir}/*.a
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
%exclude %{_libdir}/libLLVM-%{majver}.so
|
#%exclude %{_libdir}/libLLVM-%{majver}.so
|
||||||
%dir %{_libdir}/cmake/llvm
|
%dir %{_libdir}/cmake/llvm
|
||||||
%{_libdir}/cmake/llvm/*.cmake
|
%{_libdir}/cmake/llvm/*.cmake
|
||||||
%doc README.txt
|
%doc README.txt
|
||||||
@ -439,6 +446,15 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
|||||||
%{_docdir}/llvm/ocaml-html/*
|
%{_docdir}/llvm/ocaml-html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 21 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.1-2mamba
|
||||||
|
- rebuilt with binutils plugin LLVMgold.so
|
||||||
|
|
||||||
|
* Sat Dec 22 2018 Automatic Build System <autodist@mambasoft.it> 7.0.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Oct 14 2018 Automatic Build System <autodist@mambasoft.it> 7.0.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun Sep 02 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.1-4mamba
|
* Sun Sep 02 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.1-4mamba
|
||||||
- remove building with libc++ to fix e.g. Mesa build
|
- remove building with libc++ to fix e.g. Mesa build
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user