rebuilt using cmake [release 3.8.0-3mamba;Sat Jun 11 2016]
This commit is contained in:
parent
8e5bb40364
commit
c58e118598
@ -1,32 +0,0 @@
|
|||||||
diff -ru llvm-3.5.0.src/tools/clang/lib/Driver/ToolChains.cpp llvm-3.5.0.src.orig/tools/clang/lib/Driver/ToolChains.cpp
|
|
||||||
--- llvm-3.5.0.src/tools/clang/lib/Driver/ToolChains.cpp 2014-09-10 15:12:02.648826083 +0200
|
|
||||||
+++ llvm-3.5.0.src.orig/tools/clang/lib/Driver/ToolChains.cpp 2014-09-10 15:09:24.326886686 +0200
|
|
||||||
@@ -1322,7 +1322,8 @@
|
|
||||||
|
|
||||||
static const char *const ARMLibDirs[] = { "/lib" };
|
|
||||||
static const char *const ARMTriples[] = { "arm-linux-gnueabi",
|
|
||||||
- "arm-linux-androideabi" };
|
|
||||||
+ "arm-linux-androideabi",
|
|
||||||
+ "arm-openmamba-linux-gnueabi" };
|
|
||||||
static const char *const ARMHFTriples[] = { "arm-linux-gnueabihf",
|
|
||||||
"armv7hl-redhat-linux-gnueabi" };
|
|
||||||
static const char *const ARMebLibDirs[] = { "/lib" };
|
|
||||||
@@ -1333,7 +1334,7 @@
|
|
||||||
|
|
||||||
static const char *const X86_64LibDirs[] = { "/lib64", "/lib" };
|
|
||||||
static const char *const X86_64Triples[] = {
|
|
||||||
- "x86_64-linux-gnu", "x86_64-unknown-linux-gnu", "x86_64-pc-linux-gnu",
|
|
||||||
+ "x86_64-linux-gnu", "x86_64-unknown-linux-gnu", "x86_64-pc-linux-gnu", "x86_64-openmamba-linux-gnu",
|
|
||||||
"x86_64-redhat-linux6E", "x86_64-redhat-linux", "x86_64-suse-linux",
|
|
||||||
"x86_64-manbo-linux-gnu", "x86_64-linux-gnu", "x86_64-slackware-linux",
|
|
||||||
"x86_64-linux-android", "x86_64-unknown-linux"
|
|
||||||
@@ -1341,7 +1342,7 @@
|
|
||||||
static const char *const X32LibDirs[] = { "/libx32" };
|
|
||||||
static const char *const X86LibDirs[] = { "/lib32", "/lib" };
|
|
||||||
static const char *const X86Triples[] = {
|
|
||||||
- "i686-linux-gnu", "i686-pc-linux-gnu", "i486-linux-gnu", "i386-linux-gnu",
|
|
||||||
+ "i686-linux-gnu", "i686-pc-linux-gnu", "i486-linux-gnu", "i386-linux-gnu", "i586-openmamba-linux-gnu",
|
|
||||||
"i386-redhat-linux6E", "i686-redhat-linux", "i586-redhat-linux",
|
|
||||||
"i386-redhat-linux", "i586-suse-linux", "i486-slackware-linux",
|
|
||||||
"i686-montavista-linux", "i686-linux-android", "i586-linux-gnu"
|
|
||||||
Only in llvm-3.5.0.src.orig/tools/clang/lib/Driver: ToolChains.cpp.rej
|
|
30
llvm-3.7.0-openmamba-triplet.patch
Normal file
30
llvm-3.7.0-openmamba-triplet.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
--- llvm-3.7.0.src/tools/clang/lib/Driver/ToolChains.cpp.orig 2015-09-16 00:05:59.717766100 +0200
|
||||||
|
+++ llvm-3.7.0.src/tools/clang/lib/Driver/ToolChains.cpp 2015-09-16 00:13:50.282779926 +0200
|
||||||
|
@@ -1272,7 +1272,8 @@
|
||||||
|
"aarch64_be-linux-gnu"};
|
||||||
|
|
||||||
|
static const char *const ARMLibDirs[] = {"/lib"};
|
||||||
|
- static const char *const ARMTriples[] = {"arm-linux-gnueabi",
|
||||||
|
+ static const char *const ARMTriples[] = {"arm-openmamba-linux-gnueabi",
|
||||||
|
+ "arm-linux-gnueabi",
|
||||||
|
"arm-linux-androideabi"};
|
||||||
|
static const char *const ARMHFTriples[] = {"arm-linux-gnueabihf",
|
||||||
|
"armv7hl-redhat-linux-gnueabi"};
|
||||||
|
@@ -1284,7 +1285,7 @@
|
||||||
|
|
||||||
|
static const char *const X86_64LibDirs[] = {"/lib64", "/lib"};
|
||||||
|
static const char *const X86_64Triples[] = {
|
||||||
|
- "x86_64-linux-gnu", "x86_64-unknown-linux-gnu",
|
||||||
|
+ "x86_64-openmamba-linux-gnu", "x86_64-linux-gnu", "x86_64-unknown-linux-gnu",
|
||||||
|
"x86_64-pc-linux-gnu", "x86_64-redhat-linux6E",
|
||||||
|
"x86_64-redhat-linux", "x86_64-suse-linux",
|
||||||
|
"x86_64-manbo-linux-gnu", "x86_64-linux-gnu",
|
||||||
|
@@ -1293,7 +1294,7 @@
|
||||||
|
static const char *const X32LibDirs[] = {"/libx32"};
|
||||||
|
static const char *const X86LibDirs[] = {"/lib32", "/lib"};
|
||||||
|
static const char *const X86Triples[] = {
|
||||||
|
- "i686-linux-gnu", "i686-pc-linux-gnu", "i486-linux-gnu",
|
||||||
|
+ "i586-openmamba-linux-gnu", "i686-linux-gnu", "i686-pc-linux-gnu", "i486-linux-gnu",
|
||||||
|
"i386-linux-gnu", "i386-redhat-linux6E", "i686-redhat-linux",
|
||||||
|
"i586-redhat-linux", "i386-redhat-linux", "i586-suse-linux",
|
||||||
|
"i486-slackware-linux", "i686-montavista-linux", "i686-linux-android",
|
22
llvm-3.8.0-ocamldoc-install.patch
Normal file
22
llvm-3.8.0-ocamldoc-install.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
|
||||||
|
index eaa175062b61..f862f2561bfd 100644
|
||||||
|
--- a/docs/CMakeLists.txt
|
||||||
|
+++ b/docs/CMakeLists.txt
|
||||||
|
@@ -143,13 +143,15 @@ if( NOT uses_ocaml LESS 0 )
|
||||||
|
list(APPEND odoc_files -load ${odoc_file})
|
||||||
|
endforeach()
|
||||||
|
|
||||||
|
- add_custom_target(ocaml_doc
|
||||||
|
+ add_custom_command(OUTPUT BUILD_OCAML_DOCS
|
||||||
|
COMMAND ${CMAKE_COMMAND} -E remove_directory ${CMAKE_CURRENT_BINARY_DIR}/ocamldoc/html
|
||||||
|
COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_CURRENT_BINARY_DIR}/ocamldoc/html
|
||||||
|
COMMAND ${OCAMLFIND} ocamldoc -d ${CMAKE_CURRENT_BINARY_DIR}/ocamldoc/html
|
||||||
|
-sort -colorize-code -html ${odoc_files}
|
||||||
|
COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_SOURCE_DIR}/_ocamldoc/style.css
|
||||||
|
- ${CMAKE_CURRENT_BINARY_DIR}/ocamldoc/html)
|
||||||
|
+ ${CMAKE_CURRENT_BINARY_DIR}/ocamldoc/html
|
||||||
|
+ COMMENT "Creating documentation for OCaml bindings...")
|
||||||
|
+ add_custom_target(ocaml_doc ALL DEPENDS BUILD_OCAML_DOCS)
|
||||||
|
|
||||||
|
add_dependencies(ocaml_doc ${doc_targets})
|
||||||
|
|
205
llvm.spec
205
llvm.spec
@ -1,7 +1,7 @@
|
|||||||
%define gccver %(gcc -dumpversion)
|
%define gccver %(gcc -dumpversion)
|
||||||
Name: llvm
|
Name: llvm
|
||||||
Version: 3.5.1
|
Version: 3.8.0
|
||||||
Release: 1mamba
|
Release: 3mamba
|
||||||
Summary: The Low Level Virtual Machine
|
Summary: The Low Level Virtual Machine
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -12,10 +12,11 @@ Source0: http://llvm.org/releases/%{version}/llvm-%{version}.src.tar.xz
|
|||||||
Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
|
Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
|
||||||
Patch0: %{name}-3.1-llvm-config.patch
|
Patch0: %{name}-3.1-llvm-config.patch
|
||||||
Patch1: llvm-3.4-default-to-i586.patch
|
Patch1: llvm-3.4-default-to-i586.patch
|
||||||
Patch2: llvm-3.5.0-openmamba-triplet.patch
|
Patch2: llvm-3.7.0-openmamba-triplet.patch
|
||||||
Patch3: llvm-3.5.0-buildfix-CommandLine_h-getOption.patch
|
Patch3: llvm-3.5.0-buildfix-CommandLine_h-getOption.patch
|
||||||
Patch4: llvm-3.5.0-x86_64-llvm-config.patch
|
Patch4: llvm-3.5.0-x86_64-llvm-config.patch
|
||||||
Patch5: llvm-3.5.0-llvm-config.patch
|
Patch5: llvm-3.5.0-llvm-config.patch
|
||||||
|
Patch6: llvm-3.8.0-ocamldoc-install.patch
|
||||||
License: NCSA
|
License: NCSA
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -31,6 +32,8 @@ BuildRequires: perl-devel
|
|||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: ocaml
|
BuildRequires: ocaml
|
||||||
|
BuildRequires: ocaml-ctypes
|
||||||
|
BuildRequires: ocaml-ounit
|
||||||
#Requires: gcc >= %{gccver}
|
#Requires: gcc >= %{gccver}
|
||||||
#Requires: gcc-c++ >= %{gccver}
|
#Requires: gcc-c++ >= %{gccver}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -122,17 +125,55 @@ The %{name}-ocaml-devel package contains libraries and signature files for devel
|
|||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
mv cfe-%{version}.src tools/clang
|
mv cfe-%{version}.src tools/clang
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
#%patch3 -p1
|
||||||
%ifarch x86_64
|
#%ifarch x86_64
|
||||||
%patch4 -p1
|
#%patch4 -p1
|
||||||
%else
|
#%else
|
||||||
%patch5 -p1
|
#%patch5 -p1
|
||||||
%endif
|
#%endif
|
||||||
|
%patch6 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
%cmake -d build \
|
||||||
|
-DCMAKE_BUILD_TYPE=Release \
|
||||||
|
%ifarch x86_64
|
||||||
|
-DLLVM_LIBDIR_SUFFIX="64/llvm" \
|
||||||
|
%else
|
||||||
|
-DLLVM_LIBDIR_SUFFIX="/llvm" \
|
||||||
|
%endif
|
||||||
|
-DLLVM_BUILD_LLVM_DYLIB=ON \
|
||||||
|
-DLLVM_DYLIB_EXPORT_ALL=ON \
|
||||||
|
-DLLVM_LINK_LLVM_DYLIB=OFF \
|
||||||
|
%ifnarch arm
|
||||||
|
-DLLVM_ENABLE_RTTI=ON \
|
||||||
|
%else
|
||||||
|
-DCOMPILER_RT_BUILD_BUILTINS=OFF \
|
||||||
|
%endif
|
||||||
|
-DLLVM_ENABLE_FFI=ON \
|
||||||
|
-DLLVM_BUILD_TESTS=ON \
|
||||||
|
-DLLVM_BUILD_DOCS=ON \
|
||||||
|
-DLLVM_ENABLE_SPHINX=ON \
|
||||||
|
-DLLVM_ENABLE_DOXYGEN=OFF \
|
||||||
|
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
||||||
|
-DBUILD_SHARED_LIBS=ON \
|
||||||
|
-DFFI_INCLUDE_DIR=`pkg-config --variable=includedir libffi` \
|
||||||
|
-DLLVM_BINUTILS_INCDIR=/usr/include \
|
||||||
|
|
||||||
|
|
||||||
|
:<< __OLD
|
||||||
|
mkdir -p build
|
||||||
|
cd build
|
||||||
|
# 3.8.0: set libdir as %{_libdir}/llvm
|
||||||
|
%ifarch x86_64
|
||||||
|
sed -i 's|@LLVM_LIBDIR_SUFFIX@|64/%{name}|g' ../tools/llvm-config/BuildVariables.inc.in
|
||||||
|
%else
|
||||||
|
sed -i 's|@LLVM_LIBDIR_SUFFIX@|/%{name}|g' ../tools/llvm-config/BuildVariables.inc.in
|
||||||
|
%endif
|
||||||
#:<< ___EOF
|
#:<< ___EOF
|
||||||
|
ln -sf ../configure .
|
||||||
%configure \
|
%configure \
|
||||||
--with-arch=%{_target_cpu} \
|
--with-arch=%{_target_cpu} \
|
||||||
|
--target=%{_target_cpu} \
|
||||||
--libdir=%{_libdir}/%{name} \
|
--libdir=%{_libdir}/%{name} \
|
||||||
--datadir=%{_libdir}/%{name} \
|
--datadir=%{_libdir}/%{name} \
|
||||||
--disable-assertions \
|
--disable-assertions \
|
||||||
@ -151,42 +192,53 @@ mv cfe-%{version}.src tools/clang
|
|||||||
|
|
||||||
sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}/%{name}|g' Makefile.config
|
sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}/%{name}|g' Makefile.config
|
||||||
#___EOF
|
#___EOF
|
||||||
|
__OLD
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall
|
%makeinstall -C build
|
||||||
|
|
||||||
install -d %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
install -d %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
||||||
cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf << EOF
|
cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf << EOF
|
||||||
%{_libdir}/llvm
|
%{_libdir}/llvm
|
||||||
EOF
|
EOF
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_datadir}/doc/clang/html/.buildinfo
|
||||||
|
rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||||
|
|
||||||
|
mv %{buildroot}%{_prefix}/docs/ocaml %{buildroot}%{_docdir}/ocaml
|
||||||
|
|
||||||
|
%ifarch x86_64
|
||||||
|
mv %{buildroot}%{_prefix}/lib/ocaml %{buildroot}%{_libdir}/
|
||||||
|
%endif
|
||||||
|
|
||||||
# Static analyzer not installed by default:
|
# Static analyzer not installed by default:
|
||||||
# http://clang-analyzer.llvm.org/installation#OtherPlatforms
|
# http://clang-analyzer.llvm.org/installation#OtherPlatforms
|
||||||
install -d %{buildroot}%{_libdir}/cfe-analyzer
|
#install -d %{buildroot}%{_libdir}/cfe-analyzer
|
||||||
# create launchers
|
## create launchers
|
||||||
for f in scan-{build,view}; do
|
#for f in scan-{build,view}; do
|
||||||
ln -s %{_libdir}/cfe-analyzer/$f/$f %{buildroot}%{_bindir}/$f
|
# ln -s %{_libdir}/cfe-analyzer/$f/$f %{buildroot}%{_bindir}/$f
|
||||||
done
|
#done
|
||||||
|
|
||||||
( cd tools/clang/tools &&
|
#( cd tools/clang/tools &&
|
||||||
cp -pr scan-{build,view} %{buildroot}%{_libdir}/cfe-analyzer/ )
|
# cp -pr scan-{build,view} %{buildroot}%{_libdir}/cfe-analyzer/ )
|
||||||
|
|
||||||
mv %{buildroot}%{_prefix}/docs/llvm ./llvm-extradocs || true
|
#rm -rf ./llvm-extradocs
|
||||||
rm -f ./llvm-extradocs/*.tar.gz
|
#mv %{buildroot}%{_prefix}/docs/llvm ./llvm-extradocs || true
|
||||||
rm -f ./llvm-extradocs/ocamldoc/html/*.tar.gz
|
#rm -f ./llvm-extradocs/*.tar.gz
|
||||||
|
#rm -f ./llvm-extradocs/ocamldoc/html/*.tar.gz
|
||||||
|
#
|
||||||
|
#install -d cfe-extradocs
|
||||||
|
#for f in LICENSE.TXT NOTES.txt README.txt; do
|
||||||
|
# cp tools/clang/$f cfe-extradocs/
|
||||||
|
#done
|
||||||
|
##rm -rf tools/clang/docs/{doxygen*,Makefile*,*.graffle,tools}
|
||||||
|
|
||||||
install -d cfe-extradocs
|
#rm %{buildroot}%{_libdir}/%{name}/*LLVMHello.*
|
||||||
for f in LICENSE.TXT NOTES.txt README.txt; do
|
|
||||||
cp tools/clang/$f cfe-extradocs/
|
|
||||||
done
|
|
||||||
#rm -rf tools/clang/docs/{doxygen*,Makefile*,*.graffle,tools}
|
|
||||||
|
|
||||||
rm %{buildroot}%{_libdir}/%{name}/*LLVMHello.*
|
#find examples -name 'Makefile' | xargs -0r rm -f
|
||||||
|
|
||||||
find examples -name 'Makefile' | xargs -0r rm -f
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -204,19 +256,48 @@ find examples -name 'Makefile' | xargs -0r rm -f
|
|||||||
%{_bindir}/bugpoint
|
%{_bindir}/bugpoint
|
||||||
%{_bindir}/llc
|
%{_bindir}/llc
|
||||||
%{_bindir}/lli
|
%{_bindir}/lli
|
||||||
%{_bindir}/lli-child-target
|
#%{_bindir}/lli-child-target
|
||||||
%{_bindir}/llvm*
|
%{_bindir}/llvm*
|
||||||
%{_bindir}/macho-dump
|
#%{_bindir}/macho-dump
|
||||||
#%{_bindir}/c-index-test
|
#%{_bindir}/c-index-test
|
||||||
%{_libdir}/ocaml/META.llvm
|
%{_bindir}/obj2yaml
|
||||||
|
%{_bindir}/sancov
|
||||||
|
%{_bindir}/verify-uselistorder
|
||||||
|
%{_bindir}/yaml2obj
|
||||||
|
#%{_libdir}/ocaml/META.llvm
|
||||||
%exclude %{_bindir}/llvm-config
|
%exclude %{_bindir}/llvm-config
|
||||||
%{_bindir}/opt
|
%{_bindir}/opt
|
||||||
%{_bindir}/scan-build
|
%{_bindir}/scan-build
|
||||||
%{_bindir}/scan-view
|
%{_bindir}/scan-view
|
||||||
%{_libdir}/cfe-analyzer
|
%dir %{_datadir}/scan-build
|
||||||
#%{_mandir}/man1/*
|
%{_datadir}/scan-build/*
|
||||||
#%exclude %{_mandir}/man1/cfe.1.*
|
%dir %{_datadir}/scan-view
|
||||||
#%exclude %{_mandir}/man1/llvmg??.1.*
|
%{_datadir}/scan-view/*
|
||||||
|
%{_mandir}/man1/FileCheck.1*
|
||||||
|
%{_mandir}/man1/bugpoint.1*
|
||||||
|
%{_mandir}/man1/lit.1*
|
||||||
|
%{_mandir}/man1/llc.1*
|
||||||
|
%{_mandir}/man1/lli.1*
|
||||||
|
%{_mandir}/man1/llvm-ar.1*
|
||||||
|
%{_mandir}/man1/llvm-as.1*
|
||||||
|
%{_mandir}/man1/llvm-bcanalyzer.1*
|
||||||
|
%{_mandir}/man1/llvm-build.1*
|
||||||
|
%{_mandir}/man1/llvm-config.1*
|
||||||
|
%{_mandir}/man1/llvm-cov.1*
|
||||||
|
%{_mandir}/man1/llvm-diff.1*
|
||||||
|
%{_mandir}/man1/llvm-dis.1*
|
||||||
|
%{_mandir}/man1/llvm-dwarfdump.1*
|
||||||
|
%{_mandir}/man1/llvm-extract.1*
|
||||||
|
%{_mandir}/man1/llvm-lib.1*
|
||||||
|
%{_mandir}/man1/llvm-link.1*
|
||||||
|
%{_mandir}/man1/llvm-nm.1*
|
||||||
|
%{_mandir}/man1/llvm-profdata.1*
|
||||||
|
%{_mandir}/man1/llvm-readobj.1*
|
||||||
|
%{_mandir}/man1/llvm-stress.1*
|
||||||
|
%{_mandir}/man1/llvm-symbolizer.1*
|
||||||
|
%{_mandir}/man1/opt.1*
|
||||||
|
%{_mandir}/man1/scan-build.1*
|
||||||
|
%{_mandir}/man1/tblgen.1*
|
||||||
%doc CREDITS.TXT LICENSE.TXT
|
%doc CREDITS.TXT LICENSE.TXT
|
||||||
#doc llvm-testlog.txt
|
#doc llvm-testlog.txt
|
||||||
|
|
||||||
@ -231,21 +312,33 @@ find examples -name 'Makefile' | xargs -0r rm -f
|
|||||||
%{_bindir}/llvm-config
|
%{_bindir}/llvm-config
|
||||||
%{_includedir}/%{name}
|
%{_includedir}/%{name}
|
||||||
%{_includedir}/%{name}-c
|
%{_includedir}/%{name}-c
|
||||||
%{_libdir}/%{name}/*.a
|
#%{_libdir}/%{name}/*.a
|
||||||
%doc llvm-extradocs/html
|
%dir %{_datadir}/doc/llvm/html/
|
||||||
|
%{_datadir}/doc/llvm/html/*
|
||||||
%doc README.txt
|
%doc README.txt
|
||||||
|
|
||||||
%files -n clang
|
%files -n clang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/FileCheck
|
#%{_bindir}/FileCheck
|
||||||
%{_bindir}/c-index-test
|
%{_bindir}/c-index-test
|
||||||
%{_bindir}/clang
|
%{_bindir}/clang
|
||||||
%{_bindir}/clang++
|
%{_bindir}/clang++
|
||||||
|
%{_bindir}/clang-3.8
|
||||||
|
%{_bindir}/clang-cl
|
||||||
%{_bindir}/clang-check
|
%{_bindir}/clang-check
|
||||||
%{_bindir}/clang-format
|
%{_bindir}/clang-format
|
||||||
%{_bindir}/clang-tblgen
|
%{_bindir}/git-clang-format
|
||||||
%{_bindir}/count
|
#%{_bindir}/clang-tblgen
|
||||||
%{_bindir}/not
|
#%{_bindir}/count
|
||||||
|
#%{_bindir}/not
|
||||||
|
%{_prefix}/libexec/c++-analyzer
|
||||||
|
%{_prefix}/libexec/ccc-analyzer
|
||||||
|
%dir %{_libdir}/llvm/clang
|
||||||
|
%dir %{_libdir}/llvm/clang/%{version}
|
||||||
|
%{_libdir}/llvm/clang/%{version}/*
|
||||||
|
%{_libdir}/llvm/libclang.so.*
|
||||||
|
%dir %{_datadir}/clang/
|
||||||
|
%{_datadir}/clang/*
|
||||||
%{_mandir}/man1/clang.1*
|
%{_mandir}/man1/clang.1*
|
||||||
%doc tools/clang/LICENSE.TXT
|
%doc tools/clang/LICENSE.TXT
|
||||||
|
|
||||||
@ -253,7 +346,7 @@ find examples -name 'Makefile' | xargs -0r rm -f
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_includedir}/clang-c
|
%dir %{_includedir}/clang-c
|
||||||
%{_includedir}/clang-c/*.h
|
%{_includedir}/clang-c/*.h
|
||||||
%{_includedir}/clang-c/module.modulemap
|
#%{_includedir}/clang-c/module.modulemap
|
||||||
%dir %{_includedir}/clang/ARCMigrate
|
%dir %{_includedir}/clang/ARCMigrate
|
||||||
%{_includedir}/clang/ARCMigrate/*.h
|
%{_includedir}/clang/ARCMigrate/*.h
|
||||||
%dir %{_includedir}/clang/AST
|
%dir %{_includedir}/clang/AST
|
||||||
@ -329,11 +422,13 @@ find examples -name 'Makefile' | xargs -0r rm -f
|
|||||||
%{_includedir}/clang/StaticAnalyzer/Frontend/*.h
|
%{_includedir}/clang/StaticAnalyzer/Frontend/*.h
|
||||||
%dir %{_includedir}/clang/Tooling
|
%dir %{_includedir}/clang/Tooling
|
||||||
%{_includedir}/clang/Tooling/*
|
%{_includedir}/clang/Tooling/*
|
||||||
%dir %{_prefix}/lib/clang
|
#%dir %{_prefix}/lib/clang
|
||||||
%dir %{_prefix}/lib/clang/%{version}
|
#%dir %{_prefix}/lib/clang/%{version}
|
||||||
%dir %{_prefix}/lib/clang/%{version}/include
|
#%dir %{_prefix}/lib/clang/%{version}/include
|
||||||
%{_prefix}/lib/clang/%{version}/include/*.h
|
#%{_prefix}/lib/clang/%{version}/include/*.h
|
||||||
%{_prefix}/lib/clang/%{version}/include/module.modulemap
|
#%{_prefix}/lib/clang/%{version}/include/module.modulemap
|
||||||
|
%dir %{_datadir}/doc/clang/html/
|
||||||
|
%{_datadir}/doc/clang/html/*
|
||||||
%dir %{_datadir}/llvm/cmake
|
%dir %{_datadir}/llvm/cmake
|
||||||
%{_datadir}/llvm/cmake/*.cmake
|
%{_datadir}/llvm/cmake/*.cmake
|
||||||
%doc tools/clang/{NOTES.txt,README.txt}
|
%doc tools/clang/{NOTES.txt,README.txt}
|
||||||
@ -343,17 +438,29 @@ find examples -name 'Makefile' | xargs -0r rm -f
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/ocaml/*.cma
|
%{_libdir}/ocaml/*.cma
|
||||||
%{_libdir}/ocaml/*.cmi
|
%{_libdir}/ocaml/*.cmi
|
||||||
%{_libdir}/ocaml/META.llvm_*
|
%{_libdir}/ocaml/META.llvm*
|
||||||
%{_libdir}/ocaml/dllllvm*.so
|
%{_libdir}/ocaml/dllllvm*.so
|
||||||
|
|
||||||
%files ocaml-devel
|
%files ocaml-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/ocaml/*.a
|
%{_libdir}/ocaml/*.a
|
||||||
%{_libdir}/ocaml/*.cmx*
|
%{_libdir}/ocaml/*.cmx*
|
||||||
%{_libdir}/ocaml/*.mli
|
#%{_libdir}/ocaml/*.mli
|
||||||
|
%dir %{_docdir}/ocaml
|
||||||
|
%dir %{_docdir}/ocaml/html
|
||||||
|
%{_docdir}/ocaml/html/*
|
||||||
#%doc llvm-extradocs/ocamldoc/html
|
#%doc llvm-extradocs/ocamldoc/html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jun 11 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8.0-3mamba
|
||||||
|
- rebuilt using cmake
|
||||||
|
|
||||||
|
* Sat May 28 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8.0-2mamba
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Thu May 26 2016 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun Jan 18 2015 Automatic Build System <autodist@mambasoft.it> 3.5.1-1mamba
|
* Sun Jan 18 2015 Automatic Build System <autodist@mambasoft.it> 3.5.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user