automatic version update by autodist [release 19.1.1-1mamba;Wed Oct 02 2024]
This commit is contained in:
parent
da0658a1d9
commit
a3cba86a89
@ -1,30 +0,0 @@
|
|||||||
--- llvm-3.1.src/tools/llvm-config/llvm-config.cpp.orig 2012-07-20 20:40:27.421755571 +0200
|
|
||||||
+++ llvm-3.1.src/tools/llvm-config/llvm-config.cpp 2012-07-20 20:39:59.212062264 +0200
|
|
||||||
@@ -230,15 +230,15 @@
|
|
||||||
switch (DevelopmentTreeLayout) {
|
|
||||||
case MakefileStyle:
|
|
||||||
ActiveBinDir = ActiveObjRoot + "/" + LLVM_BUILDMODE + "/bin";
|
|
||||||
- ActiveLibDir = ActiveObjRoot + "/" + LLVM_BUILDMODE + "/lib";
|
|
||||||
+ ActiveLibDir = ActiveObjRoot + "/" + LLVM_BUILDMODE + "/lib/llvm";
|
|
||||||
break;
|
|
||||||
case CMakeStyle:
|
|
||||||
ActiveBinDir = ActiveObjRoot + "/bin";
|
|
||||||
- ActiveLibDir = ActiveObjRoot + "/lib";
|
|
||||||
+ ActiveLibDir = ActiveObjRoot + "/lib/llvm";
|
|
||||||
break;
|
|
||||||
case CMakeBuildModeStyle:
|
|
||||||
ActiveBinDir = ActiveObjRoot + "/bin/" + LLVM_BUILDMODE;
|
|
||||||
- ActiveLibDir = ActiveObjRoot + "/lib/" + LLVM_BUILDMODE;
|
|
||||||
+ ActiveLibDir = ActiveObjRoot + "/lib/llvm" + LLVM_BUILDMODE;
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -249,7 +249,7 @@
|
|
||||||
ActivePrefix = CurrentExecPrefix;
|
|
||||||
ActiveIncludeDir = ActivePrefix + "/include";
|
|
||||||
ActiveBinDir = ActivePrefix + "/bin";
|
|
||||||
- ActiveLibDir = ActivePrefix + "/lib";
|
|
||||||
+ ActiveLibDir = ActivePrefix + "/lib/llvm";
|
|
||||||
ActiveIncludeOption = "-I" + ActiveIncludeDir;
|
|
||||||
}
|
|
||||||
|
|
23
llvm.spec
23
llvm.spec
@ -1,7 +1,7 @@
|
|||||||
%define gccver %(gcc -dumpversion)
|
%define gccver %(gcc -dumpversion)
|
||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: llvm
|
Name: llvm
|
||||||
Version: 18.1.8
|
Version: 19.1.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: The Low Level Virtual Machine
|
Summary: The Low Level Virtual Machine
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -13,7 +13,6 @@ Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{
|
|||||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/cmake-%{version}.src.tar.xz
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/cmake-%{version}.src.tar.xz
|
||||||
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/third-party-%{version}.src.tar.xz
|
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/third-party-%{version}.src.tar.xz
|
||||||
Source6: llvm-6.0.0-llvm-config.patch
|
Source6: llvm-6.0.0-llvm-config.patch
|
||||||
Patch0: %{name}-3.1-llvm-config.patch
|
|
||||||
Patch6: llvm-3.8.0-ocamldoc-install.patch
|
Patch6: llvm-3.8.0-ocamldoc-install.patch
|
||||||
License: NCSA
|
License: NCSA
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
@ -21,7 +20,6 @@ BuildRequires: glibc-devel
|
|||||||
BuildRequires: libedit-devel
|
BuildRequires: libedit-devel
|
||||||
BuildRequires: libffi-devel
|
BuildRequires: libffi-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libncurses-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
@ -195,9 +193,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
|||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -211,6 +207,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
|||||||
%{_bindir}/llvm*
|
%{_bindir}/llvm*
|
||||||
%{_bindir}/not
|
%{_bindir}/not
|
||||||
%{_bindir}/obj2yaml
|
%{_bindir}/obj2yaml
|
||||||
|
%{_bindir}/reduce-chunk-list
|
||||||
%{_bindir}/sancov
|
%{_bindir}/sancov
|
||||||
%{_bindir}/sanstats
|
%{_bindir}/sanstats
|
||||||
%{_bindir}/split-file
|
%{_bindir}/split-file
|
||||||
@ -221,17 +218,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
|||||||
%{_bindir}/opt
|
%{_bindir}/opt
|
||||||
%dir %{_datadir}/opt-viewer
|
%dir %{_datadir}/opt-viewer
|
||||||
%{_datadir}/opt-viewer/*
|
%{_datadir}/opt-viewer/*
|
||||||
#%{_mandir}/man1/FileCheck.1*
|
|
||||||
#%{_mandir}/man1/bugpoint.1*
|
|
||||||
#%{_mandir}/man1/dsymutil.1*
|
|
||||||
#%{_mandir}/man1/lit.1*
|
|
||||||
#%{_mandir}/man1/llc.1*
|
|
||||||
#%{_mandir}/man1/lli.1*
|
|
||||||
#%{_mandir}/man1/llvm-*.1*
|
|
||||||
#%{_mandir}/man1/opt.1*
|
|
||||||
#%{_mandir}/man1/tblgen.1*
|
|
||||||
%doc llvm/CREDITS.TXT llvm/LICENSE.TXT
|
%doc llvm/CREDITS.TXT llvm/LICENSE.TXT
|
||||||
#doc llvm-testlog.txt
|
|
||||||
|
|
||||||
%files -n libllvm
|
%files -n libllvm
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -280,6 +267,12 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 02 2024 Automatic Build System <autodist@openmamba.org> 19.1.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Sep 19 2024 Automatic Build System <autodist@openmamba.org> 19.1.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sat Jun 22 2024 Automatic Build System <autodist@openmamba.org> 18.1.8-1mamba
|
* Sat Jun 22 2024 Automatic Build System <autodist@openmamba.org> 18.1.8-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user