rebuilt with gcc 8.1.0 [release 6.0.0-4mamba;Mon Jun 25 2018]

This commit is contained in:
Silvan Calarco 2024-01-06 06:26:10 +01:00
parent 21b09a1a10
commit 8e2231d63e
7 changed files with 486 additions and 130 deletions

View File

@ -0,0 +1,36 @@
From 4d613a84ce271c6225068bef67d727ae02b2e3b1 Mon Sep 17 00:00:00 2001
From: Pavel Labath <labath@google.com>
Date: Wed, 14 Mar 2018 09:28:38 +0000
Subject: [PATCH] Export LLVM_DYLIB_COMPONENTS in LLVMConfig.cmake
Summary:
This is needed so that external projects (e.g. a standalone build of
lldb) can link to the LLVM shared library via the USE_SHARED argument of
llvm_config. Without this, llvm_config would add LLVM to the link list,
but then also add the constituent static libraries, resulting in
multiply defined symbols.
Reviewers: beanz, mgorny
Subscribers: llvm-commits
Differential Revision: https://reviews.llvm.org/D44391
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@327484 91177308-0d34-0410-b5e6-96231b3b80d8
---
cmake/modules/LLVMConfig.cmake.in | 2 ++
1 file changed, 2 insertions(+)
diff --git a/cmake/modules/LLVMConfig.cmake.in b/cmake/modules/LLVMConfig.cmake.in
index fe4df5278498..e70018679846 100644
--- a/cmake/modules/LLVMConfig.cmake.in
+++ b/cmake/modules/LLVMConfig.cmake.in
@@ -13,6 +13,8 @@ set(LLVM_COMMON_DEPENDS @LLVM_COMMON_DEPENDS@)
set(LLVM_AVAILABLE_LIBS @LLVM_AVAILABLE_LIBS@)
+set(LLVM_DYLIB_COMPONENTS @LLVM_DYLIB_COMPONENTS@)
+
set(LLVM_ALL_TARGETS @LLVM_ALL_TARGETS@)
set(LLVM_TARGETS_TO_BUILD @LLVM_TARGETS_TO_BUILD@)

View File

@ -0,0 +1,262 @@
From 783006ec19853403b8fe799e4c1b9496cb03504a Mon Sep 17 00:00:00 2001
From: Bjorn Pettersson <bjorn.a.pettersson@ericsson.com>
Date: Tue, 6 Mar 2018 08:47:07 +0000
Subject: [PATCH] [DebugInfo] Discard invalid DBG_VALUE instructions in
LiveDebugVariables
Summary:
This is a workaround for pr36417
https://bugs.llvm.org/show_bug.cgi?id=36417
LiveDebugVariables will now verify that the DBG_VALUE instructions
are sane (prior to register allocation) by asking LIS if a virtual
register used in the DBG_VALUE is live (or dead def) in the slot
index before the DBG_VALUE. If it isn't sane the DBG_VALUE is
discarded.
One pass that was identified as introducing non-sane DBG_VALUE
instructtons, when analysing pr36417, was the DAG->DAG Instruction
Selection. It sometimes inserts DBG_VALUE instructions referring to
a virtual register that is defined later in the same basic block.
So it is a use before def kind of problem. The DBG_VALUE is
typically inserted in the beginning of a basic block when this
happens. The problem can be seen in the test case
test/DebugInfo/X86/dbg-value-inlined-parameter.ll
Reviewers: aprantl, rnk, probinson
Reviewed By: aprantl
Subscribers: vsk, davide, alexcrichton, Ka-Ka, eraman, llvm-commits, JDevlieghere
Differential Revision: https://reviews.llvm.org/D43956
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@326769 91177308-0d34-0410-b5e6-96231b3b80d8
---
lib/CodeGen/LiveDebugVariables.cpp | 38 +++++-
test/DebugInfo/X86/dbg-value-inlined-parameter.ll | 6 +-
.../X86/live-debug-vars-discard-invalid.mir | 141 +++++++++++++++++++++
3 files changed, 181 insertions(+), 4 deletions(-)
create mode 100644 test/DebugInfo/X86/live-debug-vars-discard-invalid.mir
diff --git a/lib/CodeGen/LiveDebugVariables.cpp b/lib/CodeGen/LiveDebugVariables.cpp
index 09168b6b9309..f3fcd004defd 100644
--- a/lib/CodeGen/LiveDebugVariables.cpp
+++ b/lib/CodeGen/LiveDebugVariables.cpp
@@ -514,6 +514,39 @@ bool LDVImpl::handleDebugValue(MachineInstr &MI, SlotIndex Idx) {
return false;
}
+ // Detect invalid DBG_VALUE instructions, with a debug-use of a virtual
+ // register that hasn't been defined yet. If we do not remove those here, then
+ // the re-insertion of the DBG_VALUE instruction after register allocation
+ // will be incorrect.
+ // TODO: If earlier passes are corrected to generate sane debug information
+ // (and if the machine verifier is improved to catch this), then these checks
+ // could be removed or replaced by asserts.
+ bool Discard = false;
+ if (MI.getOperand(0).isReg() &&
+ TargetRegisterInfo::isVirtualRegister(MI.getOperand(0).getReg())) {
+ const unsigned Reg = MI.getOperand(0).getReg();
+ if (!LIS->hasInterval(Reg)) {
+ // The DBG_VALUE is described by a virtual register that does not have a
+ // live interval. Discard the DBG_VALUE.
+ Discard = true;
+ DEBUG(dbgs() << "Discarding debug info (no LIS interval): "
+ << Idx << " " << MI);
+ } else {
+ // The DBG_VALUE is only valid if either Reg is live out from Idx, or Reg
+ // is defined dead at Idx (where Idx is the slot index for the instruction
+ // preceeding the DBG_VALUE).
+ const LiveInterval &LI = LIS->getInterval(Reg);
+ LiveQueryResult LRQ = LI.Query(Idx);
+ if (!LRQ.valueOutOrDead()) {
+ // We have found a DBG_VALUE with the value in a virtual register that
+ // is not live. Discard the DBG_VALUE.
+ Discard = true;
+ DEBUG(dbgs() << "Discarding debug info (reg not live): "
+ << Idx << " " << MI);
+ }
+ }
+ }
+
// Get or create the UserValue for (variable,offset) here.
bool IsIndirect = MI.getOperand(1).isImm();
if (IsIndirect)
@@ -522,7 +555,10 @@ bool LDVImpl::handleDebugValue(MachineInstr &MI, SlotIndex Idx) {
const DIExpression *Expr = MI.getDebugExpression();
UserValue *UV =
getUserValue(Var, Expr, MI.getDebugLoc());
- UV->addDef(Idx, MI.getOperand(0), IsIndirect);
+ if (!Discard)
+ UV->addDef(Idx, MI.getOperand(0), IsIndirect);
+ else
+ UV->addDef(Idx, MachineOperand::CreateReg(0U, RegState::Debug), false);
return true;
}
diff --git a/test/DebugInfo/X86/dbg-value-inlined-parameter.ll b/test/DebugInfo/X86/dbg-value-inlined-parameter.ll
index 9954039654bb..e83cf0aa7ffd 100644
--- a/test/DebugInfo/X86/dbg-value-inlined-parameter.ll
+++ b/test/DebugInfo/X86/dbg-value-inlined-parameter.ll
@@ -32,10 +32,10 @@
;CHECK-NEXT: DW_AT_call_line
;CHECK: DW_TAG_formal_parameter
-;FIXME: Linux shouldn't drop this parameter either...
;CHECK-NOT: DW_TAG
-;DARWIN: DW_AT_abstract_origin {{.*}} "sp"
-;DARWIN: DW_TAG_formal_parameter
+;FIXME: Shouldn't drop this parameter...
+;XCHECK: DW_AT_abstract_origin {{.*}} "sp"
+;XCHECK: DW_TAG_formal_parameter
;CHECK: DW_AT_abstract_origin {{.*}} "nums"
;CHECK-NOT: DW_TAG_formal_parameter
diff --git a/test/DebugInfo/X86/live-debug-vars-discard-invalid.mir b/test/DebugInfo/X86/live-debug-vars-discard-invalid.mir
new file mode 100644
index 000000000000..abc21bc6ac90
--- /dev/null
+++ b/test/DebugInfo/X86/live-debug-vars-discard-invalid.mir
@@ -0,0 +1,141 @@
+# RUN: llc -mtriple=x86_64-linux-gnu -start-before greedy -stop-after virtregrewriter -o - %s | FileCheck %s
+
+--- |
+ ; ModuleID = '<stdin>'
+ source_filename = "test/DebugInfo/X86/dbg-value-inlined-parameter.ll"
+ target datalayout = "e-m:o-i64:64-f80:128-n8:16:32:64-S128"
+ target triple = "x86_64-apple-darwin"
+
+ %struct.S1 = type { float*, i32 }
+
+ @p = common global %struct.S1 zeroinitializer, align 8, !dbg !0
+
+ ; Function Attrs: nounwind optsize ssp
+ define void @foobar() !dbg !15 {
+ entry:
+ tail call void @llvm.dbg.value(metadata %struct.S1* @p, metadata !18, metadata !DIExpression()) , !dbg !25
+ ret void, !dbg !32
+ }
+
+ ; Function Attrs: nounwind readnone speculatable
+ declare void @llvm.dbg.value(metadata, metadata, metadata) #2
+
+ !llvm.dbg.cu = !{!2}
+ !llvm.module.flags = !{!14}
+
+ !0 = !DIGlobalVariableExpression(var: !1, expr: !DIExpression())
+ !1 = !DIGlobalVariable(name: "p", scope: !2, file: !3, line: 14, type: !6, isLocal: false, isDefinition: true)
+ !2 = distinct !DICompileUnit(language: DW_LANG_C99, file: !3, producer: "clang version 2.9 (trunk 125693)", isOptimized: true, runtimeVersion: 0, emissionKind: FullDebug, enums: !4, retainedTypes: !4, globals: !5, imports: !4)
+ !3 = !DIFile(filename: "nm2.c", directory: "/private/tmp")
+ !4 = !{}
+ !5 = !{!0}
+ !6 = !DIDerivedType(tag: DW_TAG_typedef, name: "S1", scope: !2, file: !3, line: 4, baseType: !7)
+ !7 = !DICompositeType(tag: DW_TAG_structure_type, name: "S1", scope: !2, file: !3, line: 1, size: 128, align: 64, elements: !8)
+ !8 = !{!9, !12}
+ !9 = !DIDerivedType(tag: DW_TAG_member, name: "m", scope: !3, file: !3, line: 2, baseType: !10, size: 64, align: 64)
+ !10 = !DIDerivedType(tag: DW_TAG_pointer_type, scope: !2, baseType: !11, size: 64, align: 64)
+ !11 = !DIBasicType(name: "float", size: 32, align: 32, encoding: DW_ATE_float)
+ !12 = !DIDerivedType(tag: DW_TAG_member, name: "nums", scope: !3, file: !3, line: 3, baseType: !13, size: 32, align: 32, offset: 64)
+ !13 = !DIBasicType(name: "int", size: 32, align: 32, encoding: DW_ATE_signed)
+ !14 = !{i32 1, !"Debug Info Version", i32 3}
+ !15 = distinct !DISubprogram(name: "foobar", scope: !3, file: !3, line: 15, type: !16, isLocal: false, isDefinition: true, virtualIndex: 6, isOptimized: true, unit: !2)
+ !16 = !DISubroutineType(types: !17)
+ !17 = !{null}
+ !18 = !DILocalVariable(name: "sp", arg: 1, scope: !19, file: !3, line: 7, type: !24)
+ !19 = distinct !DISubprogram(name: "foo", scope: !3, file: !3, line: 8, type: !20, isLocal: false, isDefinition: true, scopeLine: 8, virtualIndex: 6, flags: DIFlagPrototyped, isOptimized: true, unit: !2, variables: !22)
+ !20 = !DISubroutineType(types: !21)
+ !21 = !{!13}
+ !22 = !{!18, !23}
+ !23 = !DILocalVariable(name: "nums", arg: 2, scope: !19, file: !3, line: 7, type: !13)
+ !24 = !DIDerivedType(tag: DW_TAG_pointer_type, scope: !2, baseType: !6, size: 64, align: 64)
+ !25 = !DILocation(line: 7, column: 13, scope: !19, inlinedAt: !26)
+ !26 = !DILocation(line: 16, column: 3, scope: !27)
+ !27 = distinct !DILexicalBlock(scope: !15, file: !3, line: 15, column: 15)
+ !32 = !DILocation(line: 17, column: 1, scope: !27)
+
+...
+---
+name: foobar
+tracksRegLiveness: true
+body: |
+ bb.0:
+ %1:gr64 = IMPLICIT_DEF
+ %2:gr64 = IMPLICIT_DEF
+
+ bb.1:
+ ; This DBG_VALUE will be discarded (use before def of %0).
+ DBG_VALUE debug-use %0, debug-use %noreg, !18, !DIExpression(), debug-location !25
+ %0:gr64 = IMPLICIT_DEF
+ %0:gr64 = IMPLICIT_DEF
+ %0:gr64 = IMPLICIT_DEF
+ %0:gr64 = IMPLICIT_DEF
+
+ bb.2:
+ ; This DBG_VALUE will be discarded (%1 is defined earlier, but it is not live in, so we do not know where %1 is stored).
+ DBG_VALUE debug-use %1, debug-use %noreg, !18, !DIExpression(), debug-location !25
+ %1:gr64 = IMPLICIT_DEF
+ %1:gr64 = IMPLICIT_DEF
+ %1:gr64 = IMPLICIT_DEF
+ %1:gr64 = IMPLICIT_DEF
+ ; This DBG_VALUE is kept, even if %1 is dead, it was defined in the prev instruction,
+ ; so the value should be available for as long as the register allocated to %1 is live.
+ DBG_VALUE debug-use %1, debug-use %noreg, !18, !DIExpression(), debug-location !25
+
+ bb.3:
+ %1:gr64 = IMPLICIT_DEF
+ DBG_VALUE 0, debug-use %noreg, !23, !DIExpression(), debug-location !25
+ ; This DBG_VALUE is kept, even if %1 is dead, it was defined in the prev non-dbg instruction,
+ ; so the value should be available for as long as the register allocated to %1 is live.
+ DBG_VALUE debug-use %1, debug-use %noreg, !18, !DIExpression(), debug-location !25
+
+ bb.4:
+ ; All DBG_VALUEs here should survive. %2 is livein as it was defined in bb.0, and it has use/def in the BTS64rr instruction.
+ DBG_VALUE debug-use %2, debug-use %noreg, !18, !DIExpression(), debug-location !25
+ %2:gr64 = BTS64rr %2, 0, implicit-def %eflags
+ DBG_VALUE 0, debug-use %noreg, !23, !DIExpression(), debug-location !25
+ DBG_VALUE debug-use %2, debug-use %noreg, !18, !DIExpression(), debug-location !25
+ %2:gr64 = BTS64rr %2, 0, implicit-def %eflags
+ DBG_VALUE debug-use %2, debug-use %noreg, !18, !DIExpression(), debug-location !25
+ %2:gr64 = BTS64rr %2, 0, implicit-def %eflags
+ DBG_VALUE debug-use %2, debug-use %noreg, !18, !DIExpression(), debug-location !25
+
+ bb.5:
+ RET 0, debug-location !32
+...
+
+# CHECK-LABEL: name: foobar
+
+# CHECK-LABEL: bb.1:
+## After solving https://bugs.llvm.org/show_bug.cgi?id=36579 we expect to get a
+## DBG_VALUE debug-use %noreg
+## here.
+# CHECK-NOT: DBG_VALUE
+
+# CHECK-LABEL: bb.2:
+## After solving https://bugs.llvm.org/show_bug.cgi?id=36579 we expect to get a
+## DBG_VALUE debug-use %noreg
+## here.
+# CHECK-NOT: DBG_VALUE
+# CHECK: dead renamable %rcx = IMPLICIT_DEF
+# CHECK-NEXT: dead renamable %rcx = IMPLICIT_DEF
+# CHECK-NEXT: dead renamable %rcx = IMPLICIT_DEF
+# CHECK-NEXT: dead renamable %rcx = IMPLICIT_DEF
+# CHECK-NEXT: DBG_VALUE debug-use %rcx, debug-use %noreg, !18, !DIExpression()
+
+# CHECK-LABEL: bb.3:
+# CHECK: dead renamable %rcx = IMPLICIT_DEF
+# CHECK-NEXT: DBG_VALUE 0, debug-use %noreg, !23, !DIExpression()
+# CHECK-NEXT: DBG_VALUE debug-use %rcx, debug-use %noreg, !18, !DIExpression()
+
+# CHECK-LABEL: bb.4:
+# CHECK: liveins: %rax
+# CHECK: DBG_VALUE debug-use %rax, debug-use %noreg, !18, !DIExpression()
+# CHECK-NEXT: renamable %rax = BTS64rr killed renamable %rax, 0, implicit-def %eflags
+# CHECK-NEXT: DBG_VALUE 0, debug-use %noreg, !23, !DIExpression()
+# CHECK-NEXT: DBG_VALUE debug-use %rax, debug-use %noreg, !18, !DIExpression()
+# CHECK-NEXT: renamable %rax = BTS64rr killed renamable %rax, 0, implicit-def %eflags
+# CHECK-NEXT: DBG_VALUE debug-use %rax, debug-use %noreg, !18, !DIExpression()
+# CHECK-NEXT: dead renamable %rax = BTS64rr killed renamable %rax, 0, implicit-def %eflags
+
+# CHECK-LABEL: bb.5:
+# CHECK-NEXT: RET 0

View File

@ -0,0 +1,13 @@
Index: cmake/modules/LLVM-Config.cmake
===================================================================
--- cmake/modules/LLVM-Config.cmake
+++ cmake/modules/LLVM-Config.cmake
@@ -68,7 +68,7 @@
cmake_parse_arguments(ARG "USE_SHARED" "" "" ${ARGN})
set(link_components ${ARG_UNPARSED_ARGUMENTS})
- if(USE_SHARED)
+ if(ARG_USE_SHARED)
# If USE_SHARED is specified, then we link against libLLVM,
# but also against the component libraries below. This is
# done in case libLLVM does not contain all of the components

View File

@ -0,0 +1,28 @@
From 7c9054610e354340f9474dcd13a927f929912d1d Mon Sep 17 00:00:00 2001
From: Eugene Zelenko <eugene.zelenko@gmail.com>
Date: Tue, 6 Mar 2018 23:06:13 +0000
Subject: [PATCH] [Transforms] Add missing header for InstructionCombining.cpp,
in order to export LLVMInitializeInstCombine as extern "C". Fixes PR35947.
Patch by Brenton Bostick.
Differential revision: https://reviews.llvm.org/D44140
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@326843 91177308-0d34-0410-b5e6-96231b3b80d8
---
lib/Transforms/InstCombine/InstructionCombining.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/Transforms/InstCombine/InstructionCombining.cpp b/lib/Transforms/InstCombine/InstructionCombining.cpp
index a3b2fe9e5d22..7ec73433e8f6 100644
--- a/lib/Transforms/InstCombine/InstructionCombining.cpp
+++ b/lib/Transforms/InstCombine/InstructionCombining.cpp
@@ -34,6 +34,7 @@
//===----------------------------------------------------------------------===//
#include "InstCombineInternal.h"
+#include "llvm-c/Initialization.h"
#include "llvm/ADT/APInt.h"
#include "llvm/ADT/ArrayRef.h"
#include "llvm/ADT/DenseMap.h"

View File

@ -0,0 +1,34 @@
From 866cf8f3afa0224e31d36ca0351ac5cb0d303757 Mon Sep 17 00:00:00 2001
From: Bjorn Pettersson <bjorn.a.pettersson@ericsson.com>
Date: Tue, 6 Mar 2018 13:23:28 +0000
Subject: [PATCH] Fixup for rL326769 (RegState::Debug is being truncated to a
bool)
I obviously messed up arguments to MachineOperand::CreateReg
in rL326769. This should make it work as intended.
Thanks to RKSimon for spotting this.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@326780 91177308-0d34-0410-b5e6-96231b3b80d8
---
lib/CodeGen/LiveDebugVariables.cpp | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/lib/CodeGen/LiveDebugVariables.cpp b/lib/CodeGen/LiveDebugVariables.cpp
index f3fcd004defd..8c547cdcff33 100644
--- a/lib/CodeGen/LiveDebugVariables.cpp
+++ b/lib/CodeGen/LiveDebugVariables.cpp
@@ -557,8 +557,11 @@ bool LDVImpl::handleDebugValue(MachineInstr &MI, SlotIndex Idx) {
getUserValue(Var, Expr, MI.getDebugLoc());
if (!Discard)
UV->addDef(Idx, MI.getOperand(0), IsIndirect);
- else
- UV->addDef(Idx, MachineOperand::CreateReg(0U, RegState::Debug), false);
+ else {
+ MachineOperand MO = MachineOperand::CreateReg(0U, false);
+ MO.setIsDebug();
+ UV->addDef(Idx, MO, false);
+ }
return true;
}

View File

@ -0,0 +1,9 @@
#include <bits/wordsize.h>
#if __WORDSIZE == 32
#include "llvm-config-32.h"
#elif __WORDSIZE == 64
#include "llvm-config-64.h"
#else
#error "Unknown word size"
#endif

234
llvm.spec
View File

@ -1,8 +1,8 @@
%define gccver %(gcc -dumpversion)
%define majver %(echo %version | cut -d. -f1-2)
Name: llvm
Version: 5.0.1
Release: 1mamba
Version: 6.0.0
Release: 4mamba
Summary: The Low Level Virtual Machine
Group: Development/Languages
Vendor: openmamba
@ -15,6 +15,7 @@ Source2: http://releases.llvm.org/%{version}/compiler-rt-%{version}.src.ta
Source3: http://releases.llvm.org/%{version}/clang-tools-extra-%{version}.src.tar.xz
Source4: http://releases.llvm.org/%{version}/lld-%{version}.src.tar.xz
Source5: http://releases.llvm.org/%{version}/lldb-%{version}.src.tar.xz
Source6: llvm-6.0.0-llvm-config.patch
Patch0: %{name}-3.1-llvm-config.patch
Patch1: llvm-3.4-default-to-i586.patch
Patch2: llvm-5.0.0-openmamba-triplet.patch
@ -24,6 +25,11 @@ Patch5: llvm-3.5.0-llvm-config.patch
Patch6: llvm-3.8.0-ocamldoc-install.patch
Patch7: llvm-5.0.0-llvm-shlib-build-fix.patch
Patch8: llvm-5.0.0-disable-symbolizer-test.patch
Patch9: llvm-6.0.0--export-LLVM_DYLIB_COMPONENTS-in-LLVMConfig.cmake.patch
Patch10: llvm-6.0.0-cmake-fix-a-typo-in-llvm_config-macro.patch
Patch11: llvm-6.0.0-export-LLVMInitializeInstCombine-as-extern-C.patch
Patch12: llvm-6.0.0-DebugInfo-discard-invalid-DBG_VALUE-instructions.patch
Patch13: llvm-6.0.0-fixup-for-rL326769-RegState-Debug-is-being-truncated.patch
License: NCSA
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -37,7 +43,7 @@ BuildRequires: libxml2-devel
BuildRequires: libz-devel
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: gcc-c++
BuildRequires: gcc-c++ >= 8.1.0
BuildRequires: glibc-devel
BuildRequires: ocaml
BuildRequires: ocaml-ctypes
@ -158,54 +164,79 @@ mv lldb-%{version}.src tools/lldb
#%patch5 -p1
#%endif
%patch6 -p1
%patch7 -p1
%patch8 -p1
#%patch7 -p1
#%patch8 -p1
%patch9 -p1
%patch10 -p0
%patch11 -p1
%patch12 -p1
%patch13 -p1
# https://bugs.llvm.org/show_bug.cgi?id=34123
sed -i '/LLVMSupport/d' tools/clang/tools/extra/clangd/tool/CMakeLists.txt
#sed -i '/LLVMSupport/d' tools/clang/tools/extra/clangd/tool/CMakeLists.txt
sed -i "/REMOVE_DUPLICATES/d" tools/llvm-shlib/CMakeLists.txt
%build
#:<< _EOF
%cmake -d build \
-DCMAKE_BUILD_TYPE=Release \
-DLLVM_HOST_TRIPLE="%{_target_platform}" \
-DLLVM_DEFAULT_TARGET_TRIPLE="%{_target_platform}" \
mkdir -p build
cd build
cmake \
-G Ninja \
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
-DLLVM_HOST_TRIPLE="%{_target_platform}" \
-DLLVM_DEFAULT_TARGET_TRIPLE="%{_target_platform}" \
-DLLVM_ENABLE_FFI=ON \
-DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
-DCMAKE_BUILD_TYPE=Release \
-DLLVM_BUILD_LLVM_DYLIB=ON \
-DLLVM_LINK_LLVM_DYLIB=ON \
-DPYTHON_EXECUTABLE=%{_bindir}/python \
-DLLDB_DISABLE_PYTHON=ON \
-DLLVM_INSTALL_UTILS=ON \
-DLLVM_ENABLE_SPHINX=ON \
%ifarch x86_64
-DLLVM_LIBDIR_SUFFIX="64/llvm" \
%else
-DLLVM_LIBDIR_SUFFIX="/llvm" \
-DLLVM_LIBDIR_SUFFIX="64" \
%endif
-DLLVM_BUILD_LLVM_DYLIB=ON \
-DLLVM_DYLIB_EXPORT_ALL=ON \
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
%ifnarch arm
-DLLVM_ENABLE_RTTI=ON \
-DLLVM_BUILD_TESTS=ON \
-DLLVM_BUILD_DOCS=ON \
-DLLVM_ENABLE_RTTI=ON \
-DLLVM_BUILD_TESTS=ON \
-DLLVM_BUILD_DOCS=ON \
%else
-DLLVM_BUILD_EXTERNAL_COMPILER_RT=OFF \
-DLLVM_BUILD_EXTERNAL_COMPILER_RT=OFF \
%endif
-DLLVM_ENABLE_FFI=ON \
-DLLVM_ENABLE_SPHINX=ON \
-DLLVM_ENABLE_DOXYGEN=OFF \
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
-DFFI_INCLUDE_DIR=`pkg-config --variable=includedir libffi` \
-DLLVM_BINUTILS_INCDIR=/usr/include \
-DLLVM_INSTALL_UTILS=ON \
-DLLDB_DISABLE_PYTHON=ON
-Wno-dev ..
# -DLLVM_LINK_LLVM_DYLIB=OFF \
# -DBUILD_SHARED_LIBS=ON \
#%ifarch x86_64
# -DLLVM_LIBDIR_SUFFIX="64/llvm" \
#%else
# -DLLVM_LIBDIR_SUFFIX="/llvm" \
#%endif
# -DLLVM_TARGETS_TO_BUILD="host;AMDGPU" \
ninja all ocaml_doc
#% make all docs-llvm-html docs-llvm-man docs-clang-html docs-clang-man
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
#% makeinstall -C build
cd build
export DESTDIR=%{buildroot}
ninja install
install -d %{buildroot}%{_sysconfdir}/ld.so.conf.d
cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf << EOF
%{_libdir}/llvm
EOF
#install -d %{buildroot}%{_sysconfdir}/ld.so.conf.d
#cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf << EOF
#%{_libdir}/llvm
#EOF
%ifarch x86_64
# Needed for multilib (https://bugs.archlinux.org/task/29951)
# Header stub is taken from Fedora
mv %{buildroot}%{_includedir}/llvm/Config/llvm-config{,-64}.h
cp %{SOURCE6} %{buildroot}%{_includedir}/llvm/Config/llvm-config.h
%endif
rm -f %{buildroot}%{_datadir}/doc/clang/html/.buildinfo
rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
@ -228,6 +259,10 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_bindir}/lli
#%{_bindir}/lli-child-target
%{_bindir}/llvm*
%{_bindir}/ld64.lld
%{_bindir}/ld.lld
%{_bindir}/lld
%{_bindir}/lld-link
#%{_bindir}/macho-dump
#%{_bindir}/c-index-test
%{_bindir}/obj2yaml
@ -235,8 +270,9 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_bindir}/sanstats
%{_bindir}/verify-uselistorder
%{_bindir}/yaml2obj
%{_bindir}/wasm-ld
#%{_libdir}/ocaml/META.llvm
%exclude %{_bindir}/llvm-config
#%{_bindir}/llvm-config
%{_bindir}/opt
%{_bindir}/scan-build
%{_bindir}/scan-view
@ -248,6 +284,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_datadir}/opt-viewer/*
%{_mandir}/man1/FileCheck.1*
%{_mandir}/man1/bugpoint.1*
%{_mandir}/man1/dsymutil.1*
%{_mandir}/man1/lit.1*
%{_mandir}/man1/llc.1*
%{_mandir}/man1/lli.1*
@ -264,6 +301,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_mandir}/man1/llvm-lib.1*
%{_mandir}/man1/llvm-link.1*
%{_mandir}/man1/llvm-nm.1*
%{_mandir}/man1/llvm-pdbutil.1*
%{_mandir}/man1/llvm-profdata.1*
%{_mandir}/man1/llvm-readobj.1*
%{_mandir}/man1/llvm-stress.1*
@ -280,14 +318,11 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_bindir}/clangd
%{_bindir}/count
%{_bindir}/find-all-symbols
%{_bindir}/ld.lld
%{_bindir}/liblldb-intel-mpxtable.so
%{_bindir}/lld
%{_bindir}/lld-link
%{_bindir}/lldb
%{_bindir}/lldb-argdumper
%{_bindir}/lldb-mi
%{_bindir}/lldb-server
%{_bindir}/lldb-test
%{_bindir}/lli-child-target
%{_bindir}/modularize
%{_bindir}/not
@ -300,15 +335,13 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%files -n libllvm
%defattr(-,root,root)
%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
%dir %{_libdir}/llvm
%{_libdir}/llvm/*.so.*
%{_libdir}/llvm/libLLVM-%{majver}.so
%exclude %{_libdir}/llvm/libclang.so.*
%{_libdir}/libLLVM-%{majver}.so
%{_libdir}/libLTO.so.*
%{_libdir}/liblldb.so.*
%{_libdir}/liblldbIntelFeatures.so.*
%files -n libllvm-devel
%defattr(-,root,root)
%{_bindir}/llvm-config
%{_includedir}/%{name}
%{_includedir}/%{name}-c
%dir %{_includedir}/lld
@ -318,11 +351,11 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
#%{_libdir}/%{name}/*.a
%dir %{_datadir}/doc/llvm/html/
%{_datadir}/doc/llvm/html/*
%{_libdir}/llvm/*.a
%{_libdir}/llvm/*.so
%exclude %{_libdir}/llvm/libLLVM-%{majver}.so
%dir %{_libdir}/llvm/cmake/llvm
%{_libdir}/llvm/cmake/llvm/*.cmake
%{_libdir}/*.a
%{_libdir}/*.so
%exclude %{_libdir}/libLLVM-%{majver}.so
%dir %{_libdir}/cmake/llvm
%{_libdir}/cmake/llvm/*.cmake
%doc README.txt
%files -n clang
@ -331,7 +364,6 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_bindir}/c-index-test
%{_bindir}/clang
%{_bindir}/clang++
%{_bindir}/clang-%{majver}
%{_bindir}/clang-*
%{_bindir}/git-clang-format
#%{_bindir}/clang-tblgen
@ -339,10 +371,10 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
#%{_bindir}/not
%{_prefix}/libexec/c++-analyzer
%{_prefix}/libexec/ccc-analyzer
%dir %{_libdir}/llvm/clang
%dir %{_libdir}/llvm/clang/%{version}
%{_libdir}/llvm/clang/%{version}/*
%{_libdir}/llvm/libclang.so.*
%dir %{_libdir}/clang
%dir %{_libdir}/clang/%{version}
%{_libdir}/clang/%{version}/*
%{_libdir}/libclang.so.*
%dir %{_datadir}/clang/
%{_datadir}/clang/*
%{_mandir}/man1/clang.1*
@ -355,81 +387,12 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
#%{_includedir}/clang-c/module.modulemap
%dir %{_includedir}/clang/ARCMigrate
%{_includedir}/clang/ARCMigrate/*.h
%dir %{_includedir}/clang/AST
%{_includedir}/clang/AST/*.h
%{_includedir}/clang/AST/*.def
%{_includedir}/clang/AST/*.inc
%dir %{_includedir}/clang/Analysis
%dir %{_includedir}/clang/Analysis/Analyses
%{_includedir}/clang/Analysis/Analyses/ThreadSafetyOps.def
%dir %{_includedir}/clang/Analysis/DomainSpecific
%{_includedir}/clang/Analysis/DomainSpecific/*.h
%dir %{_includedir}/clang/Analysis/FlowSensitive
%{_includedir}/clang/Analysis/FlowSensitive/DataflowValues.h
%dir %{_includedir}/clang/Analysis/Support
%{_includedir}/clang/Analysis/Support/BumpVector.h
%dir %{_includedir}/clang/ASTMatchers/
%{_includedir}/clang/ASTMatchers/*.h
%dir %{_includedir}/clang/ASTMatchers/Dynamic
%{_includedir}/clang/ASTMatchers/Dynamic/*.h
%{_includedir}/clang/Analysis/Analyses/*.h
%{_includedir}/clang/Analysis/*.h
%dir %{_includedir}/clang/Basic
%{_includedir}/clang/Basic/*.h
%{_includedir}/clang/Basic/*.def
%{_includedir}/clang/Basic/*.inc
%dir %{_includedir}/clang/CodeGen
%{_includedir}/clang/CodeGen/*.h
%dir %{_includedir}/clang/Config
%{_includedir}/clang/Config/config.h
%dir %{_includedir}/clang/Driver
%{_includedir}/clang/Driver/*.h
%{_includedir}/clang/Driver/Options.inc
%{_includedir}/clang/Driver/Types.def
%dir %{_includedir}/clang/Edit
%{_includedir}/clang/Edit/*.h
%dir %{_includedir}/clang/Format
%{_includedir}/clang/Format/Format.h
%dir %{_includedir}/clang/Frontend
%{_includedir}/clang/Frontend/*.h
%{_includedir}/clang/Frontend/*.def
%dir %{_includedir}/clang/FrontendTool
%{_includedir}/clang/FrontendTool/Utils.h
%dir %{_includedir}/clang/Index
%{_includedir}/clang/Index/*.h
%dir %{_includedir}/clang/Lex
%{_includedir}/clang/Lex/*.h
%dir %{_includedir}/clang/Parse
%{_includedir}/clang/Parse/*
%dir %{_includedir}/clang/Rewrite
%dir %{_includedir}/clang/Rewrite/Core
%{_includedir}/clang/Rewrite/Core/*.h
%dir %{_includedir}/clang/Rewrite/Frontend
%{_includedir}/clang/Rewrite/Frontend/*.h
%dir %{_includedir}/clang/Sema
%{_includedir}/clang/Sema/*.h
%{_includedir}/clang/Sema/*.inc
%dir %{_includedir}/clang/Serialization
%{_includedir}/clang/Serialization/*.h
%{_includedir}/clang/Serialization/*.inc
%dir %{_includedir}/clang/StaticAnalyzer
%dir %{_includedir}/clang/StaticAnalyzer/Checkers
%{_includedir}/clang/StaticAnalyzer/Checkers/*
%dir %{_includedir}/clang/StaticAnalyzer/Core
%{_includedir}/clang/StaticAnalyzer/Core/*.h
%{_includedir}/clang/StaticAnalyzer/Core/Analyses.def
%dir %{_includedir}/clang/StaticAnalyzer/Core/BugReporter
%{_includedir}/clang/StaticAnalyzer/Core/BugReporter/*.h
%dir %{_includedir}/clang/StaticAnalyzer/Core/PathSensitive
%{_includedir}/clang/StaticAnalyzer/Core/PathSensitive/*
%dir %{_includedir}/clang/StaticAnalyzer/Frontend
%{_includedir}/clang/StaticAnalyzer/Frontend/*.h
%dir %{_includedir}/clang/Tooling
%{_includedir}/clang/Tooling/*
%dir %{_includedir}/clang
%{_includedir}/clang/*
%dir %{_datadir}/doc/clang/html/
%{_datadir}/doc/clang/html/*
%dir %{_libdir}/llvm/cmake/clang
%{_libdir}/llvm/cmake/clang/*.cmake
%dir %{_libdir}/cmake/clang
%{_libdir}/cmake/clang/*.cmake
%doc tools/clang/{NOTES.txt,README.txt}
%doc tools/clang/docs
@ -439,7 +402,6 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_libdir}/ocaml/llvm/*.cmi
%{_libdir}/ocaml/llvm/*.mli
%{_libdir}/ocaml/META.llvm*
%{_libdir}/ocaml/stublibs/dllllvm*.so
%files ocaml-devel
%defattr(-,root,root)
@ -451,6 +413,18 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
#%doc llvm-extradocs/ocamldoc/html
%changelog
* Mon Jun 25 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.0-4mamba
- rebuilt with gcc 8.1.0
* Sun Jun 24 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.0-3mamba
- apply patches from Arch to possibly fix lld segfault
* Sat Jun 23 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.0-2mamba
- rebuilt with standard target libdir and other changes to try fixing lld crash with at least chromium build
* Tue Jun 19 2018 Automatic Build System <autodist@mambasoft.it> 6.0.0-1mamba
- automatic version update by autodist
* Mon Dec 25 2017 Automatic Build System <autodist@mambasoft.it> 5.0.1-1mamba
- automatic version update by autodist