automatic version update by autodist [release 15.0.6-1mamba;Sun Jan 01 2023]
This commit is contained in:
parent
8129537c7b
commit
a126fc9943
11
lldb-15.0.6-swig-4.1.0-2.patch
Normal file
11
lldb-15.0.6-swig-4.1.0-2.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- lldb-15.0.6.src/bindings/lua/lua-typemaps.swig.orig 2023-01-01 14:17:02.269067778 +0100
|
||||
+++ lldb-15.0.6.src/bindings/lua/lua-typemaps.swig 2023-01-01 14:17:28.746900301 +0100
|
||||
@@ -247,7 +247,7 @@
|
||||
// Typemap for file handles (e.g. used in SBDebugger::GetOutputFileHandle)
|
||||
|
||||
%typemap(out) lldb::FileSP {
|
||||
- lldb::FileSP &sp = $1;
|
||||
+ const lldb::FileSP &sp = $1;
|
||||
if (sp && sp->IsValid()) {
|
||||
luaL_Stream *p = (luaL_Stream *)lua_newuserdata(L, sizeof(luaL_Stream));
|
||||
p->closef = &LLDBSwigLuaCloseFileHandle;
|
11
lldb.spec
11
lldb.spec
@ -1,7 +1,7 @@
|
||||
%define gccver %(gcc -dumpversion)
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: lldb
|
||||
Version: 15.0.5
|
||||
Version: 15.0.6
|
||||
Release: 1mamba
|
||||
Summary: Next generation, high-performance debugger
|
||||
Group: Development/Languages
|
||||
@ -13,6 +13,7 @@ Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{
|
||||
Patch0: lldb-15.0.5-swig-4.1.0.patch
|
||||
Patch1: lldb-15.0.5-swig-4.1.0-2.patch
|
||||
Patch2: lldb-15.0.5-swig-typemap-const.patch
|
||||
Patch3: lldb-15.0.6-swig-4.1.0-2.patch
|
||||
License: NCSA
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -65,11 +66,14 @@ This package includes the lib%{name} API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}.src
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch0 -p2 -b .swig-4.1.0
|
||||
%patch1 -p1 -b .swig-4.1.0-2
|
||||
#%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
mkdir -p build
|
||||
cd build
|
||||
|
||||
@ -129,6 +133,9 @@ ninja install
|
||||
#%{_docdir}/lldb/*
|
||||
|
||||
%changelog
|
||||
* Sun Jan 01 2023 Automatic Build System <autodist@mambasoft.it> 15.0.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 26 2022 Automatic Build System <autodist@mambasoft.it> 15.0.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user