automatic version update by autodist [release 15.0.5-1mamba;Sat Nov 26 2022]
This commit is contained in:
parent
ce2ce5e8bc
commit
8129537c7b
18
lldb-15.0.5-swig-4.1.0-2.patch
Normal file
18
lldb-15.0.5-swig-4.1.0-2.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- lldb-15.0.5.src/bindings/interface/SBValueList.i.orig 2022-11-24 19:34:46.654380907 +0100
|
||||
+++ lldb-15.0.5.src/bindings/interface/SBValueList.i 2022-11-24 19:34:57.793368014 +0100
|
||||
@@ -103,7 +103,6 @@
|
||||
GetFirstValueByName (const char* name) const;
|
||||
|
||||
%extend {
|
||||
- %nothreadallow;
|
||||
std::string lldb::SBValueList::__str__ (){
|
||||
lldb::SBStream description;
|
||||
const size_t n = $self->GetSize();
|
||||
@@ -122,7 +121,6 @@
|
||||
--desc_len;
|
||||
return std::string(desc, desc_len);
|
||||
}
|
||||
- %clearnothreadallow;
|
||||
}
|
||||
|
||||
#ifdef SWIGPYTHON
|
13
lldb-15.0.5-swig-4.1.0.patch
Normal file
13
lldb-15.0.5-swig-4.1.0.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h b/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h
|
||||
index fac395807796c..942c65fcd241d 100644
|
||||
--- a/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h
|
||||
+++ b/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h
|
||||
@@ -122,7 +122,7 @@ class NativeRegisterContextLinux_ppc64le : public NativeRegisterContextLinux {
|
||||
int mode; // Defines if watchpoint is read/write/access.
|
||||
};
|
||||
|
||||
- std::array<DREG, 4> m_hwp_regs;
|
||||
+ std::array<DREG, 16> m_hwp_regs;
|
||||
|
||||
// 16 is just a maximum value, query hardware for actual watchpoint count
|
||||
uint32_t m_max_hwp_supported = 16;
|
22
lldb-15.0.5-swig-typemap-const.patch
Normal file
22
lldb-15.0.5-swig-typemap-const.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- lldb-15.0.5.src/bindings/lua/lua-typemaps.swig.orig 2022-11-26 16:36:43.056461280 +0100
|
||||
+++ lldb-15.0.5.src/bindings/lua/lua-typemaps.swig 2022-11-26 16:41:06.429936473 +0100
|
||||
@@ -247,7 +247,7 @@
|
||||
// Typemap for file handles (e.g. used in SBDebugger::GetOutputFileHandle)
|
||||
|
||||
%typemap(out) lldb::FileSP {
|
||||
- lldb::FileSP &sp = $1;
|
||||
+ const lldb::FileSP &sp = $1;
|
||||
if (sp && sp->IsValid()) {
|
||||
luaL_Stream *p = (luaL_Stream *)lua_newuserdata(L, sizeof(luaL_Stream));
|
||||
p->closef = &LLDBSwigLuaCloseFileHandle;
|
||||
--- lldb-15.0.5.src/bindings/python/python-typemaps.swig.orig 2022-11-26 16:35:16.128979395 +0100
|
||||
+++ lldb-15.0.5.src/bindings/python/python-typemaps.swig 2022-11-26 16:35:23.787933379 +0100
|
||||
@@ -435,7 +435,7 @@
|
||||
|
||||
%typemap(out) lldb::FileSP {
|
||||
$result = nullptr;
|
||||
- lldb::FileSP &sp = $1;
|
||||
+ const lldb::FileSP &sp = $1;
|
||||
if (sp) {
|
||||
PythonFile pyfile = unwrapOrSetPythonException(PythonFile::FromFile(*sp));
|
||||
if (!pyfile.IsValid())
|
18
lldb.spec
18
lldb.spec
@ -1,7 +1,7 @@
|
||||
%define gccver %(gcc -dumpversion)
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: lldb
|
||||
Version: 14.0.6
|
||||
Version: 15.0.5
|
||||
Release: 1mamba
|
||||
Summary: Next generation, high-performance debugger
|
||||
Group: Development/Languages
|
||||
@ -10,6 +10,9 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://llvm.org/
|
||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
|
||||
Patch0: lldb-15.0.5-swig-4.1.0.patch
|
||||
Patch1: lldb-15.0.5-swig-4.1.0-2.patch
|
||||
Patch2: lldb-15.0.5-swig-typemap-const.patch
|
||||
License: NCSA
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -25,7 +28,7 @@ BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libclang-devel >= 14.0.3
|
||||
BuildRequires: libclang-devel >= 15.0.5
|
||||
BuildRequires: llvm
|
||||
BuildRequires: lld
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
@ -62,11 +65,11 @@ This package includes the lib%{name} API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}.src
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch0 -p2 -b .swig-4.1.0
|
||||
%patch1 -p1 -b .swig-4.1.0-2
|
||||
#%patch2 -p1
|
||||
|
||||
%build
|
||||
#:<< __EOF
|
||||
mkdir -p build
|
||||
cd build
|
||||
|
||||
@ -77,7 +80,7 @@ cmake .. -G Ninja \
|
||||
-DLLDB_USE_SYSTEM_SIX=1 \
|
||||
-DPython3_EXECUTABLE=%{__python3} \
|
||||
-DPython3_LIBRARY=%{_libdir}/libpython%{python3_version}.so \
|
||||
-DLLDB_PYTHON_RELATIVE_PATH=%{_lib}/python3.7/site-packages \
|
||||
-DLLDB_PYTHON_RELATIVE_PATH=%{python3_sitearch} \
|
||||
-Wno-dev
|
||||
|
||||
ninja
|
||||
@ -126,6 +129,9 @@ ninja install
|
||||
#%{_docdir}/lldb/*
|
||||
|
||||
%changelog
|
||||
* Sat Nov 26 2022 Automatic Build System <autodist@mambasoft.it> 15.0.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jun 25 2022 Automatic Build System <autodist@mambasoft.it> 14.0.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user