automatic version update by autodist [release 18.1.5-1mamba;Sat May 04 2024]
This commit is contained in:
parent
2be568231c
commit
0306ef3a4c
@ -1,18 +0,0 @@
|
||||
--- lldb-15.0.5.src/bindings/interface/SBValueList.i.orig 2022-11-24 19:34:46.654380907 +0100
|
||||
+++ lldb-15.0.5.src/bindings/interface/SBValueList.i 2022-11-24 19:34:57.793368014 +0100
|
||||
@@ -103,7 +103,6 @@
|
||||
GetFirstValueByName (const char* name) const;
|
||||
|
||||
%extend {
|
||||
- %nothreadallow;
|
||||
std::string lldb::SBValueList::__str__ (){
|
||||
lldb::SBStream description;
|
||||
const size_t n = $self->GetSize();
|
||||
@@ -122,7 +121,6 @@
|
||||
--desc_len;
|
||||
return std::string(desc, desc_len);
|
||||
}
|
||||
- %clearnothreadallow;
|
||||
}
|
||||
|
||||
#ifdef SWIGPYTHON
|
@ -1,13 +0,0 @@
|
||||
diff --git a/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h b/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h
|
||||
index fac395807796c..942c65fcd241d 100644
|
||||
--- a/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h
|
||||
+++ b/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h
|
||||
@@ -122,7 +122,7 @@ class NativeRegisterContextLinux_ppc64le : public NativeRegisterContextLinux {
|
||||
int mode; // Defines if watchpoint is read/write/access.
|
||||
};
|
||||
|
||||
- std::array<DREG, 4> m_hwp_regs;
|
||||
+ std::array<DREG, 16> m_hwp_regs;
|
||||
|
||||
// 16 is just a maximum value, query hardware for actual watchpoint count
|
||||
uint32_t m_max_hwp_supported = 16;
|
@ -1,22 +0,0 @@
|
||||
--- lldb-15.0.5.src/bindings/lua/lua-typemaps.swig.orig 2022-11-26 16:36:43.056461280 +0100
|
||||
+++ lldb-15.0.5.src/bindings/lua/lua-typemaps.swig 2022-11-26 16:41:06.429936473 +0100
|
||||
@@ -247,7 +247,7 @@
|
||||
// Typemap for file handles (e.g. used in SBDebugger::GetOutputFileHandle)
|
||||
|
||||
%typemap(out) lldb::FileSP {
|
||||
- lldb::FileSP &sp = $1;
|
||||
+ const lldb::FileSP &sp = $1;
|
||||
if (sp && sp->IsValid()) {
|
||||
luaL_Stream *p = (luaL_Stream *)lua_newuserdata(L, sizeof(luaL_Stream));
|
||||
p->closef = &LLDBSwigLuaCloseFileHandle;
|
||||
--- lldb-15.0.5.src/bindings/python/python-typemaps.swig.orig 2022-11-26 16:35:16.128979395 +0100
|
||||
+++ lldb-15.0.5.src/bindings/python/python-typemaps.swig 2022-11-26 16:35:23.787933379 +0100
|
||||
@@ -435,7 +435,7 @@
|
||||
|
||||
%typemap(out) lldb::FileSP {
|
||||
$result = nullptr;
|
||||
- lldb::FileSP &sp = $1;
|
||||
+ const lldb::FileSP &sp = $1;
|
||||
if (sp) {
|
||||
PythonFile pyfile = unwrapOrSetPythonException(PythonFile::FromFile(*sp));
|
||||
if (!pyfile.IsValid())
|
@ -1,11 +0,0 @@
|
||||
--- lldb-15.0.6.src/bindings/lua/lua-typemaps.swig.orig 2023-01-01 14:17:02.269067778 +0100
|
||||
+++ lldb-15.0.6.src/bindings/lua/lua-typemaps.swig 2023-01-01 14:17:28.746900301 +0100
|
||||
@@ -247,7 +247,7 @@
|
||||
// Typemap for file handles (e.g. used in SBDebugger::GetOutputFileHandle)
|
||||
|
||||
%typemap(out) lldb::FileSP {
|
||||
- lldb::FileSP &sp = $1;
|
||||
+ const lldb::FileSP &sp = $1;
|
||||
if (sp && sp->IsValid()) {
|
||||
luaL_Stream *p = (luaL_Stream *)lua_newuserdata(L, sizeof(luaL_Stream));
|
||||
p->closef = &LLDBSwigLuaCloseFileHandle;
|
27
lldb.spec
27
lldb.spec
@ -1,7 +1,7 @@
|
||||
%define gccver %(gcc -dumpversion)
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: lldb
|
||||
Version: 18.1.4
|
||||
Version: 18.1.5
|
||||
Release: 1mamba
|
||||
Summary: Next generation, high-performance debugger
|
||||
Group: Development/Languages
|
||||
@ -12,10 +12,6 @@ URL: https://llvm.org/
|
||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/cmake-%{version}.src.tar.xz
|
||||
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/third-party-%{version}.src.tar.xz
|
||||
Patch0: lldb-15.0.5-swig-4.1.0.patch
|
||||
Patch1: lldb-15.0.5-swig-4.1.0-2.patch
|
||||
Patch2: lldb-15.0.5-swig-typemap-const.patch
|
||||
Patch3: lldb-15.0.6-swig-4.1.0-2.patch
|
||||
License: NCSA
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -74,12 +70,6 @@ mv lldb-%{version}.src lldb
|
||||
mv cmake-%{version}.src cmake
|
||||
mv third-party-%{version}.src third-party
|
||||
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch 0 -p2 -b .swig-4.1.0
|
||||
#%patch 1 -p1 -b .swig-4.1.0-2
|
||||
#%patch 3 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
mkdir -p build
|
||||
@ -90,9 +80,9 @@ cmake -G Ninja \
|
||||
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
|
||||
-DLLVM_LINK_LLVM_DYLIB=ON \
|
||||
-DLLDB_USE_SYSTEM_SIX=1 \
|
||||
-DPython3_EXECUTABLE=%{__python310} \
|
||||
-DPython3_LIBRARY=%{_libdir}/libpython%{python310_version}.so \
|
||||
-DLLDB_PYTHON_RELATIVE_PATH=%{python310_sitearch} \
|
||||
-DPython3_EXECUTABLE=%{__python3} \
|
||||
-DPython3_LIBRARY=%{_libdir}/libpython%{python3_version}.so \
|
||||
-DLLDB_PYTHON_RELATIVE_PATH=%{python3_sitearch} \
|
||||
-Wno-dev \
|
||||
../lldb
|
||||
|
||||
@ -116,9 +106,9 @@ ninja install
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/lldb
|
||||
%{_bindir}/lldb-*
|
||||
%dir %{python310_sitearch}/lldb
|
||||
%{python310_sitearch}/lldb/*
|
||||
%ifarch x86_64 aarch64
|
||||
%dir %{python3_sitearch}/lldb
|
||||
%{python3_sitearch}/lldb/*
|
||||
%ifarch x86_64
|
||||
%{_prefix}/lib/lua/*/lldb.so
|
||||
%endif
|
||||
|
||||
@ -142,6 +132,9 @@ ninja install
|
||||
#%{_docdir}/lldb/*
|
||||
|
||||
%changelog
|
||||
* Sat May 04 2024 Automatic Build System <autodist@openmamba.org> 18.1.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Apr 18 2024 Automatic Build System <autodist@openmamba.org> 18.1.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user