patch to revert setting for boardflags3 value in brcmfmac43455-sdio.raspberrypi files because not working on tested models [release 20210208-2mamba;Wed Mar 03 2021]
This commit is contained in:
parent
81017bbf8a
commit
21e8cd6ae0
@ -1,3 +1,4 @@
|
|||||||
# linux-firmware
|
# linux-firmware
|
||||||
|
|
||||||
Collection of firmware files used by the Linux Kernel.
|
Collection of firmware files used by the Linux Kernel.
|
||||||
|
|
||||||
|
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru linux-firmware-20210208/brcm.orig/brcmfmac43455-sdio.raspberrypi,4-model-b.txt linux-firmware-20210208/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
|
||||||
|
--- linux-firmware-20210208/brcm.orig/brcmfmac43455-sdio.raspberrypi,4-model-b.txt 2021-03-03 12:07:48.052343006 +0000
|
||||||
|
+++ linux-firmware-20210208/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt 2021-03-03 12:08:16.307867170 +0000
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
AvVmid_c0=1,165,2,100,2,100,2,100,2,100
|
||||||
|
boardflags=0x00480201
|
||||||
|
boardflags2=0x40800000
|
||||||
|
-boardflags3=0x48200100
|
||||||
|
+boardflags3=0x44200100
|
||||||
|
boardrev=0x1304
|
||||||
|
boardtype=0x6e4
|
||||||
|
btc_mode=1
|
@ -1,38 +1,6 @@
|
|||||||
# openmamba linux-firmware specfile
|
|
||||||
# Copyright (C) 2011-2013 by Silvan Calarco
|
|
||||||
#
|
|
||||||
# To build for a specific kernel target:
|
|
||||||
#
|
|
||||||
# rpm -ba --define="KERNEL_TARGET mamba" linux-firmware.spec
|
|
||||||
#
|
|
||||||
# default is "mamba"
|
|
||||||
#
|
|
||||||
|
|
||||||
%define kernel_majversion %(echo %KERNEL_VER | cut -d. -f1-2)
|
|
||||||
%define kernel_ver %(echo %KERNEL_VER | cut -d. -f1-3)
|
|
||||||
|
|
||||||
%if "%{?KERNEL_TARGET}" == ""
|
|
||||||
# build a mamba kernel by default
|
|
||||||
%ifarch arm
|
|
||||||
%define KERNEL_TARGET mamba-arm
|
|
||||||
%endif
|
|
||||||
%ifarch x86_64
|
|
||||||
%define KERNEL_TARGET mamba-x86_64
|
|
||||||
%endif
|
|
||||||
%ifarch %{ix86}
|
|
||||||
%define KERNEL_TARGET mamba
|
|
||||||
%endif
|
|
||||||
%else
|
|
||||||
%define KERNEL_TARGET_APPEND -%{KERNEL_TARGET}
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%if "%{?KERNEL_VER}" == ""
|
|
||||||
%define KERNEL_VER %(uname -r | sed "s|\\([0-9.]*\\)mamba|\\1|" )
|
|
||||||
%endif
|
|
||||||
|
|
||||||
Name: linux-firmware
|
Name: linux-firmware
|
||||||
Version: 20210208
|
Version: 20210208
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Collection of firmware files used by the Linux Kernel
|
Summary: Collection of firmware files used by the Linux Kernel
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -40,20 +8,10 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/
|
URL: https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/
|
||||||
Source: git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/master/linux-firmware-%{version}.tar.bz2
|
Source: git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/master/linux-firmware-%{version}.tar.bz2
|
||||||
# packaged created from git clone
|
Patch0: linux-firmware-20210208-brcmfmac43455-sdio.raspberrypi-fix-boardflags3.patch
|
||||||
# git clone git://git.kernel.org/pub/scm/linux/kernel/git/dwmw2/linux-firmware.git
|
|
||||||
# cd linux-firmware
|
|
||||||
# git archive --format=tar --prefix=linux-firmware-0.0.git20120908/ HEAD | xz > ../../SOURCES/linux-firmware-0.0.git20120908.tar.xz
|
|
||||||
License: Distributable
|
License: Distributable
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
#BuildRequires: kernel-%{KERNEL_TARGET} >= %{kernel_majversion}
|
|
||||||
#BuildRequires: kernel-%{KERNEL_TARGET} <= %{kernel_majversion}.255
|
|
||||||
#BuildRequires: kernel-%{KERNEL_TARGET}-sound >= %{kernel_majversion}
|
|
||||||
#BuildRequires: kernel-%{KERNEL_TARGET}-sound <= %{kernel_majversion}.255
|
|
||||||
#BuildRequires: kernel-%{KERNEL_TARGET}-wireless >= %{kernel_majversion}
|
|
||||||
#BuildRequires: kernel-%{KERNEL_TARGET}-wireless <= %{kernel_majversion}.255
|
|
||||||
#BuildRequires: kmod
|
|
||||||
Provides: iwlwifi-firmware
|
Provides: iwlwifi-firmware
|
||||||
Obsoletes: iwlwifi-firmware
|
Obsoletes: iwlwifi-firmware
|
||||||
Provides: rt2860-firmware
|
Provides: rt2860-firmware
|
||||||
@ -67,73 +25,19 @@ Obsoletes: rt2501-firmware
|
|||||||
Provides: linux_firmware
|
Provides: linux_firmware
|
||||||
Provides: linux-firmware-extra
|
Provides: linux-firmware-extra
|
||||||
Obsoletes: linux-firmware-extra
|
Obsoletes: linux-firmware-extra
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Collection of firmware files used by the Linux Kernel.
|
Collection of firmware files used by the Linux Kernel.
|
||||||
|
|
||||||
#%package extra
|
|
||||||
#Summary: Collection of extra firmware files that are not used by the Linux Kernel modules
|
|
||||||
#Group: System/Kernel and Hardware
|
|
||||||
#Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
#
|
|
||||||
#%description extra
|
|
||||||
#Collection of extra firmware files that are not used by the Linux Kernel modules.
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
#[ -e /lib/modules/%{KERNEL_VER}%{KERNEL_TARGET}/modules.order ] || {
|
|
||||||
# echo "ERROR: missing a file that indicates that kernel version here is wrong; aborting."
|
|
||||||
# exit 1
|
|
||||||
#}
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall
|
%makeinstall
|
||||||
#install -d -m0755 %{buildroot}/lib/firmware
|
|
||||||
#cp -a * %{buildroot}/lib/firmware/
|
|
||||||
|
|
||||||
#find /lib/modules/%{KERNEL_VER}%{KERNEL_TARGET}/ -type f -name *.ko | \
|
|
||||||
#while read l; do
|
|
||||||
# /sbin/modinfo $l | grep ^firmware: | sed "s|firmware:[[:space:]]*|/lib/firmware/|" >> extracted-kernel-firmware.list
|
|
||||||
#done
|
|
||||||
|
|
||||||
#cat extracted-kernel-firmware.list | sort -u > kernel-firmware.list
|
|
||||||
#while read l; do
|
|
||||||
# [ -e %{buildroot}${l} ] && echo "${l}" >> matching-firmware.list
|
|
||||||
#done < kernel-firmware.list
|
|
||||||
|
|
||||||
#pushd %{buildroot}/lib/firmware
|
|
||||||
## atk3k-1.fw needs microcode files in /lib/firmware/ar3k
|
|
||||||
#grep "ath3k-1.fw" %{_builddir}/%{name}-%{version}/matching-firmware.list && {
|
|
||||||
# find ar3k/ -type f | \
|
|
||||||
# while read l; do
|
|
||||||
# [ -e %{buildroot}/lib/firmware/${l} ] && echo "/lib/firmware/${l}" >> %{_builddir}/%{name}-%{version}/matching-firmware.list
|
|
||||||
# done
|
|
||||||
#}
|
|
||||||
|
|
||||||
## add symlinked files
|
|
||||||
#find -type l -exec readlink -f {} \; | \
|
|
||||||
# while read l; do
|
|
||||||
# n=`echo "${l/*\/lib\/firmware\/}"`
|
|
||||||
# grep ${n} %{_builddir}/%{name}-%{version}/matching-firmware.list || \
|
|
||||||
# echo "/lib/firmware/${n}" >> %{_builddir}/%{name}-%{version}/matching-firmware.list
|
|
||||||
# done
|
|
||||||
#popd
|
|
||||||
|
|
||||||
#find %{buildroot}/lib/firmware/ \( -type f -or -type l \) -and \
|
|
||||||
# -not -name LICENSE\* -and -not -name LICENCE\* -and -not -name GPL-3 | \
|
|
||||||
#while read l; do
|
|
||||||
# f=`echo $l | sed "s|%{buildroot}||"`
|
|
||||||
# grep "^$f$" matching-firmware.list || echo "${f}" >> not-matching-firmware.list
|
|
||||||
#done
|
|
||||||
#%ifarch arm
|
|
||||||
## Conflicting with raspberrypi-firmware
|
|
||||||
#rm -f %{buildroot}/lib/firmware/brcm/brcmfmac43430-sdio.bin
|
|
||||||
#%endif
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -144,6 +48,9 @@ Collection of firmware files used by the Linux Kernel.
|
|||||||
/lib/firmware/*
|
/lib/firmware/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 03 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 20210208-2mamba
|
||||||
|
- patch to revert setting for boardflags3 value in brcmfmac43455-sdio.raspberrypi files because not working on tested models
|
||||||
|
|
||||||
* Thu Feb 11 2021 Automatic Build System <autodist@mambasoft.it> 20210208-1mamba
|
* Thu Feb 11 2021 Automatic Build System <autodist@mambasoft.it> 20210208-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user