update to 2.29 [release 2.29-1mamba;Fri May 17 2024]
This commit is contained in:
parent
b637088d77
commit
0b50893118
121
links-2.29-configure-c99.patch
Normal file
121
links-2.29-configure-c99.patch
Normal file
@ -0,0 +1,121 @@
|
||||
Most of the issues are historic problems in autoconf 2.13, but the
|
||||
memrchr change is package-specific and needs to be upstreamed.
|
||||
|
||||
Furthermore, upstream still seems to be using autoconf 2.13 for
|
||||
new releases, so until they switch, we'll have to keep patching this
|
||||
downstream.
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 477d84bfd3092e41..3562cc6a3d9a09b0 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -995,7 +995,7 @@ cat > conftest.$ac_ext << EOF
|
||||
#line 998 "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
-main(){return(0);}
|
||||
+int main(){return(0);}
|
||||
EOF
|
||||
if { (eval echo configure:1003: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
ac_cv_prog_cc_works=yes
|
||||
@@ -1258,8 +1258,8 @@ else
|
||||
#define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
|
||||
#define XOR(e, f) (((e) && !(f)) || (!(e) && (f)))
|
||||
int main () { int i; for (i = 0; i < 256; i++)
|
||||
-if (XOR (islower (i), ISLOWER (i)) || toupper (i) != TOUPPER (i)) exit(2);
|
||||
-exit (0); }
|
||||
+if (XOR (islower (i), ISLOWER (i)) || toupper (i) != TOUPPER (i)) return 2;
|
||||
+return 0; }
|
||||
|
||||
EOF
|
||||
if { (eval echo configure:1268: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
|
||||
@@ -2044,7 +2044,7 @@ for ac_kw in inline __inline__ __inline; do
|
||||
#include "confdefs.h"
|
||||
|
||||
int main() {
|
||||
-} $ac_kw foo() {
|
||||
+} $ac_kw int foo() {
|
||||
; return 0; }
|
||||
EOF
|
||||
if { (eval echo configure:2053: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
||||
@@ -2311,12 +2311,12 @@ else
|
||||
#include "confdefs.h"
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
-main()
|
||||
+int main(void)
|
||||
{
|
||||
FILE *f=fopen("conftestval", "w");
|
||||
- if (!f) exit(1);
|
||||
+ if (!f) return 1;
|
||||
fprintf(f, "%d\n", sizeof(unsigned short));
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo configure:2325: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
|
||||
@@ -2351,12 +2351,12 @@ else
|
||||
#include "confdefs.h"
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
-main()
|
||||
+int main(void)
|
||||
{
|
||||
FILE *f=fopen("conftestval", "w");
|
||||
- if (!f) exit(1);
|
||||
+ if (!f) return 1;
|
||||
fprintf(f, "%d\n", sizeof(unsigned));
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo configure:2365: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
|
||||
@@ -2391,12 +2391,12 @@ else
|
||||
#include "confdefs.h"
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
-main()
|
||||
+int main(void)
|
||||
{
|
||||
FILE *f=fopen("conftestval", "w");
|
||||
- if (!f) exit(1);
|
||||
+ if (!f) return 1;
|
||||
fprintf(f, "%d\n", sizeof(unsigned long));
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo configure:2405: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
|
||||
@@ -2432,12 +2432,12 @@ else
|
||||
#include "confdefs.h"
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
-main()
|
||||
+int main(void)
|
||||
{
|
||||
FILE *f=fopen("conftestval", "w");
|
||||
- if (!f) exit(1);
|
||||
+ if (!f) return 1;
|
||||
fprintf(f, "%d\n", sizeof(unsigned long long));
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo configure:2446: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
|
||||
@@ -4033,6 +4033,7 @@ else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 4037 "configure"
|
||||
#include "confdefs.h"
|
||||
+#define _GNU_SOURCE
|
||||
#include <string.h>
|
||||
int main() {
|
||||
char * volatile str = ""; volatile int l = 1; return !!memrchr(str, 0, l);
|
||||
@@ -8933,6 +8934,8 @@ cat > conftest.$ac_ext <<EOF
|
||||
#line 8932 "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
+char ${x_direct_test_function}(void);
|
||||
+
|
||||
int main() {
|
||||
${x_direct_test_function}()
|
||||
; return 0; }
|
58
links.spec
58
links.spec
@ -1,60 +1,64 @@
|
||||
Name: links
|
||||
Version: 2.15
|
||||
Version: 2.29
|
||||
Release: 1mamba
|
||||
Summary: A graphics and text mode web browser, released under GPL
|
||||
Group: Applications/Web
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://links.twibright.com/
|
||||
Source0: http://links.twibright.com/download/links-%{version}.tar.bz2
|
||||
Source1: %{name}-desktop
|
||||
Patch0: links-2.29-configure-c99.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
%if "%{?stage1}" != "1"
|
||||
BuildRequires: libdirectfb-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libX11-devel
|
||||
%endif
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libavif-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdirectfb-devel
|
||||
BuildRequires: libevent-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgomp-devel
|
||||
BuildRequires: libgpm-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: librsvg-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libwebp-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: pkgconfig
|
||||
%if "%{?stage1}" != "1"
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: /usr/bin/convert
|
||||
%endif
|
||||
Provides: links2 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Obsoletes: links2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Provides: links2
|
||||
Obsoletes: links2 < 2.25
|
||||
|
||||
%description
|
||||
Links2 runs in graphics mode (mouse required) on X Window System (UN*X, Cygwin), SVGAlib, Linux Framebuffer, OS/2 PMShell, AtheOS GUI or in text mode (mouse optional) on UN*X console, ssh/telnet virtual terminal, vt100 terminal, xterm, and virtually any other text terminal.
|
||||
Mouse is supported for GPM, xterm, and OS/2.
|
||||
Links supports colors on terminal.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%define _default_patch_fuzz 2
|
||||
%patch 0 -p1 -b .configure-c99
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-javascript \
|
||||
--without-pmshell \
|
||||
--without-atheos \
|
||||
--without-svgalib \
|
||||
%if "%{?stage1}" == "1"
|
||||
--without-gpm \
|
||||
--without-ssl
|
||||
%else
|
||||
--with-libfl \
|
||||
--enable-graphics \
|
||||
--with-x
|
||||
%endif
|
||||
--with-ssl
|
||||
|
||||
%make
|
||||
|
||||
@ -94,9 +98,13 @@ exit 0
|
||||
%{_datadir}/pixmaps/links.png
|
||||
%endif
|
||||
%{_mandir}/man1/links.*
|
||||
%doc AUTHORS COPYING ChangeLog NEWS README
|
||||
%doc AUTHORS COPYING
|
||||
#ChangeLog NEWS README
|
||||
|
||||
%changelog
|
||||
* Fri May 17 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.29-1mamba
|
||||
- update to 2.29
|
||||
|
||||
* Sat Mar 24 2018 Automatic Build System <autodist@mambasoft.it> 2.15-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user