217 lines
6.8 KiB
RPMSpec
217 lines
6.8 KiB
RPMSpec
Name: libz
|
|
Version: 1.2.11
|
|
Release: 4mamba
|
|
Summary: The zlib compression and decompression library
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.gzip.org/zlib/
|
|
Source: http://www.zlib.net/zlib-%{version}.tar.gz
|
|
Patch0: %{name}-1.2.4-missing_zutil_header.patch
|
|
Patch1: libz-1.2.4-autotools.patch
|
|
Patch2: libz-1.2.5-gentoo.patch
|
|
License: BSD
|
|
Obsoletes: zlib
|
|
Provides: zlib = %{version}-%{release}
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
## AUTOBUILDREQ-END
|
|
%ifarch x86_64
|
|
Obsoletes: lib32-libz
|
|
%endif
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
The zlib compression library provides in-memory compression and decompression functions, including integrity checks of the uncompressed data.
|
|
This version of the library supports only one compression method (deflation), but other algorithms may be added later, which will have the same stream interface.
|
|
The zlib library is used by many different system programs.
|
|
|
|
%package devel
|
|
Summary: Static libraries and headers for %{name}
|
|
Group: Development/Libraries
|
|
Obsoletes: zlib-devel
|
|
Provides: zlib-devel = %{version}-%{release}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
The zlib compression library provides in-memory compression and decompression functions, including integrity checks of the uncompressed data.
|
|
This version of the library supports only one compression method (deflation), but other algorithms may be added later, which will have the same stream interface.
|
|
The zlib library is used by many different system programs.
|
|
|
|
This package contains static libraries and header files needed for development.
|
|
|
|
%package -n libminizip1
|
|
Summary: Minizip manipulates files from a .zip archive
|
|
Group: System/Libraries
|
|
Provides: minizip
|
|
Obsoletes: minizip
|
|
|
|
%description -n libminizip1
|
|
Minizip manipulates files from a .zip archive.
|
|
|
|
%package -n libminizip1-devel
|
|
Summary: Static libraries and headers for libminizip
|
|
Group: Development/Libraries
|
|
Requires: libminizip1 = %{?epoch:%epoch:}%{version}-%{release}
|
|
Provides: minizip-devel
|
|
Obsoletes: minizip-devel
|
|
|
|
%description -n libminizip1-devel
|
|
Minizip manipulates files from a .zip archive.
|
|
|
|
This package contains static libraries and header files needed for development.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n zlib-%{version}
|
|
#%patch0 -p1 -b .missing_zutil_header
|
|
#%patch1 -p1 -b .atools
|
|
#%patch2 -p1 -b .g
|
|
|
|
%build
|
|
CC=%{_target_platform}-gcc \
|
|
CFLAGS="%{optflags}" \
|
|
CXXLAGS="%{optflags}" \
|
|
./configure --prefix=%{_prefix} --libdir=%{_libdir}
|
|
|
|
%make
|
|
|
|
cd contrib/minizip
|
|
cp Makefile Makefile.orig
|
|
cp ../README.contrib readme.txt
|
|
autoreconf --install
|
|
%configure --enable-static=no
|
|
%make CC=%{_host}-gcc
|
|
cd ../..
|
|
|
|
%if "%{_target_cpu}" == "%{_build_cpu}"
|
|
%make test
|
|
%endif
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
%makeinstall
|
|
|
|
#install -d %{buildroot}/%{_lib}
|
|
#mv %{buildroot}%{_libdir}/libz.so.* %{buildroot}/%{_lib}
|
|
#ln -sf ../../%{_lib}/libz.so.%{version} %{buildroot}%{_libdir}/libz.so
|
|
|
|
cd contrib/minizip
|
|
%makeinstall
|
|
cd ../..
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%post -n libminizip1 -p /sbin/ldconfig
|
|
%postun -n libminizip1 -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libz.so.*
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%{_includedir}/*.h
|
|
%{_libdir}/libz.a
|
|
%{_libdir}/libz.so
|
|
%{_libdir}/pkgconfig/zlib.pc
|
|
%{_mandir}/man3/zlib.*
|
|
%doc ChangeLog FAQ README
|
|
|
|
%files -n libminizip1
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libminizip.so.*
|
|
|
|
%files -n libminizip1-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/minizip
|
|
%{_includedir}/minizip/*.h
|
|
%{_libdir}/libminizip.la
|
|
%{_libdir}/libminizip.so
|
|
%{_libdir}/pkgconfig/minizip.pc
|
|
%doc contrib/minizip/MiniZip64_info.txt contrib/minizip/MiniZip64_Changes.txt
|
|
|
|
%changelog
|
|
* Tue Sep 29 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.11-4mamba
|
|
- rebuilt with libminizip as libminizip1 legacy package; added debug package
|
|
|
|
* Thu Jan 16 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.11-3mamba
|
|
- x86_64: obsolete lib32-libz
|
|
|
|
* Sun Sep 30 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.11-2mamba
|
|
- move library from /%{_lib} to %{_libdir}
|
|
|
|
* Sat Jun 17 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.11-1mamba
|
|
- update to 1.2.11
|
|
- rebuilt with --enable-static=no for libminizip
|
|
|
|
* Sun Dec 11 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.8-2mamba
|
|
- install minizip headers for chromium
|
|
|
|
* Tue Apr 30 2013 Automatic Build System <autodist@mambasoft.it> 1.2.8-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 07 2012 Automatic Build System <autodist@mambasoft.it> 1.2.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 13 2012 Automatic Build System <autodist@mambasoft.it> 1.2.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 10 2010 gil <puntogil@libero.it> 1.2.5-3mamba
|
|
- add new sub package minizip
|
|
|
|
* Wed Aug 18 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.5-2mamba
|
|
- make libz.so symlink relative to make it work in cross-build enviroments
|
|
|
|
* Sat May 08 2010 Automatic Build System <autodist@mambasoft.it> 1.2.5-1mamba
|
|
- automatic update to 1.2.5 by autodist
|
|
|
|
* Sat Apr 10 2010 Davide Madrisan <davide.madrisan@gmail.com> 1.2.4-1mamba
|
|
- update to 1.2.4
|
|
- update patch
|
|
|
|
* Wed Jun 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.3-3mamba
|
|
- specfile updated
|
|
|
|
* Fri Sep 16 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.3-2qilnx
|
|
- fixed broken symlink libz.so
|
|
- modified package name from zlib to libz to match QiLinux standards
|
|
|
|
* Mon Sep 12 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.3-1qilnx
|
|
- update to version 1.2.3 by autospec
|
|
- cross platform build support
|
|
|
|
* Tue Jul 26 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.2-4qilnx
|
|
- fix for QSA-2005-081 (CAN-2005-1849)
|
|
|
|
* Thu Jul 07 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.2-3qilnx
|
|
- security fix QSA-2005-079 (CAN-2005-2096)
|
|
- use RPM_OPT_FLAGS
|
|
|
|
* Wed Jan 26 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.2-2qilnx
|
|
- added missing devel package requirement for main package
|
|
|
|
* Fri Nov 05 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.2-1qilnx
|
|
- update to version 1.2.2 by autospec
|
|
|
|
* Mon Sep 13 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.1-4qilnx
|
|
- security fix: CAN-2004-0797
|
|
|
|
* Fri May 14 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.1-3qilnx
|
|
- fixed zlib.so link
|
|
|
|
* Wed May 12 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.1-2qilnx
|
|
- added patch0: zutil.h is needed by some software at compile time
|
|
|
|
* Wed Mar 10 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.1-1qilnx
|
|
- specfile cleanups and version update
|
|
|
|
* Fri Apr 11 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it>
|
|
- creation of zlib package
|