automatic version update by autodist [release 1.2.8-1mamba;Tue Apr 30 2013]
This commit is contained in:
parent
42b0686dff
commit
c725cb9526
@ -1,2 +1,6 @@
|
|||||||
# libz
|
# libz
|
||||||
|
|
||||||
|
The zlib compression library provides in-memory compression and decompression functions, including integrity checks of the uncompressed data.
|
||||||
|
This version of the library supports only one compression method (deflation), but other algorithms may be added later, which will have the same stream interface.
|
||||||
|
The zlib library is used by many different system programs.
|
||||||
|
|
||||||
|
68
libz-1.2.4-autotools.patch
Normal file
68
libz-1.2.4-autotools.patch
Normal file
@ -0,0 +1,68 @@
|
|||||||
|
diff -up zlib-1.2.4/contrib/minizip/configure.ac.atools zlib-1.2.4/contrib/minizip/configure.ac
|
||||||
|
--- zlib-1.2.4/contrib/minizip/configure.ac.atools 2010-03-29 10:28:50.000000000 +0200
|
||||||
|
+++ zlib-1.2.4/contrib/minizip/configure.ac 2010-03-29 10:28:50.000000000 +0200
|
||||||
|
@@ -0,0 +1,13 @@
|
||||||
|
+# -*- Autoconf -*-
|
||||||
|
+# Process this file with autoconf to produce a configure script.
|
||||||
|
+
|
||||||
|
+AC_INIT([minizip], [1.2.4], [bugzilla.redhat.com])
|
||||||
|
+AC_CONFIG_SRCDIR([minigzip.c])
|
||||||
|
+AC_CONFIG_MACRO_DIR([m4])
|
||||||
|
+AM_INIT_AUTOMAKE([foreign])
|
||||||
|
+LT_INIT
|
||||||
|
+
|
||||||
|
+AC_SUBST([HAVE_UNISTD_H], [0])
|
||||||
|
+AC_CHECK_HEADER([unistd.h], [HAVE_UNISTD_H=1], [])
|
||||||
|
+AC_CONFIG_FILES([Makefile minizip.pc])
|
||||||
|
+AC_OUTPUT
|
||||||
|
diff -up zlib-1.2.4/contrib/minizip/Makefile.am.atools zlib-1.2.4/contrib/minizip/Makefile.am
|
||||||
|
--- zlib-1.2.4/contrib/minizip/Makefile.am.atools 2010-03-29 10:28:50.000000000 +0200
|
||||||
|
+++ zlib-1.2.4/contrib/minizip/Makefile.am 2010-03-29 10:32:11.000000000 +0200
|
||||||
|
@@ -0,0 +1,31 @@
|
||||||
|
+ACLOCAL_AMFLAGS = -I m4 --install
|
||||||
|
+
|
||||||
|
+lib_LTLIBRARIES = libminizip.la
|
||||||
|
+
|
||||||
|
+libminizip_la_SOURCES = \
|
||||||
|
+ ioapi.c \
|
||||||
|
+ mztools.c \
|
||||||
|
+ unzip.c \
|
||||||
|
+ zip.c
|
||||||
|
+
|
||||||
|
+# do not build the static version of libminizip
|
||||||
|
+libminizip_la_CFLAGS = -shared -I ../.. -L../..
|
||||||
|
+libminizip_la_LDFLAGS = -version-info 1:0:0 -lz
|
||||||
|
+
|
||||||
|
+minizip_includedir = $(includedir)/minizip
|
||||||
|
+minizip_include_HEADERS = \
|
||||||
|
+ crypt.h \
|
||||||
|
+ ioapi.h \
|
||||||
|
+ mztools.h \
|
||||||
|
+ unzip.h \
|
||||||
|
+ zip.h
|
||||||
|
+
|
||||||
|
+pkgconfigdir = $(libdir)/pkgconfig
|
||||||
|
+pkgconfig_DATA = minizip.pc
|
||||||
|
+
|
||||||
|
+EXTRA_PROGRAMS = miniunzip minizip
|
||||||
|
+
|
||||||
|
+miniunzip_SOURCES = miniunz.c
|
||||||
|
+miniunzip_LDADD = libminizip.la
|
||||||
|
+
|
||||||
|
+minizip_SOURCES = minizip.c
|
||||||
|
+minizip_LDADD = libminizip.la
|
||||||
|
diff -up zlib-1.2.4/contrib/minizip/minizip.pc.in.atools zlib-1.2.4/contrib/minizip/minizip.pc.in
|
||||||
|
--- zlib-1.2.4/contrib/minizip/minizip.pc.in.atools 2010-03-29 10:28:50.000000000 +0200
|
||||||
|
+++ zlib-1.2.4/contrib/minizip/minizip.pc.in 2010-03-29 10:28:50.000000000 +0200
|
||||||
|
@@ -0,0 +1,11 @@
|
||||||
|
+prefix=@prefix@
|
||||||
|
+exec_prefix=@exec_prefix@
|
||||||
|
+libdir=@libdir@
|
||||||
|
+includedir=@includedir@/minizip
|
||||||
|
+
|
||||||
|
+Name: minizip
|
||||||
|
+Description: Minizip zip file manipulation library
|
||||||
|
+Requires:
|
||||||
|
+Version: @PACKAGE_VERSION@
|
||||||
|
+Libs: -L${libdir} -lminizip -lz
|
||||||
|
+Cflags: -I${includedir}
|
13
libz-1.2.4-missing_zutil_header.patch
Normal file
13
libz-1.2.4-missing_zutil_header.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- zlib-1.2.4/Makefile.in 2010-03-14 03:10:27.000000000 +0100
|
||||||
|
+++ zlib-1.2.4/Makefile.in.fix 2010-04-11 14:57:04.000000000 +0200
|
||||||
|
@@ -182,8 +182,8 @@
|
||||||
|
|
||||||
|
install: install-libs
|
||||||
|
-@if [ ! -d $(DESTDIR)$(includedir) ]; then mkdir -p $(DESTDIR)$(includedir); fi
|
||||||
|
- cp zlib.h zconf.h $(DESTDIR)$(includedir)
|
||||||
|
- chmod 644 $(DESTDIR)$(includedir)/zlib.h $(DESTDIR)$(includedir)/zconf.h
|
||||||
|
+ cp zlib.h zconf.h zutil.h $(DESTDIR)$(includedir)
|
||||||
|
+ chmod 644 $(DESTDIR)$(includedir)/zlib.h $(DESTDIR)$(includedir)/zconf.h $(DESTDIR)$(includedir)/zutil.h
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
cd $(DESTDIR)$(includedir); rm -f zlib.h zconf.h
|
12
libz-1.2.5-gentoo.patch
Normal file
12
libz-1.2.5-gentoo.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up zlib-1.2.5/zlib.h.pom zlib-1.2.5/zlib.h
|
||||||
|
--- zlib-1.2.5/zlib.h.pom 2010-04-20 06:12:48.000000000 +0200
|
||||||
|
+++ zlib-1.2.5/zlib.h 2010-06-16 13:08:59.000000000 +0200
|
||||||
|
@@ -1578,7 +1578,7 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
|
||||||
|
# define gzoffset gzoffset64
|
||||||
|
# define adler32_combine adler32_combine64
|
||||||
|
# define crc32_combine crc32_combine64
|
||||||
|
-# ifdef _LARGEFILE64_SOURCE
|
||||||
|
+# ifndef _LARGEFILE64_SOURCE
|
||||||
|
ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
|
||||||
|
ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
|
||||||
|
ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));
|
232
libz.spec
Normal file
232
libz.spec
Normal file
@ -0,0 +1,232 @@
|
|||||||
|
Name: libz
|
||||||
|
Version: 1.2.8
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: The zlib compression and decompression library
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.gzip.org/zlib/
|
||||||
|
Source: http://www.zlib.net/zlib-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-1.2.4-missing_zutil_header.patch
|
||||||
|
Patch1: libz-1.2.4-autotools.patch
|
||||||
|
Patch2: libz-1.2.5-gentoo.patch
|
||||||
|
License: BSD
|
||||||
|
Obsoletes: zlib
|
||||||
|
Provides: zlib = %{version}-%{release}
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
The zlib compression library provides in-memory compression and decompression functions, including integrity checks of the uncompressed data.
|
||||||
|
This version of the library supports only one compression method (deflation), but other algorithms may be added later, which will have the same stream interface.
|
||||||
|
The zlib library is used by many different system programs.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Obsoletes: zlib-devel
|
||||||
|
Provides: zlib-devel = %{version}-%{release}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The zlib compression library provides in-memory compression and decompression functions, including integrity checks of the uncompressed data.
|
||||||
|
This version of the library supports only one compression method (deflation), but other algorithms may be added later, which will have the same stream interface.
|
||||||
|
The zlib library is used by many different system programs.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%package -n minizip
|
||||||
|
Summary: Minizip manipulates files from a .zip archive
|
||||||
|
Group: System/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Obsoletes: minizip-devel
|
||||||
|
|
||||||
|
%description -n minizip
|
||||||
|
Minizip manipulates files from a .zip archive.
|
||||||
|
|
||||||
|
%ifarch x86_64_disabled
|
||||||
|
%package -n lib32-libz
|
||||||
|
Summary: The zlib compression and decompression library (32 bit)
|
||||||
|
Group: System/Libraries
|
||||||
|
|
||||||
|
%description -n lib32-libz
|
||||||
|
The zlib compression library provides in-memory compression and decompression functions, including integrity checks of the uncompressed data.
|
||||||
|
This version of the library supports only one compression method (deflation), but other algorithms may be added later, which will have the same stream interface.
|
||||||
|
The zlib library is used by many different system programs.
|
||||||
|
|
||||||
|
%package -n lib32-libz-devel
|
||||||
|
Summary: 32bit static libraries and headers for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: lib32-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n lib32-libz-devel
|
||||||
|
The zlib compression library provides in-memory compression and decompression functions, including integrity checks of the uncompressed data.
|
||||||
|
This version of the library supports only one compression method (deflation), but other algorithms may be added later, which will have the same stream interface.
|
||||||
|
The zlib library is used by many different system programs.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n zlib-%{version}
|
||||||
|
%patch0 -p1 -b .missing_zutil_header
|
||||||
|
%patch1 -p1 -b .atools
|
||||||
|
#%patch2 -p1 -b .g
|
||||||
|
|
||||||
|
mkdir contrib/minizip/m4
|
||||||
|
cp test/minigzip.c contrib/minizip
|
||||||
|
iconv -f windows-1252 -t utf-8 <ChangeLog >ChangeLog.tmp
|
||||||
|
mv ChangeLog.tmp ChangeLog
|
||||||
|
|
||||||
|
%build
|
||||||
|
CC=%{_target_platform}-gcc \
|
||||||
|
CFLAGS="%{optflags}" \
|
||||||
|
CXXLAGS="%{optflags}" \
|
||||||
|
./configure --prefix=%{_prefix} --libdir=%{_libdir}
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
(
|
||||||
|
cd contrib/minizip
|
||||||
|
# autoreconf --install
|
||||||
|
# % configure \
|
||||||
|
# CPPFLAGS="-I%{_builddir}/zlib-%{version}" \
|
||||||
|
# LDFLAGS="-L%{_builddir}/zlib-%{version}"
|
||||||
|
%make CC=%{_host}-gcc
|
||||||
|
)
|
||||||
|
|
||||||
|
%if "%{_target_cpu}" == "%{_build_cpu}"
|
||||||
|
%make test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
install -d %{buildroot}/%{_lib}
|
||||||
|
mv %{buildroot}%{_libdir}/libz.so.* %{buildroot}/%{_lib}
|
||||||
|
ln -sf ../../%{_lib}/libz.so.%{version} %{buildroot}%{_libdir}/libz.so
|
||||||
|
|
||||||
|
cd contrib/minizip
|
||||||
|
install -D -m0755 minizip %{buildroot}%{_bindir}/minizip
|
||||||
|
install -D -m0755 miniunz %{buildroot}%{_bindir}/miniunz
|
||||||
|
cd ../..
|
||||||
|
|
||||||
|
%ifarch x86_64_disabled
|
||||||
|
make clean
|
||||||
|
CC=%{_target_platform}-gcc \
|
||||||
|
CFLAGS="%{optflags} -m32" \
|
||||||
|
CXXLAGS="%{optflags} -m32" \
|
||||||
|
./configure --prefix=%{_prefix} --libdir=%{_prefix}/lib
|
||||||
|
%make
|
||||||
|
make install-libs DESTDIR=%{buildroot}
|
||||||
|
|
||||||
|
install -d %{buildroot}/lib
|
||||||
|
mv %{buildroot}%{_prefix}/lib/libz.so.* %{buildroot}/lib
|
||||||
|
ln -sf ../../lib/libz.so.%{version} %{buildroot}%{_prefix}/lib/libz.so
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
/%{_lib}/libz.so.*
|
||||||
|
%{_mandir}/man3/zlib.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libz.a
|
||||||
|
%{_libdir}/libz.so
|
||||||
|
%{_libdir}/pkgconfig/zlib.pc
|
||||||
|
%{_includedir}/zconf.h
|
||||||
|
%{_includedir}/zlib.h
|
||||||
|
%{_includedir}/zutil.h
|
||||||
|
%doc ChangeLog FAQ README
|
||||||
|
|
||||||
|
%files -n minizip
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/minizip
|
||||||
|
%{_bindir}/miniunz
|
||||||
|
%doc contrib/minizip/MiniZip64_info.txt contrib/minizip/MiniZip64_Changes.txt
|
||||||
|
|
||||||
|
%ifarch x86_64_disabled
|
||||||
|
%files -n lib32-libz
|
||||||
|
%defattr(-,root,root)
|
||||||
|
/lib/libz.so.*
|
||||||
|
|
||||||
|
%files -n lib32-libz-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_prefix}/lib/libz.a
|
||||||
|
%{_prefix}/lib/libz.so
|
||||||
|
%{_prefix}/lib/pkgconfig/zlib.pc
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Apr 30 2013 Automatic Build System <autodist@mambasoft.it> 1.2.8-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon May 07 2012 Automatic Build System <autodist@mambasoft.it> 1.2.7-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Apr 13 2012 Automatic Build System <autodist@mambasoft.it> 1.2.6-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Nov 10 2010 gil <puntogil@libero.it> 1.2.5-3mamba
|
||||||
|
- add new sub package minizip
|
||||||
|
|
||||||
|
* Wed Aug 18 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.5-2mamba
|
||||||
|
- make libz.so symlink relative to make it work in cross-build enviroments
|
||||||
|
|
||||||
|
* Sat May 08 2010 Automatic Build System <autodist@mambasoft.it> 1.2.5-1mamba
|
||||||
|
- automatic update to 1.2.5 by autodist
|
||||||
|
|
||||||
|
* Sat Apr 10 2010 Davide Madrisan <davide.madrisan@gmail.com> 1.2.4-1mamba
|
||||||
|
- update to 1.2.4
|
||||||
|
- update patch
|
||||||
|
|
||||||
|
* Wed Jun 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.3-3mamba
|
||||||
|
- specfile updated
|
||||||
|
|
||||||
|
* Fri Sep 16 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.3-2qilnx
|
||||||
|
- fixed broken symlink libz.so
|
||||||
|
- modified package name from zlib to libz to match QiLinux standards
|
||||||
|
|
||||||
|
* Mon Sep 12 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.3-1qilnx
|
||||||
|
- update to version 1.2.3 by autospec
|
||||||
|
- cross platform build support
|
||||||
|
|
||||||
|
* Tue Jul 26 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.2-4qilnx
|
||||||
|
- fix for QSA-2005-081 (CAN-2005-1849)
|
||||||
|
|
||||||
|
* Thu Jul 07 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.2-3qilnx
|
||||||
|
- security fix QSA-2005-079 (CAN-2005-2096)
|
||||||
|
- use RPM_OPT_FLAGS
|
||||||
|
|
||||||
|
* Wed Jan 26 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.2-2qilnx
|
||||||
|
- added missing devel package requirement for main package
|
||||||
|
|
||||||
|
* Fri Nov 05 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.2-1qilnx
|
||||||
|
- update to version 1.2.2 by autospec
|
||||||
|
|
||||||
|
* Mon Sep 13 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.1-4qilnx
|
||||||
|
- security fix: CAN-2004-0797
|
||||||
|
|
||||||
|
* Fri May 14 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.1-3qilnx
|
||||||
|
- fixed zlib.so link
|
||||||
|
|
||||||
|
* Wed May 12 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.1-2qilnx
|
||||||
|
- added patch0: zutil.h is needed by some software at compile time
|
||||||
|
|
||||||
|
* Wed Mar 10 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.1-1qilnx
|
||||||
|
- specfile cleanups and version update
|
||||||
|
|
||||||
|
* Fri Apr 11 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it>
|
||||||
|
- creation of zlib package
|
Loading…
Reference in New Issue
Block a user