85 lines
2.3 KiB
RPMSpec
85 lines
2.3 KiB
RPMSpec
%define gitver %(echo %version | cut -d. -f3)
|
|
Name: libyuv
|
|
Version: 0.20240515git.8f039f6
|
|
Release: 1mamba
|
|
Summary: An open source project that includes YUV scaling and conversion functionality
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://chromium.googlesource.com/libyuv/libyuv/
|
|
Source: https://chromium.googlesource.com/libyuv/libyuv.git/stable@%{gitver}/libyuv-%{version}.tar.bz2
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libjpeg-devel
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
|
|
%description
|
|
libyuv is an open source project that includes YUV scaling and conversion functionality.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%package tools
|
|
Group: Applications/Graphics
|
|
Summary: Utility applications for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description tools
|
|
This package contains utility applications for %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
sed -i 's|yuvconvert ${JPEG_LIBRARY}|${ly_lib_shared} ${JPEG_LIBRARY}|g' CMakeLists.txt
|
|
sed -i "s|DESTINATION lib|DESTINATION %{_lib}|" CMakeLists.txt
|
|
|
|
%build
|
|
%cmake -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libyuv.so
|
|
%doc AUTHORS LICENSE
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
|
|
%{_includedir}/libyuv.h
|
|
%dir %{_includedir}/libyuv
|
|
%{_includedir}/libyuv/*.h
|
|
%{_libdir}/libyuv.a
|
|
%doc README.chromium README.md
|
|
|
|
%files tools
|
|
%defattr(-,root,root)
|
|
%{_bindir}/yuvconvert
|
|
|
|
%changelog
|
|
* Sun Jul 21 2024 Automatic Build System <autodist@openmamba.org> 0.20240515git.8f039f6-1mamba
|
|
- update to 0.20240515git.8f039f6
|
|
|
|
* Thu Mar 24 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20210428git.eb6e7bb-1mamba
|
|
- package created using the webbuild interface
|