rebuilt with python 2.7 [release 2.9.1-2mamba;Mon Nov 25 2013]

This commit is contained in:
Silvan Calarco 2024-01-06 06:13:29 +01:00
parent 38ef886a18
commit 32f13308d6
3 changed files with 244 additions and 0 deletions

View File

@ -1,2 +1,9 @@
# libxml2
This library allows to manipulate XML files.
It includes support to read, modify and write XML and HTML files.
There is DTDs support this includes parsing and validation even with complex DtDs, either at parse time or later once the document has been modified.
The output can be a simple SAX stream or and in-memory DOM like representations.
In this case one can use the built-in XPath and XPointer implementation to select subnodes or ranges.
A flexible Input/Output mechanism is available, with existing HTTP and FTP modules and combined to an URI library.

View File

@ -0,0 +1,12 @@
diff -Nru libxml2-2.7.8.orig//configure.in libxml2-2.7.8/configure.in
--- libxml2-2.7.8.orig//configure.in 2010-11-04 18:01:19.000000000 +0100
+++ libxml2-2.7.8/configure.in 2011-02-11 21:19:21.708818426 +0100
@@ -84,7 +84,7 @@
esac
fi
AC_SUBST(VERSION_SCRIPT_FLAGS)
-AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -z "$VERSION_SCRIPT_FLAGS"])
+AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -n "$VERSION_SCRIPT_FLAGS"])
dnl
dnl We process the AC_ARG_WITH first so that later we can modify

225
libxml2.spec Normal file
View File

@ -0,0 +1,225 @@
%define majver %(echo %version | cut -d. -f 1-2)
Name: libxml2
Version: 2.9.1
Release: 2mamba
Summary: Library providing XML and HTML support
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.xmlsoft.org/
# bugfixes: ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
Source: ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
#Source: http://ftp.gnome.org/pub/GNOME/sources/libxml2/%{majver}/libxml2-%{version}.tar.bz2
Patch0: %{name}-2.7.8-configure_fix_USE_VERSION_SCRIPT.patch
License: MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: bash
BuildRequires: glibc-devel
%if "%{stage1}" != "1"
BuildRequires: gtk-doc
BuildRequires: libpython-devel
%endif
BuildRequires: ldconfig
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
This library allows to manipulate XML files.
It includes support to read, modify and write XML and HTML files.
There is DTDs support this includes parsing and validation even with complex DtDs, either at parse time or later once the document has been modified.
The output can be a simple SAX stream or and in-memory DOM like representations.
In this case one can use the built-in XPath and XPointer implementation to select subnodes or ranges.
A flexible Input/Output mechanism is available, with existing HTTP and FTP modules and combined to an URI library.
%package devel
Group: Development/Libraries
Summary: Devel files for the library providing XML and HTML support
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
This library allows to manipulate XML files.
It includes support to read, modify and write XML and HTML files.
There is DTDs support this includes parsing and validation even with complex DtDs, either at parse time or later once the document has been modified.
The output can be a simple SAX stream or and in-memory DOM like representations.
In this case one can use the built-in XPath and XPointer implementation to select subnodes or ranges.
A flexible Input/Output mechanism is available, with existing HTTP and FTP modules and combined to an URI library.
This package contains static libraries and header files need for development.
%if "%{stage1}" != "1"
%package -n python-libxml2
Group: System/Libraries
Summary: Python support for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%py_requires
%description -n python-libxml2
Python support for libxml2.
%endif
%package utils
Group: Development/Libraries
Summary: Utilities for the libxml library providing XML and HTML support
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description utils
This package contains some utilities to manipulate XML files.
%package apidocs
Summary: %{name} API documentation
Group: Documentation
Requires: gtk-doc
%description apidocs
%{name} API documentation.
%prep
%setup -q
#%patch0 -p1
%build
#autoreconf
%configure \
--enable-shared \
--disable-static \
--with-legacy \
%if "%{stage1}" != "1"
--with-python=%{_prefix} \
PYTHON=%{__python} \
%else
--without-python \
--disable-gtk-doc
%endif
%make PYTHON_SITE_PACKAGES=%{python_sitearch}
#make tests
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall PYTHON_SITE_PACKAGES=%{python_sitearch}
install AUTHORS COPYING Copyright NEWS README TODO* \
%{buildroot}%{_datadir}/doc/%{name}-%{version}/
install -d -m 0755 %{buildroot}%{_sysconfdir}/sgml
install -d -m 0755 %{buildroot}%{_sysconfdir}/xml
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libxml2.so.*
%dir %{_sysconfdir}/sgml
%dir %{_sysconfdir}/xml
%files devel
%defattr(-,root,root)
%{_bindir}/xml2-config
%{_datadir}/aclocal/libxml.m4
%dir %{_datadir}/doc/libxml2-%{version}
%{_datadir}/doc/libxml2-%{version}/*
%{_includedir}/*
%{_libdir}/libxml2.la
%{_libdir}/libxml2.so
%{_libdir}/pkgconfig/*
%{_mandir}/man1/xml2-config.*
%{_mandir}/man3/*
%files utils
%defattr(-,root,root)
%{_bindir}/xmlcatalog
%{_bindir}/xmllint
%{_libdir}/xml2Conf.sh
%{_mandir}/man1/xmlcatalog.*
%{_mandir}/man1/xmllint.*
%if "%{stage1}" != "1"
%files -n python-libxml2
%defattr(-,root,root)
%{python_sitearch}/*
%{_datadir}/doc/libxml2-python-%{version}/
%endif
%files apidocs
%defattr(-,root,root)
%{_datadir}/gtk-doc/html/%{name}/
%changelog
* Mon Nov 25 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.1-2mamba
- rebuilt with python 2.7
* Sat Apr 27 2013 Automatic Build System <autodist@mambasoft.it> 2.9.1-1mamba
- automatic version update by autodist
* Fri Oct 12 2012 Automatic Build System <autodist@mambasoft.it> 2.9.0-1mamba
- automatic version update by autodist
* Sat Aug 11 2012 Automatic Build System <autodist@mambasoft.it> 2.8.0-1mamba
- automatic version update by autodist
* Fri Feb 11 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.8-1mamba
- update to 2.7.8
* Sat Jun 26 2010 Automatic Build System <autodist@mambasoft.it> 2.7.7-2mamba
- automatic rebuild by autodist
* Sun Apr 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.7-1mamba
- update to 2.7.7
* Sat Oct 24 2009 Automatic Build System <autodist@mambasoft.it> 2.7.6-1mamba
- automatic update by autodist
* Tue Sep 29 2009 Automatic Build System <autodist@mambasoft.it> 2.7.5-1mamba
- update to 2.7.5
* Tue Dec 09 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.30-2mamba
- rebuild with python 2.6
* Fri Nov 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.30-1mamba
- update to 2.6.30
* Wed Apr 11 2007 Davide Madrisan <davide.madrisan@gmail.com> 2.6.27-2mamba
- new subpackage apidocs with API documentation
- do not build static libraries
* Tue Apr 10 2007 Tiziano Pratellesi <tiziano.pratellesi@openmamba.org> 2.6.27-1mamba
- update to 2.6.27
* Thu Jan 04 2007 Davide Madrisan <davide.madrisan@qilinux.it> 2.6.26-1qilnx
- update to version 2.6.26 by autospec
- man3 page moved to devel package
* Fri Sep 23 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.6.22-1qilnx
- update to version 2.6.22 by autospec
- added build requirements and gtk-doc
- package `python-libxml2' requires python
* Tue Aug 09 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.20-1qilnx
- update to version 2.6.20 by autospec
* Tue Feb 23 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.17-2qilnx
- rebuilt with python support
* Tue Feb 22 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.17-1qilnx
- update to version 2.6.17 by autospec
- tests disables
* Fri Dec 10 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.15-2qilnx
- documentation moved to devel package
* Tue Nov 09 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.6.15-1qilnx
- updated to 2.6.15 (also fixes QSA-2004-053 (CAN-2004-989))
- moved xml2-config binary and man page to the devel package
* Mon Mar 01 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.6.7-1qilnx
- rebuilt with latest available version (include a security fix: CAN-2004-0110)
* Wed May 21 2003 Silvan Calarco <silvan.calarco@qinet.it> 2.5.7-1qilnx
- first build