rebuilt with libdav1d [release 1.2.12-2mamba;Mon May 23 2022]
This commit is contained in:
parent
a609c3b2f1
commit
89f9a6c7f1
20
libxine-1.2.12-libdav1d-1.0.0.patch
Normal file
20
libxine-1.2.12-libdav1d-1.0.0.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- a/src/video_dec/dav1d.c
|
||||||
|
+++ b/src/video_dec/dav1d.c
|
||||||
|
@@ -544,11 +544,17 @@
|
||||||
|
|
||||||
|
/* multithreading */
|
||||||
|
ncpu = xine_cpu_count();
|
||||||
|
+#if DAV1D_API_VERSION_MAJOR > 5
|
||||||
|
+ settings.n_threads = ncpu + 1;
|
||||||
|
+ xprintf(stream->xine, XINE_VERBOSITY_DEBUG, LOG_MODULE ": "
|
||||||
|
+ "Using %d threads\n", settings.n_threads);
|
||||||
|
+#else
|
||||||
|
settings.n_frame_threads = (ncpu > 8) ? 4 : (ncpu < 2) ? 1 : ncpu/2;
|
||||||
|
settings.n_tile_threads = MAX(1, ncpu - settings.n_frame_threads + 1);
|
||||||
|
xprintf(stream->xine, XINE_VERBOSITY_DEBUG, LOG_MODULE ": "
|
||||||
|
"Using %d frame threads, %d tile threads\n",
|
||||||
|
settings.n_frame_threads, settings.n_tile_threads);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* dri frame allocator */
|
||||||
|
settings.allocator.cookie = this;
|
23
libxine.spec
23
libxine.spec
@ -1,7 +1,7 @@
|
|||||||
%define pkgname xine-lib
|
%define pkgname xine-lib
|
||||||
|
|
||||||
Name: libxine
|
Name: libxine
|
||||||
Version: 1.2.11
|
Version: 1.2.12
|
||||||
Release: 2mamba
|
Release: 2mamba
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Summary: A free multimedia player. It plays back CDs, DVDs, and VCDs
|
Summary: A free multimedia player. It plays back CDs, DVDs, and VCDs
|
||||||
@ -14,12 +14,11 @@ Source: http://downloads.sourceforge.net/sourceforge/xine/%{pkgname}-%{ve
|
|||||||
Patch0: %{name}-1.1.19-ffmpeg.patch
|
Patch0: %{name}-1.1.19-ffmpeg.patch
|
||||||
Patch1: %{name}-1.2.2-fix_building_on_non_x86_systems.patch
|
Patch1: %{name}-1.2.2-fix_building_on_non_x86_systems.patch
|
||||||
Patch2: libxine-1.2.3-missing-header.patch
|
Patch2: libxine-1.2.3-missing-header.patch
|
||||||
|
Patch3: libxine-1.2.12-libdav1d-1.0.0.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: ldconfig
|
|
||||||
BuildRequires: libGConf-devel
|
BuildRequires: libGConf-devel
|
||||||
BuildRequires: libGL-devel
|
|
||||||
BuildRequires: libGLU-devel
|
BuildRequires: libGLU-devel
|
||||||
BuildRequires: libICE-devel
|
BuildRequires: libICE-devel
|
||||||
BuildRequires: libMagick-devel
|
BuildRequires: libMagick-devel
|
||||||
@ -50,8 +49,10 @@ BuildRequires: libe2fs-devel
|
|||||||
BuildRequires: libfaad2-devel
|
BuildRequires: libfaad2-devel
|
||||||
BuildRequires: libfame-devel
|
BuildRequires: libfame-devel
|
||||||
BuildRequires: libflac-devel
|
BuildRequires: libflac-devel
|
||||||
|
BuildRequires: libgcrypt-devel
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libglvnd-devel
|
||||||
BuildRequires: libgnome-vfs-devel
|
BuildRequires: libgnome-vfs-devel
|
||||||
BuildRequires: libgnutls-devel
|
BuildRequires: libgnutls-devel
|
||||||
BuildRequires: libgomp-devel
|
BuildRequires: libgomp-devel
|
||||||
@ -62,6 +63,7 @@ BuildRequires: libkrb5-devel
|
|||||||
BuildRequires: libmad-devel
|
BuildRequires: libmad-devel
|
||||||
BuildRequires: libmng-devel
|
BuildRequires: libmng-devel
|
||||||
BuildRequires: libmodplug-devel
|
BuildRequires: libmodplug-devel
|
||||||
|
BuildRequires: libmusepack-devel
|
||||||
BuildRequires: libnfs-devel
|
BuildRequires: libnfs-devel
|
||||||
BuildRequires: libnsl-devel
|
BuildRequires: libnsl-devel
|
||||||
BuildRequires: libogg-devel
|
BuildRequires: libogg-devel
|
||||||
@ -94,6 +96,7 @@ BuildRequires: libbonobo-devel
|
|||||||
BuildRequires: libgomp-devel
|
BuildRequires: libgomp-devel
|
||||||
BuildRequires: libIDL-devel
|
BuildRequires: libIDL-devel
|
||||||
BuildRequires: libslang-devel
|
BuildRequires: libslang-devel
|
||||||
|
BuildRequires: libdav1d-devel
|
||||||
%if "%{_target_cpu}" == "i586"
|
%if "%{_target_cpu}" == "i586"
|
||||||
BuildRequires: librte-devel
|
BuildRequires: librte-devel
|
||||||
%endif
|
%endif
|
||||||
@ -103,8 +106,7 @@ BuildRequires: transfig >= 3.2.4
|
|||||||
BuildRequires: ImageMagick
|
BuildRequires: ImageMagick
|
||||||
Provides: %{pkgname} = %{epoch}:%{version}-%{release}
|
Provides: %{pkgname} = %{epoch}:%{version}-%{release}
|
||||||
Requires: %{name}-tools = %{epoch}:%{version}-%{release}
|
Requires: %{name}-tools = %{epoch}:%{version}-%{release}
|
||||||
Obsoletes: libxine1
|
Obsoletes: libxine1 < 2:1.2.12
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
# FIXME (missing Build Requirements):
|
# FIXME (missing Build Requirements):
|
||||||
# - sgmltools
|
# - sgmltools
|
||||||
@ -125,7 +127,7 @@ Group: Development/Libraries
|
|||||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||||
Requires: %{name}-tools = %{epoch}:%{version}-%{release}
|
Requires: %{name}-tools = %{epoch}:%{version}-%{release}
|
||||||
Provides: %{pkgname}-devel = %{epoch}:%{version}-%{release}
|
Provides: %{pkgname}-devel = %{epoch}:%{version}-%{release}
|
||||||
Obsoletes: libxine1-devel
|
Obsoletes: libxine1-devel < 2:1.2.12
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
xine is a free (GPL-licensed) high-performance, portable and reusable multimedia playback engine.
|
xine is a free (GPL-licensed) high-performance, portable and reusable multimedia playback engine.
|
||||||
@ -148,6 +150,7 @@ This is the devel package for the xine-lib library.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{pkgname}-%{version}
|
%setup -q -n %{pkgname}-%{version}
|
||||||
#%patch2 -p1
|
#%patch2 -p1
|
||||||
|
%patch3 -p1 -b .libdav1d-1.0.0
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="$RPM_OPT_FLAGS -fomit-frame-pointer -Xlinker -zmuldefs"
|
export CFLAGS="$RPM_OPT_FLAGS -fomit-frame-pointer -Xlinker -zmuldefs"
|
||||||
@ -233,6 +236,12 @@ mv %{buildroot}%{_datadir}/doc/xine-lib \
|
|||||||
%{_datadir}/xine-lib/*
|
%{_datadir}/xine-lib/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 23 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.12-2mamba
|
||||||
|
- rebuilt with libdav1d
|
||||||
|
|
||||||
|
* Thu Mar 10 2022 Automatic Build System <autodist@mambasoft.it> 1.2.12-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Jan 22 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.11-2mamba
|
* Fri Jan 22 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.11-2mamba
|
||||||
- rebuilt without libesound
|
- rebuilt without libesound
|
||||||
|
|
||||||
@ -484,7 +493,7 @@ mv %{buildroot}%{_datadir}/doc/xine-lib \
|
|||||||
- new version rebuild
|
- new version rebuild
|
||||||
- added ESD (libesound) support
|
- added ESD (libesound) support
|
||||||
|
|
||||||
* Thu Dec 29 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1rc3a-1qilnx
|
* Mon Dec 29 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1rc3a-1qilnx
|
||||||
- rebuilt with latest rc ("emergency bugfix release")
|
- rebuilt with latest rc ("emergency bugfix release")
|
||||||
|
|
||||||
* Thu Dec 18 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1rc3-1qilnx
|
* Thu Dec 18 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1rc3-1qilnx
|
||||||
|
Loading…
Reference in New Issue
Block a user