added pkgconfig patch [release 1.1-3mamba;Wed Aug 20 2014]

This commit is contained in:
Silvan Calarco 2024-01-06 06:10:00 +01:00
parent d64f01241a
commit 358364b586
2 changed files with 71 additions and 1 deletions

View File

@ -0,0 +1,64 @@
From fc4f25c4d16aaff7dcb5dd42cc20b292f4eb2218 Mon Sep 17 00:00:00 2001
From: Dave Airlie <airlied@redhat.com>
Date: Tue, 4 Aug 2009 13:08:42 +1000
Subject: [PATCH] git add x86.pc
---
Makefile | 15 ++++++++++++---
x86.pc.in | 10 ++++++++++
2 files changed, 22 insertions(+), 3 deletions(-)
create mode 100644 x86.pc.in
diff --git a/Makefile b/Makefile
index 951b617..953a499 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
OBJECTS = x86-common.o
CFLAGS ?= -O2 -Wall -DDEBUG -g
LIBDIR ?= /usr/lib
+INCLUDEDIR ?= /usr/include
ifeq ($(BACKEND),x86emu)
OBJECTS += thunk.o x86emu/decode.o x86emu/debug.o x86emu/fpu.o \
@@ -29,10 +30,18 @@ objclean:
rm -f *.o *~
clean: objclean
- rm -f *.so.1 *.a
+ rm -f *.so.1 *.a x86.pc
-install: libx86.so.1
+x86.pc:
+ sed -e's,@prefix@,/usr,' x86.pc.in > x86.pc
+ sed -e's,@exec_prefix@,/usr,' -i x86.pc
+ sed -e's,@libdir@,${LIBDIR},' -i x86.pc
+ sed -e's,@includedir@,${INCLUDEDIR},' -i x86.pc
+ sed -e's,@PACKAGE_VERSION@,1.1,' -i x86.pc
+
+install: libx86.so.1 x86.pc
install -D libx86.so.1 $(DESTDIR)$(LIBDIR)/libx86.so.1
install -D libx86.a $(DESTDIR)$(LIBDIR)/libx86.a
+ install -D x86.pc $(DESTDIR)$(LIBDIR)/pkgconfig/x86.pc
ln -sf libx86.so.1 $(DESTDIR)$(LIBDIR)/libx86.so
- install -p -m 0644 -D lrmi.h $(DESTDIR)/usr/include/libx86.h
+ install -p -m 0644 -D lrmi.h $(DESTDIR)$(INCLUDEDIR)/libx86.h
diff --git a/x86.pc.in b/x86.pc.in
new file mode 100644
index 0000000..711d90d
--- /dev/null
+++ b/x86.pc.in
@@ -0,0 +1,10 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: x86
+Description: Library providing x86 emulator access
+Version: @PACKAGE_VERSION@
+Cflags: -I${includedir}
+Libs: -L${libdir} -lx86
--
1.5.4.1

View File

@ -1,6 +1,6 @@
Name: libx86
Version: 1.1
Release: 2mamba
Release: 3mamba
Summary: A hardware-independent library for executing real-mode x86 code
Group: System/Libraries
Vendor: openmamba
@ -9,6 +9,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.codon.org.uk/~mjg59/libx86/
Source: http://www.codon.org.uk/%7Emjg59/libx86/downloads/libx86-%{version}.tar.gz
Patch0: %{name}-0.99-ifmask.patch
Patch1: libx86-1.1-add-pkgconfig.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -30,6 +31,7 @@ This package contains the development files for %{name}.
%prep
%setup -q
%patch0 -p0
%patch1 -p1
%build
%make LIBDIR=%{_libdir} BACKEND=x86emu
@ -50,8 +52,12 @@ This package contains the development files for %{name}.
%{_libdir}/libx86.a
%{_libdir}/libx86.so
%{_includedir}/libx86.h
%{_libdir}/pkgconfig/x86.pc
%changelog
* Wed Aug 20 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1-3mamba
- added pkgconfig patch
* Wed Nov 21 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1-2mamba
- rebuilt with BACKEND=x86emu which makes it portable on non x86 archs (needs retest on x86)