automatic update by autodist [release 1.2-1mamba;Tue Oct 01 2013]
This commit is contained in:
parent
f2df19f0dc
commit
dd3a0f2252
@ -1,2 +1,4 @@
|
|||||||
# libwxsvg
|
# libwxsvg
|
||||||
|
|
||||||
|
wxSVG is C++ library to create, manipulate and render SVG files.
|
||||||
|
|
||||||
|
27
libwxsvg-1.0.7-avutil.patch
Normal file
27
libwxsvg-1.0.7-avutil.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
diff -Nru wxsvg-1.0.7.orig//configure wxsvg-1.0.7/configure
|
||||||
|
--- wxsvg-1.0.7.orig//configure 2010-10-10 18:18:59.000000000 +0200
|
||||||
|
+++ wxsvg-1.0.7/configure 2011-02-17 18:13:41.372955179 +0100
|
||||||
|
@@ -16510,9 +16510,9 @@
|
||||||
|
|
||||||
|
fi
|
||||||
|
# check path for old ffmpeg
|
||||||
|
- for ac_header in ffmpeg/avutil.h
|
||||||
|
+ for ac_header in libavutil/avutil.h
|
||||||
|
do :
|
||||||
|
- ac_fn_cxx_check_header_mongrel "$LINENO" "ffmpeg/avutil.h" "ac_cv_header_ffmpeg_avutil_h" "$ac_includes_default"
|
||||||
|
+ ac_fn_cxx_check_header_mongrel "$LINENO" "libavutil/avutil.h" "ac_cv_header_ffmpeg_avutil_h" "$ac_includes_default"
|
||||||
|
if test "x$ac_cv_header_ffmpeg_avutil_h" = x""yes; then :
|
||||||
|
cat >>confdefs.h <<_ACEOF
|
||||||
|
#define HAVE_FFMPEG_AVUTIL_H 1
|
||||||
|
diff -Nru wxsvg-1.0.7.orig//configure.in wxsvg-1.0.7/configure.in
|
||||||
|
--- wxsvg-1.0.7.orig//configure.in 2010-08-29 19:58:45.000000000 +0200
|
||||||
|
+++ wxsvg-1.0.7/configure.in 2011-02-17 18:14:13.172397867 +0100
|
||||||
|
@@ -183,7 +183,7 @@
|
||||||
|
if test x$enable_ffmpeg = xyes; then
|
||||||
|
PKG_CHECK_MODULES(FFMPEG, [libavformat >= 50.0.0 libavcodec >= 51.0.0 libavutil >= 49.0.0 libswscale])
|
||||||
|
# check path for old ffmpeg
|
||||||
|
- AC_CHECK_HEADERS([ffmpeg/avutil.h])
|
||||||
|
+ AC_CHECK_HEADERS([libavutil/avutil.h])
|
||||||
|
CXXFLAGS="$CXXFLAGS -DUSE_FFMPEG $FFMPEG_CFLAGS"
|
||||||
|
LIBS="$LIBS $FFMPEG_LIBS"
|
||||||
|
fi
|
137
libwxsvg.spec
Normal file
137
libwxsvg.spec
Normal file
@ -0,0 +1,137 @@
|
|||||||
|
Name: libwxsvg
|
||||||
|
Epoch: 1
|
||||||
|
Version: 1.2
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A C++ library to create, manipulate and render SVG files
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.wxsvg.org/
|
||||||
|
Source: http://downloads.sourceforge.net/wxsvg/wxsvg/%{version}/wxsvg-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-1.0.7-avutil.patch
|
||||||
|
License: LGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libart_lgpl-devel
|
||||||
|
BuildRequires: libavcodec-devel
|
||||||
|
BuildRequires: libavformat-devel
|
||||||
|
BuildRequires: libavutil-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libswscale-devel
|
||||||
|
BuildRequires: libwxBase-unicode-devel
|
||||||
|
BuildRequires: libwxGTK-unicode-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
Provides: wxsvg
|
||||||
|
Obsoletes: wxsvg
|
||||||
|
BuildRoot: %{_tmppath}/wxSVG-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
wxSVG is C++ library to create, manipulate and render SVG files.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Provides: wxsvg-devel
|
||||||
|
Obsoletes: wxsvg-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
wxSVG is C++ library to create, manipulate and render SVG files.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n wxsvg-%{version}
|
||||||
|
chmod +x configure
|
||||||
|
|
||||||
|
%build
|
||||||
|
#libtoolize --force
|
||||||
|
#./autogen.sh
|
||||||
|
%configure --enable-ffmpeg
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
#%{_bindir}/calculette
|
||||||
|
#%{_bindir}/svgui
|
||||||
|
%{_bindir}/svgview
|
||||||
|
%{_libdir}/libwxsvg.so.*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_includedir}/wxSVG/*.h
|
||||||
|
%{_includedir}/wxSVGXML/*.h
|
||||||
|
%{_libdir}/libwxsvg.a
|
||||||
|
%{_libdir}/libwxsvg.la
|
||||||
|
%{_libdir}/libwxsvg.so
|
||||||
|
%{_libdir}/pkgconfig/libwxsvg.pc
|
||||||
|
%doc ChangeLog TODO
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Oct 01 2013 Automatic Build System <autodist@mambasoft.it> 1.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Aug 27 2013 Automatic Build System <autodist@mambasoft.it> 1.1.16-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue May 28 2013 Automatic Build System <autodist@mambasoft.it> 1.1.15-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Apr 14 2013 Automatic Build System <autodist@mambasoft.it> 1.1.14-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Mar 01 2013 Automatic Build System <autodist@mambasoft.it> 1.1.13-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Jan 21 2013 Automatic Build System <autodist@mambasoft.it> 1.1.12-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Aug 16 2012 Automatic Build System <autodist@mambasoft.it> 1.1.9-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Oct 20 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.2-1mamba
|
||||||
|
- update to 1.1.2
|
||||||
|
|
||||||
|
* Sun Jul 24 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.10-1mamba
|
||||||
|
- update to 1.0.10
|
||||||
|
|
||||||
|
* Thu Feb 17 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.7-1mamba
|
||||||
|
- update to 1.0.7
|
||||||
|
- renamed from wxsvg to libwxsvg
|
||||||
|
|
||||||
|
* Wed Jun 30 2010 Automatic Build System <autodist@mambasoft.it> 1.0.1-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed Jun 09 2010 Automatic Build System <autodist@mambasoft.it> 1.0.1-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Dec 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-1mamba
|
||||||
|
- update to 1.0.1
|
||||||
|
|
||||||
|
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0b10-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0b10-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Jun 30 2008 gil <puntogil@libero.it> 1.0b10-1mamba
|
||||||
|
- update to 1.0b10
|
||||||
|
|
||||||
|
* Sun Feb 03 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0b8-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user