150 lines
4.8 KiB
RPMSpec
150 lines
4.8 KiB
RPMSpec
%define apiver %(echo %version | cut -d. -f 1-2)
|
|
|
|
Name: libwpd
|
|
Version: 0.10.3
|
|
Release: 2mamba
|
|
Summary: A library for importing WordPerfect (tm) documents
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://libwpd.sourceforge.net/
|
|
Source: http://prdownloads.sourceforge.net/libwpd/libwpd-%{version}.tar.gz
|
|
Patch0: libwpd-0.10.3-gcc-11.1.0.patch
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: librevenge-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: pkgconfig
|
|
BuildRequires: doxygen
|
|
|
|
%description
|
|
Libwpd is a C++ library designed to help process WordPerfect documents.
|
|
It is most commonly used to import WordPerfect documents into other word processors.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Static libraries and headers for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
Libwpd is a C++ library designed to help process WordPerfect documents.
|
|
It is most commonly used to import WordPerfect documents into other word processors.
|
|
Libwpd exposes a simple callback-based API, allowing it to be easily plugged into any C or C++ application.
|
|
It strictly depends only on an implementation of the STL, although by interfacing with a library which abstracts the Microsoft OLE format (such as libgsf), you gain the ability to import OLE-embedded WordPerfect documents.
|
|
This package contains static libraries and header files needed for development.
|
|
|
|
%package tools
|
|
Group: Applications/Publishing
|
|
Summary: Programs for manipulating WordPerfect documents
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description tools
|
|
Libwpd is a C++ library designed to help process WordPerfect documents.
|
|
This package package contains various programs for manipulating WordPerfect format files.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
%patch0 -p1
|
|
|
|
%build
|
|
%configure
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
%makeinstall
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libwpd-%{apiver}.so.*
|
|
#%{_libdir}/libwpd-stream-%{majorminor}.so.*
|
|
%doc CREDITS
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/libwpd-%{apiver}
|
|
%{_includedir}/libwpd-%{apiver}/*
|
|
%{_libdir}/libwpd-*.la
|
|
%{_libdir}/libwpd-*.so
|
|
%{_libdir}/pkgconfig/*.pc
|
|
%dir %{_docdir}/libwpd
|
|
%{_docdir}/libwpd/*
|
|
%doc ChangeLog TODO
|
|
|
|
%files tools
|
|
%defattr(-,root,root)
|
|
%{_bindir}/wpd2html
|
|
%{_bindir}/wpd2raw
|
|
%{_bindir}/wpd2text
|
|
%doc README
|
|
|
|
%changelog
|
|
* Sat Jun 12 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.3-2mamba
|
|
- rebuilt with debug package and gcc 11 patch
|
|
|
|
* Mon Jan 07 2019 Automatic Build System <autodist@mambasoft.it> 0.10.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Sep 13 2017 Automatic Build System <autodist@mambasoft.it> 0.10.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 31 2015 Automatic Build System <autodist@mambasoft.it> 0.10.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jun 17 2014 Automatic Build System <autodist@mambasoft.it> 0.10.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 18 2013 Automatic Build System <autodist@mambasoft.it> 0.9.9-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri May 17 2013 Automatic Build System <autodist@mambasoft.it> 0.9.8-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 12 2013 Automatic Build System <autodist@mambasoft.it> 0.9.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 0.9.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 03 2011 Automatic Build System <autodist@mambasoft.it> 0.9.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jul 23 2011 Automatic Build System <autodist@mambasoft.it> 0.9.2-1mamba
|
|
- automatic update to 3.0.3.0 by autodist
|
|
|
|
* Mon Jan 31 2011 Automatic Build System <autodist@mambasoft.it> 0.9.1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Nov 21 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.0-1mamba
|
|
- update to 0.9.0
|
|
|
|
* Wed Jul 08 2009 Automatic Build System <autodist@mambasoft.it> 0.8.14-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Aug 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.11-1mamba
|
|
- update to 0.8.11
|
|
|
|
* Wed Mar 21 2007 Davide Madrisan <davide.madrisan@qilinux.it> 0.8.9-1qilnx
|
|
- update to version 0.8.9 by autospec
|
|
- also fixes the security issue CVE-2007-0002
|
|
- new subpackage libwpd-tools
|
|
|
|
* Sun Oct 23 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.3-1qilnx
|
|
- update to version 0.8.3 by autospec
|
|
|
|
* Tue Aug 09 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.8.2-1qilnx
|
|
- package created by autospec
|