rebuilt with debug package and gcc 11 patch [release 0.10.3-2mamba;Sat Jun 12 2021]
This commit is contained in:
parent
3270fa8d28
commit
f2e5d68f5a
25
libwpd-0.10.3-gcc-11.1.0.patch
Normal file
25
libwpd-0.10.3-gcc-11.1.0.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff --git a/src/lib/WPXContentListener.cpp b/src/lib/WPXContentListener.cpp
|
||||||
|
index ab0f9b1..0b559e6 100644
|
||||||
|
--- a/src/lib/WPXContentListener.cpp
|
||||||
|
+++ b/src/lib/WPXContentListener.cpp
|
||||||
|
@@ -23,6 +23,7 @@
|
||||||
|
* Corel Corporation or Corel Corporation Limited."
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include <cstddef>
|
||||||
|
#include "WPXContentListener.h"
|
||||||
|
#include "WPXPageSpan.h"
|
||||||
|
#include "libwpd_internal.h"
|
||||||
|
diff --git a/src/lib/WPXTable.cpp b/src/lib/WPXTable.cpp
|
||||||
|
index 0ad202a..3ff35e1 100644
|
||||||
|
--- a/src/lib/WPXTable.cpp
|
||||||
|
+++ b/src/lib/WPXTable.cpp
|
||||||
|
@@ -25,6 +25,8 @@
|
||||||
|
* Corel Corporation or Corel Corporation Limited."
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include <cstddef>
|
||||||
|
+
|
||||||
|
#include "WPXTable.h"
|
||||||
|
|
||||||
|
#include "libwpd_internal.h"
|
16
libwpd.spec
16
libwpd.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: libwpd
|
Name: libwpd
|
||||||
Version: 0.10.3
|
Version: 0.10.3
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A library for importing WordPerfect (tm) documents
|
Summary: A library for importing WordPerfect (tm) documents
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -10,16 +10,17 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://libwpd.sourceforge.net/
|
URL: http://libwpd.sourceforge.net/
|
||||||
Source: http://prdownloads.sourceforge.net/libwpd/libwpd-%{version}.tar.gz
|
Source: http://prdownloads.sourceforge.net/libwpd/libwpd-%{version}.tar.gz
|
||||||
|
Patch0: libwpd-0.10.3-gcc-11.1.0.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: librevenge-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
BuildRequires: librevenge-devel
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Libwpd is a C++ library designed to help process WordPerfect documents.
|
Libwpd is a C++ library designed to help process WordPerfect documents.
|
||||||
@ -35,8 +36,7 @@ Libwpd is a C++ library designed to help process WordPerfect documents.
|
|||||||
It is most commonly used to import WordPerfect documents into other word processors.
|
It is most commonly used to import WordPerfect documents into other word processors.
|
||||||
Libwpd exposes a simple callback-based API, allowing it to be easily plugged into any C or C++ application.
|
Libwpd exposes a simple callback-based API, allowing it to be easily plugged into any C or C++ application.
|
||||||
It strictly depends only on an implementation of the STL, although by interfacing with a library which abstracts the Microsoft OLE format (such as libgsf), you gain the ability to import OLE-embedded WordPerfect documents.
|
It strictly depends only on an implementation of the STL, although by interfacing with a library which abstracts the Microsoft OLE format (such as libgsf), you gain the ability to import OLE-embedded WordPerfect documents.
|
||||||
|
This package contains static libraries and header files needed for development.
|
||||||
This package contains static libraries and header files need for development.
|
|
||||||
|
|
||||||
%package tools
|
%package tools
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
@ -47,8 +47,11 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
Libwpd is a C++ library designed to help process WordPerfect documents.
|
Libwpd is a C++ library designed to help process WordPerfect documents.
|
||||||
This package package contains various programs for manipulating WordPerfect format files.
|
This package package contains various programs for manipulating WordPerfect format files.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -89,6 +92,9 @@ This package package contains various programs for manipulating WordPerfect form
|
|||||||
%doc README
|
%doc README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jun 12 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.3-2mamba
|
||||||
|
- rebuilt with debug package and gcc 11 patch
|
||||||
|
|
||||||
* Mon Jan 07 2019 Automatic Build System <autodist@mambasoft.it> 0.10.3-1mamba
|
* Mon Jan 07 2019 Automatic Build System <autodist@mambasoft.it> 0.10.3-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user