This repository has been archived on 2024-11-07. You can view files and clone it, but cannot push or open issues or pull requests.
libwebkit-gtk3/libwebkit-gtk3.spec

502 lines
18 KiB
RPMSpec

# --enable-debug turn on debugging [default=no]
# --enable-indexeddb enable the indexed database API [default=no]
# --enable-input-speech enable the speech input API [default=no] broken
# --enable-image-resizer enable image resizer [default=no]
# --enable-wml enable support for WML [default=no]
# --enable-directory-upload enable support for directory upload [default=no]
# --enable-file-system enable support for HTML5 FileSystem API [default=no]
# --enable-web-timing enable support for Web Timing [default=no]
# --enable-blob enable support for Blob [default=no]
# --enable-coverage enable code coverage support [default=no]
# --enable-opcode-stats Enable Opcode statistics (default: disabled)
# --enable-gtk-doc use gtk-doc to build documentation [[default=no]]
# --enable-gtk-doc-pdf build documentation in pdf format [[default=no]]
# --with-gtk=2.0|3.0 the GTK+ version to use (default: 2.0)
%define majver %(echo %version | cut -d. -f 1-2)
Name: libwebkit-gtk3
Version: 2.4.11
Release: 1mamba
Summary: Port of WebKit embeddable web component to GTK+
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
##URL: http://live.gnome.org/WebKitGtk
URL: http://www.webkitgtk.org/
Source0: http://www.webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
Patch0: libwebkit-gtk-1.3.10-nspluginwrapper.patch
Patch1: libwebkit-gtk-1.3.10-no-execmem.patch
Patch2: libwebkit-gtk-1.3.10-stamp-po.patch
Patch3: libwebkit-gtk-1.8.2-bison-2.6.patch
Patch4: libwebkit-gtk3-2.0.0-missing-header.patch
Patch5: libwebkit-gtk3-2.4.11-gcc-6.1.patch
License: BSD, LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libcairo-devel
BuildRequires: libdbus-devel
BuildRequires: libdbus-glib-devel
BuildRequires: libenchant-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libgeoclue-devel
BuildRequires: libGL-devel
BuildRequires: libglib-devel
BuildRequires: libgst-plugins-base-devel
BuildRequires: libgstreamer-devel
BuildRequires: libgtk2-devel
BuildRequires: libgtk-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libicu-devel
BuildRequires: libjpeg-devel
BuildRequires: libpango-devel
BuildRequires: libpng-devel
BuildRequires: libsecret-devel
BuildRequires: libselinux-devel
BuildRequires: libsoup-devel
BuildRequires: libsqlite-devel
BuildRequires: libstdc++6-devel
BuildRequires: libwebp-devel
BuildRequires: libX11-devel
BuildRequires: libXcomposite-devel
BuildRequires: libXdamage-devel
BuildRequires: libXfixes-devel
BuildRequires: libxml2-devel
BuildRequires: libXrender-devel
BuildRequires: libxslt-devel
BuildRequires: libXt-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
#BuildRequires: libgcrypt-devel
#BuildRequires: libglitz-devel
#BuildRequires: libgnutls-devel
#BuildRequires: libgpg-error-devel
#BuildRequires: libpixman-devel
#BuildRequires: libpthread-stubs-devel
#BuildRequires: libselinux-devel
#BuildRequires: libSM-devel
#BuildRequires: libtasn1-devel
#BuildRequires: libuuid-devel
#BuildRequires: libXau-devel
#BuildRequires: libxcb-devel
#BuildRequires: libxcb-util-devel
#BuildRequires: libXcursor-devel
#BuildRequires: libXdmcp-devel
#BuildRequires: libXext-devel
#BuildRequires: libXinerama-devel
#BuildRequires: libXrandr-devel
BuildRequires: bison
BuildRequires: flex
BuildRequires: GConf-devel
BuildRequires: gobject-introspection-devel
BuildRequires: gperf
BuildRequires: gst-plugins-bad-devel
BuildRequires: icu
#BuildRequires: libavahi-devel
#BuildRequires: libcares-devel
#BuildRequires: libcurl-devel
#BuildRequires: libe2fs-devel
#BuildRequires: libgnome-keyring-devel
#BuildRequires: libgnome-vfs-devel
#BuildRequires: libidn-devel
#BuildRequires: libkrb5-devel
#BuildRequires: libopenldap-devel
#BuildRequires: libopenssl-devel
#BuildRequires: libpcre-devel
#BuildRequires: libqt4-devel
#BuildRequires: librsvg-devel
#BuildRequires: libsasl-devel
#BuildRequires: libssh2-devel
BuildRequires: libtool
#BuildRequires: libxkbfile-devel
#BuildRequires: ORBit2-devel
BuildRequires: perl
BuildRoot: %{_tmppath}/%{name}-%{version}-root
# WebKit was configured with the following options:
# Build configuration:
# Enable debugging (slow) : no
# Enable GCC build optimization : yes
# Code coverage support : yes
# Unicode backend : icu
# Font backend : freetype
# Optimized memory allocator : yes
# Features:
# 3D Transforms : yes
# 3D Canvas (WebGL) : no
# Blob support : yes
# Directory upload : no
# Fast Mobile Scrolling : yes
# JIT compilation : yes
# Filters support : yes
# Geolocation support : yes
# JavaScript debugger/profiler support : yes
# MathML support : yes
# HTML5 offline web applications support : yes
# HTML5 channel messaging support : yes
# HTML5 client-side session and persistent storage support : yes
# HTML5 client-side database storage support : yes
# HTML5 FileSystem API support : no
# HTML5 sandboxed iframe support : yes
# HTML5 server-sent events support : yes
# HTML5 video element support : yes
# Fullscreen API support : yes
# Icon database support : yes
# Image resizer support : no
# Link prefetch support : no
# Opcode stats : no
# SharedWorkers support : yes
# Speech input support : no
# SVG support : yes
# SVG animation support : yes
# SVG fonts support : yes
# SVG foreign object support : yes
# SVG as image support : yes
# SVG use element support : yes
# WML support : no
# Web Audio support : no
# Web Sockets support : yes
# Web Timing support : no
# Web Workers support : yes
# XHTML-MP support : yes
# XPATH support : yes
# XSLT support : yes
# GTK+ configuration:
# GTK+ version : 2.0
# GDK target : x11
# Hildon UI extensions : no
# Introspection support : yes
# WebKit2 support : no
# http://svn.webkit.org/repository/webkit/tags/Safari-6531.9/
%description
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: %{name}-gir
Obsoletes: %{name}-gir
%description devel
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains libraries and header files need for development.
%package gir
Group: Development/Libraries
Summary: GObject introspection data for %{name}
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
Requires: gobject-introspection
%description gir
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains introspection data for %{name}. It can be used by packages using the
GIRepository format to generate dynamic bindings.
%package jsc
Group: Applications/Networking
Summary: JavaScriptCore shell for WebKit GTK+
%description jsc
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains WebKit's JavaScript engine. It allows you to interact with the JavaScript engine directly.
%package webinspector
Group: Applications/Networking
Summary: Data files for WebKit GTK+'s Web Inspector
Obsoletes: Webkit
%description webinspector
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains the data files necessary for Web Inspector to work.
%package doc
Group: Documentation
Summary: Documentation for %{name}
%description doc
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains the documentation for %{name},
%prep
%setup -q -n webkitgtk-%{version}
#-D -T
#:<< __EOF
%patch0 -p0
#%patch4 -p1
#%patch1 -p0
#%patch2 -p0
#%patch3 -p1
#__EOF
%patch5 -p1
%build
#:<< __EOF
#./autogen.sh
#%ifarch arm %{ix86}
## Use linker flags to reduce memory consumption on low-mem architectures
#EXTRA_CFLAGS="-Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
#%endif
%ifnarch x86_64
# To workaround ar 4GB file limit:
# https://bugs.launchpad.net/ubuntu/+source/binutils/+bug/1043507
EXTRA_CFLAGS="-g0 -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
EXTRA_CXXFLAGS="-g0 -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
%endif
CFLAGS="%{optflags} -DLIBSOUP_I_HAVE_READ_BUG_594377_AND_KNOW_SOUP_PASSWORD_MANAGER_MIGHT_GO_AWAY $EXTRA_CFLAGS"
CXXFLAGS="%{optflags} $EXTRA_CXXFLAGS" \
%configure \
%ifarch arm
--disable-jit \
%else
--enable-jit \
%endif
--with-gtk=3.0 \
--enable-geolocation \
--enable-channel-messaging \
--enable-fast-mobile-scrolling \
--enable-web-sockets \
--enable-filters \
--enable-coverage \
--enable-introspection \
--enable-mathml \
--enable-video \
PYTHON=%{__python}
# --enable-3D-transforms \
# --enable-xhtmlmp \
mkdir -p DerivedSources/webkit
mkdir -p DerivedSources/WebCore
#__EOF
## https://bugs.webkit.org/show_bug.cgi?id=34846
# V=1 seems a workaround for make error 'argument list too long'
%make V=1 || make V=1
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
#%ifarch arm %{ix86}
## Use linker flags to reduce memory consumption on low-mem architectures
#EXTRA_CFLAGS="-Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
#%endif
#CFLAGS="%{optflags} -DLIBSOUP_I_HAVE_READ_BUG_594377_AND_KNOW_SOUP_PASSWORD_MANAGER_MIGHT_GO_AWAY $EXTRA_CFLAGS"
%makeinstall V=1
mkdir -p %{buildroot}%{_bindir}/
install -m 755 Programs/GtkLauncher %{buildroot}%{_bindir}/GtkLauncher
#for doc in WebKit/LICENSE WebKit/gtk/po/README WebKit/gtk/NEWS Source/WebCore/icu/LICENSE Source/WebCore/LICENSE-APPLE Source/WebCore/LICENSE-LGPL-2 \
# Source/WebCore/LICENSE-LGPL-2.1 Source/JavaScriptCore/COPYING.LIB Source/JavaScriptCore/THANKS Source/JavaScriptCore/AUTHORS \
# Source/JavaScriptCore/icu/README Source/JavaScriptCore/icu/LICENSE Source/JavaScriptCore/pcre/COPYING Source/JavaScriptCore/pcre/AUTHORS ;do
# mkdir -p %{buildroot}%{_docdir}/webkitgtk-%{version}
# cp -p $doc %{buildroot}%{_docdir}/webkitgtk-%{version}/$(echo $doc | sed -e 's!/!.!g')
#done
%find_lang WebKitGTK-3.0
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post
/sbin/ldconfig
%{_bindir}/glib-compile-schemas %{_datadir}/glib-2.0/schemas
:
%postun
/sbin/ldconfig
%{_bindir}/glib-compile-schemas %{_datadir}/glib-2.0/schemas
:
%files -f WebKitGTK-3.0.lang
%defattr(-,root,root)
%{_bindir}/GtkLauncher
%{_libdir}/libwebkitgtk-3.0.so.*
%{_libdir}/libwebkit2gtk-3.0.so.*
%{_libdir}/libjavascriptcoregtk-3.0.so.*
%{_libdir}/girepository-1.0/JavaScriptCore-3.0.typelib
%{_libdir}/girepository-1.0/WebKit-3.0.typelib
%{_libdir}/girepository-1.0/WebKit2-3.0.typelib
%{_libdir}/girepository-1.0/WebKit2WebExtension-3.0.typelib
%{_libdir}/webkit2gtk-3.0/injected-bundle/libwebkit2gtkinjectedbundle.la
%{_libdir}/webkit2gtk-3.0/injected-bundle/libwebkit2gtkinjectedbundle.so
%dir %{_datadir}/webkitgtk-3.0
%{_datadir}/webkitgtk-3.0/*
%{_libexecdir}/WebKitPluginProcess
%{_libexecdir}/WebKitWebProcess
%{_libexecdir}/WebKitNetworkProcess
%files devel
%defattr(-,root,root)
%dir %{_includedir}/webkitgtk-3.0
%{_includedir}/webkitgtk-3.0/*
%{_libdir}/libwebkitgtk-3.0.la
%{_libdir}/libwebkitgtk-3.0.so
%{_libdir}/libjavascriptcoregtk-3.0.la
%{_libdir}/libjavascriptcoregtk-3.0.so
%{_libdir}/libwebkit2gtk-3.0.la
%{_libdir}/libwebkit2gtk-3.0.so
%{_datadir}/gir-1.0/JavaScriptCore-3.0.gir
%{_datadir}/gir-1.0/WebKit-3.0.gir
%{_datadir}/gir-1.0/WebKit2-3.0.gir
%{_datadir}/gir-1.0/WebKit2WebExtension-3.0.gir
%{_libdir}/pkgconfig/webkit2gtk-3.0.pc
%{_libdir}/pkgconfig/javascriptcoregtk-3.0.pc
%{_libdir}/pkgconfig/webkitgtk-3.0.pc
%{_libdir}/pkgconfig/webkit2gtk-web-extension-3.0.pc
%files doc
%defattr(-,root,root)
%dir %{_datadir}/gtk-doc/html/webkitgtk
%{_datadir}/gtk-doc/html/webkitgtk/*
%dir %{_datadir}/gtk-doc/html/webkit2gtk
%{_datadir}/gtk-doc/html/webkit2gtk/*
%dir %{_datadir}/gtk-doc/html/webkitdomgtk
%{_datadir}/gtk-doc/html/webkitdomgtk/*
%files jsc
%defattr(-,root,root)
%{_bindir}/jsc-3
%changelog
* Sun Aug 21 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.11-1mamba
- update to 2.4.11
* Tue Jul 22 2014 Automatic Build System <autodist@mambasoft.it> 2.4.4-1mamba
- automatic update by autodist
* Wed Jun 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.3-1mamba
- update to 2.4.3
* Thu Nov 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-2mamba
- rebuilt because previous release was packaged with a buggy rpm release
* Wed Nov 13 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-1mamba
- update to 2.2.2
* Sat Aug 31 2013 Automatic Build System <autodist@mambasoft.it> 2.1.90.1-1mamba
- automatic update by autodist
* Fri Aug 23 2013 Automatic Build System <autodist@mambasoft.it> 2.1.4-1mamba
- automatic update by autodist
* Sun Jul 21 2013 Automatic Build System <autodist@mambasoft.it> 2.1.3-1mamba
- automatic update by autodist
* Mon Jun 17 2013 Automatic Build System <autodist@mambasoft.it> 2.0.3-1mamba
- update to 2.0.3
* Mon Jun 17 2013 Automatic Build System <autodist@mambasoft.it> 2.1.1-1mamba
- automatic version update by autodist
* Sun Apr 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-2mamba
- rebuilt with devhelp 3.8.0
* Tue Apr 02 2013 Automatic Build System <autodist@mambasoft.it> 2.0.0-1mamba
- automatic version update by autodist
* Fri Mar 22 2013 Automatic Build System <autodist@mambasoft.it> 1.11.92-1mamba
- automatic version update by autodist
* Wed Mar 13 2013 Automatic Build System <autodist@mambasoft.it> 1.11.91-1mamba
- automatic version update by autodist
* Sat Mar 02 2013 Automatic Build System <autodist@mambasoft.it> 1.11.90-1mamba
- automatic version update by autodist
* Thu Oct 04 2012 Automatic Build System <autodist@mambasoft.it> 1.10.0-1mamba
- update to 1.10.0
* Wed Aug 15 2012 Automatic Build System <autodist@mambasoft.it> 1.8.2-1mamba
- automatic version update by autodist
* Wed Jun 06 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-2mamba
- build for gtk3; rename to libwebkit-gtk3 (libwebkit-gtk is the gtk 2.0 version)
* Sun May 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-1mamba
- update to 1.8.1
* Fri Feb 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.10-2mamba
- rebuilt in devel
- buildrequire libjpeg-devel instead of libjpeg-turbo-devel
* Wed Jan 26 2011 gil <puntogil@libero.it> 1.3.10-1mamba
- update to 1.3.10
* Mon Nov 29 2010 gil <puntogil@libero.it> 1.3.6-2mamba
- rebuilt devel
* Tue Nov 09 2010 gil <puntogil@libero.it> 1.3.6-1mamba
- update to 1.3.6
* Thu Oct 07 2010 gil <puntogil@libero.it> 1.3.4-1mamba
- update to 1.3.4
* Wed Oct 06 2010 gil <puntogil@libero.it> 1.2.5-1mamba
- update to 1.2.5
* Mon Sep 13 2010 gil <puntogil@libero.it> 1.2.4-1mamba
- update to 1.2.4
* Thu Jul 22 2010 gil <puntogil@libero.it> 1.2.3-1mamba
- update to 1.2.3
* Wed Jun 23 2010 gil <puntogil@libero.it> 1.2.1-1mamba
- update to 1.2.1
* Sat Apr 24 2010 gil <puntogil@libero.it> 1.2.0-2mamba
- edit spec file
* Tue Apr 20 2010 gil <puntogil@libero.it> 1.2.0-1mamba
- update to 1.2.0
* Sat Dec 26 2009 gil <puntogil@libero.it> 1.1.15.4-1mamba
- update to 1.1.15.4
* Thu Jul 02 2009 gil <puntogil@libero.it> 1.1.10-1mamba
- update to 1.1.10
* Thu Jun 11 2009 gil <puntogil@libero.it> 1.1.9-1mamba
- update to 1.1.9
* Fri May 29 2009 gil <puntogil@libero.it> 1.1.8-1mamba
- update to 1.1.8
* Sat May 16 2009 gil <puntogil@libero.it> 1.1.7-1mamba
- update to 1.1.7
* Thu May 07 2009 gil <puntogil@libero.it> 1.1.6-1mamba
- update to 1.1.6
* Sat Apr 18 2009 gil <puntogil@libero.it> 1.1.5-1mamba
- update to 1.1.5
* Sat Mar 28 2009 gil <puntogil@libero.it> 1.1.4-1mamba
- update to 1.1.4
* Mon Nov 17 2008 gil <puntogil@libero.it> 1.0.1-1mamba
- package created by autospec