405 lines
15 KiB
RPMSpec
405 lines
15 KiB
RPMSpec
# --enable-debug turn on debugging [default=no]
|
|
# --enable-indexeddb enable the indexed database API [default=no]
|
|
|
|
# --enable-input-speech enable the speech input API [default=no] broken
|
|
|
|
# --enable-image-resizer enable image resizer [default=no]
|
|
# --enable-wml enable support for WML [default=no]
|
|
# --enable-directory-upload enable support for directory upload [default=no]
|
|
# --enable-file-system enable support for HTML5 FileSystem API [default=no]
|
|
# --enable-web-timing enable support for Web Timing [default=no]
|
|
# --enable-blob enable support for Blob [default=no]
|
|
# --enable-coverage enable code coverage support [default=no]
|
|
# --enable-opcode-stats Enable Opcode statistics (default: disabled)
|
|
# --enable-gtk-doc use gtk-doc to build documentation [[default=no]]
|
|
# --enable-gtk-doc-pdf build documentation in pdf format [[default=no]]
|
|
# --with-gtk=2.0|3.0 the GTK+ version to use (default: 2.0)
|
|
|
|
%define majver %(echo %version | cut -d. -f 1-2)
|
|
Name: libwebkit-gtk
|
|
Version: 1.8.3
|
|
Release: 1mamba
|
|
Summary: Port of WebKit embeddable web component to GTK+
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
##URL: http://live.gnome.org/WebKitGtk
|
|
URL: http://www.webkitgtk.org/
|
|
Source0: http://www.webkitgtk.org/releases/webkit-%{version}.tar.xz
|
|
Patch0: libwebkit-gtk-1.3.10-nspluginwrapper.patch
|
|
Patch1: libwebkit-gtk-1.3.10-no-execmem.patch
|
|
Patch2: libwebkit-gtk-1.3.10-stamp-po.patch
|
|
Patch3: libwebkit-gtk-1.8.2-bison-2.6.patch
|
|
License: BSD, LGPL
|
|
BuildRequires: libgcrypt-devel
|
|
BuildRequires: libglitz-devel
|
|
BuildRequires: libgnutls-devel
|
|
BuildRequires: libgpg-error-devel
|
|
BuildRequires: libpixman-devel
|
|
BuildRequires: libpthread-stubs-devel
|
|
BuildRequires: libselinux-devel
|
|
BuildRequires: libSM-devel
|
|
BuildRequires: libtasn1-devel
|
|
BuildRequires: libuuid-devel
|
|
BuildRequires: libXau-devel
|
|
BuildRequires: libxcb-devel
|
|
BuildRequires: libxcb-util-devel
|
|
BuildRequires: libXcomposite-devel
|
|
BuildRequires: libXcursor-devel
|
|
BuildRequires: libXdamage-devel
|
|
BuildRequires: libXdmcp-devel
|
|
BuildRequires: libXext-devel
|
|
BuildRequires: libXfixes-devel
|
|
BuildRequires: libXinerama-devel
|
|
BuildRequires: libXrandr-devel
|
|
BuildRequires: libXrender-devel
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libatk-devel
|
|
BuildRequires: libcairo-devel
|
|
BuildRequires: libdbus-devel
|
|
BuildRequires: libdbus-glib-devel
|
|
BuildRequires: libenchant-devel
|
|
BuildRequires: libexpat-devel
|
|
BuildRequires: libfontconfig-devel
|
|
BuildRequires: libfreetype-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libgdk-pixbuf-devel
|
|
BuildRequires: libgeoclue-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libgst-plugins-base-devel
|
|
BuildRequires: libgstreamer-devel
|
|
BuildRequires: libgtk-devel
|
|
BuildRequires: libICE-devel
|
|
BuildRequires: libicu-devel
|
|
BuildRequires: libjpeg-devel
|
|
BuildRequires: libpango-devel
|
|
BuildRequires: libpng-devel
|
|
BuildRequires: libsoup-devel
|
|
BuildRequires: libsqlite-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libxml2-devel
|
|
BuildRequires: libxslt-devel
|
|
BuildRequires: libXt-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: bison
|
|
BuildRequires: flex
|
|
BuildRequires: GConf-devel
|
|
BuildRequires: gobject-introspection-devel
|
|
BuildRequires: gperf
|
|
BuildRequires: gst-plugins-bad-devel
|
|
BuildRequires: icu
|
|
BuildRequires: libavahi-devel
|
|
BuildRequires: libcares-devel
|
|
BuildRequires: libcurl-devel
|
|
BuildRequires: libe2fs-devel
|
|
BuildRequires: libgnome-keyring-devel
|
|
BuildRequires: libgnome-vfs-devel
|
|
BuildRequires: libidn-devel
|
|
BuildRequires: libkrb5-devel
|
|
BuildRequires: libopenldap-devel
|
|
BuildRequires: libopenssl-devel
|
|
BuildRequires: libpcre-devel
|
|
BuildRequires: libqt4-devel
|
|
BuildRequires: librsvg-devel
|
|
BuildRequires: libsasl-devel
|
|
BuildRequires: libssh2-devel
|
|
BuildRequires: libtool
|
|
BuildRequires: libxkbfile-devel
|
|
BuildRequires: ORBit2-devel
|
|
BuildRequires: perl
|
|
Provides: libwebkit
|
|
Obsoletes: libwebkit
|
|
Provides: WebKit
|
|
Obsoletes: WebKit
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
# WebKit was configured with the following options:
|
|
|
|
# Build configuration:
|
|
# Enable debugging (slow) : no
|
|
# Enable GCC build optimization : yes
|
|
# Code coverage support : yes
|
|
# Unicode backend : icu
|
|
# Font backend : freetype
|
|
# Optimized memory allocator : yes
|
|
# Features:
|
|
# 3D Transforms : yes
|
|
# 3D Canvas (WebGL) : no
|
|
# Blob support : yes
|
|
# Directory upload : no
|
|
# Fast Mobile Scrolling : yes
|
|
# JIT compilation : yes
|
|
# Filters support : yes
|
|
# Geolocation support : yes
|
|
# JavaScript debugger/profiler support : yes
|
|
# MathML support : yes
|
|
# HTML5 offline web applications support : yes
|
|
# HTML5 channel messaging support : yes
|
|
# HTML5 client-side session and persistent storage support : yes
|
|
# HTML5 client-side database storage support : yes
|
|
# HTML5 FileSystem API support : no
|
|
# HTML5 sandboxed iframe support : yes
|
|
# HTML5 server-sent events support : yes
|
|
# HTML5 video element support : yes
|
|
# Fullscreen API support : yes
|
|
# Icon database support : yes
|
|
# Image resizer support : no
|
|
# Link prefetch support : no
|
|
# Opcode stats : no
|
|
# SharedWorkers support : yes
|
|
# Speech input support : no
|
|
# SVG support : yes
|
|
# SVG animation support : yes
|
|
# SVG fonts support : yes
|
|
# SVG foreign object support : yes
|
|
# SVG as image support : yes
|
|
# SVG use element support : yes
|
|
# WML support : no
|
|
# Web Audio support : no
|
|
# Web Sockets support : yes
|
|
# Web Timing support : no
|
|
# Web Workers support : yes
|
|
# XHTML-MP support : yes
|
|
# XPATH support : yes
|
|
# XSLT support : yes
|
|
|
|
# GTK+ configuration:
|
|
# GTK+ version : 2.0
|
|
# GDK target : x11
|
|
# Hildon UI extensions : no
|
|
# Introspection support : yes
|
|
# WebKit2 support : no
|
|
|
|
# http://svn.webkit.org/repository/webkit/tags/Safari-6531.9/
|
|
|
|
%description
|
|
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Static libraries and headers for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Provides: libwebkit-devel
|
|
Obsoletes: libwebkit-devel
|
|
|
|
%description devel
|
|
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
|
|
|
|
This package contains libraries and header files need for development.
|
|
|
|
%package gir
|
|
Group: Development/Libraries
|
|
Summary: GObject introspection data for %{name}
|
|
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: gobject-introspection
|
|
|
|
%description gir
|
|
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
|
|
|
|
This package contains introspection data for %{name}. It can be used by packages using the
|
|
GIRepository format to generate dynamic bindings.
|
|
|
|
%package jsc
|
|
Group: Applications/Networking
|
|
Summary: JavaScriptCore shell for WebKit GTK+
|
|
|
|
%description jsc
|
|
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
|
|
|
|
This package contains WebKit's JavaScript engine. It allows you to interact with the JavaScript engine directly.
|
|
|
|
%package webinspector
|
|
Group: Applications/Networking
|
|
Summary: Data files for WebKit GTK+'s Web Inspector
|
|
Obsoletes: Webkit
|
|
|
|
%description webinspector
|
|
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
|
|
|
|
This package contains the data files necessary for Web Inspector to work.
|
|
|
|
%package doc
|
|
Group: Documentation
|
|
Summary: Documentation for %{name}
|
|
|
|
%description doc
|
|
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
|
|
|
|
This package contains the documentation for %{name},
|
|
|
|
%prep
|
|
|
|
%setup -q -n webkit-%{version}
|
|
%patch0 -p0
|
|
#%patch1 -p0
|
|
#%patch2 -p0
|
|
%patch3 -p1
|
|
|
|
%build
|
|
#./autogen.sh
|
|
CFLAGS="%{optflags} -DLIBSOUP_I_HAVE_READ_BUG_594377_AND_KNOW_SOUP_PASSWORD_MANAGER_MIGHT_GO_AWAY" \
|
|
%configure \
|
|
--with-gtk=2.0 \
|
|
--enable-geolocation \
|
|
--enable-3D-transforms \
|
|
--enable-channel-messaging \
|
|
--enable-xhtmlmp \
|
|
--enable-fast-mobile-scrolling \
|
|
--enable-web-sockets \
|
|
--enable-filters \
|
|
--enable-coverage \
|
|
--enable-introspection \
|
|
--enable-mathml \
|
|
--enable-video \
|
|
%ifarch arm
|
|
--disable-jit \
|
|
%else
|
|
--enable-jit \
|
|
%endif
|
|
PYTHON=%{__python}
|
|
|
|
mkdir -p DerivedSources/webkit
|
|
mkdir -p DerivedSources/WebCore
|
|
|
|
# https://bugs.webkit.org/show_bug.cgi?id=34846
|
|
#% make
|
|
make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
|
|
mkdir -p %{buildroot}%{_libexecdir}/webkit
|
|
install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/webkit
|
|
|
|
#for doc in WebKit/LICENSE WebKit/gtk/po/README WebKit/gtk/NEWS Source/WebCore/icu/LICENSE Source/WebCore/LICENSE-APPLE Source/WebCore/LICENSE-LGPL-2 \
|
|
# Source/WebCore/LICENSE-LGPL-2.1 Source/JavaScriptCore/COPYING.LIB Source/JavaScriptCore/THANKS Source/JavaScriptCore/AUTHORS \
|
|
# Source/JavaScriptCore/icu/README Source/JavaScriptCore/icu/LICENSE Source/JavaScriptCore/pcre/COPYING Source/JavaScriptCore/pcre/AUTHORS ;do
|
|
# mkdir -p %{buildroot}%{_docdir}/webkitgtk-%{version}
|
|
# cp -p $doc %{buildroot}%{_docdir}/webkitgtk-%{version}/$(echo $doc | sed -e 's!/!.!g')
|
|
#done
|
|
|
|
%find_lang webkit-2.0
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
/sbin/ldconfig
|
|
%{_bindir}/glib-compile-schemas %{_datadir}/glib-2.0/schemas
|
|
|
|
%postun
|
|
/sbin/ldconfig
|
|
%{_bindir}/glib-compile-schemas %{_datadir}/glib-2.0/schemas
|
|
|
|
%files -f webkit-2.0.lang
|
|
%defattr(-,root,root)
|
|
%{_libexecdir}/webkit/GtkLauncher
|
|
%{_libdir}/libwebkitgtk-1.0.so.*
|
|
%{_libdir}/libjavascriptcoregtk-1.0.so.*
|
|
%dir %{_datadir}/webkitgtk-1.0
|
|
%{_datadir}/webkitgtk-1.0/*
|
|
#%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/webkitgtk-1.0
|
|
%{_includedir}/webkitgtk-1.0/*
|
|
%{_libdir}/libwebkitgtk-1.0.la
|
|
%{_libdir}/libwebkitgtk-1.0.so
|
|
%{_libdir}/libjavascriptcoregtk-1.0.la
|
|
%{_libdir}/libjavascriptcoregtk-1.0.so
|
|
%{_libdir}/pkgconfig/javascriptcoregtk-1.0.pc
|
|
%{_libdir}/pkgconfig/webkit-1.0.pc
|
|
|
|
%files doc
|
|
%defattr(-,root,root)
|
|
%dir %{_datadir}/gtk-doc/html/webkitgtk
|
|
%{_datadir}/gtk-doc/html/webkitgtk/*
|
|
|
|
%files gir
|
|
%defattr(-,root,root)
|
|
%{_libdir}/girepository-1.0/JSCore-1.0.typelib
|
|
%{_libdir}/girepository-1.0/WebKit-1.0.typelib
|
|
%{_datadir}/gir-1.0/JSCore-1.0.gir
|
|
%{_datadir}/gir-1.0/WebKit-1.0.gir
|
|
|
|
%files jsc
|
|
%defattr(-,root,root)
|
|
%{_bindir}/jsc-1
|
|
|
|
%changelog
|
|
* Mon Nov 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.3-1mamba
|
|
- update to 1.8.3
|
|
|
|
* Wed Aug 15 2012 Automatic Build System <autodist@mambasoft.it> 1.8.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-1mamba
|
|
- update to 1.8.1
|
|
|
|
* Fri Feb 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.10-2mamba
|
|
- rebuilt in devel
|
|
- buildrequire libjpeg-devel instead of libjpeg-turbo-devel
|
|
|
|
* Wed Jan 26 2011 gil <puntogil@libero.it> 1.3.10-1mamba
|
|
- update to 1.3.10
|
|
|
|
* Mon Nov 29 2010 gil <puntogil@libero.it> 1.3.6-2mamba
|
|
- rebuilt devel
|
|
|
|
* Tue Nov 09 2010 gil <puntogil@libero.it> 1.3.6-1mamba
|
|
- update to 1.3.6
|
|
|
|
* Thu Oct 07 2010 gil <puntogil@libero.it> 1.3.4-1mamba
|
|
- update to 1.3.4
|
|
|
|
* Wed Oct 06 2010 gil <puntogil@libero.it> 1.2.5-1mamba
|
|
- update to 1.2.5
|
|
|
|
* Mon Sep 13 2010 gil <puntogil@libero.it> 1.2.4-1mamba
|
|
- update to 1.2.4
|
|
|
|
* Thu Jul 22 2010 gil <puntogil@libero.it> 1.2.3-1mamba
|
|
- update to 1.2.3
|
|
|
|
* Wed Jun 23 2010 gil <puntogil@libero.it> 1.2.1-1mamba
|
|
- update to 1.2.1
|
|
|
|
* Sat Apr 24 2010 gil <puntogil@libero.it> 1.2.0-2mamba
|
|
- edit spec file
|
|
|
|
* Tue Apr 20 2010 gil <puntogil@libero.it> 1.2.0-1mamba
|
|
- update to 1.2.0
|
|
|
|
* Sat Dec 26 2009 gil <puntogil@libero.it> 1.1.15.4-1mamba
|
|
- update to 1.1.15.4
|
|
|
|
* Thu Jul 02 2009 gil <puntogil@libero.it> 1.1.10-1mamba
|
|
- update to 1.1.10
|
|
|
|
* Thu Jun 11 2009 gil <puntogil@libero.it> 1.1.9-1mamba
|
|
- update to 1.1.9
|
|
|
|
* Fri May 29 2009 gil <puntogil@libero.it> 1.1.8-1mamba
|
|
- update to 1.1.8
|
|
|
|
* Sat May 16 2009 gil <puntogil@libero.it> 1.1.7-1mamba
|
|
- update to 1.1.7
|
|
|
|
* Thu May 07 2009 gil <puntogil@libero.it> 1.1.6-1mamba
|
|
- update to 1.1.6
|
|
|
|
* Sat Apr 18 2009 gil <puntogil@libero.it> 1.1.5-1mamba
|
|
- update to 1.1.5
|
|
|
|
* Sat Mar 28 2009 gil <puntogil@libero.it> 1.1.4-1mamba
|
|
- update to 1.1.4
|
|
|
|
* Mon Nov 17 2008 gil <puntogil@libero.it> 1.0.1-1mamba
|
|
- package created by autospec
|