update to 1.8.3 [release 1.8.3-1mamba;Mon Nov 19 2012]

This commit is contained in:
Silvan Calarco 2024-01-06 06:07:34 +01:00
parent c879aec81d
commit 607b0c1123
6 changed files with 994 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libwebkit-gtk # libwebkit-gtk
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.

View File

@ -0,0 +1,11 @@
--- Source/JavaScriptCore/wtf/Platform.h 2011-01-11 02:07:11.000000000 +0100
+++ Source/JavaScriptCore/wtf/Platform.h-gil 2011-01-26 09:59:21.000000000 +0100
@@ -1036,7 +1036,7 @@
#endif
/* Setting this flag prevents the assembler from using RWX memory; this may improve
security but currectly comes at a significant performance cost. */
-#if PLATFORM(IOS)
+#if PLATFORM(IOS) || PLATFORM(X86) || PLATFORM(X86_64)
#define ENABLE_ASSEMBLER_WX_EXCLUSIVE 1
#else
#define ENABLE_ASSEMBLER_WX_EXCLUSIVE 0

View File

@ -0,0 +1,12 @@
--- Source/WebCore/plugins/PluginDatabase.cpp 2011-01-08 17:50:59.000000000 +0100
+++ Source/WebCore/plugins/PluginDatabase.cpp-gil 2011-01-26 09:54:45.000000000 +0100
@@ -393,6 +393,9 @@
paths.append("/usr/lib64/mozilla/plugins");
paths.append("/usr/lib/nsbrowser/plugins");
paths.append("/usr/lib64/nsbrowser/plugins");
+ /* And for nspluginwrapper */
+ paths.append("/usr/lib64/mozilla/plugins-wrapped");
+ paths.append("/usr/lib/mozilla/plugins-wrapped");
String mozHome(getenv("MOZILLA_HOME"));
mozHome.append("/plugins");

View File

@ -0,0 +1,11 @@
--- GNUmakefile.am 2011-01-10 19:04:18.000000000 +0100
+++ GNUmakefile.am-gil 2011-01-26 10:04:36.000000000 +0100
@@ -268,7 +268,7 @@
# Older automake versions (1.7) place Plo files in a different place so we need
# to create the output directory manually.
-all-local:
+all-local: stamp-po
$(mkdir_p) $(top_builddir)/$(DEPDIR)/DerivedSources
# remove built sources and program directories

View File

@ -0,0 +1,554 @@
diff --git a/Source/WebCore/css/CSSGrammar.y b/Source/WebCore/css/CSSGrammar.y
index c7c10b541cd46ad4febc6efe289e81b2cfb0861e..1c604e76b4da4cc65f395bc4a73b112561bd5c84 100644
--- a/Source/WebCore/css/CSSGrammar.y
+++ b/Source/WebCore/css/CSSGrammar.y
@@ -53,14 +53,13 @@ using namespace HTMLNames;
#define YYMAXDEPTH 10000
#define YYDEBUG 0
-// FIXME: Replace with %parse-param { CSSParser* parser } once we can depend on bison 2.x
-#define YYPARSE_PARAM parser
-#define YYLEX_PARAM parser
-
%}
%pure_parser
+%parse-param { CSSParser* parser }
+%lex-param { CSSParser* parser }
+
%union {
bool boolean;
char character;
@@ -89,7 +88,7 @@ using namespace HTMLNames;
%{
-static inline int cssyyerror(const char*)
+static inline int cssyyerror(void*, const char*)
{
return 1;
}
diff --git a/Source/WebCore/css/CSSParser.cpp b/Source/WebCore/css/CSSParser.cpp
index 650844060477cfc6ea6fdeaf11ec63b34ac646e7..8369549dbff25537cf93a11237a9bbbac4fe50f2 100644
--- a/Source/WebCore/css/CSSParser.cpp
+++ b/Source/WebCore/css/CSSParser.cpp
@@ -114,7 +114,7 @@
extern int cssyydebug;
#endif
-extern int cssyyparse(void* parser);
+extern int cssyyparse(WebCore::CSSParser*);
using namespace std;
using namespace WTF;
diff --git a/Source/WebCore/xml/XPathGrammar.y b/Source/WebCore/xml/XPathGrammar.y
index 2eba5b35bd2338272a0f4ec756d137e47d2d59c8..d558211db2d89ea13716762a51397755560f66f3 100644
--- a/Source/WebCore/xml/XPathGrammar.y
+++ b/Source/WebCore/xml/XPathGrammar.y
@@ -34,6 +34,7 @@
#include "XPathParser.h"
#include "XPathPath.h"
#include "XPathPredicate.h"
+#include "XPathStep.h"
#include "XPathVariableReference.h"
#include <wtf/FastMalloc.h>
@@ -44,8 +45,6 @@
#define YYLTYPE_IS_TRIVIAL 1
#define YYDEBUG 0
#define YYMAXDEPTH 10000
-#define YYPARSE_PARAM parserParameter
-#define PARSER static_cast<Parser*>(parserParameter)
using namespace WebCore;
using namespace XPath;
@@ -53,6 +52,7 @@ using namespace XPath;
%}
%pure_parser
+%parse-param { WebCore::XPath::Parser* parser }
%union
{
@@ -71,7 +71,7 @@ using namespace XPath;
%{
static int xpathyylex(YYSTYPE* yylval) { return Parser::current()->lex(yylval); }
-static void xpathyyerror(const char*) { }
+static void xpathyyerror(void*, const char*) { }
%}
@@ -118,7 +118,7 @@ static void xpathyyerror(const char*) { }
Expr:
OrExpr
{
- PARSER->m_topExpr = $1;
+ parser->m_topExpr = $1;
}
;
@@ -138,7 +138,7 @@ AbsoluteLocationPath:
'/'
{
$$ = new LocationPath;
- PARSER->registerParseNode($$);
+ parser->registerParseNode($$);
}
|
'/' RelativeLocationPath
@@ -150,7 +150,7 @@ AbsoluteLocationPath:
{
$$ = $2;
$$->insertFirstStep($1);
- PARSER->unregisterParseNode($1);
+ parser->unregisterParseNode($1);
}
;
@@ -159,22 +159,22 @@ RelativeLocationPath:
{
$$ = new LocationPath;
$$->appendStep($1);
- PARSER->unregisterParseNode($1);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->registerParseNode($$);
}
|
RelativeLocationPath '/' Step
{
$$->appendStep($3);
- PARSER->unregisterParseNode($3);
+ parser->unregisterParseNode($3);
}
|
RelativeLocationPath DescendantOrSelf Step
{
$$->appendStep($2);
$$->appendStep($3);
- PARSER->unregisterParseNode($2);
- PARSER->unregisterParseNode($3);
+ parser->unregisterParseNode($2);
+ parser->unregisterParseNode($3);
}
;
@@ -183,58 +183,58 @@ Step:
{
if ($2) {
$$ = new Step(Step::ChildAxis, *$1, *$2);
- PARSER->deletePredicateVector($2);
+ parser->deletePredicateVector($2);
} else
$$ = new Step(Step::ChildAxis, *$1);
- PARSER->deleteNodeTest($1);
- PARSER->registerParseNode($$);
+ parser->deleteNodeTest($1);
+ parser->registerParseNode($$);
}
|
NAMETEST OptionalPredicateList
{
String localName;
String namespaceURI;
- if (!PARSER->expandQName(*$1, localName, namespaceURI)) {
- PARSER->m_gotNamespaceError = true;
+ if (!parser->expandQName(*$1, localName, namespaceURI)) {
+ parser->m_gotNamespaceError = true;
YYABORT;
}
if ($2) {
$$ = new Step(Step::ChildAxis, Step::NodeTest(Step::NodeTest::NameTest, localName, namespaceURI), *$2);
- PARSER->deletePredicateVector($2);
+ parser->deletePredicateVector($2);
} else
$$ = new Step(Step::ChildAxis, Step::NodeTest(Step::NodeTest::NameTest, localName, namespaceURI));
- PARSER->deleteString($1);
- PARSER->registerParseNode($$);
+ parser->deleteString($1);
+ parser->registerParseNode($$);
}
|
AxisSpecifier NodeTest OptionalPredicateList
{
if ($3) {
$$ = new Step($1, *$2, *$3);
- PARSER->deletePredicateVector($3);
+ parser->deletePredicateVector($3);
} else
$$ = new Step($1, *$2);
- PARSER->deleteNodeTest($2);
- PARSER->registerParseNode($$);
+ parser->deleteNodeTest($2);
+ parser->registerParseNode($$);
}
|
AxisSpecifier NAMETEST OptionalPredicateList
{
String localName;
String namespaceURI;
- if (!PARSER->expandQName(*$2, localName, namespaceURI)) {
- PARSER->m_gotNamespaceError = true;
+ if (!parser->expandQName(*$2, localName, namespaceURI)) {
+ parser->m_gotNamespaceError = true;
YYABORT;
}
if ($3) {
$$ = new Step($1, Step::NodeTest(Step::NodeTest::NameTest, localName, namespaceURI), *$3);
- PARSER->deletePredicateVector($3);
+ parser->deletePredicateVector($3);
} else
$$ = new Step($1, Step::NodeTest(Step::NodeTest::NameTest, localName, namespaceURI));
- PARSER->deleteString($2);
- PARSER->registerParseNode($$);
+ parser->deleteString($2);
+ parser->registerParseNode($$);
}
|
AbbreviatedStep
@@ -259,23 +259,23 @@ NodeTest:
else if (*$1 == "comment")
$$ = new Step::NodeTest(Step::NodeTest::CommentNodeTest);
- PARSER->deleteString($1);
- PARSER->registerNodeTest($$);
+ parser->deleteString($1);
+ parser->registerNodeTest($$);
}
|
PI '(' ')'
{
$$ = new Step::NodeTest(Step::NodeTest::ProcessingInstructionNodeTest);
- PARSER->deleteString($1);
- PARSER->registerNodeTest($$);
+ parser->deleteString($1);
+ parser->registerNodeTest($$);
}
|
PI '(' LITERAL ')'
{
$$ = new Step::NodeTest(Step::NodeTest::ProcessingInstructionNodeTest, $3->stripWhiteSpace());
- PARSER->deleteString($1);
- PARSER->deleteString($3);
- PARSER->registerNodeTest($$);
+ parser->deleteString($1);
+ parser->deleteString($3);
+ parser->registerNodeTest($$);
}
;
@@ -293,14 +293,14 @@ PredicateList:
{
$$ = new Vector<Predicate*>;
$$->append(new Predicate($1));
- PARSER->unregisterParseNode($1);
- PARSER->registerPredicateVector($$);
+ parser->unregisterParseNode($1);
+ parser->registerPredicateVector($$);
}
|
PredicateList Predicate
{
$$->append(new Predicate($2));
- PARSER->unregisterParseNode($2);
+ parser->unregisterParseNode($2);
}
;
@@ -315,7 +315,7 @@ DescendantOrSelf:
SLASHSLASH
{
$$ = new Step(Step::DescendantOrSelfAxis, Step::NodeTest(Step::NodeTest::AnyNodeTest));
- PARSER->registerParseNode($$);
+ parser->registerParseNode($$);
}
;
@@ -323,13 +323,13 @@ AbbreviatedStep:
'.'
{
$$ = new Step(Step::SelfAxis, Step::NodeTest(Step::NodeTest::AnyNodeTest));
- PARSER->registerParseNode($$);
+ parser->registerParseNode($$);
}
|
DOTDOT
{
$$ = new Step(Step::ParentAxis, Step::NodeTest(Step::NodeTest::AnyNodeTest));
- PARSER->registerParseNode($$);
+ parser->registerParseNode($$);
}
;
@@ -337,8 +337,8 @@ PrimaryExpr:
VARIABLEREFERENCE
{
$$ = new VariableReference(*$1);
- PARSER->deleteString($1);
- PARSER->registerParseNode($$);
+ parser->deleteString($1);
+ parser->registerParseNode($$);
}
|
'(' Expr ')'
@@ -349,15 +349,15 @@ PrimaryExpr:
LITERAL
{
$$ = new StringExpression(*$1);
- PARSER->deleteString($1);
- PARSER->registerParseNode($$);
+ parser->deleteString($1);
+ parser->registerParseNode($$);
}
|
NUMBER
{
$$ = new Number($1->toDouble());
- PARSER->deleteString($1);
- PARSER->registerParseNode($$);
+ parser->deleteString($1);
+ parser->registerParseNode($$);
}
|
FunctionCall
@@ -369,8 +369,8 @@ FunctionCall:
$$ = createFunction(*$1);
if (!$$)
YYABORT;
- PARSER->deleteString($1);
- PARSER->registerParseNode($$);
+ parser->deleteString($1);
+ parser->registerParseNode($$);
}
|
FUNCTIONNAME '(' ArgumentList ')'
@@ -378,9 +378,9 @@ FunctionCall:
$$ = createFunction(*$1, *$3);
if (!$$)
YYABORT;
- PARSER->deleteString($1);
- PARSER->deleteExpressionVector($3);
- PARSER->registerParseNode($$);
+ parser->deleteString($1);
+ parser->deleteExpressionVector($3);
+ parser->registerParseNode($$);
}
;
@@ -389,14 +389,14 @@ ArgumentList:
{
$$ = new Vector<Expression*>;
$$->append($1);
- PARSER->unregisterParseNode($1);
- PARSER->registerExpressionVector($$);
+ parser->unregisterParseNode($1);
+ parser->registerExpressionVector($$);
}
|
ArgumentList ',' Argument
{
$$->append($3);
- PARSER->unregisterParseNode($3);
+ parser->unregisterParseNode($3);
}
;
@@ -412,9 +412,9 @@ UnionExpr:
$$ = new Union;
$$->addSubExpression($1);
$$->addSubExpression($3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
;
@@ -430,9 +430,9 @@ PathExpr:
{
$3->setAbsolute(true);
$$ = new Path(static_cast<Filter*>($1), $3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
|
FilterExpr DescendantOrSelf RelativeLocationPath
@@ -440,10 +440,10 @@ PathExpr:
$3->insertFirstStep($2);
$3->setAbsolute(true);
$$ = new Path(static_cast<Filter*>($1), $3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($2);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($2);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
;
@@ -453,9 +453,9 @@ FilterExpr:
PrimaryExpr PredicateList
{
$$ = new Filter($1, *$2);
- PARSER->unregisterParseNode($1);
- PARSER->deletePredicateVector($2);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->deletePredicateVector($2);
+ parser->registerParseNode($$);
}
;
@@ -465,9 +465,9 @@ OrExpr:
OrExpr OR AndExpr
{
$$ = new LogicalOp(LogicalOp::OP_Or, $1, $3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
;
@@ -477,9 +477,9 @@ AndExpr:
AndExpr AND EqualityExpr
{
$$ = new LogicalOp(LogicalOp::OP_And, $1, $3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
;
@@ -489,9 +489,9 @@ EqualityExpr:
EqualityExpr EQOP RelationalExpr
{
$$ = new EqTestOp($2, $1, $3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
;
@@ -501,9 +501,9 @@ RelationalExpr:
RelationalExpr RELOP AdditiveExpr
{
$$ = new EqTestOp($2, $1, $3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
;
@@ -513,17 +513,17 @@ AdditiveExpr:
AdditiveExpr PLUS MultiplicativeExpr
{
$$ = new NumericOp(NumericOp::OP_Add, $1, $3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
|
AdditiveExpr MINUS MultiplicativeExpr
{
$$ = new NumericOp(NumericOp::OP_Sub, $1, $3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
;
@@ -533,9 +533,9 @@ MultiplicativeExpr:
MultiplicativeExpr MULOP UnaryExpr
{
$$ = new NumericOp($2, $1, $3);
- PARSER->unregisterParseNode($1);
- PARSER->unregisterParseNode($3);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($1);
+ parser->unregisterParseNode($3);
+ parser->registerParseNode($$);
}
;
@@ -546,8 +546,8 @@ UnaryExpr:
{
$$ = new Negative;
$$->addSubExpression($2);
- PARSER->unregisterParseNode($2);
- PARSER->registerParseNode($$);
+ parser->unregisterParseNode($2);
+ parser->registerParseNode($$);
}
;
diff --git a/Source/WebCore/xml/XPathParser.cpp b/Source/WebCore/xml/XPathParser.cpp
index 62d8ee37fd6ebb74a580a00c59beb6cd40c5a8b7..b5e6a9237593b4aaa2a243f2ff9d86e57f930a97 100644
--- a/Source/WebCore/xml/XPathParser.cpp
+++ b/Source/WebCore/xml/XPathParser.cpp
@@ -32,24 +32,21 @@
#include "XPathEvaluator.h"
#include "XPathException.h"
#include "XPathNSResolver.h"
+#include "XPathPath.h"
#include "XPathStep.h"
#include <wtf/StdLibExtras.h>
#include <wtf/text/StringHash.h>
-int xpathyyparse(void*);
-
+using namespace WebCore;
using namespace WTF;
using namespace Unicode;
+using namespace XPath;
-namespace WebCore {
-namespace XPath {
-
-class LocationPath;
-
-#include "XPathGrammar.h"
+extern int xpathyyparse(WebCore::XPath::Parser*);
+#include "XPathGrammar.h"
Parser* Parser::currentParser = 0;
-
+
enum XMLCat { NameStart, NameCont, NotPartOfName };
typedef HashMap<String, Step::Axis> AxisNamesMap;
@@ -630,5 +627,3 @@ void Parser::deleteNodeTest(Step::NodeTest* t)
delete t;
}
-}
-}

404
libwebkit-gtk.spec Normal file
View File

@ -0,0 +1,404 @@
# --enable-debug turn on debugging [default=no]
# --enable-indexeddb enable the indexed database API [default=no]
# --enable-input-speech enable the speech input API [default=no] broken
# --enable-image-resizer enable image resizer [default=no]
# --enable-wml enable support for WML [default=no]
# --enable-directory-upload enable support for directory upload [default=no]
# --enable-file-system enable support for HTML5 FileSystem API [default=no]
# --enable-web-timing enable support for Web Timing [default=no]
# --enable-blob enable support for Blob [default=no]
# --enable-coverage enable code coverage support [default=no]
# --enable-opcode-stats Enable Opcode statistics (default: disabled)
# --enable-gtk-doc use gtk-doc to build documentation [[default=no]]
# --enable-gtk-doc-pdf build documentation in pdf format [[default=no]]
# --with-gtk=2.0|3.0 the GTK+ version to use (default: 2.0)
%define majver %(echo %version | cut -d. -f 1-2)
Name: libwebkit-gtk
Version: 1.8.3
Release: 1mamba
Summary: Port of WebKit embeddable web component to GTK+
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
##URL: http://live.gnome.org/WebKitGtk
URL: http://www.webkitgtk.org/
Source0: http://www.webkitgtk.org/releases/webkit-%{version}.tar.xz
Patch0: libwebkit-gtk-1.3.10-nspluginwrapper.patch
Patch1: libwebkit-gtk-1.3.10-no-execmem.patch
Patch2: libwebkit-gtk-1.3.10-stamp-po.patch
Patch3: libwebkit-gtk-1.8.2-bison-2.6.patch
License: BSD, LGPL
BuildRequires: libgcrypt-devel
BuildRequires: libglitz-devel
BuildRequires: libgnutls-devel
BuildRequires: libgpg-error-devel
BuildRequires: libpixman-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libselinux-devel
BuildRequires: libSM-devel
BuildRequires: libtasn1-devel
BuildRequires: libuuid-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libxcb-util-devel
BuildRequires: libXcomposite-devel
BuildRequires: libXcursor-devel
BuildRequires: libXdamage-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXfixes-devel
BuildRequires: libXinerama-devel
BuildRequires: libXrandr-devel
BuildRequires: libXrender-devel
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libcairo-devel
BuildRequires: libdbus-devel
BuildRequires: libdbus-glib-devel
BuildRequires: libenchant-devel
BuildRequires: libexpat-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libgeoclue-devel
BuildRequires: libglib-devel
BuildRequires: libgst-plugins-base-devel
BuildRequires: libgstreamer-devel
BuildRequires: libgtk-devel
BuildRequires: libICE-devel
BuildRequires: libicu-devel
BuildRequires: libjpeg-devel
BuildRequires: libpango-devel
BuildRequires: libpng-devel
BuildRequires: libsoup-devel
BuildRequires: libsqlite-devel
BuildRequires: libstdc++6-devel
BuildRequires: libX11-devel
BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
BuildRequires: libXt-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: bison
BuildRequires: flex
BuildRequires: GConf-devel
BuildRequires: gobject-introspection-devel
BuildRequires: gperf
BuildRequires: gst-plugins-bad-devel
BuildRequires: icu
BuildRequires: libavahi-devel
BuildRequires: libcares-devel
BuildRequires: libcurl-devel
BuildRequires: libe2fs-devel
BuildRequires: libgnome-keyring-devel
BuildRequires: libgnome-vfs-devel
BuildRequires: libidn-devel
BuildRequires: libkrb5-devel
BuildRequires: libopenldap-devel
BuildRequires: libopenssl-devel
BuildRequires: libpcre-devel
BuildRequires: libqt4-devel
BuildRequires: librsvg-devel
BuildRequires: libsasl-devel
BuildRequires: libssh2-devel
BuildRequires: libtool
BuildRequires: libxkbfile-devel
BuildRequires: ORBit2-devel
BuildRequires: perl
Provides: libwebkit
Obsoletes: libwebkit
Provides: WebKit
Obsoletes: WebKit
BuildRoot: %{_tmppath}/%{name}-%{version}-root
# WebKit was configured with the following options:
# Build configuration:
# Enable debugging (slow) : no
# Enable GCC build optimization : yes
# Code coverage support : yes
# Unicode backend : icu
# Font backend : freetype
# Optimized memory allocator : yes
# Features:
# 3D Transforms : yes
# 3D Canvas (WebGL) : no
# Blob support : yes
# Directory upload : no
# Fast Mobile Scrolling : yes
# JIT compilation : yes
# Filters support : yes
# Geolocation support : yes
# JavaScript debugger/profiler support : yes
# MathML support : yes
# HTML5 offline web applications support : yes
# HTML5 channel messaging support : yes
# HTML5 client-side session and persistent storage support : yes
# HTML5 client-side database storage support : yes
# HTML5 FileSystem API support : no
# HTML5 sandboxed iframe support : yes
# HTML5 server-sent events support : yes
# HTML5 video element support : yes
# Fullscreen API support : yes
# Icon database support : yes
# Image resizer support : no
# Link prefetch support : no
# Opcode stats : no
# SharedWorkers support : yes
# Speech input support : no
# SVG support : yes
# SVG animation support : yes
# SVG fonts support : yes
# SVG foreign object support : yes
# SVG as image support : yes
# SVG use element support : yes
# WML support : no
# Web Audio support : no
# Web Sockets support : yes
# Web Timing support : no
# Web Workers support : yes
# XHTML-MP support : yes
# XPATH support : yes
# XSLT support : yes
# GTK+ configuration:
# GTK+ version : 2.0
# GDK target : x11
# Hildon UI extensions : no
# Introspection support : yes
# WebKit2 support : no
# http://svn.webkit.org/repository/webkit/tags/Safari-6531.9/
%description
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libwebkit-devel
Obsoletes: libwebkit-devel
%description devel
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains libraries and header files need for development.
%package gir
Group: Development/Libraries
Summary: GObject introspection data for %{name}
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
Requires: gobject-introspection
%description gir
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains introspection data for %{name}. It can be used by packages using the
GIRepository format to generate dynamic bindings.
%package jsc
Group: Applications/Networking
Summary: JavaScriptCore shell for WebKit GTK+
%description jsc
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains WebKit's JavaScript engine. It allows you to interact with the JavaScript engine directly.
%package webinspector
Group: Applications/Networking
Summary: Data files for WebKit GTK+'s Web Inspector
Obsoletes: Webkit
%description webinspector
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains the data files necessary for Web Inspector to work.
%package doc
Group: Documentation
Summary: Documentation for %{name}
%description doc
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
This package contains the documentation for %{name},
%prep
%setup -q -n webkit-%{version}
%patch0 -p0
#%patch1 -p0
#%patch2 -p0
%patch3 -p1
%build
#./autogen.sh
CFLAGS="%{optflags} -DLIBSOUP_I_HAVE_READ_BUG_594377_AND_KNOW_SOUP_PASSWORD_MANAGER_MIGHT_GO_AWAY" \
%configure \
--with-gtk=2.0 \
--enable-geolocation \
--enable-3D-transforms \
--enable-channel-messaging \
--enable-xhtmlmp \
--enable-fast-mobile-scrolling \
--enable-web-sockets \
--enable-filters \
--enable-coverage \
--enable-introspection \
--enable-mathml \
--enable-video \
%ifarch arm
--disable-jit \
%else
--enable-jit \
%endif
PYTHON=%{__python}
mkdir -p DerivedSources/webkit
mkdir -p DerivedSources/WebCore
# https://bugs.webkit.org/show_bug.cgi?id=34846
#% make
make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
mkdir -p %{buildroot}%{_libexecdir}/webkit
install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/webkit
#for doc in WebKit/LICENSE WebKit/gtk/po/README WebKit/gtk/NEWS Source/WebCore/icu/LICENSE Source/WebCore/LICENSE-APPLE Source/WebCore/LICENSE-LGPL-2 \
# Source/WebCore/LICENSE-LGPL-2.1 Source/JavaScriptCore/COPYING.LIB Source/JavaScriptCore/THANKS Source/JavaScriptCore/AUTHORS \
# Source/JavaScriptCore/icu/README Source/JavaScriptCore/icu/LICENSE Source/JavaScriptCore/pcre/COPYING Source/JavaScriptCore/pcre/AUTHORS ;do
# mkdir -p %{buildroot}%{_docdir}/webkitgtk-%{version}
# cp -p $doc %{buildroot}%{_docdir}/webkitgtk-%{version}/$(echo $doc | sed -e 's!/!.!g')
#done
%find_lang webkit-2.0
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post
/sbin/ldconfig
%{_bindir}/glib-compile-schemas %{_datadir}/glib-2.0/schemas
%postun
/sbin/ldconfig
%{_bindir}/glib-compile-schemas %{_datadir}/glib-2.0/schemas
%files -f webkit-2.0.lang
%defattr(-,root,root)
%{_libexecdir}/webkit/GtkLauncher
%{_libdir}/libwebkitgtk-1.0.so.*
%{_libdir}/libjavascriptcoregtk-1.0.so.*
%dir %{_datadir}/webkitgtk-1.0
%{_datadir}/webkitgtk-1.0/*
#%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
%files devel
%defattr(-,root,root)
%dir %{_includedir}/webkitgtk-1.0
%{_includedir}/webkitgtk-1.0/*
%{_libdir}/libwebkitgtk-1.0.la
%{_libdir}/libwebkitgtk-1.0.so
%{_libdir}/libjavascriptcoregtk-1.0.la
%{_libdir}/libjavascriptcoregtk-1.0.so
%{_libdir}/pkgconfig/javascriptcoregtk-1.0.pc
%{_libdir}/pkgconfig/webkit-1.0.pc
%files doc
%defattr(-,root,root)
%dir %{_datadir}/gtk-doc/html/webkitgtk
%{_datadir}/gtk-doc/html/webkitgtk/*
%files gir
%defattr(-,root,root)
%{_libdir}/girepository-1.0/JSCore-1.0.typelib
%{_libdir}/girepository-1.0/WebKit-1.0.typelib
%{_datadir}/gir-1.0/JSCore-1.0.gir
%{_datadir}/gir-1.0/WebKit-1.0.gir
%files jsc
%defattr(-,root,root)
%{_bindir}/jsc-1
%changelog
* Mon Nov 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.3-1mamba
- update to 1.8.3
* Wed Aug 15 2012 Automatic Build System <autodist@mambasoft.it> 1.8.2-1mamba
- automatic version update by autodist
* Sun May 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-1mamba
- update to 1.8.1
* Fri Feb 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.10-2mamba
- rebuilt in devel
- buildrequire libjpeg-devel instead of libjpeg-turbo-devel
* Wed Jan 26 2011 gil <puntogil@libero.it> 1.3.10-1mamba
- update to 1.3.10
* Mon Nov 29 2010 gil <puntogil@libero.it> 1.3.6-2mamba
- rebuilt devel
* Tue Nov 09 2010 gil <puntogil@libero.it> 1.3.6-1mamba
- update to 1.3.6
* Thu Oct 07 2010 gil <puntogil@libero.it> 1.3.4-1mamba
- update to 1.3.4
* Wed Oct 06 2010 gil <puntogil@libero.it> 1.2.5-1mamba
- update to 1.2.5
* Mon Sep 13 2010 gil <puntogil@libero.it> 1.2.4-1mamba
- update to 1.2.4
* Thu Jul 22 2010 gil <puntogil@libero.it> 1.2.3-1mamba
- update to 1.2.3
* Wed Jun 23 2010 gil <puntogil@libero.it> 1.2.1-1mamba
- update to 1.2.1
* Sat Apr 24 2010 gil <puntogil@libero.it> 1.2.0-2mamba
- edit spec file
* Tue Apr 20 2010 gil <puntogil@libero.it> 1.2.0-1mamba
- update to 1.2.0
* Sat Dec 26 2009 gil <puntogil@libero.it> 1.1.15.4-1mamba
- update to 1.1.15.4
* Thu Jul 02 2009 gil <puntogil@libero.it> 1.1.10-1mamba
- update to 1.1.10
* Thu Jun 11 2009 gil <puntogil@libero.it> 1.1.9-1mamba
- update to 1.1.9
* Fri May 29 2009 gil <puntogil@libero.it> 1.1.8-1mamba
- update to 1.1.8
* Sat May 16 2009 gil <puntogil@libero.it> 1.1.7-1mamba
- update to 1.1.7
* Thu May 07 2009 gil <puntogil@libero.it> 1.1.6-1mamba
- update to 1.1.6
* Sat Apr 18 2009 gil <puntogil@libero.it> 1.1.5-1mamba
- update to 1.1.5
* Sat Mar 28 2009 gil <puntogil@libero.it> 1.1.4-1mamba
- update to 1.1.4
* Mon Nov 17 2008 gil <puntogil@libero.it> 1.0.1-1mamba
- package created by autospec