rebuilt with cmake [release 1.3.7-2mamba;Tue May 09 2023]
This commit is contained in:
parent
5a9d7220ec
commit
6f2ab9f5ea
20
libvorbis-1.3.7-soname.patch
Normal file
20
libvorbis-1.3.7-soname.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- libvorbis-1.3.7/lib/CMakeLists.txt.orig 2020-04-15 18:20:52.000000000 +0200
|
||||||
|
+++ libvorbis-1.3.7/lib/CMakeLists.txt 2023-05-09 12:34:57.295329566 +0200
|
||||||
|
@@ -79,11 +79,14 @@
|
||||||
|
add_library(vorbisfile ${VORBISFILE_SOURCES})
|
||||||
|
|
||||||
|
get_version_info(VORBIS_VERSION_INFO "V_LIB_CURRENT" "V_LIB_AGE" "V_LIB_REVISION")
|
||||||
|
- set_target_properties(vorbis PROPERTIES SOVERSION ${VORBIS_VERSION_INFO})
|
||||||
|
+ set_target_properties(vorbis PROPERTIES SOVERSION "0")
|
||||||
|
+ set_target_properties(vorbis PROPERTIES VERSION ${VORBIS_VERSION_INFO})
|
||||||
|
get_version_info(VORBISENC_VERSION_INFO "VE_LIB_CURRENT" "VE_LIB_AGE" "VE_LIB_REVISION")
|
||||||
|
- set_target_properties(vorbisenc PROPERTIES SOVERSION ${VORBISENC_VERSION_INFO})
|
||||||
|
+ set_target_properties(vorbisenc PROPERTIES SOVERSION "2")
|
||||||
|
+ set_target_properties(vorbisenc PROPERTIES VERSION ${VORBISENC_VERSION_INFO})
|
||||||
|
get_version_info(VORBISFILE_VERSION_INFO "VF_LIB_CURRENT" "VF_LIB_AGE" "VF_LIB_REVISION")
|
||||||
|
- set_target_properties(vorbisfile PROPERTIES SOVERSION ${VORBISFILE_VERSION_INFO})
|
||||||
|
+ set_target_properties(vorbisfile PROPERTIES SOVERSION "3")
|
||||||
|
+ set_target_properties(vorbisfile PROPERTIES VERSION ${VORBISFILE_VERSION_INFO})
|
||||||
|
|
||||||
|
target_include_directories(vorbis
|
||||||
|
PUBLIC
|
@ -1,21 +1,21 @@
|
|||||||
Name: libvorbis
|
Name: libvorbis
|
||||||
Version: 1.3.7
|
Version: 1.3.7
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A general purpose public domain audio and music encoding format
|
Summary: A general purpose public domain audio and music encoding format
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Aleph0 <aleph0@openmamba.org>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.vorbis.com
|
URL: https://xiph.org/vorbis/
|
||||||
Source: http://downloads.xiph.org/releases/vorbis/libvorbis-%{version}.tar.gz
|
Source: http://downloads.xiph.org/releases/vorbis/libvorbis-%{version}.tar.gz
|
||||||
Patch0: libvorbis-1.3.4-pkg-config.patch
|
Patch0: libvorbis-1.3.4-pkg-config.patch
|
||||||
|
Patch1: libvorbis-1.3.7-soname.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libogg-devel
|
BuildRequires: libogg-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: cmake
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The libvorbis package contains a general purpose audio and music encoding format.
|
The libvorbis package contains a general purpose audio and music encoding format.
|
||||||
@ -24,32 +24,28 @@ This is useful for creating (encoding) and playing (decoding) sound in a public
|
|||||||
%package devel
|
%package devel
|
||||||
Summary: Static libraries and headers for %{name}
|
Summary: Static libraries and headers for %{name}
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: libogg-devel
|
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
The libvorbis package contains a general purpose audio and music encoding format.
|
The libvorbis package contains a general purpose audio and music encoding format.
|
||||||
This is useful for creating (encoding) and playing (decoding) sound in a public domain format.
|
This is useful for creating (encoding) and playing (decoding) sound in a public domain format.
|
||||||
|
This package contains static libraries and header files needed for development.
|
||||||
This package contains static libraries and header files need for development.
|
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
#%patch0 -p1
|
||||||
|
%patch 1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%cmake -d build
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
rm -fr pckdocs
|
%makeinstall -C build
|
||||||
%makeoldinstall \
|
|
||||||
docdir=%{_builddir}/%{name}-%{version}/pckdocs
|
|
||||||
|
|
||||||
rm -f %{buildroot}%{_libdir}/*.a
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -66,21 +62,23 @@ rm -f %{buildroot}%{_libdir}/*.a
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_datadir}/aclocal/*
|
%dir %{_includedir}/vorbis
|
||||||
|
%{_includedir}/vorbis/*.h
|
||||||
%{_libdir}/libvorbis.so
|
%{_libdir}/libvorbis.so
|
||||||
%{_libdir}/libvorbisenc.so
|
%{_libdir}/libvorbisenc.so
|
||||||
%{_libdir}/libvorbisfile.so
|
%{_libdir}/libvorbisfile.so
|
||||||
%{_libdir}/libvorbis.la
|
|
||||||
%{_libdir}/libvorbisenc.la
|
|
||||||
%{_libdir}/libvorbisfile.la
|
|
||||||
%{_libdir}/pkgconfig/vorbis.pc
|
%{_libdir}/pkgconfig/vorbis.pc
|
||||||
%{_libdir}/pkgconfig/vorbisenc.pc
|
%{_libdir}/pkgconfig/vorbisenc.pc
|
||||||
%{_libdir}/pkgconfig/vorbisfile.pc
|
%{_libdir}/pkgconfig/vorbisfile.pc
|
||||||
%dir %{_includedir}/vorbis
|
%dir %{_libdir}/cmake/Vorbis
|
||||||
%{_includedir}/vorbis/*.h
|
%{_libdir}/cmake/Vorbis/Vorbis*.cmake
|
||||||
%doc pckdocs/*
|
|
||||||
|
#%doc pckdocs/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 09 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.7-2mamba
|
||||||
|
- rebuilt with cmake
|
||||||
|
|
||||||
* Wed Jul 22 2020 Automatic Build System <autodist@mambasoft.it> 1.3.7-1mamba
|
* Wed Jul 22 2020 Automatic Build System <autodist@mambasoft.it> 1.3.7-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user